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Target Audience
The intended audience for this User Guide is:

· Administrators
· Process Authors
· Contributors

About the User Guide
The purpose of this guide is to offer all users of the Nimbus® software, detailed step-by-step instructions on how to
use the extensive functionality available.  The topics covered in depth are as follows:

· Administration
· Maps and Diagrams
· Documents
· Templates
· Storyboards
· Statement Sets
· Data Tables
· Scorecards
· Searches
· Content Collaboration
· Action Management
· Reporting
· Printing

About TIBCO Nimbus
Nimbus® is a process management mapping application that allows corporate information to be presented
graphically and hierarchically in the form of maps and diagrams. It provides a simple user-interface that enables
any employee within an organization to access information that is relevant and essential to fulfill their role. 

Maps are a collection of diagrams created by process authors. A map is initially created as a draft version until it is
promoted to a master. Maps may also comprise a number of scenarios. Access rights can be assigned to individual
users and groups, allowing or preventing access to an entire map or parts of a map. Continuous improvement to
processes is achieved through a number of collaboration features. Acknowledgement requests ensure users are
aware of process content that affects their roles. Reviews ensure that content is kept up-to-date. Feedback and
change requests allow users to suggest improvements. Users can also be notified when content changes through
the use of subscriptions.

Statement sets are a hierarchical set of regulatory and auditable statements that ensure compliance to specific
business and legal requirements, such as ISO 9001, 27001, CMMi, internal company policies, etc. Statements can
be linked to activities that are related to compliance and governance.



Getting Started in TIBCO Nimbus

TIBCO Nimbus® User Guide Page 8

Fundamentals of Process Mapping

Finding Maps

Find a map

Maps can be searched for in the Open/Manage window.

· Searches against map names and level 1 diagram titles.

· Searches only on maps that you have access to.

· Searches on draft and master maps in all folders (except the Deleted folder).

The search operation works by filtering the maps on view in the Open/Manage window.

Method

1. From the File menu choose Open/Manage.

2. Click Search. 

3. Enter your search term in the search text box, then click OK.

Note: Previous searches are remembered and can be selected by clicking the drop-down arrow  to the
right of the text box.

Any maps that don't match the search term will be hidden. To redisplay all maps again choose Cancel
Search:

Related topics

Opening maps

Creating maps

Saving maps

Printing maps

Deleting maps

Copying maps
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Renaming maps

Opening Maps

Open a map

Method

1. From the File menu choose Open/Manage.

2. Select a process map and click Open.

Hint: You can open multiple maps by holding Ctrl when selecting maps.

Related topics

Finding maps

Creating maps

Saving maps

Printing maps

Deleting maps

Copying maps

Renaming maps

Creating Maps

Create a map

Method

1. From the File menu choose Open/Manage.

2. Click New.

3. Click to select either the Process Repository or a sub-folder to create the map in.

Hint: You can create a new folder by clicking Create Folder.

4. Enter the name and title of the new map.

Note: To define multiple languages for the top-level diagram title click Edit Language Variants .

5. If desired, choose a template to apply to the map from the Template drop-down list.

6. Click OK.
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Related topics

Opening maps

Saving maps

Printing maps

Deleting maps

Copying maps

Renaming maps

Creating templates

Saving Maps

Save a map

Method

1. From the File menu choose Save to save as the current name or Save As... to save a copy of the map.

Note: Diagrams are automatically saved when you navigate to another diagram and maps are automatically
saved when you close it.

Related topics

Opening maps

Creating maps

Printing maps

Deleting maps

Copying maps

Renaming maps

Deleting Maps

Delete a map

Method

1. From the File menu choose Open/Manage.

2. Select the map(s) that you want to delete and click Delete, then click Yes.

Note: C lick All if you have selected to delete multiple maps and do not want to confirm every deletion.
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Related topics

Opening maps

Creating maps

Saving maps

Printing maps

Copying maps

Renaming maps

Copy a map

Copy a map

Method

1. From the File menu choose Open/Manage.

2. Select the map that you want to copy and click Copy.

3. Choose the location in the Process Repository where you want to copy the map to and click OK.

Hint: You can create a copy of a map in the same location by choosing Save As... from the File menu and

saving the map under a different name.

Related topics

Opening maps

Creating maps

Saving maps

Printing maps

Deleting maps

Renaming maps

Renaming Maps

Rename a map

Method

1. From the File menu choose Open/Manage.

2. Select the map that you want to rename and click Rename.
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Related topics

Opening maps

Creating maps

Saving maps

Printing maps

Deleting maps

Copying maps
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Installation and Setup

Installing

Create a shortcut

It is recommended that shortcuts are created automatically through a network installation, thereby ensuring that
the Windows registry is correctly configured. Once a shortcut has been created it can be made available to users
to copy to their desktops.

Note: Creating a shortcut manually may fail if you do not have administrative privileges on the operating
system.

To manually create a shortcut:

The shortcut properties should be set as follows:

Description:  TIBCO Nimbus
Target (or Command Line): <program directory>\Ctrl.exe <data directory>

For example: 
C:\TIBCO Nimbus\Client\Ctrl.exe "C:\TIBCO Nimbus\Process Repository"

Note: If there are any spaces in the directory paths then you must include inverted commas.

Passwords

Recover a password

If you have forgotten your password then please contact your administrator. If you are an administrator then
please contact TIBCO Nimbus Support. 

Reset a user's password

For information on resetting a user's password see Resetting a user's password.

Change a password

You can change your existing password.

Note: Administrators can enforce that users change their password after a specified time in the system options.

1. From the Tools menu choose Users and then Change Password.

2. In the Current Password text box enter your current password.

3. In the New Password text box enter a new password.

4. Click OK.

Running from the Command Line

Run TIBCO Nimbus from the command line

TIBCO Nimbus can be run from the command line and a specific map or diagram can be automatically opened.

1. On the Windows Start menu click Run.

2. Enter the path to TIBCO Nimbus, for example C:\TIBCO Nimbus\Client\Ctrl.exe.

3. At the end of the path, type a space and then type a startup switch if required.

https://support.tibco.com/login.htm
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Command Line Parameters

It is possible to run TIBCO Nimbus and specify a map or specific diagram to open. These
command line parameters can be obtained from the Where Am I? dialog (from the Map menu
choose Where Am I?...).

Example 1

"C:\TIBCO Nimbus\Client\Ctrl.exe" "C:\TIBCO Nimbus\Process Repository\" "Draft\My First
Process Repository"

This command will launch TIBCO Nimbus and open the map My First Process Repository at
level 1.

Example 2

"C:\TIBCO Nimbus\Client\Ctrl.exe" "C:\TIBCO Nimbus\Process Repository\" "Draft\My First
Process Repository.MAP\9FBCF02D6F504A53B2CC5044754804BC"

This command will launch TIBCO Nimbus and open the map My First Process Repository at the
diagram ID that is specified at the end.

Transferring Text Between Languages

Transfer text between language variants

Following the migration from a previous major version, all diagram text and resource text is marked with the
default English (United States) language variant. If your default language is not English US then you can copy or
move the text to another language variant. This operation can be run on all maps in the process repository, or a
selected map.

Note: For either operation to proceed, it will require the diagrams within the selected scope to be locked. If a
lock cannot be established the selected operation will not commence and you will be notified which diagrams
cannot be locked.

Logs - both operations are logged in the MajorOps.log file, which can be found in .../Process Repository/Users/
LOG.

For information on creating language variants click here.

1. From the Administration menu choose Language Variants, and then either Copy Text or Move Text.

2. Select the scope of the operation.

3. Choose the Source Language and Target Language.

4. Click OK.

System Configuration

About the system configuration
Only administrators have access to the system options. System options are defined for an entire process
repository and includes all maps, diagrams and files contained within.

1. From the Administration menu choose System Options.
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Hint: You can reset the system options back to the default settings by clicking Reset (located at the bottom-

left of the System Options dialog).

Exporting the system options
You can export the system options setup as a CSV file by clicking Export.

Audit logs
Any changes to the system options is recorded in an audit log. To view this log click Audit Log.

General

Registration Code Expiry Reminder
A reminder can be set to notify administrators before the registration code expires.

Default Image Folder
A default image folder can be selected. This folder will be automatically accessed when users add new images

to a diagram.

Help Menus
Alternative files or URLs can be specified for when users access the Quick Start Guide, On-line Guide and

Tutorial from the Help menu.

1. Click Configure Help Menus.

2. Select the relevant check box for the source file that you want to redirect and click File Browse .

Landing Pages
Define the available landing pages for users. A landing page is a URL, such as a TIBCO Nimbus Web Server
page (or any URL), that users will be directed to after logging in to the Web Server. Default landing pages can
be specified for all authors and contributors, or for specific users.

Notes:

· 'http://' will be prefixed to any URLs that do not have a prefixed protocol.
· If users do not have access to a particular landing page, for example the Maps page, they will be

redirected to their Home page.
· Relative paths can be used, for example '/webmytopics/' (these will only work if the slashes are

correct).
· If URLs such as the Home page or Log In page are used, the user will be logged out.

1. Click Landing Pages.

2. Click New Item .
3. Specify the name and URL, then click OK.

Note: To edit or delete an existing landing page, right-click the landing page and choose Properties or
Delete respectively.

To set the default landing pages for contributors and authors, see Default Contributor Settings and Default
Author Settings. Setting the landing page for a specific user is achieved in the Details tab of the User
Accounts window.

Welcome Panel
Specify whether to display accessible Nimbus®-related content (such as news and events) on users' Welcome
pages in the Author Client, downloaded from the Internet when the client is launched.

TIBCO Nimbus Batch Server
Select whether to use the Batch Server for all supported operations. If this option is disabled you can still
specify individual batch operations to use the Batch Server. This option must also be enabled to allow authors
to manage access rights and unlock diagrams in the web. For information on the Batch Server please see the
associated help file, found in the TIBCO Nimbus Batch Server sub-folder. 

Access

Default new maps to private access makes all new maps created only accessible to administrators and
diagram authors, i.e. the default user access rights will be set to Access Denied. If this option is not
selected then the default user access rights are Read and write.
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Default new documents to private access makes all new documents that are registered accessible
only to administrators and the user who registered it. All other users are denied read and write access
unless the file's access rights are modified.

Show support buttons in Where Am I window enables a support button on the Where Am I window,
allowing users to Email support.

Allow only administrators to set diagram access rights allows only map and TIBCO Nimbus
administrators to set access rights on diagrams. By default only diagram owners and authors can set
diagram access rights.

Allow any author with read/write access to unlock a diagram enables any process author with
read/write access to a diagram to unlock the draft following promotion. By default only diagram owners
and authors, map and TIBCO Nimbus  administrators can unlock draft diagrams.

Allow any author with read/write access to request authorization enables any process author with
read/write access to a diagram to request authorization. By default only diagram owners and authors, map
and TIBCO Nimbus  administrators can request authorization.

Allow any author with read/write access to set authorizers enables any process author with read/
write access to a diagram to set and update the list of authorizers. By default only diagram owners and
authors, map and TIBCO Nimbus  administrators can assign diagram authorizers.

Allow all authors to update the access rights on scenarios enables any process author with access
to a scenario to set access rights. By default only diagram owners and authors can set diagram access
rights.

Allow only administrators to run reports across a map selection enables only administrators to
use the Map Selection scope option when running a report. This is useful in a large environment where
running a report across an entire process map with a large amount of content may cause a system
performance bottleneck for users accessing the system.

Auto set map administrator when map is created via exporting or copying will maintain the map
administrator of any diagrams that are exported or copied.

Change log entries are read only will allow new change log entries to be added but existing change log
entries cannot be edited.

Allow Shapes Toolbar allows process authors to use the Shapes toolbar. Note that this option can also be
set for individual maps in the Map Properties.

Allow data table records to be added and edited in master maps allows users with sufficient access
rights to add and edit data table attachment records in master maps.

Data Privacy Mode will hide the Active Users window and the license information in the About window
from all users except administrators. It will also hide the User Accounts window from all users except
administrators and account managers.

Default Access Rights

You can assign the default and specific access rights for new documents and new maps.

Note: If the option to default new maps or documents to private access is enabled then you cannot specify the
respective default access rights for maps and documents.

New Document

Default Access allows you to define the access rights for all users when a document is registered in
the Document Registry.

Read and write assigns read and write access to new documents, allowing all users to view the
documents and edit the details.
Read only assigns read only access to new documents, allowing all users to view but not edit the
documents.
Access denied assigns access denied to new documents, preventing all users from viewing and
editing the documents.
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Specific User Access allows you to define the access rights for specific users or user groups when a
document is registered. For example, you may want to set the default user access to read only but

allow certain users read and write access to all new documents. Click Add  to search for and add
users and user groups (see Searching for and adding users for more information).

Grant all users access to new Master documents will automatically allow all users to view a
document when it is promoted from a draft to a master version, regardless of the access rights defined
for the draft document.

Transfer Draft document access rights on initial Master promotions will maintain the access
rights of a draft document when it is promoted to a master version.

New Map

Default Access allows you to define the access rights for all users when a map is created.

Read and write assigns read and write access to new maps, allowing all users to view and edit
them.
Read only assigns read-only access to new maps, allowing all users to view but not edit them.
Access denied assigns access denied to new maps, preventing all users from viewing and editing
them.

Specific User Access allows you to define the access rights for specific users or user groups when a
new map is created. For example, you may want to set the default user access to read only but allow

certain users read and write access to all new maps. Click Add  to search for and add users and
user groups (see Searching for and adding users for more information).

New Scorecard

Default Access allows you to define the access rights for all users when a new scorecard is
registered.

Read and write assigns read and write access to new scorecards, allowing all users to view and
edit them.
Read only assigns read-only access to new scorecards, allowing all users to view but not edit
them.
Access denied assigns access denied to new scorecards, preventing all users from viewing and
editing them.

Specific User Access allows you to define the access rights for specific users or user groups when a
new scorecard is registered. For example, you may want to set the default user access to read only but

allow certain users read and write access to all new scorecards. Click Add  to search for and add
users and user groups (see Searching for and adding users for more information).

New Statement Set

Default Access allows you to define the access rights for all users when a new statement set is
registered.

Read and write assigns read and write access to new statement sets, allowing all users to view
and edit them.
Read only assigns read-only access to new statement sets, allowing all users to view but not edit
them.
Access denied assigns access denied to new statement sets, preventing all users from viewing
and editing them.

Specific User Access allows you to define the access rights for specific users or user groups when a
new statement set is registered. For example, you may want to set the default user access to read only

but allow certain users read and write access to all new statement sets. Click Add  to search for and
add users and user groups (see Searching for and adding users for more information
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Display

Custom Text

Text allows you to define text to be included in the footer of printed diagrams. Select Include on
Print to enable it.

Default Currency Display

The display of currency when conducting costing can be defined.

Calculate cost period and total FTE with rounded values will round up or down the cost periods
and FTEs when calculating the total cost period and FTE for diagrams.

Default Custom Colors

Custom colors can be defined and will be available on the color palette whenever the option to use
colors is available. For example, when changing diagram object colors and creating style sheets.

To define custom colors:

1. Click Define Custom Colors.

2. Select a custom color box and click Define Custom Colors.

3. Choose a color by moving the cross-hairs on the color palette and click Add to Custom Colors.

Note: After moving the cross-hair you must move the slider on the right to choose the depth of
color.

Default Font

The default font will be used whenever text is applied, for example when defining an activity or flow
line.

Default resource hint text behavior

Hint text can be associated with resources so that when users roll their mouse over a resource it will
display some text. One of the options when enabling hint text for a given resource is to use the system
option hint text. Here you can specify what the system option for resource hint text is.

Show resource name as hint text will display the resource name as the hint text.

Show custom hint text will display the custom hint text that has been defined for a particular
resource. If no custom hint text has been defined then no hint text will be displayed.

Show resource info field 1 as hint text will display a resource's info field 1 as hint text.

Show resource info field 2 as hint text will display a resource's info field 2 as hint text.

Templates

Default Template allows you to choose a default template. Default templates can be automatically
applied to new maps that are created and applied to existing diagrams that do not have an associated
template (see below).

Automatically apply default template to all new maps will automatically apply the default
template to all diagrams when new maps are created.

Automatically apply default template to diagrams without a template will apply the default
template to any diagrams that do not have a template assigned. Note: This function will not work on
diagrams that have been marked as none.

Only allow administrators to apply templates to authorized diagrams will prevent all users
(except administrators) from applying templates to authorized diagrams.

Allow administrators to apply templates on master maps will allow only administrators to apply
templates to master maps.
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User-defined Templates

You can define three user-defined fields to be made available to insert into free text boxes when 
creating templates.

Styles

Global Settings

Enable Diagram Conversion will enable the global diagram theme styling to be applied from the web
client

Enable Global Theme for Modern Style Maps will apply a consistent theme across all draft
diagrams.  This will hide any existing activity, resource and line styles.

Style Sheets

Automatically use default style sheet on new objects will automatically apply the selected
default style sheet to all new objects created.

Free Text Style Tag Names

Up to ten different styles can be defined and made available for stylizing free text objects using the
right-click pop-up menu. Here you can rename the styles to something more appropriate.

To define or modify a free text style tag, see Defining free text styles.

Apply rounding to the corners of standard activities will apply rounded corners to all activities
in existing diagrams (and when creating new diagrams). You can set the amount of rounding applied
(from 1 to 40). Note that this does not affect flowchart shapes.

Apply rounding to the corners of dog-leg lines will apply rounded corners to all dog-leg lines in
existing diagrams (and when creating new diagrams). You can set the amount of rounding applied
(from 1 to 40).

Language Variants

Multiple text variants can be stored against a number of diagram objects, such as activities, free text, note
bubbles, flow lines, etc. A user's locale setting will determine which object text variant is displayed. Since a single
map can store multiple text translations at the object level, there is no need to create multiple versions of a map
for different languages. Attachments and links can also be tagged for a specific language.

Note: Text can be transferred between language variants - see Transferring text between language variants for
more information.

To add a new language:

1. Click Add.

2. From the Language drop-down list choose the language.

Is Default Language will set the language as the default language for Process Authors when creating
diagram objects. Other languages specified can be selected. Only one language can be set as the default
language.

Default Attachment Logo Hint allows you to modify the default hint text of attachment logos for the
language.

Default Drill Down Logo Hint allows you to modify the default hint text of drill downs for the language.

3. Click OK to finish.

To edit an existing language variant:
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Select the language and click Edit.

To delete an existing language variant:

Select the language and click Delete.

Document Control

Change Requests

Control Ref Prefix allows you to define a prefix to attach to change request IDs.

Default change request due dates to will automatically advance a change request due date by x
number of weeks when a change request is progressed in the Web Server environment. Note that this
will also automatically advance the due date when progressing a change request in the Author Client,
although users can update the date manually, if required.

Fields to be defined on CR submission allows you to add fields to change requests by associating a
data table. By default, the 'Change Request - DEFAULT' system data table is associated with change
requests. This includes the Audit Reference and User Reference fields. Additional fields can be added to
the data table - see Editing data tables. You can choose a different data table from the drop-down list -
see Creating data tables.

Version Numbers

Default Format allows you to define the default version numbering format.

Automatic update version numbers allows you to choose how draft document version numbers are
updated.

Increment when draft is unlocked for editing will automatically increment the draft version
when documents are unlocked.

Increment when draft is promoted will automatically increment the draft version when
documents are promoted.

Manual version number control will not automatically increment the draft version when
documents are promoted, requiring users to manually update the version number each time.

Whole number version numbers will automatically increment draft document versions using whole
numbers (this option is grayed out for the 'Manual version number control' option).

Separate version numbers for Internal WP Document attachments displays separate version
numbers (to the associated diagram) for Internal WP Documents attachments, otherwise the version is
assumed to be the same as the diagram and no version numbers are displayed.

Separate version numbers for Internal Image attachments displays separate version numbers
(to the associated diagram) for Internal Image attachments, otherwise the version is assumed to be the
same as the diagram and no version numbers are displayed.

Master Only Options

Acknowledgement requests to be raised in the master only will only allow an acknowledgement
request to be made against master diagrams and Document Registry documents.

Subscriptions to be added in the master only will only allow users to be subscribed to master
diagrams and Document Registry documents.

Sign Off Options

Require a user to enter their password when signing off a To-Do will require a password when
signing off a To-Do.

Note: If you use SSO, users will need to sign-off content using there IdP credentials.

Require a user to enter their user name when signing off a To-Do will require a user name
when signing off a To-Do.
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Archives

A number of system options define how archived maps are stored. It is also possible to allow web users to access
archived maps. For more information on archives, please refer to the Administration Guide - under 
Maintenance/Archiving Maps.

Storage location for map archives allows a different location to be specified to store archived maps in.
If left blank, map archives are stored in the Archives sub-folder within the process repository. Consider
your disk space requirements as you may want to store archived maps on a different server to provide
more space for the process repository to grow. Important: If you specify a different location, it must be
accessible to users and to the TIBCO Nimbus Web Server in order to allow users to access archived maps.
If the Process Repository is stored on a remote server then it is not possible to specify a local location to
store archives in.

Automatically archive on promotion will automatically archive diagrams and documents following their
promotion. Note that this option will be grayed out if the option to use the TIBCO Nimbus Batch Server for
promoting draft content is selected.

Store compressed static version of map archives will store compressed static versions of map
archives. Note: This requires the Archive Utility (CtrlArchive.exe) to be scheduled to run at regular
intervals - see the Administration Guide for information on this utility.

Automatically remove old archives after is the duration to store archived maps before either moving
them or permanently deleting them. Choose one of the following two options:

Permanently remove old archives will permanently delete archived maps.

Move old archives to a specified location will move old archives to a specified location.

Quick Access Archive Settings

For providing users with quick access to archives in the Author Client and web interface, you have two
options. Note that once an archived map is made unavailable, it will remain in the system until it is
permanently deleted. It is recommended to keep these values as low as possible due to the amount of disk
space required to store uncompressed archived maps. 

Allow quick access to archives up to x month old allows you to set how long to keep archived maps
available to users.

Keep last x archives for quick access allows you to set the number of archives to be available to
users at any one time for a given map. Once this number is exceeded for a specific map, access to the
oldest archive will be removed. This option is useful if maps are being promoted and archived a lot in a
short period of time, for example during extensive mapping exercises and the launch phase of projects.

Authorization

Authorizers must enter notes when authorizing will force users to enter a note when they authorize
a diagram or document.

Include reason field when authorizing will allow users to select a reason for authorizing a diagram or
document from a predefined list.

Authorizers must select a reason when authorizing will force users to choose one of the predefined
reasons when authorizing a diagram or document.

Authorization Reasons

When users authorize a diagram or document they can choose a reason from a predefined list.
Items in the list can be added, deleted and edited.

To add a new reason click Add. To edit an existing reason, or to delete a reason, select the item in
the list and click Edit or Delete.
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Draft Promotion

Use TIBCO Nimbus Batch Server will use the Batch Server when promoting diagrams. For more
information see the help file that is installed with the Batch Server.

Perform single archive for consecutive promotions of the same map will take a single archive of
a current master map for a series of promotion operations within the same map. This option is only
available if the 'Use TIBCO Nimbus Batch Server option is selected. This option is useful as it prevents
duplicate archives being created when different sections of the same map are promoted at similar times.
The Batch Server will first queue up the draft promotions for the same map, then archive the master in
one operation and then allow all draft promotions to run through against that map.

Override promotion is an administrator only function will allow only administrators to use the
override promotion option when promoting diagrams.

Automatically unlock draft after promotion will unlock diagram and Document Registry document
drafts following promotion. Note: This option is not advised for large installations of TIBCO Nimbus where
multiple users are responsible for promoting and unlocking drafts.

Automatically promote after draft has been authorized will automatically promote draft diagrams
and Document Registry documents to master copies following authorization. Note: Automatic promotion
will only begin if the user who completes the authorization cycle has the rights to promote the diagrams or
Document Registry documents. This function is not available in the web server. This option is not advised
for large installations of TIBCO Nimbus where multiple users are responsible for promoting and unlocking
drafts.

Automatically send an acknowledgement request after promotion will automatically send an
acknowledgement request to the assigned acknowledgers of a diagram or document following its
promotion. If enabled then you must specify two parameters - x Weeks for acknowledgement defines
the delay following promotion, in weeks, before a request is sent out. The Default acknowledgement
request due dates to x weeks in advance is the default number of weeks to define the due dates on
automatic acknowledgement requests after they have been sent out.

Always ask user to confirm prior to sending automatic acknowledgement request will prompt
the user to confirm sending automatic acknowledgement requests to the acknowledgers when a diagram
or document is promoted. If No is selected then the diagram or document will still be promoted but
acknowledgement requests will not be sent out. The 'Automatically send an acknowledgement request
after promotion' option must be enabled.

Reviews

Review Sign Off is text that can displayed to users on the Review window when users are completing a
review request. Note that this is optional.

Review Outcome allows you to manage the options that are available to users when completing reviews.
Review outcomes must be associated with an action from the following list:

None will complete the review without further action required from users.
Raise Change Request will allow users to create a change request when completing a review
request. Note that completing the change request form will be optional to users.
Raise Action will allow users to create an action when completing a review request. Note that
completing the new action form will be optional for users.
Notify Review Requestor will email a reviewer's comments to the person that raised the review
request.
Notify Owner will email a reviewer's comments to the owner of the content.
Raise Change Request (Mandatory) will force users to complete the new change request form
when completing the review.

Links

TIBCO Nimbus always determines file associations when launching file links will override the
application specified by users to launch attached file links  with the Windows default application. For
example, a user may have specified a .txt file to launch in Microsoft Word. If this option is enabled then the
application will launch in Notepad, i.e. the Windows default application used to launch .txt files.

Force UNC paths when file links, metric links and registry documents are added should be used
if users have different mappings on their machines to the network drives. File paths will be converted from
mapped drives into UNC (Universal  Naming Convention) path names (for example N:\documents will be
converted to \\servername\share\documents\) when file links, metric links and document links are added
to the system. If this option is not selected and users have different mappings for networked drives, they
may not be able to access file links, metric links and Document Registry links. Note: This will not work for
local drives.
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Use action server when users launch an email link will use the internal Email system as opposed to
using users' default Windows Email program. Note: The Action Server must be configured for this option to
work. Please refer to the Administrator's Guide located on the CD.

Default new links to launch in the same browser window will launch URL links in the same window
as the web browser. Note: This option can be overridden for individual URL attachments.

Always show popup menu for attachments will always display a pop-up menu when users access an
attachment, even if only one attachment exists. Note: Enable this option with caution as process authors
may hide menu functions on free text boxes, for example, or links that they may not want users to see.

Allow access to file properties from file links reports will allow users to view file properties in the
Document Registry through Windows Explorer.

Allow use of Excel based metric links will allow the use of Excel-based metric links. By disabling this
option, existing Excel-based metric links will not be updated on diagrams and on users' Home pages, and
Process Authors cannot create these types of metric links in the Author Client. Note: Performance issues
may arise if many Excel-based metric links are created, therefore this option is disabled by default.

Allow Excel macros to be launched for metric links will allow Excel macros to be defined and run for
metric links.

Automatically refresh Excel metric links when opening diagram will refresh metric links when
diagrams are opened. Note: This may affect performance and therefore may need to be disabled.

Force non-standard URL launching for all users allows non-standard URL launching for customers
who are unable to launch URL links/attachments.

Include diagram titles in new or updated flow line link tables will include the title of diagrams when
flow line links are created or updated.

Allow link navigation from master diagrams into draft diagrams in the Author Client will allow
users to access links in the author client that point from master to draft diagrams. If this option is not
selected then users will be prevented from accessing draft diagrams. Note that users must have access to
the draft diagram to follow a specific link.

Allow users to follow links from master diagrams into draft diagrams in the Web will allow users
to access links in the web server that point from master to draft diagrams. If this option is not selected
then users will be prevented from accessing draft diagrams. Note that users must have access to the draft
diagram to follow a specific link.

Use a download style link when accessing documents in the web will provide users with a choice of
saving or launching a document when they click a document link in the web. If this option is not selected
then the document will automatically launch.

Allow File/Application Links to be added will allow users to add external file and application links to
diagram objects.

Allow Web Links (URL) to be added will allow users to add web links to diagram objects.

Example URL

This allows you to change the example URL that appears in the URL attachment window.

Maps

Drill Down Copy and Pasting

Maximum drill downs that can be pasted allows you to limit the number of drill down diagrams that
can be pasted during a copy and paste operation. This prevents performance bottlenecks when copying
large maps.

Maximum drill downs that can be imported allows you to limit the number of diagrams that can be
imported as drill downs. Note: Administrators can override this limit when importing maps.

Override default warning message with this text will override the default system warning when
users attempt to copy drill downs that exceed the value set above.

Deleted Maps

Remove maps in the Deletion Recover Manager after is the number of days to keep deleted
maps before the SSync -mapsclean process removes them (this process must be scheduled to run). 
Note: 30 day is the maximum number of days permitted.
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Variants

In this option you can change the identifier that's used for all process variant levels. 

Variant Identifier is the identifier that you want to assign to process variant levels. Choose from Letters,
Roman Numerals or Numbers with brackets.

Notifications

Email Notifications

Certain system notifications relating to the management of maps can be automatically Emailed to
associated users (for example, an Email requesting acknowledgement can be automatically sent to
acknowledgers when an acknowledgement request is created). These automatically-generated
notifications can be switched on or off. The email titles and notification text can also be modified,
including the notification text sent to new users upon the creation of their account (the option to send an
Email notification to new users of a particular user group must be switched on in the Email Notifications
options).

Notify diagram's primary contact when user adds feedback will notify the primary contact
(author or owner, as specified) when users add feedback to diagrams. If disabled then notifications are
not sent.

Notify feedback topic creator when a reply is added will notify the creators of feedback when
other users reply to their feedback. If disabled then notifications are not sent.

Notify requestor upon authorizer's approval will notify the user that requested authorization when
authorizers have approved content. If disabled then notifications are not sent.

Notify draft diagram's primary contact when a feedback is added on the master will notify the
primary contact (author or owner, as specified) of draft diagrams when new feedback is added to master
diagrams as opposed to the primary contact on the master diagrams. Note: This also requires the
Notify diagram's primary contact when user adds feedback option to be enabled.

Notify draft diagram's author when change request on master is allocated will notify authors
of draft diagrams when new change requests are added to master diagrams as opposed to the author on
the master diagrams.

Notify user when change request is removed will notify users that are currently assigned to a
change request if the change request is deleted.

To change the text of Email notification items:

1. Click Advanced, select the notification that you want to edit and click Edit Text.

2. Edit the Email Subject, if required.

3. In the Email Text tab, edit the email body text, if required. 

4. Click OK .

Note: For information on each of the notifications see Notification Descriptions.

Substitution Text Fields

You can insert substitution fields in the notification text, for example you can add the name of the
user by inserting <USER>. When editing the text for a particular notification, from the Tools menu
choose Insert Field.

<BASE_URL> will be substituted by the base URL of the Web Server.

<BASE_URL_SHORT> is the base URL of the Web Server, but without CtrlWebISAPI.dll on the
end.

Action Notifications

The following fields can be inserted into action-related notifications:

<ACTION_NUM> ID number of the action record
<ACTION_SUBJECT
>

Subject of the action record
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<ACTION_OWNER> Owner of the action
<ACTION_STATUS
>

Status of the user's individual action record

<ACTION_DUEDAT
E>

Due date of the user's individual action record

<ACTION_CATEGO
RY>

Category of the action record

<ACTION_STARTD
ATE>

Start date of the action record

<ACTION_PRIORIT
Y>

Priority of the action record

<ACTION_HOST> Title and link to the associated host item, for example the
diagram or document

<ACTION_DETAILS
_LINK>

Direct link to the action record

<ACTION_SIGNOFF
_LINK>

Direct link to the user's My Actions page with the 'Change
Status of Action' dialog displayed for the particular action
record

To modify the text of a number of the substitution text fields, from the Tools menu choose

Configure Text Fields. Select the text field and click Edit Text. Modify the text, then click OK .

To create a new substitution text field, in the Configure Text Fields dialog (from the Tools menu

choose Configure Text Fields) click New Field , then enter the input field name. To define the
notification text for the newly created substitution text field, select the field and click Edit Text.

Notification Styles

Common styles can be defined and applied to the text in system notification Emails. In the
Notification Email Text dialog, click the Common Styles tab (on the right) to select it. The Common
Styles tab serves as a CSS (cascading style sheet), so you can define HTML styles and apply them
to any notification text. Unless any other styles have been defined you will see the body style; this
style is the style of all notification text that is not formatted by any other style. 

To add or modify existing styles click Edit Text.
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For examples on using CSS, see www.w3schools.com/Css

Additional Information

Include new change log entries in subscription emails will include a change log of any new
changes made to diagrams and documents when subscribers are Emailed.

User must enter details when requesting authorization forces users to enter details when
requesting authorization of diagrams and documents. This information will appear in the Email sent to
authorizers.

Add change log entry when version number manually updated will automatically add a change
log when users manually update the version number of a diagram or document.

What if multiple Web Servers exist?

http://www.w3schools.com/Css
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If multiple Web Server installations exist that all point to the same Process Repository, you can specify which
URL is sent in notifications for individual users. See User account details for more information.

Who gets sent what?

Authorizations

Authorization requests and notifications are sent to the respective assigned authorizers. Authorization
rejections, cancellations and request cancellations are sent to the process author and owner of a map.

Acknowledgements

Acknowledgement request notifications are sent to the respective assigned acknowledgers.

Reviews

Review request and review completed notifications are sent to the respective assigned reviewers. Review
rejected notifications are sent to the originators of reviews.

Promotions

Promotion-ready notifications are sent to the respective assigned promoters.

Subscriptions

Subscription notifications are sent to the respective subscribers.

Draft Unlocked

When a draft diagram is unlocked, notifications are sent to the process author and owner of the diagram.

Actions

New actions notifications are sent to the respective assigned action users.

Overdue and Escalated Notifications

Overdue notifications, such as an overdue authorization notification, are sent to users to remind them
about an overdue To-do item. Escalated notifications are sent to users' line managers to inform them that
one of their direct reports has an overdue To-do item.

Notification Descriptions

Notifications are an important aspect of managing process content as they ensure that users are notified of any To-
do actions that are assigned to them. These To-dos are triggered by key stages within the process management
life cycle and ensure this life cycle is backed up by solid workflow to ensure contributors are currently updated with
the latest version of a process or document. This guide provides a definitive list of all notification types in
Nimbus®, their respective triggers and recipients.

Note: Notifications require that the Action Server is installed and configured to utilize your corporation's email
system. See the Administration Guide for information on installing and configuring the Action Server. Users must
also have an email address and mobile number defined in their user accounts to receive the appropriate
notifications.

Notification type Recipient(s)

Acknowledgements

Acknowledgement Request
Acknowledgement request created
for a diagram or document

Assigned Acknowledgers

Acknowledgement Reminder
User has not acknowledged an item
before the set reminder date

Assigned Acknowledgers
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Overdue Acknowledgement
User has not acknowledged an item
before the set due date

Assigned Acknowledgers

Escalated Overdue
Acknowledgement
User has not acknowledged an item
before the set escalation date

User's Line Manager

Actions

New Action
Action created for a diagram,
document, metric link, storyboard
or a general action

Action Assignees

Action Cleared
User has completed an action

Action Owner

Action Reminder
User has not completed an action

Action Assignee

Overdue Action
User has not completed an action
before the set due date

Action Assignee

Escalated Overdue Action
User has not completed the action
before the set escalation date

User's Line Managers

Authorizations

Authorization Request
Authorization request created for a
diagram or document

Assigned Authorizers

Authorization Notification
User authorizes an item

Originator

Authorization Rejection
User rejects an item

Originator

Authorization Request
Canceled
Originator cancels an authorization
request after an authorizer has
authorized an item

Assigned Authorizers

Authorization Canceled
Originator cancels an authorization
request after an authorizer has
authorized an item

Assigned Authorizers

Overdue Authorization
User has not authorized an item
before the set due date

Assigned Authorizers

Authorization
User has not authorized an item
before the set reminder date

Assigned Authorizers

Escalated Overdue
Authorization
User has not authorized an item
before the set escalation date

User's Line Manager

Change Requests

Change Request Allocated
Change request owner allocates a
change request

Author

Change Request Implemented
Author makes the required
changes

Originator

Change Request - More
Information Required
Author requires more information

Originator
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Change Request Rejected
Owner rejects the change request

Originator

Change Request Removed
Owner deletes the change request

Current Assignee

Change Request Reviewed -
More Information Required
Owner requests more information

Originator

Change Request Reviewed And
Allocated
Owner progresses the change
request to the author to implement
the changes

Originator

Change Request Resubmitted
Originator modifies the change
request and re-submits it

Primary Email Contact (diagrams)

Owner (documents)

New Change Request to Review
Change request submitted for
diagram or document

Primary Email Contact (diagrams)

Owner (documents)

Draft Unlocked

Draft Unlocked
Author unlocks a diagram or
document for editing

Primary Email Contact (diagrams)

Owner (documents)

Memos

Memo Added Notification
User submits a memo against a
diagram or document

Primary Email Contact (diagrams)
Owner (documents)

Memo Reply Notification
User replies to an existing diagram
or document memo

Originator

Passwords

Password Reset Notification
Administrator resets a user's
password

User

Password Retry Limit Exceeded
User fails to log in to the system
after the defined number of
permitted retries

All Nimbus® Administrators

Promotion Ready

Promotion Ready Notification
All assigned authorizers have
authorized a diagram (note, this
does not apply to documents)

Draft Promoters

Reviews

New Review Action
New ad-hoc or recurring review
created

Assigned Reviewers

Review Action Cleared
User signs off a review

Originator

Review Action Completed By
All Reviewers
All review requests cleared

Originator

Review Rejected
Review request rejected by an
assigned reviewer

Assigned Reviewer
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Review Reminder
User has not reviewed an item
before the set reminder date

Assigned Reviewer

Overdue Review
User has not reviewed an item
before the set overdue date

Assigned Reviewer

Escalated Overdue Review
User has not reviewed an item
before the set escalation date

User's Line Manager

Subscriptions

Subscription Notification
Diagram or document updated
(promoted), or the version number
manually incremented

Subscribed Users

New Feedback
Feedback has been added to a
diagram or document

Subscribed Users

New Reply
A reply to feedback has been
added to a diagram or document

Subscribed Users

New Users

Welcome New User -

Contributor Account Created

New contributor added to the

system via synchronization

User

Welcome New User - Process

Author Account Created

New author added to the system

via synchronization

User

 Batch Server

Server Operation Cancelled
Operation run by the Batch Server
has been cancelled

Requested User

Server Operation Completed
Operation run by the Batch Server
has completed

Requested User

Server Operation Failed
Operation run by the Batch Server
has failed

Requested User

Reminders
These settings apply to reminders for acknowledgements, reviews, recurring reviews, actions, change requests
and authorization requests. 

Note: SMS and email reminders can only be sent to users if they have a mobile number and email address
specified in their user account. For escalation reminders, the line manager must be specified in the Reports To
field in users' accounts.

Enable email reminders will send email reminders to users for any overdue To-do items.

Enable SMS reminders will send SMS reminders to users for any overdue To-do items.

Reminder interval (days) is the frequency of days in which email and SMS reminders are sent.

Start reminders prior to due date (days) is the date in which to start sending email and SMS
reminders prior to the due date.

Enable escalations will send email and SMS reminders to users' line managers in order to escalate a
request.
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Start escalation after due date (days) is the number of days to send an email notification to users'
line managers.

Allow authors to change settings allows process authors to modify the notification and escalation
settings, as set above, before a request is sent out. If this option is disabled then the options set in the
system options will be applied and cannot be modified. 

The respective Reminders & Escalation user group permission must also be enabled for
a particular user group to allow an author to edit the reminder and escalation settings when
sending acknowledgement, authorization, review and action requests.

To change a value, double-click a row to display the options for a particular reminder. For example, double click
the Enable escalations row to enable or disable escalations for a particular To-do type.

Notification Text

The text that is sent out in notification emails can be modified in the System Options. The following items in the
Notifications system options  apply:

Acknowledgement Reminder
Action Reminder
Authorization Reminder
Review Reminder
Overdue Acknowledgement
Overdue Action
Overdue Authorization
Overdue Review
Escalated Overdue Acknowledgement
Escalated Overdue Action
Escalated Overdue Authorization
Escalated Overdue Review

Storyboards

Prompt user for change log entry if storyboard has changed will force a user to enter a change
log entry when modifying a storyboard.

Create a log entry when a user changes a storyboard will automatically create a change log
entry when a storyboard is modified.

Include attachments from input and output lines will include attachments on any activity input
and output lines when viewing a storyboard in Text View mode (note that this option does not apply to
the TIBCO Nimbus Player Desktop Edition and iPhone/iPad apps).

Show Storyboard icons on Activities will display relevant icons on each activity that is part of a
storyboard sequence 

Users

User Accounts

User account name separator is the separator that is used when creating user accounts (for example,
john.smith, john/smith, etc).

Default account name to lower case forces account names to be lower-cased.

Show logged in user name on title bar displays the name of the user name that is logged in on the title
bar.

Show totals for each user type in user accounts window displays the total number of users in the
system and the number in each user type category.

Show account name in full name displays the user's full name as well as the account name on the title
bar.

Additional fields for user accounts allows additional fields to be provided on all user accounts by
associating a data table. Note that if LDAP is being used, only the following data table field types are
supported - alpha, short alpha, URLs and pop-up lists.

Log On
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Enable automatic log on when account name matches network log on name will automatically log in
users when the client starts if their TIBCO Nimbus user name is identical to their network user name. Note:
LDAP must be enabled. For more information on LDAP synchronization see the Administration Guide that is
included on the CD.

Notify Administrators when password retry limit is exceeded will Email the administrators when
users exceed the permitted number of log in attempts as specified below.

Incorrect password retry limit is the number of failed attempts that users are permitted when logging
into their accounts. After the number of permitted retries is exceeded, TIBCO Nimbus will close and the user
must launch the application to retry logging in.

Minimum password length defines the minimum number of characters permitted for user account
passwords.

Minimum password complexity allows you to specify that passwords must contain at least 1, 2 or 3 of the
following password security requisites (0 means that passwords do not require any of the requisites):

· Uppercase and lowercase characters

· Numericals (0 - 9)

· Non-alphabetic characters (e.g. !, $, #)

Password expiry period (in months) is the number of months that passwords are valid for before users
are forced to change them.

Default Author Settings

These settings apply to all process authors. 

Note: These features can also be enabled or disabled for individual process authors in their user settings.

General Map Functions

Allow Map Packaging allows process authors to package any map that they have access to.

Allow Unpackaging allows process authors to unpackage a map into a process repository.

Allow Creation of New Maps allows process authors to create new maps. Note: If you deselect this option
and do not want process authors to create new maps you must also deselect the Default Map Creation
option in the System Options and select User specific map creation privileges option.

Allow Folder Create, Rename and Delete allows process authors to create and delete map folders in a
process repository.

Resources

Central Resource Manager allows process authors to manage the central resource library, including being
able to add, edit and delete central resource values. By default this will mean that process authors can see
all central resource costs.

See Central Cost allows process authors to see all central resource costs.

Local Resource Manager allows process authors to create, edit and delete local map resources.

Web Interface Options

Allow Access to Maps Page allows process authors to view the Maps page in the web server.

Miscellaneous

Action Manager allows process authors to create actions, edit actions and manage users' actions..

Action Creator  allows process authors to create actions.

Data Tables Manager allows process authors to create, edit and delete data tables.

Rules Manager allows process authors to create, edit and delete highlight rules.

Storyboard Manager allows process authors to create, edit and delete storyboards.

Scorecard Manager allows process authors to create, edit and delete scorecards.

Scorecard Editor allows process authors to edit scorecards.

Statement Set Manager allows process authors to create, edit and delete statement sets.

Report Manager allows process authors to create, edit and delete scheduled reports.
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Landing Page

Choose a default landing page for all authors. A landing page is a URL, such as a TIBCO Nimbus Web Server
page, that users will be directed to after logging in to the Web Server. Note: Landing pages are defined in
System Options - General.

Default Contributor Settings

These settings apply to all contributors, regardless of what modules they have.

Note: These features can also be enabled or disabled for individual contributors in their user settings.

Settings

Change Subscription allows users to subscribe and unsubscribe from diagrams and documents.
Access Logs allows users to view audit, acknowledgement and change logs.
Send Emails allows users to send emails to diagram owners and authors.
See Diagram Details allows users to view the details of diagrams.
Change the Diagram Scale allows users to change the scale of diagrams.
See Draft Maps allows users to view draft diagrams.
See Draft Documents allows users to view draft documents.
See Promotion Ready Diagrams allows users to view promotion ready diagrams.
See Promotion Ready Documents allows users to view promotion ready documents.

Feedback

See Feedback allows users to view all feedback for process content that they have access to.
Add Feedback allows users to add feedback to process content.

Change Requests

See Change Request allows users to view all change requests for process content that they have access to.
Add Change Request allows users to add change requests.

Landing Page

Choose a default landing page for all contributors. A landing page is a URL, such as a TIBCO Nimbus Web
Server page, that users will be directed to after logging in to the Web Server. Note: Landing pages are
defined in System Options - General.

Default Change Module Settings

These settings apply to all contributors with the Change Module.

Note: These features can also be enabled or disabled for individual contributors (with the Change Module) in
their user settings.

Settings

See Draft Maps allows users to view draft diagrams.
See Draft Documents allows users to view draft documents.
See Scenarios allows users to view scenario diagrams.
See Central Cost allows process authors to see all central resource costs.

Web Interface Options

Allow Access to Maps Page allows users to view the Maps page.
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Default Action Module Settings

These settings apply to all contributors with the Action Module.

Note: These features can also be enabled or disabled for individual contributors (with the Action Module) in their
user settings.

Settings

Action Manager allows users to create actions, edit actions and manage users' actions.

Action Creator allows users to create actions.

See Draft Maps allows users to view draft diagrams.

See Draft Documents allows users to view draft documents.

Advanced

Restructure Locking Timeouts

Inactive Use Timeout is the number of minutes of inactivity on a particular diagram before a user is
automatically logged out.

Pending Lock Polling is the time period that the system will check for users waiting to perform a
restructuring operation. See About diagram locking for more information.

Resources

Allow dynamic resource updating on draft locked diagrams will dynamically update resources in
locked draft diagrams without having to unlock the draft and go through the authorization cycle again.

Enable advanced draft locked resources update facility will allow resources that have been
renamed to be updated in locked draft diagrams without having to unlock the draft and go through the
authorization cycle again. For more information on updating resources in locked draft diagrams see 
Updating draft resources.

Business Controls

Include resources when updating the style of a business control activity will update
associated resources if a business rule is applied that changes the style of the activity. Deselect this
option if you do not want the resource style to also change.

Reports

Minimum physical memory required to run a report is the minimum amount of free system
physical memory required before any reports can be run. It is worth noting that running reports can
consume a considerable amount of memory, especially in Citrix environments.

Image Handling

Large images can affect performance, especially if many images are used in process maps (such as images
on diagrams and background images). The following settings will force the reduction of stored images.

Automatically reduce large images will reduce the size of images used in maps if larger than
800x600.
Maximum height before needing reduction is the maximum height permitted for original stored
images before they are reduced.
Maximum width before needing reduction is the maximum width permitted for original stored
images before being reduced in size.
Reduced image size should be no more than is the maximum percentage (compared to the
displayed image size) permitted for original stored images before being reduced.

Automation Properties
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Enable automation properties on activities allows activities to be labeled for automation when
exporting to Business Studio from the web.

Map Administration

About map administration
Process Maps are a collection of process diagrams, created by process authors, that reside in a process
repository. A map is initially created as a draft version until it is promoted to a master version. Maps may also
comprise a number of scenarios. Access rights can be assigned to individual users and groups, allowing or
preventing access to an entire map or parts of a map. Map administrators can be assigned and these users have
administration privileges for a given map.

Assign map administrators
and draft promoters 

Promote multiple maps Create a folder in the
process repository

Edit folder access rights Remove broken flow line
links

Remove broken diagram
links

Delete a map and recover a
deleted map

Set map access points Set map options

Create and remove drafts Update draft resources Build line link back links

Refresh diagram titles Remove non-visual data Define map abbreviations
and references

Toggle the display of
activity IDs on or off

Remove broken file links Update styles

About diagram locking
When a user accesses a diagram it becomes locked in order to prevent other users from changing it. A lock can
also be caused by another user performing, or waiting to perform, a restructuring operation, for example
resetting ID numbers, inserting a diagram, etc. The diagrams affected by a restructuring operation will remain
inaccessible until the operation is complete.

After a period of user inactivity (set in the system options) the lock will be automatically released and the
diagrams can then be accessed.

Assign map administrators
Map administrators have certain administrative privileges on maps. For example, map administrators can modify
map properties, change access rights, add and remove authorizers, request authorization, cancel authorization,
add and remove reviews, edit and delete recurring reviews, add and remove acknowledgers, request
acknowledgement and manage subscriptions. Only process authors and administrators can be assigned as map
administrators.

Note: Assigning a user as a map administrator does not automatically provide them with access to a map.

1. From the Map menu choose Map Properties.

2. Select the Map Administrators tab.

3. Click Add Administrator  to add users.
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Assign a Primary Email Contact
The Primary Email Contact can be set as either the owner or author for a scope of diagrams. Primary Email
Contacts are notified when new change requests are submitted, or existing ones resubmitted, when draft diagrams
are unlocked and when new feedback is submitted against a diagram.

1. From the Manage menu choose Primary Email Contact.

2. Choose either owner or author.

3. Select the scope to assign the Primary Email Contact to, then click OK.

Assign draft promoters
Draft promoters can promote draft diagrams to master diagrams. By default the person who created the map is
automatically assigned as a draft promoter but any user can be a draft promoter. 

Note: Assigning a user as a draft promoter does not automatically provide them with access to a map.

1. From the Map menu choose Map Properties.

2. Select the Draft Promoters tab.

3. Click Add Promoter  to add users.

Promote multiple maps
Multiple maps can be promoted in one operation from the Open and Manage window.

  Available to administrators only

1. In the Open and Manage window (from the File menu choose Open / Manage), hold Ctrl and select the maps
that you want to promote.

2. Right-click a selected map and choose Promote.

Create a folder
Maps can be organized in folders within a process repository and access to these folders can be defined. Only
administrators and process authors may create, delete and edit folders. Note: They must have the Allow Folder
Create, Rename and Delete option enabled in their user settings.

 

1. From the File menu choose Open/Manage.

2. Click Create Folder.

3. Click in the New Folder Name text box and enter the folder name.

4. Select the default view rights of all users.

Access Allowed allows users to view the folder and access the maps within.

Access Denied prevents users from viewing the folder and accessing the maps within.

Note: To define specific users or user groups view rights, click Add  and select the user(s) or user

group(s).
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Hint: To optimize security it is also advised to establish a secured process repository. For more

information please refer to the Administrator's Guide that is supplied on the CD.

Rename a folder
Map folders can be renamed. 

Note: You must have access rights to a particular folder to rename it.

1. From the File menu choose Open/Manage.

2. Right-click the folder that you want to rename and choose Rename Folder.

3. Click in the New Name field and type the new name for the folder, then click OK.

Edit folder access rights
Access rights to folders within the process repository can be defined for all users and specific users and user
groups. Only administrators can modify folder access rights.

1. From the File menu choose Open/Manage.

2. Right-click a folder in the process repository and choose Edit Access Rights.

3. Select the default view rights of all users.

Access Allowed allows users to view the folder and access the maps within.

Access Denied prevents users from viewing the folder and accessing the maps within.

Note: To define specific user or user group viewing rights, click Add  and select the user(s) or user

group(s).

Hint: To optimize security it is also advised to establish a secured process repository. For more

information please refer to the Administrator's Guide that is supplied on the CD.

Set map access points
You can define whether process authors and users access a map at the draft or master level.

1. From the Map menu choose Map Properties.

2. Select the Accessing tab.

3. Choose the default entry point from the relevant drop-down list for process authors and users.

Note: To define specific user and user group entry points click Specific User Entry Point. C lick Add

 and select the user(s) or user group(s).

Set map options
Map settings can be applied for all users of the map. Advanced features allow drafts to be created or removed,
resources updated, line link back links to be built and all non visual data to be removed.

1. From the Maps menu choose Map Properties.

2. Select the Options tab.
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Settings

Include master map in web search will include the master version of the map when users
search in the web interface.

Include draft map in web search will include the draft version of the map when users search in
the web interface.

Include scenario map(s) in web search will include any scenarios of the map when users
search in the web interface.

Show draft banner when in draft copy will display the word Draft in the background of all draft
diagrams. This is automatically turned on when a draft is promoted.

Prevent unpackage overwriting will prevent the map from being overwritten in an unpackage
operation.

Allow Shapes Toolbar allows process authors to use the Shapes toolbar.

Create a log entry when a user changes a diagram will automatically create a 'Updated at
<hh:mm> log entry whenever a diagram is changed or saved.

Advanced Features

Create New Draft

Update Draft Resources

Clear Non Visual Data

Remove Draft Copy

Build Line Link Back Links

Remove Broken File Links

Remove Broken Diagram Links

Remove Broken Flow Line Links

Update styles

Add maps to users' favorites
You can add a selection of maps to one or more user groups' Web favorites. When a map is added, it will add the
level 1 diagram to users' favorites.

1. From the File menu choose Open/Manage.

2. Select the map(s) that you want to add to user groups' favorites.

Hint: Hold Ctrl to select multiple maps.

3. Right-click one of the selected maps and choose Add to User Group Favorites.

4. Select the user group(s), then click OK.
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Web Diagram Display Mode
Maps created in the Author Client can be opened in the Web Server in either Classic or Modern mode.  Choose
how to display a process map in the Web Server.

1. From the Map menu choose Map Properties.

2. Select the Advanced tab.

Classic mode  A map created in the Author Client will be available to view only in the Web Server. 

Modern mode permits view and edit, however the following functionality will not be available;
Background colors and images, BPMN shapes and lines, Costing, Flowchart shapes, Menu function
links, Metrics, Signposts, SAP links and certain Business styles will not be applied.

Click Check compatibility to identify which items on the diagram will not be accessibility before
opting in.

Note: The compatibility report is run against master, draft, and scenario maps.

 3.    C lick OK.

Note: This feature is disabled if the classic diagram conversion is turned ON in the Web Server. After you
convert your classic diagram to a modern diagram in the Web Server, you cannot edit it in the Author
Client. For more information on converting classic maps to modern maps, see the Map Conversion
guide.

Add a default data table attachment
A data table is a flexible way of capturing data significant to a process and within the context of activities, for
example business requirements, system details used to perform activities, KPIs (Key Performance Indicators),
audit results, etc.

Note: By default, upon installation an <Activity-DEFAULT> data table is added to the System Tables in the Data
Table Management Console.

Note: The <Activity-DEFAULT> data table uses RACI charting, (Responsibility, Accountability, Consult, Inform).

Note: The default data table definition can be amended.  For more information see Rename a data table.

For more information on creating and using data tables, see Data Tables.

Add a default data table:

1. From the Map menu choose Map Properties.

2. Select the Advanced tab.

3. Select the Create a default data table attachment for each new activity check box.

4. From the drop-down select the Data table definition to use.

6. Click OK.

Add a default data table with an empty record:

1. From the Map menu choose Map Properties.

2. Select the Advanced tab.

3. Select the Create a default data table attachment for each new activity check box.
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4. From the drop-down select the Data table definition to use.

5. Select the Add an empty record to the data table check box.

Note: When running a report all blank records will be available to amend or update. For more information

see Amend data table records

Related topics

Generate a data table report

Create and remove drafts
Existing drafts can be deleted and a new draft created from the master. This could be useful if a master has been
packaged and a draft is required in order to work on, for example.

To remove the current draft and create a new draft:

1. From the Map menu choose Map Properties.

2. Select the Options tab.

3. Click Create New Draft.

To remove the current draft without creating a new draft:

1. From the Map menu choose Map Properties.

2. Select the Options tab.

3. Click Remove Draft Copy.

Related topics

Scenarios

Update draft resources
Automatically update all resource names in a map that have been renamed in the resource library.

Note: This option is only available if the Enable advanced draft locked resource update facility system
option is enabled. See Advanced System Options for more information.

1. From the Map menu choose Map Properties.

2. Select the Options tab.

3. Click Update Draft Resources.



Administration

TIBCO Nimbus® User GuidePage 41

Build line link back links
You can ensure that all flow line links have working links to diagrams in a selected scope of diagrams, i.e. all
inputs connect to outputs and vice-versa.

1. From the Map menu choose Map Properties.

2. Select the Options tab.

3. Click Build Line Link Back Links.

4. Select the scope of diagrams to check and click OK.

Related topics

Flow line links

Remove broken file links
Broken file links can be removed from all diagrams within a map, i.e. any links that point to non-existent files can
be removed, including locked diagrams and master maps. This is useful if you want to share a map without the
associated attachments.

Note: Any diagrams that you do not have at least Read access to will be ignored.

1. From the Map menu choose Map Properties.

2. Select the Options tab.

3. Click Remove Broken File Links.

4. Click OK to continue with the operation.

Remove broken diagram links
Broken diagram links can be removed from all diagrams in the currently open map, including diagram
attachment links, sign posts and sign post logo links. Note that links to diagrams in the Deleted folder are not
treated as broken and therefore will not be removed as part of this operation.

Note: Any diagrams that you do not have access to will be ignored.

1. From the Map menu choose Map Properties.

2. Select the Options tab.

3. Click Remove Broken Diagram Links.

Remove broken flow line links
Broken flow line links can be removed from all diagrams in the currently open map. A broken flow line link is a
flow line that links to a non-existent diagram or map. Note that if the diagram that is linked to still exists, but the
target flow line no longer exists, the flow line link will be maintained. This rule also applies to links to diagrams in
the Deleted folder.

Note: Any diagrams that you do not have access to will be ignored.

1. From the Map menu choose Map Properties.
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2. Select the Options tab.

3. Click Remove Broken Flow Line Links.

Refresh diagram titles
When a drill down is created from an activity, the child diagram title will assume the parent activity's ID. You can
automatically update child diagram titles if the parent activity IDs are modified using the Refresh Titles option.

Note: Some diagram titles may be locked and prevented from being edited.

1. From the Map menu choose Refresh Titles.

2. Select the scope of diagrams to refresh the titles for.

Current Diagram updates the current diagram from the parent diagram only.

Current Diagram And Lower Levels updates the current diagram from the parent diagram and
all child diagrams from that level.

Current Process Map updates all diagrams in the process map.

Remove non-visual data
Non-visual data (feedback, change requests, subscriptions, acknowledgement log, change log, history audit log,
authorizers, reviewers and acknowledgers) can be removed from a selected scope of diagrams.

1. From the Map menu choose Map Properties.

2. Select the Options tab.

3. Click Clear Non Visual Data.

4. Select the items that you want to remove.

5. Select the scope of diagrams that you want to remove the items from.

Create a backup archive before clearing the selected items will create an archive of the selected

diagrams. It is advisable that this option is enabled as removing non-visual data cannot be undone.

Delete a map
Maps can be deleted.

Note: This method will not permanently delete a map and maps can be restored following this operation.

1. From the File menu choose Open/Manage.

2. Select the process map and click Delete.

Note: To permanently delete a map you must do this from the Deletion Recovery Manager (from the

File menu choose Deletion Recovery Manager).

Related topics

Recovering deleted maps
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Recover a deleted map
Deleted maps and diagrams can be restored. Master and draft maps must be recovered separately.

Note: Diagrams that have been deleted by removing a drill-down will be restored as a new map. To reintegrate it
back into a map you must import it as a drill down.

 

1. From the File menu choose Deletion Recovery Manager.

2. Select the maps and diagrams that you want to recover.

Note: Hold Ctrl to select multiple maps or diagrams.

3. Click Recover and select a destination.

Clearing Recovered Map Entries

Once a map or diagram has been recovered it will appear as gray in the list. To remove all recovered
map log entries, from the File menu choose Clear Redundant Entries.

Related topics

Deleting maps

Define abbreviations
Abbreviations that are used in maps can be defined and made accessible to users in the web server.
Abbreviations that are added to master maps will be automatically copied to the draft version. Abbreviations
added to draft maps will be copied over to the master version when a diagram or map is promoted.
Administrators and process authors can add, edit and delete abbreviations in the web server.

1. From the Map menu choose Abbreviations.

2. From the File menu choose New.

3. Enter the abbreviation and its meaning in the respective text boxes.

4. Click OK.

Note: To delete an abbreviation, select it from the list and from the File menu choose Delete.

Importing Abbreviations

You can import a set of abbreviations from a CSV file with the following format:

<Abbreviation>,<Meaning>

For example:

WIP,Work in progress
TBC,To be confirmed
...
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From the Map menu choose Abbreviations. From the File menu choose Import
from CSV. Select the file to import and click Open.

Note: Abbreviations are limited to 994 characters.

Commas within the text

If there are commas within the text that you are importing, please ensure that you
enclose them within quote marks, otherwise the text will not be imported correctly.
Also, there must be no space after the comma.

The following will work:

BPM,Business Process Management "," John Smith

The following will not work (due to the space after the comma):

BPM,Business Process Management ", " John Smith

Related topics

Defining references

Define references
References that are used in maps can be defined and made accessible to users in the web server. References
that are added to master maps will be automatically copied to the draft version. References added to draft maps
will be copied over to the master version when a diagram or map is promoted. Administrators and process
authors can add, edit and delete references in the web server.

1. From the Map menu choose References.

2. From the File menu choose New.

3. Enter the reference id and reference in the respective text boxes.

4. Click OK.

Note: To delete a reference, select it from the list and from the File menu choose Delete.

Importing References

You can import a set of references from a CSV file with the following format:

<Reference>,<Description>

For example:

CAUR,Common Approach Uncommon Results (Ian Gotts)
BPM,Business Process Management (John Smith)
...

From the Map menu choose References. From the File menu choose Import
from CSV. Select the file to import and click Open.

Commas within the text

If there are commas within the text that you are importing, please ensure that you
enclose them within quote marks, otherwise the text will not be imported correctly.
Also, there must be no space after the comma.

The following will work:

BPM,Business Process Management "," John Smith

The following will not work (due to the space after the comma):
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BPM,Business Process Management ", " John Smith

Related topics

Defining abbreviations

Toggle the display of activity IDs
The display of activity IDs (automatically assigned by the system when an activity is created) can be toggled on
or off.

1. From the Map menu choose Toggle IDs.

2. In the Toggle Activity IDs panel choose to turn activity IDs on or off.

3. Select the scope of diagrams to apply the operation to.

Related topics

Diagram scope lists

Redirect Unloaded Attachments
When unloading packaged maps into a process repository, it is possible to redirect where attachments are saved
to.

1. From the Administration menu choose Attachment Unload Redirection.

2. Click Add.

3. In the File or filter text box define a specific file or file type that you want to redirect.

For example, *.doc will redirect all files with the .doc extension. You can also define a specific file, such as
Sales2007.ppt, which will redirect only that specific file.

4. Click Browse to select a folder to use as the redirected attachment save folder.

5. Click OK.

Removing Rules

Select the rule from the list and click Delete, or double-click the rule and deselect Redirect enabled.

Reordering Rules

You can reorder the rules in order of precedence by selecting the rule and clicking Move Up  and Move

Down . For example, if the first rule in the  list redirects Document1.doc to Folder A and the second rule
redirects general *.doc files to Folder B, if Document1.doc is unloaded it will be sent to Folder A as this is the
first rule that applies in the list.

Related topics

Importing maps

Packaging maps
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Updating Styles
You can update all attachment icons and drill down arrows by applying a selected style sheet. This method will be
applied to all draft and master diagrams in a map, regardless of access rights and authorization statuses of
diagrams.

1. From the Map menu choose Map Properties.

2. Click the Options tab and then click Update Styles.

3. From the Style drop-down options, select the style sheet that you want to apply.

4. Select either Attachment Icons, Drill Down Arrows, or both.

5. Click OK.

Document Registry Administration

About Document Registry administration
The Document Registry, accessible in both the client and the web server, allows you to manage and control
external files (MS Office files, drawings, multimedia files, etc) and also make them available to authors in order
to associate with process activities. The Document Registry provides the following benefits and functionality:

Manage document information and version control

Information can be defined for individual files and all files have a unique ID. Information such as division,
department, document type, confidentiality level, etc., can be defined for files and files are subject to version
control.

Register files easily

Individual files or all files within a folder can be registered easily. Attached files on diagrams that are not already
in the Document Registry can also be registered.

Access files with simplicity and speed

Files can be easily accessed from the Document Registry, assuming users have the correct privileges to do so. A
powerful search facility allows documents to be searched for by a number of different fields, including defined
custom categories. Users also have the same access in the web server.

Link to files from maps

Documents in the Document Registry can be directly linked to from a number of different objects within a map.
The benefit of storing documents in the Document Registry means that users do not need to know the location of
the file.

Administration

Access to the Document Registry is determined by users' Document Registry access settings. Also, separate
access rights can be defined for individual files in the Document Registry. Document Registry administrators can
define Document Registry settings, document parameters, document types and confidentiality levels. Document
Registry administrators can also correct mistakes or change controlled information specific to a file without the
need to reauthorize a file.

Set the Document Registry system options
Document Registry system options allow administrators and Document Registry administrators to configure and
control various aspects of the Document Registry.

 

1. From the Documents menu choose Document Registry.

2. From the File menu choose Administration and then Document Registry System Options.

General
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Fields that must not be empty allows you to specify which fields are mandatory to define when users
register files.

Show All Files filter option by default makes the All Files option the default selection in the
authorization drop-down list.

Keep deleted records will keep any files that are deleted in the Document Registry. Deleted files
appear as light gray in the list and cannot be accessed unless reinstated (right-click the file and choose 
Undelete).

Enforce notes when unlocking draft forces users to enter a note when unlocking a draft document.

Include all files with master documents in authorized filters will include files that have been
promoted already (i.e. they have master versions) but are undergoing another review (i.e. their status is
Update Pending) when users choose to search by All Authorized in the Authorization filter.

Show access denied documents will include files that users do not have the rights to view in
Document Registry searches.

Automatically create back links for related documentation will automatically add back links to
files that are being referenced as related documentation by other files. For example, if you are adding
File B as related documentation for File A, then File A will also be added as related documentation in the
details for File B. This option will also remove both links if one of the related document links is removed.

Maximum list results for cached records mode is the maximum number of files that are returned
when users perform a Document Registry search in Cached Records mode.

File Locations

· Automatic relocation of new documents (Drafts) defines what happens to files when they
are registered in the Document Registry.

· Do not relocate will link to files in their existing location.

· Copy new documents when added will make copies of files in the Document Registry.

· Move new documents when added will move files into the Document Registry.

Location for promoted documents (Masters) defines where files are saved to when they are
promoted.

Web Link File Locations allows you to specify the location to save draft and master web link files
(.cwl) to. If no locations are specified then web link files will be saved to the Process RepositoryATTACH
\Web Links\Draft and the Process RepositoryATTACH\Web Links\Master folders.

Reviews

Manual Review Scheduling will require users to manually schedule file reviews, i.e. they must specify
the date and all other file review options.

Automatically schedule review upon authorization will automatically schedule a review when a file
is authorized. If this option is selected then you must specify the time period for the automatic schedule
to begin.

Defaults

Default Promoter allows you to specify a user who will automatically become the draft promoter when
files are registered. 

Note: To assign specific users or user groups select the Default to specific user option, click Define

and then click Add  to add user(s) or user group(s).

Drop Downs
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Define the display filter drop-down titles.

Prompt for drop down list item codes allows a code to be manually specified when Document
Registry drop-down items are created. If this option is disabled then a code will be automatically
assigned to drop-down items upon creation. If automatically creating a drop-down category, the first 3
letters will be used (for example, if a drop-down list is called Department, then drop-down list items
would have the codes DEP01, DEP02, etc.).

Access

Allow drop down fields to be updated on locked records allows the drop-down fields of promoted
files to be updated.

Allow comment field to be updated on locked records allows the comment field of promoted files
to be updated.

Allow author field to be updated on locked records allows the author field of promoted files to be
updated.

Allow draft version field to be updated on locked records allows the draft version of promoted
files to be updated.

Allow only administrators to set document access rights restricts the setting of file access rights
to administrators and Document Registry administrators only.

Allow owners and authors to define document promoters allows file owners and authors to define
document promoters, otherwise only administrators and Document Registry administrators can define
document promoters.

Define category drop downs
Up to seven category drop-down lists can be defined and used to categorize documents, thereby facilitating
filtered searching in the Document Registry. Drop-down items can be nested so that the selection of one item is
dependent upon the selection of a previous item.

To define the category labels:

1. From the Documents menu choose Document Registry.

2. From the File menu choose Administration and then Document Registry System Options.

3. Click the Drop Downs tab to select it.

4. Define or edit any of the drop-down labels.

5. Click OK.

To add category items to drop-down lists:

1. From the Documents menu choose Document Registry.

2. From the File menu choose Administration and then one of the Drop Down <x> List options.

3. Click New drop down item .

4. Enter the details for the drop-down item.

General tab
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Code (optional) allows you to enter a code. This is only visible if you add the respective code column for
the Document Registry and cannot be searched against.

Note: There is a Document Registry system option that disables this field, allowing the system to
automatically assign category item codes.

Name is the name of the drop-down item that is available for users to select from the drop-down list.

Group Under (optional) allows you to choose a drop-down item from a parent drop-down list. Note:
Drop-down list 2 items can only be grouped under drop-down list 1 items, drop-down 3 items can only be
grouped under drop-down 2 items, etc. If Item 2 is grouped under Item 1, then Item 1 must first be
selected before the user can select item 2.

Default allows you to set the drop-down list item as the default item. This will automatically select the
item in the drop-down list when a new file is registered.

User Groups tab

Associate user groups with a category item. When a file is registered and a category item is selected that
has associated user groups, those user groups will be automatically assigned to the file. See About My
Searches for more information.

1. Select the user group from the list of Available User Groups and click Add .

Keywords

Associate keywords with a category item. When a file is registered and a category item is selected that
has associated keywords, those keywords will be automatically assigned to the file. See About My
Searches and for more information.

Note: File categories can be updated over a scope of documents or all documents in the Document
Registry. See Updating file categories for more information.

1. Select a keyword from the list of available keywords and click Add .

Define specific user filter access
You can grant or restrict access to individual filter options in the authorization drop-down list for specific users
and user groups. For example, you may want to restrict users within a user group from being able to search for
unauthorized documents in the Document Registry.

1. From the Documents menu choose Document Registry.

2. From the File menu choose Administration and then Specific User Filter Access.

3. Click Add .

4. Click Select User or Group  and select a user or user group.

5. From the Filter Option choose the Authorization filter option.

6. From the Access drop-down list choose to either grant or deny access to the filter option.

7. Click OK.

8. Repeat steps 3-7 for each filter option that you want to define.
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Restore an archived document
A file is archived when a draft copy is overwritten with a new draft copy or a master copy overwritten with a new
master copy. Archived files can be restored.

Note: Files cannot be overwritten when restoring an archived file.

1. From the Documents menu choose Document Registry.

2. From the File menu choose Administration and then Administer Archive Manager.

3. Select the file that you want to restore and from the File menu choose Restore File.

Note: To permanently delete a file from the Document Registry, select the file and click Delete. 

Replace path names
Search and replace document file paths if the location of documents in the Document Registry have changed. 

Note: This operation cannot be undone and therefore an option to backup the Document Registry is provided
(files are backed up in the DocRegistry/Backup folder).

1. From the Documents menu choose Document Registry.

2. From the File menu choose Administration and then Path Name Replace.

3. In the Search On box either enter the path name or click Select Path Name To Search  to select the
path that you want to replace.

4. In the Replace With box either enter the path name or click Select Path Name For Replace  to select
the path that you want to replace with.

Build back links for related documentation
If a file is referenced by another file as a related document then you can create back links to ensure that the file
being linked to also references the file being linked from, i.e. the related documentation link works both ways.
This operation will run through the entire Document Registry and create back links for files that require it.

Note: A Document Registry system option Automatically create back links for related documentation will
automatically create back links when documents are added as related documents.

1. From the Documents menu choose Document Registry.

2. From the File menu choose Administration and then Build Back Links for Related Documents.

Remove unused files
Files that are not linked to from process maps can be removed from the Document Registry and placed in a
specified folder.

1. From the Document menu choose Document Registry.

2. From the File menu choose Administration and then Remove Unused Documents.

3. Click Select Folder and choose a location to store the unused documents in.
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Define user access
Access rights to the Document Registry can be defined for individual users. See Editing user accounts for more
information.

User Administration

Summary of User Rights

Summary of user rights

The following user account types exist in TIBCO Nimbus.

Process Authors
Users responsible for the creation, editing and management (reviews, authorizations) of process content held within

the Process Repository. Process Authors have access to both the Author Client and Web Client.

Process Authors with the Administrator role allow these users to perform the same tasks as the Administrator user

account in previous versions of Nimbus®, for example they have access to all functionality in Nimbus®, and they

can undertake administrative tasks and integrate with third-party applications.

Contributors
Consumers of processes and related content who have access to the Web Server. Contributors have limited access

to functionality through the Web Server, however a contributor’s capability can be augmented by additional licenses

of one or more modules.

· Contributors with the Action Module have access to the action management functionality. This means that

they can view actions, have actions assigned to them and create new actions.

· Contributors with the Change Module have access to authorizations and reviews, and can manage access

rights and unlock diagrams that they own. This means that they can be requested to authorize and review

process content. Additionally, contributors with this module can view the cost of central resources, access

scenario maps, and access the Maps page in the web. If the license permits it, these users also have access

to the Author Client (please contact Technical Support if the contributor requires access to the Author

Client). However, without this module, contributors can still be requested to acknowledge process content,

and they can also view and add change requests and feedback. 

· Contributors (which now includes Mobile Module) can download storyboards and associated attachments

from the Web Server to the TIBCO Nimbus Player Desktop Edition, iPhone, iPad and iPod.

Functionality
Contributor Account

Contributor Change Module and
Diagram Owner

Action Module

Authorize

Review

Unlock Diagrams

Manage Access
Rights

Acknowledge

Create Change
Requests

Add Feedback

Create/View
Actions

See Central
Resource Costs
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View Drafts

View Scenarios

View Maps Page

Change Diagram
Scale

Table. Access Rights for contributors (in the Web)

Additional System Roles

There are a number of additional roles that can be assigned to Process Authors and Contributors, providing them
with further access to functionality within TIBCO Nimbus. These roles are assigned in the Settings tab of the User
Account window.

Process Authors

Action Manager allows users to manage users' actions, and create/modify action categories and statuses.
Action Creator allows users to create actions.
Data Tables Manager allows users to create data table definitions and data table folders. These users can
also delete and modify data table definitions and data table folders for definitions and folders where they
have been granted read/write access.
Data Tables Administrator allows users to create, modify and delete any data table definition and data
table folder regardless of access rights.
Rules Manager allows users to create, delete and modify highlight rules.
Storyboard Manager allows users create, delete and modify storyboards.
Scorecard Manager allows users to create, delete and modify scorecards.
Scorecard Editor allows users to modify existing scorecard records.
Statement Set Manager allows users to create, delete and modify statement sets.
Statement Set Administrator allows users to create, delete and modify statement sets regardless of
access rights
Account Manager allows users to create and manage non-administrator type user accounts.
Central Resource Manager allows users to manage the Central Resource Library. Users can add, delete
and edit central resource values. By default these users can see all central resource rates.
See Central Cost allows users to see the cost rates of central resources.
Local Resource Manager allows users to create, edit and delete local map resources.
Report Manager allows users to create, edit and delete scheduled reports.

Note: Process Authors with the Administrator account type are assigned the above system roles by default.

Contributors

Action Manager allows users to manage users' actions (requires Action Module), and create/modify action
categories and statuses.
Action Creator allows users to create actions (requires Action Module).
See Central Cost allows users to see the cost rates of central resources (requires Change Module).

Resources and Roles

Resources

A resource dictates who, or what, is responsible for completing a particular activity in a process. At the higher
level processes of an enterprise, the activity resource is usually the process owner, i.e. the person ultimately
responsible for the overall process. At the lower levels, resources are usually the job titles, machines and
systems responsible for executing specific activities. Multiple resources may be assigned to a single activity as
well as permitting single resources to be assigned to multiple activities. It is also possible to merge two resources.

Resources are managed in resource libraries. Rates can be defined for resources which allows for activity-based
costing to be performed for a process. Users that do not possess specific cost viewing rights will not be able to
see costs for resources in the Central Resource Library.

Note: It is possible to automatically update all resource names in a map. For more information see Updating
draft resources.
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Reporting on Resources

A number of resource-based reports are available in the Author Client, including:

Resources: Identifies where a selected resource exists within a specified scope of diagrams and displays
information such as the diagram, activity, other resources, etc. Note that Suppliers are the other resources on
any activities connected as inputs to a particular activity, and Customers are the other resources on activities
connected as outputs from a particular activity.

Resource Groups: Shows a list of all resource groups. 

Resource Costs: Builds a list of all resource within the specified scope of diagrams and includes all costing
information relevant to the activity resource relationship. 

Resource Usage: A usage count for all central resources. This is based on the resources used across a
selected scope of diagrams. 

User Resources: Lists all the users and their resource roles. 

User Activities: Identifies all activities where a selected user or user group exists based on their assigned
resource roles within a specified scope of diagrams. 

For information on reporting see Generating reports.

Resources are managed in resource libraries and two types of resource library exist. Central Resource Library
holds resources that are available to all maps in the Process Repository, whereas Local resource libraries
hold resources that are associated with specific map versions, for example draft maps, scenarios, etc. Local
resources are only visible to the maps that they are associated with, although local resources can be copied to
the Central Resource Library. Resources are usually created/added to local libraries and then moved to the
Central Resource Library if that resource is going to be used as a standard resource within the Process
Repository.

Note: Where a resource exists in both the central and local library, the local resource cost will override the
central resource when activity-based costing is calculated and the resource state will display Override.

Related topics

Creating resources  
Creating resource groups  
Importing resources  
Editing resources and resource groups  
Roles  
Process costing
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Resources are job titles, systems or machines that are assigned to specific activities within a process to identify
responsibility for completing that activity. For more information see About resources. 

Click here to view a screenshot of the Resource Library dialog

To create a resource:

1. From the Tools menu choose Resources and then Resource Library.

2. In the Resource Library dialog, select either the Central Library or a local map.

Note: If resource groups exist you can create a new resource within a group by selecting the group
before proceeding to Step 3.

3. From the Resource menu choose New.

4. Enter the following details for the new resource:

Resource Name is the full title of the resource (for example, Supervisor of IT Planning and
Coordination).
Display Name is the name of the resource as it will be displayed on activities (for example,
Supervisor).
Info Field 1 and Info Field 2 allows additional information to be added about the resource, for
example department.
Rate is the rate of the resource, defined as Per second, minute, hour, day, week or year.

Note: The Display Name will be used to display the resource on activities. If the Display Name is not
specified then the Resource Name will be used.

Support for multiple languages

In the Language Variant panel you can define the resource in a different language (the available
languages are set by an Administrator in the System Options). The resource text that is displayed
will depend on the user's PC locale; the default language will be displayed if a user's PC locale is set
to a language that has not been defined for a particular resource.

5. Click OK.

To copy resource to a resource group:

1. From the Tools menu choose Resources and then Resource Library.

2. Right-click the resource from the Central Library or a resource group and choose Copy.

3. Right-click the resource group and choose Paste.

Note: A copy of the resource will always exist in the Central Resource Library. This method allows you
to promote a local resource to a central resource.

Related topics

Adding resources

Merging resources

Importing resources

Creating resource groups

Deleting resources and resource groups
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Editing resources and resource groups

Assigning roles

There may be a case where two resources exist in the resource library that are the same but assume different
titles. Resources can be merged into one and all references to both resources will be directed towards the single
merged resource.

1. From the Tools menu choose Resources and then Resource Library.

2. Right-click the resource that you want merge into another resource and choose Select Item for
Merge.

Note: The resource selected here will be deleted and the information will be merged into the resource
selected in the next step. If any information is different then the information in the resource selected in
the next step will be maintained.

3. Right-click the second resource that you want to merge the first resource with and choose Merge with
Selected Item.

Related topics

Creating resources

Importing resources

Creating resource groups

Deleting resources and resource groups

Editing resources and resource groups

Assigning roles

Resources can be imported in CSV format.

The format is name,cost,info field 1,info field 2,display name,group name

Examples:

Printer,2,HP (Color),First Floor,HP Color Printer,Printers
Fax Machine,2,Sony,Second Floor,Sony Fax Machine,Fax Machines

Note: All fields but the name field are optional. If you are specifying a group then it must already exist in the
process repository as groups are not created as part of the import process.

1. From the Tools menu choose Resources and then Resource Library.

2. From the File menu choose Import Resources.

3. Locate the CSV file and click Open.

Related topics

Creating resources
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Merging resources

Creating resource groups

Deleting resources and resource groups

Editing resources and resource groups

Assigning roles

Central and Local resources can be grouped and resource groups can be nested within other groups. Once a
resource group is created you can drag resources into the group.

Note: If the resource is a Central resource then it will be copied into the resource group.

1. From the Tools menu choose Resources and then Resource Library.

2. Select the Central or Local library.

Note: You can create a sub-group by selecting an existing resource group.

3. From the Group menu choose New Group.

4. Enter the group name and a group description.

Support for multiple languages

In the Language Variant panel you can define the resource group in a different language (the
available languages are set by an Administrator in the System Options). The resource group text
that is displayed will depend on the user's PC locale; the default language will be displayed if a
user's PC locale is set to a language that has not been defined for a particular resource group.

5. Click OK.

Related topics

Creating resources

Merging resources

Importing resources

Deleting resources and resource groups

Editing resources and resource groups

Assigning roles

1. Right-click the resource or resource group and choose Properties or Group Properties respectively.

Related topics

Creating resources

Merging resources
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Importing resources

Creating resource groups

Deleting resources and resource groups

Assigning roles

Resources and resource groups can be deleted (if you have the rights to do so). Deleting a local resource will
remove the resource and all references to it in a map. Deleting a central resource will remove the resource and all
references to it in maps except where a local copy exists, in which case the references will remain. Deleting a
resource that exists in a resource group, or deleting a group, will only remove the resource from the group, i.e. it
will not delete the resource. Where the resource exists in both a local library and the central library and the
resource is deleted from the local library, the resource will remain in the central library and all map references will
then refer to the central resource.

1. From the Tools menu choose Resources and then Resource Library.

2. Right-click the resource or resource group and choose Delete or Delete Group respectively.

Related topics

Creating resources

Merging resources

Importing resources

Creating resource groups

Deleting resources and resource groups

Editing resources and resource groups

Assigning roles

Roles

Users can be assigned a variety of roles within an organization and this can be reflected in TIBCO Nimbus. Roles
provide the ability to align people with what they do in a process and to make their involvement visible. In TIBCO
Nimbus, roles are created by assigning central resources to users or user groups. For example, a resource exists
called Area Manager. By associating this resource to Fred Smith, Fred Smith will assume the Area Manager role
and any responsibilities associated with the role.

Roles can be associated with users, user groups, diagrams and storyboards. Assigning a role to a user group will
assign the role to all users within the group.

In the web server, users can search master diagrams, storyboards and transactions against their assigned
role(s). Users also have the ability to search for diagrams, storyboards and transactions against other roles that
exist.

Related topics

Assigning roles

Importing user roles

Creating resources
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Roles can be assigned to users, user groups, diagrams and storyboards. Assigning roles to user groups will
assign the role to all users within the group. Only Central Resources can be assigned as roles. For more
information see About roles.

Note: Roles are associated with diagrams by assigning resources to specific activities. See Assigning resources
for information on assigning roles to diagrams.

 

To assign a role to a user:

1. From the Tools menu choose Users and then User Accounts.

2. Right-click a member and choose Roles.

3. In the Select Roles dialog specify the resource search criteria and click Find.

Note: You can enter the resource name directly if you know it. You can also filter the search to the

Central Resource Library or to a specific local resource library. If you want to retrieve all resources
within the Process Repository then ensure the <ALL CENTRAL> group is selected and click Find.

4. Select a role and click Add Resources To List .

Hint: You can select multiple roles by holding Ctrl.

5. Click OK.

To assign a role to a storyboard:

1. From the Tools menu choose Storyboards.

2. Right-click the storyboard and choose Properties.

3. Click Roles.

4. In the Select Roles dialog specify the resource search criteria and click Find.

Note: You can enter the resource name directly if you know it. You can also filter the search to the
Central Resource Library or to a specific local resource library. If you want to retrieve all resources
within the Process Repository then ensure the <ALL CENTRAL> group is selected and click Find.

5. Select a role and click Add Resources To List .

Hint: You can select multiple roles by holding Ctrl.

6. Click OK.

To remove roles from users, user groups and storyboards:

1. Select a role from the list of associated roles (on the right) and click Remove Resources From List

.

Hint: You can select multiple roles by holding Ctrl.

Related topics
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About roles

User roles can be imported from CSV formats. A single resource may be assigned multiple roles.

The format is user account,role

For example:

Fred.Smith,General Manager
Fred.Smith,Technical Director
Kate.Jones,General Manager
Kate.Jones,Analyst

Note: If the user account does not exist then the line will be ignored.

1. From the Tools menu choose Users, then User Accounts.

2. From the File menu choose Import User Roles.

3. Locate the CSV file and click Open.

Users

About user accounts

There are three active user account types that exist, including:

Process Authors

These users create, edit and manage the content held within the Process Repository. Author are also
entitled to download and use the TIBCO Nimbus Player Desktop Edition and the TIBCO Nimbus Player
iPhone Edition.

Administrator - allows Process Authors to perform administrative duties in TIBCO Nimbus, including
creating and maintaining user accounts, configuring the system, running administrative tasks, integrating
with third-party applications, etc.

Contributors

These users have access to the TIBCO Nimbus Web Interface only. Contributors cannot create or modify
content in the Process Repository. See Summary of user rights for more information.

Change Module - allows contributors to assist in change management, including authorizations,
reviews, promotion, etc.

Action Module - allows contributors to use the action management functionality. Users can access the
Action Registry, be assigned to actions, edit actions and create actions. Note: To create actions users
must also be assigned either the Action Manager or Action Creator role (in the Settings tab).

Contributor (which includes Mobile Module) allows contributors to download storyboards and
associated attachments to their TIBCO Nimbus Player Desktop Edition, iPhone, iPod and iPad (limited to 3
devices).

Note: Any purchased 'Contributor' licenses entitle the user to the contributor account plus all associated
modules, i.e. Contributors with Change or Action modules.

Unassigned

These users have no rights or access in either the Desktop Client or the Web Interface.

Summary of User Rights...

Related topics
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Summary of user rights

Create a user account

Each TIBCO Nimbus user, including users of the web server, must have a user account setup that defines their
access rights, contact information, group membership, etc.

1. From the Tools menu choose Users and then User Accounts.

2. From the Member menu choose New User.

User settings

Related topics

Group permissions

Importing user accounts

Editing user accounts

Creating user groups

Assigning roles

Edit a user account

Administrators and account managers can update user accounts. See User details for more information on user
accounts.

Note: User accounts can be accessed from the User (Details) List report (accessed from the Reports menu in
the User Accounts window). Double-click a user account to access it.

1. From the Tools menu choose Users and then User Accounts.

2. Right-click the user account and choose Properties.

Hint: You can select the user's group in the left-hand pane to filter the display.

Related topics

User account details

Deleting user accounts

User account details

The following settings apply to user accounts. Depending upon the user account type, some settings will not be
applicable. To access a user's account details see Editing a user account.

General tab

First Name and Last Name are the user's real names.
Account is the user account name. This is automatically created once the user's first and last names are
defined, although it can be edited. Note: The account separator (default '.') is set in the System Options by
an administrator.
Password is the user account password that is required for the user to log into TIBCO Nimbus.

Additional informational fields include their mobile phone number, work phone number and Email address for
contact purposes.
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Important: For users to receive notifications, such as To-Do notifications, a valid Email address must be
specified.

Account Type is the user account type. For more information see About user accounts.

This account is not to be managed via LDAP will allow you to manage a user's account outside of LDAP.
By deselecting this option you can configure any of the parameters, for example user name, password, etc.,
for a particular user account. LDAP will ignore the user account when synchronization occurs. Note: This
option is only displayed if LDAP has been enabled. See the Administration Guide that is supplied on the CD for
more information on LDAP synchronization.

Details tab

Provide details about the user.

Reports To is the user's line manager. Past due (overdue) To-Do notifications are sent to users' line
managers.
Job Title is the user's job title.
Comment allows you to add a comment about the user (such as favorite animal).

The URL substitution field allows dynamic URL links that are user-specific to be defined in diagrams. If
<USER> appears in a URL link then it will be replaced by whatever text appears in the URL substitution field
for a specific user when the user accesses the URL. For example, USER1 has a URL substitution of DEV and
USER2 of CON. A diagram URL link is defined as the following:  

http://companyx/example/list.asp&dept=<USER>&view=1  

When USER1 launches the URL they will be directed to http://companyx/example/list.asp&dept=DEV&view=1.
 
When USER2 launches the URL they will be directed to http://companyx/example/list.asp&dept=CON&view=1.

Preferred Server allows you to choose the URL of the Web Server to send out in email notifications to a
particular user, assuming multiple Web Server installations exist. If no Web Server is specified then the
default Web Server will be assumed. The Web Server URLs are defined in the ServerURL.npdta file (.../TIBCO
Nimbus/Process Repository).

Landing Page allows you to choose a landing page for the user. A landing page is a URL, such as a TIBCO
Nimbus Web Server page, that users will be directed to after logging in to the Web Server. 

Notes: Landing pages are defined in the System Options - General. Administrators can specify a default
landing page for all authors and contributors. However, specifying a landing page for individual users will
override the default landing page. 

Hint: To specify a landing page for multiple users, hold Ctrl and select the users in the User Accounts
window and then right-click a selected account and choose Set Landing Page.

Street Address, City, State/Province, Zip/Post Code, Country are the user's address details.

Additional tab

Provide any additional information about the user. 

Note: This tab may not be present if the system has not been configured to enable additional information to be
supplied (see Users in the system options for information about associating a data table with user accounts).

Settings tab

Process Authors

The following roles and settings are available for Process Authors:

Allow Map Packaging allows users to package maps that they have access to.
Allow Unpackaging allows users to unpackage maps into the Process Repository.
Allow Folder Create, Rename and Delete allows users to create, rename and delete map folders in the
Process Repository.
Allow Creation of New Maps allows users to create new maps in the Process Repository.

Allow Access to Maps Page allows users to access the Maps page.
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The following settings allow you to define how SAP transactions are launched (note: SAP must be enabled
and configured by an administrator):

Allow user to select either SAP GUI or SAP web interface allows the user to launch SAP transactions in
both the GUI and web interface environments.
Use SAP transaction launcher allows the user to launch SAP transactions only in the SAP GUI.
Use SAP web interface allows the user to launch SAP transactions only in the SAP web-interface
environment.

Action Manager allows users to manage users' actions.
Action Creator allows users to create actions.
Data Tables Manager allows users to create data table definitions and data table folders. These users can
also delete and modify data table definitions and data table folders for definitions and folders where they
have been granted read/write access.
Data Tables Administrator allows users to create, modify and delete any data table definition and data
table folder regardless of access rights.
Rules Manager allows users to create, delete and modify highlight rules.
Storyboard Manager allows users to create, delete, modify and publish storyboards that they have access
to.
Scorecard Manager allows users to create, delete and modify scorecards that they have access to.
Scorecard Editor allows users to modify existing scorecard records.
Statement Set Manager allows users to create, delete and modify statement sets.
Statement Set Administrator allows users to create, delete and modify statement sets regardless of
access rights
Account Manager allows users to create and manage non-administrator type user accounts.
Central Resource Manager allows users to manage the Central Resource Library. Users can add, delete
and edit central resource values. By default these users can see all central resource rates.
See Central Cost allows users to see the cost rates of central resources.
Local Resource Manager allows users to create, edit and delete local map resources.
Report Manager allows users to create, edit and delete scheduled reports.

Contributors

The following roles and settings are available for Contributors in the Web Server:

Change Subscription allows users to subscribe and unsubscribe from diagrams and documents.
Access Logs allows users to view audit, acknowledgement and change logs.
Send Emails allows users to send emails to diagram owners and authors.
See Diagram Details allows users to view the details of diagrams.

Allow Access to Maps Page allows users to view the Maps page (requires Change Module).

The following settings allow you to define how SAP transactions are launched (note: SAP must be enabled
and configured by an administrator):

Allow user to select either SAP GUI or SAP web interface allows the user to launch SAP transactions in
both the GUI and web interface environments.
Use SAP transaction launcher allows the user to launch SAP transactions only in the SAP GUI.
Use SAP web interface allows the user to launch SAP transactions only in the SAP web-interface
environment.

Action Manager allows users to manage users' actions requires (requires Action Module).
Action Creator allows users to create actions (requires Action Module).
See Central Cost allows users to see the cost rates of central resources (requires Change Module).

See Feedback allows users to view all feedback for process content that they have access to.
Add Feedback allows users to add feedback to process content.
See Change Requests allows users to view all change requests for process content that they have access
to (requires Change Module). Note that users can still progress changes requests assigned to them without
this option enabled.
Add Change Request allows users to add change requests (requires Change Module). Note that users can
still progress change requests assigned to them without this option enabled.
See Draft Documents allows users to view draft documents (access rights apply).
See Promotion Ready Documents allows users to view draft documents but only if they have been
authorized and are awaiting promotion (access rights apply).

See Draft Maps allows users to view draft diagrams (access rights apply).
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See Promotion Ready Diagrams allows users to view draft diagrams but only if they have been
authorized and are ready for promotion (access rights apply).
See Scenarios allows users to view scenario diagrams (requires Change Module).
Change the Diagram Scale allows users to change the scale of diagrams.

Document Registry tab

The following rights are available for Process Authors and Contributors in the Document Registry.

Access Rights defines the level of access the user has in the Document Registry:

Administrator provides full access and administrative rights to the Document Registry.
Default provides almost full access to the Document Registry with no administrative rights. These users
cannot add folders, import links from a map or change the Document Registry system default layout.
Read Only provides only read access to the Document Registry or map attachment links that relate to
the Document Registry.
Access Denied restricts users from accessing the Document Registry. Note: For users to launch
documents in process maps they must have the Allow Launch option enabled.

Allow Launch allows users to launch documents from process maps (this applies only if the user has not
been granted access to the Document Registry).
Allow Delete allows users to delete documents that they have read/write access to in the Document Registry
(requires Change Module).

Membership tab

Group membership is selected here. For more information see About user groups. To add the user to a group,

select the group from the Available Groups list and click Add user to group(s) . Multiple groups can be
selected by holding Ctrl.

Information

View information about the user. Click Registered Devices to view a list of the different devices that a user has
downloaded storyboards to. You can remove a device from a user's account, for example if a user has a new PC.
Select the device and from the File menu choose Delete.

Profile

Provide additional information about the user and add a photo to their profile. You can also enable or disable
subscription settings for a user.

Notify me when a user leaves a feedback item will email the user when another user leaves feedback for
any diagrams or documents that the user is subscribed to.

Notify me when a user leaves a reply to a feedback item will email the user when another user replies to
feedback for any diagrams or documents that the user is subscribed to.

Hint: To specify the subscription settings for multiple users, hold Ctrl and select the users in the User Accounts
window and then right-click a selected account and choose Change Subscription Settings.

Related topics

About Resources
About Roles

Replace a user account

The Search and Replace functionality allows you to search through a process repository and replace one user
with another. For example, if an existing user leaves the company and a new user starts to replace that user, you
might want to transfer access rights, roles, To-do items, etc., to the new user.

  Available to administrators only

1. From the Tools menu choose User and then User Accounts.
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2. In the User Accounts dialog, from the Tools menu choose User Search and Replace Wizard.

The User Search and Replace Wizard is displayed.

3. Please read the information on the first step, then click Next.

4. Specify the target and source users, then click Next.

Select the target user that you are replacing in the Find text box. Select the source user that you are
replacing with in the Replace text box.

Options for handling duplicate users allows you to specify what to do in the case of duplicate users
being assigned to the same list, for example if both users are assigned as acknowledgers for a particular
diagram. Choose to remove the target where both users exist in the same list or to ignore it and leave
both users assigned.

5. Select the process data to include in the operation, then click Next.

Tell me more about the options (Online Help only)

6. Choose to run the operation now, or as part of the SSync process, then click Finish.

Note: You will not be able to do anything in the Author Client while the Search and Replace functionality is
working. It is therefore recommended that you run the process as a batch job, i.e. out of hours, especially if
there is a large amount of data in the process repository.

 

Viewing and Updating Batch Operations

If the operation has been run as part of the SSync process, i.e. as a batch operation, you can view past results
and modify the options of any pending items - in the User Accounts window, from the Tools menu choose Batch
Operations. A report-style window will be displayed.

To edit the options for a pending item, double-click the item. Pending items can also be deleted by selecting them
and pressing Delete. To open the log file for a selected item, right-click the item and choose View Log (note
that this option is only available for complete and failed items).

Logging

A log file is generated that logs the result of the operation (whether it has been run immediately or as a batch
operation), including any issues found. The log file is stored in ...\Process Repository\System\Logs\User
Search and Replace.

Change a user account type

You can change a user's account type, for example you may want to upgrade a contributor to a process author.

1. From the Tools menu choose Users and then User Accounts.

2. Select the user and from the User menu choose Change to and choose a user account type.

Related topics

Changing settings for multiple users

Update users' modules

You can enable or disable all modules, or individual modules, for selected contributors. Please note that you must
have sufficient licenses for specific account types to update users' modules.

1. From the Tools menu choose Users, then User Accounts.
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2. Select the user(s) that you want to change modules for.

3. From the User menu choose Change Module Settings, then choose one of the following options:

Enable Change Module enables the Change module for selected users.

Enable Action Module enables the Action module for selected users.

Disable Change Module disables the Change module for selected users.

Disable Action Module disables the Action module for selected users.

Enable Mobile Module for selected users.

Disable Mobile Module for selected users.

Enable All Modules enables all modules for selected users.

Disable All Modules disables all modules for selected users.

Related topics

Changing settings for multiple users
Change a user account type

Import user accounts

User accounts can be imported from a CSV file. The format is:

Last Name,First Name,Groups,Email,Account Name,Password,Account Type,Preferred
Server,Change Module,Action Module,Reports To,Job Title,Comment,URL Substitution,Landing
Page (name),Street Address,City,State/Province,Zip/Post Code,Country,Mobile Phone,Work
Phone,System Roles

For example:

Jones,Jack,Technical;Project Management;UK,jjones@email.com,Jack.Jones,******,Contributor,http://
<Server>/TIBCO Nimbus/CtrlWebISAPI.dll,True,False,True,John Doe,Engineer,Works from
home,Storyboards,1 Hollywood Drive,Los Angeles,California,123456,United States of
America,1234567890,9876543210,Statement Set Manager

Import Rules

· Important: If any of the fields in the CSV file are left blank and you choose to update existing user
information from the import file, any information that already exists for those blank fields will be removed in
the user's account.

· The password field is optional. If it is left blank then a random password will be generated and the new user
will be sent a Password Reset email.

· The groups field is optional. If used, one or more groups can be defined and separated by semi-colons and the
user will become a member of those groups. If the group does not exist then the group will be created.

· The preferred server field is the user's preferred server URL, as defined in the ServerURL.npdta file (set in the 
Details tab of users' account details). Either the full URL can be specified, or an integer value. This value is
case-insensitive and if no match is found then the default preferred server will be used.

· The account type field can be either Admin, Author or Contributor. For information on account types see
About user accounts.

· The Contributor modules field (which now include Mobile) can be Change or Action.

· The first line in the CSV file is ignored as it will be assumed that this contains column header information.

· A log file is created in the root of the Process Repository, listing all users that have been imported.

1. From the Tools menu choose Users and then User Accounts.

2. From the File menu choose Import User Accounts From CSV.

3. Click Browse to locate the CSV file.

4. Choose one of the following options:

· Ignore / Skip existing users will not update user accounts that already exist in the system.
· Allow passwords to be reset/changed for existing user accounts
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· Update existing users with information in the import file will update any existing user accounts
in the system with the information in the import file.
§ Only add new group memberships from import file will add any new group memberships

from the import file. Group memberships that do not exist in the import file will not be removed.
§ Overwrite group Memberships from import file will add new group memberships from the

import file. Any group memberships that are not in the import file will be removed.

5. Click OK.

Related topics

Creating user accounts

Editing user accounts

Importing user roles

Change settings for multiple users

You can change user settings and Document Registry access for users within the same group.

1. From the Tools menu choose Users and then User Accounts.

2. Select the users that you want to change settings for and from the User menu choose Change Settings
Across Multiple Users.

For information on user settings see User account details.

Related topics

Changing user account types

Reset a user's password

You can reset a specific user's password, for example if they have forgotten their password and have requested a
new one. The new password will be sent via email and the user may change it once logged in. New passwords are
randomly generated and the following rules apply:

· It must at least 8 characters in length, or the length specified as the Minimum password length if greater than
8, set in the system options.

· It must contain letters and numbers, or it must comply to the Minimum password complexity system option if
this is set to 3.

1. From the Tools menu choose Users and then User Accounts.

2. Double-click the user that you want to reset the password for.

3. Click Reset Password.

Change passwords for multiple users

It may be necessary to reset multiple user's passwords to a single password. Any new password specified must
adhere to the password complexity rules, as set out in the system options.

Note: This operation is available to TIBCO Nimbus administrators only.

1. From the Tools menu choose Users and then User Accounts.

2. Select the users that you want to change the passwords for.

3. From the User menu choose Change Password Across Multiple Users.
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4. Type a new password and click OK.

Delete a user

User accounts can be deleted.

1. From the Tools menu choose User and then User Accounts.

2. Select the user account and from the Member menu choose Delete.

To reinstate a user:

1. From the Tools menu choose User Accounts.

2. From the Reports menu choose Deleted User List.

3. Right-click the deleted user account and choose Recreate User.

To permanently delete a user:

1. From the Tools menu choose User Accounts.

2. From the Reports menu choose Deleted User List.

3. Right-click the user account and choose Purge User.

Reset a user's preferences

You can reset a user's preferences to the default settings again. This operation will also include any options the
user has selected when using TIBCO Nimbus, such as the default launch option for transaction links.

1. From the Tools menu choose Users and then User Accounts.

2. Select the user group to display a list of associated users.

3. Right-click the user and choose Reset User's Preferences.

4. Click Yes to confirm the operation.

Resend acknowledgement requests

When a user joins a new user group, you can resend them any previous acknowledgement requests that relate to
their new group membership. This ensures that users are made aware of any new processes, documents and
storyboards that relate to their new role.

 This option is only available to TIBCO Nimbus administrators.

Note: If the user has joined a group that is a member of other groups, i.e. the group is a sub-group of one or
more parent groups, they will also receive any acknowledgement requests that exist for associated parent
groups. 

To resend acknowledgement requests:

1. In the User Accounts window, right-click the user and choose Send Acknowledgements. 

2. Select the user group(s) that you want to send current acknowledgement requests for, i.e. select the group(s)
that the user has recently joined, then click Next. 

3. Define the reminder and escalation details and click OK.
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View active users

You can view which users are currently using the author client. If required, you can also send an email to all active
users.

1. From the Tools menu choose Users, then Active Users.

Email Active Users

To email all active users, from the File menu (in the Active Users window) choose Email All Active Users.

Remove Inactive Users

Sometimes user accounts may be shown as active but are actually inactive. This may occur, for example, if a
user quits the Author Client abnormally. To remove a user from the list of active users, select the user and
from the File menu choose Remove Record of Active User.

User Groups

About user groups

Users can become members of a group, thereby providing them with a variety of group-specific permissions.
Each user must be a member of one of the following default system user groups. These relate to a user's account
type and include the following: 

Everyone

This group contains all users. Upon installation of TIBCO Nimbus, the Everyone group will be assigned all
permissions, i.e. every user will have full access to the system.

Administrators

These users can create and maintain user accounts and have access to all features within the Author Client
and Web interface. At least one administrator must exist in the system.

Authors

These users create, edit and manage the content held within the Process Repository. By default, they have
access to the majority of functionality in TIBCO Nimbus and can access both the Author Client and Web
interface.

Contributors

These users have access to the Web Client only and have limited capabilities. Additional modules can be
assigned to contributors which provide additional access to functionality. See Summary of User Rights for
more information on contributors.

Unassigned

These users do not have any access to either the client or web server. Users in this group may have been
automatically added to the Process Repository following the unloading of a packaged map, for example.

Aside from the above system user groups, custom groups can be created. Users that are members of a custom
group will inherit the group's permissions. Roles can also be associated with a group, thereby associating the role
to all group members.

How do I view which custom groups users are members of?

You can view which custom groups users have been assigned to by including the Groups field in the User
Details List report. This is also useful as it highlights any users that are not members of any custom groups.
Note that this does not apply to the system default user groups (for example, administrators, process authors,
change managers, etc). 
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From the Reports menu (in the User Accounts window), choose User Details List. To add the Group column to
the report, from the View menu choose Column Customizing, then click and drag the Group column header
onto the existing report headers.

Create a user group

A user group will provide members with specific permissions associated with the group. Groups allow user
permission rights to be maintained easily without having to update individual user accounts.

Note: By default, user groups are not managed by LDAP. If you want a user group to be managed by LDAP you
must enable it specifically for each user group.

1. From the Tools menu choose Users and then User Accounts.

2. From the Group menu choose New Group.

General

Name and Description is the name and description of the user group.
This group is managed via LDAP allows you to use LDAP to manage the user group. If selected you
must enter the corresponding distinguished name as it appears in the directory service, for example:

CN=Sales,OU=Nimbus_Groups,DC=TIBCO,DC=co,DC=uk

Membership

Groups can be members of other groups and will inherit any unique permissions from the other
group(s). To add the group to another group, select the group from the Available Groups list and click 

Add group to group(s) . Multiple groups can be selected by holding Ctrl.

Permissions

Select or deselect specific group permissions. These permissions relate to functionality within the client,
allowing you to grant or restrict access to specific functionality.

Related topics

Importing user groups

Assigning roles

Group memberships

The following settings apply to user groups. Right-click a group in the User Accounts dialog and choose Group
Properties.

General

Name and Description are the names and descriptions of the user group.

Membership
Groups can be members of other groups and will inherit any unique permissions from the other group(s). To
add the group to another group, select the group from the Available Groups list and click Add group to group(s) 

. Multiple groups can be selected by holding Ctrl.

Permissions

Select or deselect specific group permissions. These permissions relate to areas of functionality that will
permit or restrict users from accessing in the client. See Group permissions for more information.
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Related topics

Group permissions

Group permissions

TIBCO Nimbus comprises a number of areas of features and functionality and each area can be enabled or
disabled on a user-group basis. Disabling certain features of functionalities for a user group will prevent users
within a particular user group from accessing them. This is useful, for example, if you don't want certain users to
access a particular area of functionality until they have been trained on it.

By default, the <Everyone> group allows all users to access all features and functionality of TIBCO Nimbus. If
you need to restrict access to a certain area of functionality or a particular function then you must disable that
option in the <Everyone> group. By disabling a feature or area of functionality, the feature or functionality
becomes controlled. You can then grant access to particular user groups by enabling the option in the properties
of specific user groups.

Note: User group permissions work in conjunction with user settings, so a user must have both a user group
permission and the associated user setting or role enabled for them to access a  particular function. You can still
assign a particular setting or role to a user, but if they are in a user group where the associated user group
permission is turned off, then they will not be able to access that particular functionality, or perform a particular
role. For example, if you assign the statement set manager role to a user, but the Statement Sets permission is
disabled for their user group, then the user will not be able to perform the duties associated with a statement set
manager as they will not have access to statement sets.

To disable features or functionality in the <Everyone> group:

1. From the Tools menu choose Users and then User Accounts.

2. Right-click the <Everyone> group and choose Group Properties.

3. Click the Permissions tab and deselect the options that you want to disable for all users.

Note: Whilst administrators are included in the <Everyone> group, you cannot disable functionality for the
Administrators group, i.e. administrators always have full access.

To enable or disable features or functionality for a specific user group:

1. From the Tools menu choose Users and then User Accounts.

2. Right-click the group and choose Group Properties.

3. Click the Permissions tab and select or deselect the options that you want to enable for those users within
the user group.

Note: If a user appears in two user groups, one with a particular feature disabled and one with it enabled,
the user will have access to the feature.

The following table describes each user group permission.

User Group Permission Description

Abbreviations Create, manage and view map abbreviations

Acknowledgements

Acknowledge Acknowledge content

Acknowledgement Log View acknowledgement logs

Acknowledgers Assign acknowledgers
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Reminders & Escalation
(Author)

Modify reminders and escalations when creating acknowledgement requests

Request Acknowledgement Request content acknowledgement

Actions

Action Management Removes access to all action functionality

My Actions Access My Actions list (Author Client)

Reminders & Escalation
(Author)

Modify default reminder and escalation settings when creating actions

Active Resources in the Web View information about resources (Web)

Archive Manager Archive and restore maps in Archive Manager

Archives (Web) Hides the archive section in the Web 

Attachment Analysis (Author) Report on all external file attachments referenced in a process repository

Attachment Overwrite Protection
(Author)

Prevent attachments from being overwritten in a map

Audit Trail List View content audit trail lists

Authorization

Audit Trail View audit trails for authorizations

Authorize/Reject Authorize content

Authorizers Assign content authorizers

Cancel Authorization Cancel authorization requests

Progress Tracking View progress of authorization requests

Promote Draft Copy Promote draft content

Reminders & Escalation Modify reminders and escalations when creating authorization requests

Request Request content authorizations

Resynch Diagram IDs Resynchronize diagram IDs

To Do List View Authorization To Do list and sign off requests through it (Author Client)

Unlock Draft Unlock draft content for editing

Backgrounds (Author) Modify map backgrounds

Change Log View change logs

Change Requests

New Change Request Create new change requests

Reminders & Escalation
(Author)

Modify reminders and escalations when creating change requests

View Change Requests View existing change requests

Compare and Update Compare and update diagrams

Costing

Costing Defaults (Author) Set costing defaults

Costing Visibility Toggle costing visibility on/off
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Refresh Hierarchically Refresh diagram costs hierarchically

Data tables

Data Tables Create and edit data tables

Show/Hide Show/hide data tables on activities

Deletion Recovery Manager
(Author)

Restore deleted maps and permanently delete maps in Deletion Recovery
Manager

Diagram Notation Switch between viewing simple and BPMN diagrams (if available)

Feedback Add feedback to content (Web)

Highlight Rules

Apply Highlight Rules Apply diagram highlight rules

Highlight Rules Create and manage highlight rules

Import/Export

Export to BPM-Xchange Export diagrams to BPM-Xchange

Export to MS PowerPoint Export diagrams to PowerPoint

Export to MS Project Export diagrams to Project

Export to MS Word Export diagrams to Word

Export to Simul8 Export diagrams to Simul8

Export to XML Export diagrams to XML

Import from ARIS (Author) Import data from ARIS

Import from BPM-Xchange
(Author)

Import data from BPM-xchange

Import from iGrafx (Author) Import data from iGrafx

Import from Visio (Author) Import data from Visio

Integrity Check (Author) Run diagram integrity checks

Keywords

Add Keywords Add keywords to content

Keyword Search Conduct keyword searching (Web)

Keywords Create and manage keywords/keyword groups, associate keywords with
users/user groups in the Keywords Library

My Searches Settings (Author) Associate keywords to content through My Searches options

My Searches Console (Author) Manage keywords and content associations in the My Searches Console

Package Map (Author) Package maps

Page Setup (Author) Define the page setup for printing

Primary Email Contact Specify primary email contacts for content

Print Print content

Recurring Reviews Create and manage recurring reviews

References Create, manage and view map references

Refresh Flow Link Titles (Author) Refresh flow link titles
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Refresh Input/Output Text (Author) Refresh input and output text on diagrams

Refresh Titles (Author) Refresh  diagram titles

Reports

Document Reports Generate and view document reports

Main Reports Generate and view main reports

Reports in the Web Generate and view web reports

Storyboard Reports Generate and view storyboard reports

User and Group Reports Generate and view user and group reports

Resources

Resources Library Create and manage central and local resources

Show/Hide (Author) Show/hide resources on diagrams

Reviews

Reminders & Escalations Modify reminders and escalations when creating reviews

Reviews Assign reviewers, create and manage reviews and sign-off reviews

Scenarios

Add/Remove/Rename (Author) Add and manage scenarios

Copy Scenario to Draft
(Author)

Create drafts from scenarios

Select View scenarios

Scorecards Enable or disable all scorecard functionality

Statement Link Indicators (Author) Display indicators on activities that do not have statements associated with
them (Author Client)

Statement Sets Enable or disable all statement set functionality

Storyboards Enable or disable all storyboard functionality

Subscriptions Subscribe to diagrams and documents (Web)

Swimlane Properties Create swimlane diagrams

Templates (Author) Create and manage diagram templates

Unload Packaged Map (Author) Unload packaged maps into a process repository

User Group Favorites

Global (Edit All User Group
Favorites) (Author) 

Edit group favorites for any user group (Author Client)

Membership Only (Author) Edit group favorites only for user groups that users are members of (Author
Client)

Version Manager (Author) Update diagram information in Version Manager

View

Activity Details Panel View the Activity Details Panel

Diagram List View the Diagram List

Feedback List View the Feedback List
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Hierarchical Diagram List View the Hierarchical Diagram List

Hierarchy Diagram View the Hierarchy Diagram

My Information View My Information

Object List View the Object List

Subscription List View the Subscription List

Toolbars & Panels Customize toolbars and panels

Web Delete Group Favorites Delete group favorite content (Web)

Web My Favorites Enable access to the Home page. 

If disabled, users will not have access to their Home page, nor will they be
able to add favorite items. The Visible Home Page sections and Custom Home
Page section will be also be hidden in users' My Profile.

Web My Roles Enable access to the My Roles page

Where Am I Enable access to Where Am I

Related topics

Group memberships
User settings

Categorise a user group

User groups can be categorized to allow for even more precise content targeting for users in the web server
within their My Searches tab. For more information see Defining user group categories.

Assign a user to a user group

Users can be assigned to one or more user groups. Users within the user group will inherit all user group
permissions and any specific access rights to diagrams, documents, storyboards, attachments, etc.

1. From the Tools menu choose Users and then User Accounts.

2. Click and drag the user onto the user group (in the left pane).

How do I view which custom groups users are members of?

You can view which custom groups users have been assigned to by including the Groups field in the User
Details List report. This is also useful as it highlights any users that are not members of any custom groups.
Note that this does not apply to the system default user groups (for example, administrators, process authors,
change managers, etc). 

From the Reports menu (in the User Accounts window), choose User Details List. To add the Group column to
the report, from the View menu choose Column Customizing, then click and drag the Group column header
onto the existing report headers.

Related topics

Creating user groups
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Import user groups

User groups can be imported from a CSV file. The format is:

Group Name,Group Description,Parent Group 1;Parent Group 2;Parent Group n,Use LDAP,LDAP
DN,LDAP Server

For example:

Group A,Group A Description,,Yes,Group1DN,LDAPServer1
Group B,Group B Description,Group A,Yes,Group2DN,LDAPServer1

The following rules apply:

· The first line in the CSV file is ignored as it will be assumed that this contains column header information.

· A log file (GroupImport.log) is created in the root of the Process Repository, listing the results of the import.

· Distinguished names must be unique.

1. From the Tools menu choose Users and then User Accounts.

2. From the File menu choose Import User Groups from CSV.

3. From the Select Import File field, click Browse to locate the CSV file that you want to import.

Ignore/Skip existing groups will not upload or modify any user groups that already exist in the system.
Allow passwords to be reset/changed for existing user accounts
Overwrite existing groups on import will update any duplicate groups in the system from the
information in the CSV file.

4. Click OK.

Related topics

Creating user accounts

Importing user accounts

Importing user roles

Delete a user group

You can delete user groups. User accounts that exist within the user group will not be deleted.

1. From the Tools menu choose User Accounts.

2. Select the user group (on the left) and from the Group menu choose Delete Group.

User and Group Administration

LDAP Management

LDAP management allows user accounts and groups to be managed automatically. 

There may occasionally be a requirement to add an account that is not part of your organizations LDAP.  For
example, if an administrator is required to test functionality, or an external body require temporary access for
audit purposes.
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Enabling and Disabling LDAP Management for Specific Users and User Groups

By default, if LDAP is enabled then user accounts will be automatically managed by LDAP. User groups are not

managed by LDAP unless specifically flagged.

To enable or disable LDAP user management:

1. Select Tools > Users > User Accounts.

2. Right-click the user and choose Properties. 

3. Select or clear the This account is not to be managed via LDAP check box.

To enable or disable LDAP user group management:

1. Select Tools > Users > User Accounts.

2. Right-click the user group and choose Group Properties. 

3. Select the This group is managed via LDAP check box.

4. Enter the distinguished name (DN) for the user group (this must match the corresponding directory server

group name). 

To disable LDAP management, clear the This group is managed via LDAP check box.

Note: If LDAP is enabled you cannot disable LDAP management for the main user group roles.

Note: LDAP group members that are not found will be skipped and will not be included as part of the

synchronized group.

To set the Ignore LDAP Flag (Admin Utility):

The Admin Utility allows you to enable or disable the Ignore LDAP flag for specific user groups. This is useful

if you want some groups to use a separate Nimbus® user name and password to log in, and some groups are

to be managed by LDAP.

1. Run the Admin Utility (AdminUtil.exe, found in the Utilities folder on the CD Image)  

2. From the Tools menu choose Toggle Ignore LDAP. 

3. Select to set the Ignore LDAP flag to On or Off 

4. Select the check boxes of your user types, and then click Apply.

Note: LDAP group members that are not found will be skipped and not included as part of the synchronized

group.

Statement and Audit Managers

Assign statement and audit managers

See Assigning statement set managers, Assigning statement managers and Assigning audit managers for more
information.

User Preferences

User Preferences

As a user you have a number of options that you can enable or disable depending upon your personal
preferences.

1. From the Tools menu choose Users and then Preferences.
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Display and Editing

Diagram access and display settings defines how maps are displayed when they are initially
accessed.

Always reset zoom will display diagrams at 100% zoom.

Zoom to fit, only when larger than viewable area will shrink diagrams that are larger than the
viewing area to fit on the screen.

Always zoom to fit will shrink large diagrams and expand small diagrams to fit on the screen.

Highlight parent when moving up a level will automatically highlight the parent activity when
you navigate up a level.

Enter text immediately when new activity created will prompt you to enter text whenever a
new activity is created.

Enter text immediately when new line created will prompt you to enter text whenever a new
flow line is created.

Automatically switch back to select mode after drawing will automatically switch the mode
back to Select and Edit following the creation of a new object.

Show process repository drive letter on caption bar will display the drive letter of the current
process repository on the Windows caption bar.

Show release number on caption bar will display the current major release number of TIBCO
Nimbus.

Automatically generate input and output activities on new drill downs will automatically
create the input and output activities, including flow lines, when a drill down is created. If deselected
then the new diagram will contain only the input and output flow lines, i.e. no activities.

Default to additional language panel if regional settings match will place the cursor in the
additional text entry field when defining the text for particular objects; however, there must be an
additional language variant specified in TIBCO Nimbus that matches the user's own regional language
setting. If disabled, or if the regional language setting does not match an available language variant,
the cursor will focus in the main default language text entry field.

Show all activities in the Activity Details Panel will display all activities in a diagram within the
Activity Details Panel, otherwise only a selected activity will be displayed.

General

Default Map Folder allows you to select to access a different process map folder upon start up.
Note: Only sub-folders within the current process repository can be selected.

Links

Launching URLs determines how URLs are launched in TIBCO Nimbus. The Standard URL
launching method option will launch the URL normally. The Non-standard URL launching
method will launch a web browser and pass URLs as parameters. This method is used if the
Windows configuration is setup so that it prevents URLs from being launched properly.

Show diagram link redirection prompt will prompt you to choose whether you want to redirect
diagram links when exporting or copying drill downs.

Show title prompt for new internal WP attachments will prompt you to enter the title of any WP
documents that are created.

Remember selected choice of SAP environment will remember the choice of SAP environment
to launch when a SAP transaction is launched in the Web Server. Deselect this option to prompt a
choice every time (where applicable).

Default User Preferences

Default user preferences can be defined and these are automatically applied to new user accounts that are
created. See User preferences for more information on specific options.

1. From the Tools menu choose Users and then Default Preferences.

2. Modify any settings and click OK. See User preferences for more information.
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Switching User Accounts

Switch user accounts

Switching user accounts provides you with the ability to test diagram access rights on a map, for example,
without having to log out and then in again as a different user. Note: The name of the logged-on user is always
displayed in the title bar.

1. From the Tools menu choose Users and then Switch User.

User Group Favorites

Manage user group favorites

In the Web Server, administrators can associate particular favorite items (such as diagrams, documents,
storyboards, metrics, reports) with specific user groups. Favorites appear on user's Home pages and
administrators can manage group favorites through the client.

You can also easily add multiple maps and documents to user groups' favorites. See Add maps to users' favorites
and Add files to users' favorites for more information.

1. From the Administration menu choose Manage User Group Favorites.

2. Do one of the following:

To copy a favorite item from one user group to another user group:

Right-click the favorite(s) and choose Copy Favorites.  Search for the user group(s) that you want to
copy to, select them and click OK.

Hint: To select multiple favorite items and user groups hold Ctrl.

To rename a favorite item:

Right-click the favorite item and choose Properties. Enter a new title and click OK.

To delete a favorite item:

Select the favorite item and press Delete.

Hint: To select multiple favorite items hold Ctrl.

To redirect a favorite item from draft to master, or vice-versa:

Metric and diagram favorite items point to either the draft or master version of a diagram. You can
redirect any group metric or diagram links from either the master to draft, or vice-versa.

Select the favorite item(s) and from the Tools menu choose Update Draft to Master or Update
Master to Draft.

Hint: To select multiple favorite items hold Ctrl.
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Creating Diagrams

Adding and Editing Objects

Activities

An activity is an event in a process that is initiated by an input or output, usually described by a verb (action) +
noun (person, place, thing, event, substance or quality).

Are you creating BPMN style diagrams?

1. Click Draw Activity  on the Drawing toolbar.

Note: To display the Drawing toolbar, from the View menu choose Toolbars & Panels. On the Toolbars
tab select the Diagram Button Bar check box.

2. With the crosshairs as your cursor, click and drag an area on the map to create an activity box, then release
the mouse button.

3. Enter the text for the activity in the text box and click OK.

Hint: When text is highlighted you can embolden (Ctrl+B), italicize (Ctrl+I) or underline (Ctrl+U) it.

Note: Right-click anywhere on the diagram after creating an activity to return to select mode.

Keywords

Selected text can be used to define and add keywords to the Keywords Library. Keywords created in this
way will be automatically associated with the current diagram. Highlight the text that you want to define as a
keyword, right-click it and choose Add as Keyword. See My Searches for more information on keywords.

Commentary Text

Commentary text is a way to provide additional supporting information about an activity to users. Associated
activity commentary text is accessible to users in storyboards, in the Activity Details Panel for a selected

activity and when a user hovers their mouse over the commentary icon  on an activity within a diagram.

To add commentary text to an activity, right-click the activity and choose Commentary. Commentary text
can also be created for multiple languages, as you can with general activity text. To prevent commentary
text appearing as hint text when users roll their mouse over the commentary icon, right-click the activity and
deselect Show Commentary as Hint Text. You can also deselect this option for multiple selected activities

in one operation. Commentary text can be edited by clicking the commentary icon  for an activity, or
right-clicking an activity and choosing Commentary.

Hint: You can also define commentary text at the same time as defining activity text. In the Text window,
after defining/modifying the activity text, choose File > Save and Edit Commentary.

Support for multiple languages

TIBCO Nimbus allows processes to be created to support multiple languages by allowing activity and
commentary text to be defined in different languages (the available languages are set by an
Administrator in the System Options). The text that is displayed will depend on the user's PC locale; the
default language will be displayed if a user's PC locale is set to a language that has not been defined for
a particular object.

To specify text for an additional language select Show additional language text entry panel, then
choose the language from the Language drop-down list and enter the text in the box below. Repeat this
step for any other languages that you want to define.

Note: If a language appears in red then the language variant is not supported in the current process
repository.
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Hint: To test how a diagram looks in a different language, from the View menu choose Switch
Language and then choose a language to display.

Drawing Tips

· To draw a square, hold Shift as you draw the activity box.

· You can automatically duplicate the last activity box that was created using a single click on the diagram

when the Draw Activity button  is enabled.

· To change the shape of an activity, right-click it and from the Colors And Styles menu choose
Change Shape.

· If you don't want to enter text whenever you create an activity you can switch off automatic text entry.
See User Preferences for more information.

· You can change the line and fill colors, line style and add object shadows.

· Run a spellchecker - from the Tools menu choose Check Spelling.

Related topics

Adding auto-generated activities

Adding flow lines

Creating drill downs

Adding resources

Adding attachments and links

Adding notes

Reassigning activity IDs

Moving objects

Locking objects
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Cutting, copying and pasting objects

Deleting objects

You can create a number of activities automatically and choose the layout.

1. From the Diagram menu choose Auto Generate Activities.

2. Select the activity shape, the amount of activities required and the layout.

3. Click OK.

Examples:

The following examples use 10 rectangle activities (specified in the Options panel).

Row

Column

Staggered

User Defined (3 x 3)

Related topics

Adding activities



Maps and Diagrams

TIBCO Nimbus® User Guide Page 82

Nimbus® diagrams can be exported to an XML file and then imported into TIBCO Business Studio for automation.
You can label activities by automation task type. The available task types are None, Manual Task, User Task,
Service Task and Receive Task. When you create a new activity it will be assigned the None task type by default.
When a resource is added it will automatically change to User Task.

Note: The Enable automation properties on activities system option must be enabled to allow activities to be
labeled for automation.

1. Right-click the activity and from the Task Type (Automation) options choose an appropriate task type for
the activity.

Flow Lines

A flow line forms the input and outputs of an activity. When an activity is moved within a diagram, the flow line
will remain connected unless it is disconnected first. Straight flow lines are used to connect two parallel, i.e.
aligned, activities and dog-leg flow lines are used to connect two activities that are not aligned.

 

1. Click either Draw Straight Line  or Draw Dog-leg Line  on the Drawing Toolbar.

Note: To display the Drawing toolbar, from the View menu choose Toolbars & Panels. On the Toolbars
tab select the Diagram Button Bar check box.

2. With the crosshairs as your cursor, click and drag a line from the start point to the end point. 

Support for multiple languages

TIBCO Nimbus allows processes to be created to support multiple languages by allowing diagram object
text to be defined in different languages (the available languages are set by an Administrator in the 
System Options). The object text that is displayed will depend on the user's PC locale; the default
language will be displayed if a user's PC locale is set to a language that has not been defined for a
particular object.

To specify text for an additional language select Show additional language text entry panel, then
choose the language from the Language drop-down list and enter the text in the box below. Repeat this
step for any other languages that you want to define.

Note: If a language appears in red then the language variant is not supported in the current process
repository.

Hint: To test how a diagram looks in a different language, from the View menu choose Switch
Language and then choose a language to display.
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Flow Lines

Joining two activity boxes with a straight line
If you are joining two activity boxes, simply click and drag from the inside of one activity
box to the inside of the other activity box.

Joining two activity boxes with a dog-leg line
An activity box has four sections when drawing a dog-leg flow line, allowing you to connect
from the top, bottom, left or right of an activity. Click and drag from one section of one
activity to another section of the other activity.

Related topics

Adding flow line text

Flow line links

Disconnecting flow lines

1.  Click the flow line to select it, move the cursor to the end of the flow line end which you want to disconnect

until a cross appears ( ), then drag the flow line out of the activity box.
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Note: If you cannot disconnect the flow line then it may be locked.

Related topics

Locking objects

Deleting objects

Text can be added to flow lines and the input and output triggers of activities can be defined in this way. The text
becomes associated with the flow line, therefore if the flow line is moved then the text is moved with it.

1. Double-click the flow line and enter the text.

Note: To change the font, from the Edit menu choose Font. When text is highlighted you can embolden (Ctrl
+B), italicize (Ctrl+I) or underline (Ctrl+U) it.

2. Click OK .

Keywords

Selected text can be used to define and add keywords to the Keywords Library. Keywords created in this way
will be automatically associated with the current diagram. Highlight the text that you want to define as a
keyword, right-click it and choose Add as Keyword.

See My Searches for more information on keywords.

Commentary Text

Commentary text is a way to provide additional supporting information about a flow line to users. Associated
flow line commentary text is accessible to users in storyboards, in the Activity Details Panel for a selected
activity and when a user hovers their mouse over the flow line within a diagram.

To add commentary text to a flow line, right-click the flow line and choose Commentary. Commentary text
can also be created for multiple languages, as you can with general flow line text. To prevent commentary
text appearing as hint text when users roll their mouse over the flow line, right-click the flow line and
deselect Show Commentary as Hint Text. You can also deselect this option for multiple selected flow lines
in one operation. Commentary text can be edited by right-clicking a flow line and choosing Commentary.

Hint: You can also define commentary text at the same time as defining flow line text. In the Text window,
after defining/modifying the flow line text, choose File > Save and Edit Commentary.

Support for multiple languages

TIBCO Nimbus allows processes to be created to support multiple languages by allowing diagram object text
to be defined in different languages (the available languages are set by an Administrator in the System
Options). The object text that is displayed will depend on the user's PC locale; the default language will be
displayed if a user's PC locale is set to a language that has not been defined for a particular object.

To specify text for an additional language select Show additional language text entry panel, then choose the
language from the Language drop-down list and enter the text in the box below. Repeat this step for any
other languages that you want to define.

Hint: To test how a diagram looks in a different language, from the View menu choose Switch Language and
then choose a language to display.
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When a part of a process resides outside of the process that you are mapping and it cannot be mapped for
whatever reason, for example if part of the process is the responsibility of a different company, you can mark an
input or output flow line as 'externally connected' to indicate this. Hints can be added to provide users with an
explanation.

1. Right-click the flow line and choose Externally Connected.

Note: You can change the display of the icon by right-clicking it and choosing Properties. To add a hint, right-
click the icon and choose Hint Text.

Images

 

1. Click New Image   on the Drawing Toolbar.

Note: To display the Drawing toolbar, from the View menu choose Toolbars & Panels. On the Toolbars tab
select the Diagram Button Bar check box.

2. With the crosshairs as your cursor, click and drag an area for your image to appear in.
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3. Locate the image and choose Open.

Image Tips

Rescale an image by right-clicking on the image and choosing Scale To.

Attachments and links can be added to images. See Creating Attachments and Links.

Images can be made transparent, allowing some objects behind an image to be visible.
Right-click the image and choose Transparent.

Related topics

Adding hints

Making images transparent

Replacing images

Resizing images

Deleting images

Moving objects

Locking objects

Cutting, copying and pasting objects

1. Right-click on the image and choose Reset Size to reset the size to its original size, or Reset Width or
Reset Height to reset the width or height.

Hint: Rescale an image by right-clicking on the image and choosing Scale To.

Related topics

Flipping images

Moving objects

Locking objects

Cutting, copying and pasting objects

Selecting objects

Images can be flipped vertically or horizontally.

1. Right-click the image and choose either Flip Horizontally or Flip Vertically.
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1. Right-click the image and choose Replace Image.

Setting an image to transparent will make some areas of the image see thru, allowing parts of objects to be visible
when the image is placed over them.

1. Right-click the image and choose Transparent.

Hint: To make an image opaque, repeat this step and deselect Transparent.

Related topics

Flipping images

1. Click the image to select it and press Delete.

Note: If the image has attachments or links associated with it, hold Shift when selecting the image to select
it.

Free Text

Free text allows you to add floating text to a diagram that is not attached to any objects.

1. Click Draw Free Text   on the Drawing Toolbar.

Note: To display the Drawing toolbar, from the View menu choose Toolbars & Panels. On the Toolbars
tab check the Diagram Button Bar check box.

2. With the crosshairs as your cursor, click and drag an area for the free text to appear in.

3. Enter the text and click OK . 

Note: To change the font, from the Edit menu choose Font. When text is highlighted you can embolden
(Ctrl+B), italicize (Ctrl+I) or underline (Ctrl+U) it.

Keywords

Selected text can be used to define and add keywords to the Keywords Library. Keywords created in this
way will be automatically associated with the current diagram.

Highlight the text that you want to define as a keyword, right-click it and choose Add as Keyword.

See My Searches for more information on keywords.

Support for multiple languages

TIBCO Nimbus allows processes to be created to support multiple languages by allowing diagram object
text to be defined in different languages (the available languages are set by an Administrator in the 
System Options). The object text that is displayed will depend on the user's PC locale; the default
language will be displayed if a user's PC locale is set to a language that has not been defined for a
particular object.
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To specify text for an additional language select Show additional language text entry panel, then
choose the language from the Language drop-down list and enter the text in the box below. Repeat this
step for any other languages that you want to define.

Note: If a language appears in red then the language variant is not supported in the current process
repository.

Hint: To test how a diagram looks in a different language, from the View menu choose Switch
Language and then choose a language to display.

Related topics

Moving objects

Locking objects

Cutting, copying and pasting objects

Deleting objects

1. Double-click the free text object.

2. Edit the text and click OK .

Note: To change the font, font color, font size, etc., of the existing text you must first highlight it. When text
is highlighted you can embolden (Ctrl+B), italicize (Ctrl+I) or underline (Ctrl+U) it.

Keywords

Selected text can be used to define and add keywords to the Keywords Library. Keywords
created in this way will be automatically associated with the current diagram.

Highlight the text that you want to define as a keyword, right-click it and choose Add as
Keyword.
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See My Searches for more information on keywords.

Notes Bubbles

Notes can be added to activities to provide additional information about an activity. Users can access the
information contained within a notes bubble by clicking it.

1. Right-click the activity and choose Notes Bubble.

2. Enter the text for the note and click OK .

Note: When text is highlighted you can embolden (Ctrl+B), italicize (Ctrl+I) or underline (Ctrl+U) it.

Keywords

Selected text can be used to define and add keywords to the Keywords Library. Keywords
created in this way will be automatically associated with the current diagram.

Highlight the text that you want to define as a keyword, right-click it and choose Add as
Keyword.

See My Searches for more information on keywords.

Support for multiple languages

TIBCO Nimbus allows processes to be created to support multiple languages by allowing diagram object
text to be defined in different languages (the available languages are set by an Administrator in the 
System Options). The object text that is displayed will depend on the user's PC locale; the default
language will be displayed if a user's PC locale is set to a language that has not been defined for a
particular object.

To specify text for an additional language select Show additional language text entry panel, then
choose the language from the Language drop-down list and enter the text in the box below. Repeat this
step for any other languages that you want to define.

Note: If a language appears in red then the language variant is not supported in the current process
repository.

Hint: To test how a diagram looks in a different language, from the View menu choose Switch
Language and then choose a language to display.
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Related topics

Adding hints

Moving objects

Locking objects

Cutting, copying and pasting objects

Deleting objects

1. Right-click the notes bubble and choose Edit Bubble Text.

2. Edit the text and click OK .

Note: To change the font, font color, font size, etc., of the existing text you must first highlight it. When text
is highlighted you can embolden (Ctrl+B), italicize (Ctrl+I) or underline (Ctrl+U) it.

Keywords

Selected text can be used to define and add keywords to the Keywords Library. Keywords
created in this way will be automatically associated with the current diagram.

Highlight the text that you want to define as a keyword, right-click it and choose Add as
Keyword.

See My Searches for more information on keywords.
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Hints

Hints can be added to free text, images, attachment logos, drill down icons and notes to provide extra
information to users when they hover the mouse over   specific object.

 

1. Right-click the object and choose Hint Text.

2. Enter the text for the hint and click OK .

Note: If you do not want the hint to be displayed until a later date then clear the Show Hint check box.
When text is highlighted you can embolden (Ctrl+B), italicize (Ctrl+I) or underline (Ctrl+U) it.

Support for multiple languages

TIBCO Nimbus allows processes to be created to support multiple languages by allowing diagram hint
text to be defined in different languages (the available languages are set by an Administrator in the 
System Options). The object text that is displayed will depend on the user's PC locale; the default
language will be displayed if a user's PC locale is set to a language that has not been defined for a
particular object.

To specify text for an additional language select Show additional language text entry panel, then
choose the language from the Language drop-down list and enter the text in the box below. Repeat this
step for any other languages that you want to define.

Note: If a language appears in red then the language variant is not supported in the current process
repository.

Hint: To test how a diagram looks in a different language, from the View menu choose Switch
Language and then choose a language to display.
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Related topics

Showing/hiding hints

Adding notes

Adding free text

1. Right-click the object and choose Hint Text.

2. Modify the hint text and click OK .

Note: To change the font, font color, font size, etc., of the existing text you must first highlight it. When text
is highlighted you can embolden (Ctrl+B), italicize (Ctrl+I) or underline (Ctrl+U) it.

Related topics

Showing/hiding hints

Hints can be displayed or hidden.

1. Right-click the object that has the hint attached and select or deselect Show Hint.
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Selecting Objects

Select an object

1. Ensure Select  is enabled on the toolbar.

2. Do one of the following:

To select a single object click the object to select it.

Note: If the object is linked, hold Alt when selecting it.

To select multiple objects hold Shift and click each respective object.

To select a group of objects click and drag a box around the group of objects and release the mouse
button.

To select all objects of a particular type use the following shortcuts:

Object Shortcut

All Objects Ctrl+A

Activities Shift+Ctrl+A 

Resources Shift+Ctrl+R

Link Lines Shift+Ctrl+L

Link Text Shift+Ctrl+T

Free Text Shift+Ctrl+F

Signposts Shift+Ctrl+S

Activity Logos Shift+Ctrl+G

Activity Notes Shift+Ctrl+N

Drill Down Logos Shift+Ctrl+D

Attachment Logos Shift+Ctrl+H

Signpost Logos Shift+Ctrl+P

Costing Boxes Shift+Ctrl+C

Images Shift+Ctrl+I

Related topics

Moving objects

Locking objects

Cutting, copying and pasting objects

Deleting objects
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Aligning, Resizing and Positioning Objects

Align an object

Objects can be aligned with other objects.

1. Click the object that you want other objects to be aligned with to select it.

2. Hold Shift and select the objects that you want to align to the object selected in Step 1.

3. From the Edit menu choose Align and one of the following options:

Lefts aligns the objects vertically with the left-hand side of the first selected object

Rights aligns the objects vertically with the right-hand side of the first selected object

Space Apart Centers creates equal spaces between objects horizontally

Tops aligns the tops of the objects in line with the first selected object

Middles aligns the middles of the objects in line with the first selected object

Bottoms aligns the bottoms of the objects in line with the first selected object

Space Apart Middles creates equal spaces between objects vertically

Related topics

Resizing objects

Aligning flow lines

Locking objects

Align flow lines

Flow lines can be aligned and merged when tidying up your diagrams.

To align floating ends of flow lines:

You can align the floating ends of flow lines in the same way that you align objects.

1. Select the flow line that you want to align against, then hold Ctrl and select the other flow lines that you are
aligning it with.

2. From the Edit menu choose Align and then either Lefts, Rights, Tops or Bottoms (depending on which
side of the activity the flow lines are).
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To align input and output flow lines:

You can align the input line with an output line on the same activity.

1. Select the flow lines that you want to align.

2. Right-click the flow line that you want to align against, then choose Align, then Align Selected Input/
Outputs.

To merge the start or end points of floating flow lines:

You can merge the start or end points of floating lines.

1. Select the flow lines that you want to merge.

2. Right-click the flow line that you want to merge the start or end points with and choose Align, then choose
one of the following options:

· Merge Floating Start Points will merge all the other floating start points with the start point of the
clicked-on flow line

· Merge Floating End Points will merge all the other floating end points with the end point of the
clicked-on flow line

Related topics
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Aligning objects

Resizing objects

Locking objects

Resize an object

Resize any object in a diagram. You can also resize objects in relation to a selected object.

To resize a single object:

1. Click the object to select it.

Note: If an object is linked, for example a sign post, hold Shift when selecting it.

2. Move the cursor over one of the resizing handles , then click and drag the handle to a new position.

To resize objects in relation to a selected object:

1. Click the object that you want to resize against.

Note: Hold Shift when selecting linked objects.

2. Hold Shift and select the objects that you want to resize against the object selected in Step 1.

3. From the Edit menu choose Size and then choose a sizing option.

Related topics

Aligning objects

Aligning flow lines

Locking objects

Lock an object's position

Locking an object to its position prevents the object from being moved. You can lock the position of any object in
a diagram, including activity elements such as attachments, notes, etc.

1. Right-click the object and choose Position Locked.

Note: To unlock an object, deselect Position Locked.

Related topics

Select an object

Moving objects

Cutting, copying and pasting objects

Deleting objects
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Moving Objects

Move an object

Objects can be moved in a diagram. If an activity is moved then any notes, attachments, etc., and flow-line links
to other activities will be maintained.

1. Click and drag the object to the desired location.

Note: To move an object that is linked, including notes, or if the object is small, hold Alt as you click and
drag it. You can also move activity elements, for example attachments or notes, from one activity to another
using this method.

If an object cannot be moved then it may be locked.

Related topics

Select an object

Locking objects

Cutting, copying and pasting objects

Deleting objects

Lock an object

Locking an object to its position prevents the object from being moved. You can lock the position of any object in
a diagram, including activity elements such as attachments, notes, etc.

1. Right-click the object and choose Position Locked.

Related topics

Select an object

Moving objects

Cutting, copying and pasting objects

Deleting objects

Cut, copy and paste an object

Objects can be cut, copied, and pasted within the same diagram or map, between maps or into applications that
recognize enhanced metafile formats such as Microsoft's PowerPoint and Word applications. Drill downs cannot be
cut however.

 

To copy or cut an object:

1. Select the object, then from the Edit menu choose Cut or Copy.
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To paste copied or cut objects:

1. From the Edit menu choose Paste.

Note: Activity-based objects, for example notes and attachments, can only be pasted onto other activities.

Related topics

Selecting objects

Locking objects

Moving objects

Deleting objects

Deleting Objects

Delete an object

Any objects can be deleted from a diagram (assuming you have the correct access rights).

1. Select the object and press Delete.

Note: If the object is linked, for example a free text box might be hyper-linked, hold Alt when selecting the
object. If you accidentally delete an object and want to restore it immediately, from the Edit menu choose
Undo.

Related topics

Select an object

Locking objects

Cutting, copying and pasting objects

Moving objects

Assigning Resources

Assign a resource

A resource is an individual, identified by their job title, or a machine or system, that is responsible for a particular
activity within a process. See About resources for more information.
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1. Right-click the activity and choose Resources.

2. Select the user to add as a resource.

3. Select or deselect the following options:

Show will display the resource on the diagram.

Costed will take the cost of the resource into account if costing is calculated. A resource that is
responsible for a particular activity but does not perform the activity might be a resource that is no
costed, for example. Resources that are not costed appear with an asterisk on the diagram.

Percentage is the percentage of time that a resource is dedicated to  a particular activity and is taken
into account when calculating process costs.

Reordering Resources

You can change the order of assigned resources as they are displayed on the activity by

selecting an assigned resource and clicking Move Up  or Move Down .

Resource Tips

To create a new local resource click Add Local Resource.

Resources can be copied from one activity to another. Simply click the resource to select it,
press Ctrl+C to copy it, select the activity that you want to copy it to and press Ctrl+V.
Alternatively, hold Ctrl, then click and drag the resource from one activity to another.

Related topics

Resources

Costing

Removing resources

Reporting

Remove a resource

1. Right-click the activity and choose Resources.

2. Choose the resource from the list of associated resources and click  Remove Resources From List.
Hold Ctrl to select multiple resources to add.

Display or hide a resource

Assigned resources can be displayed or hidden for a particular diagram or across a scope of diagrams.

1. From the Tools menu choose Resources and then Show/Hide.

2. In the Resource Name text box enter the name of the resource and click Find.

Note: To display all central resources and local resources for the current process you can click Find without
specifying a resource name.
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You can also specify part of a resource name in the Resource Name text box. For example, entering 'ad' will
return all resources with 'ad' in the name, such as Administrator, Admin Clerk, etc.

3. Select the resource(s) and click Add Resources To List .

4. Choose the scope of diagrams that you want the resource to be displayed or hidden for.

5. Select or deselect the checkbox in the Show column, as required.

6. Click OK.

Assigning resource hints

Hint text can be added to individual resources so that when users hover their mouse over a resource in the client
or web server a hint will be displayed.

1. Right-click the activity resource and choose Hint Text.

2. Select an appropriate option:

Show resource hint text as per system option will display either info field 1, info field 2 or the
custom hint text (which must be defined) as the hint text. See System Options (Display) for more
information.

Show resource info field 1 as hint text will display the resource's info field 1 as the hint text.

Show resource info field 2 as hint text will display the resource's info field 2 as the hint text.

Show custom hint text will display the text that you define in the Hint Text text box.

3. Click OK.

Hiding Resource Hint Text

To hide a resource's hint text, right-click the resource and deselect Show Hint.

Related topics

Creating resources

Text Tools

Replace text

It is possible to replace object or attachment-associated text in a map, including activities, note bubbles, lines,
sign posts, file and URL links, Excel measures, hint text and internal images.

Important Note: Replacing text cannot be undone, therefore it is advisable to package the map before
committing to this operation.

1. From the Search menu choose Replace.

2. Click in the Text To Find text box and enter the text that you want to replace.

3. Click in the Replace With text box and enter the text that you want to replace it with.

4. In the Scope tab select the scope of diagrams that you want to perform the search and replace on.

5. Select any of the options below:

Update Version Numbers will update diagram and attachment version numbers.
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Whole Words Only will only replace whole words as defined in the Text To Find box. If you want to
replace part of a word then deselect this option.

6. In the Search And Replace On tab select or deselect the objects that you want to perform the search and
replace on.

7. Click OK.

Related topics

Changing text cases

Finding text

Checking spelling

Change text cases

Text cases in activities, notes, lines, free text and sign posts can be changed for a scope of diagrams.

1. From the Tools menu choose Change Case.

2. Select the scope of diagrams to check.

3. Select the case option from the following:

UPPERCASE will change all text to uppercase.

lowercase will change all text to lowercase.

Word Case will change the first letter of every word to uppercase and all other letters to lowercase.

Sentence case will change the first letter in a sentence, dictated by a full-stop, to uppercase and all
other letters to lowercase.

Object case will change the first letter to uppercase and all other letters to lowercase (ignoring any
sentence structure).

4. Select which objects to apply the operation to.

5. Click OK.

Related topics

Replacing text

Finding text

Checking spelling

Find text

Search for specific object-related text within a scope of diagrams.

1. From the Search menu choose Find.

2. In the Text To Find text box enter the text that you want to search for.

3. Choose the scope of diagrams to search.

Whole Words Only will only replace whole words as defined in the Text To Find box.
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4. Select the Search On tab and select or deselect the objects to search on.

5. Click OK.

Related topics

Replacing text

Changing text cases

Checking spelling

Check spelling

Automatic correction

When defining the text for activities, flow lines, free text, storyboard steps, etc, incorrect words will be
automatically highlighted with a red underline (unless you have previously disabled this option). To correct a
highlighted mistake, right-click the underlined word and choose the correct spelling. Note that by default, some
words are automatically corrected as you type.

Other options available from the right-click menu:

Ignore will ignore the spelling in that instance only.

Ignore All will ignore the spelling in all instances, i.e. if the spelling appears in other objects then it will not be
highlighted as a mistake.

Add will add the word to your dictionary as a valid spelling.

Change All will change all instances of the spelling in the same text to a selected spelling.

Auto Correct will automatically correct this and all future spellings with a selected spelling.

Spelling will open the Spell Checker.

Configuring Your Spell Checker

A number of options allow you to customize the way in which your spell checker works. In the Spelling window
click Options. Here you can configure your spell checker by selecting or deselecting the various options.

Manual Correction

You can check the spelling of a number of objects in a diagram or scope of diagrams. You can also update diagram
version numbers if any amendments are made.

1. From the Tools menu choose Check Spelling.

Update version numbers will update the version numbers of any diagrams that are amended following the
spell check.

2. Choose the scope of diagrams to check.

3. Select or deselect any of the options that will be spell checked.

4. Click OK.

Related topics

Replacing text

Changing text cases

Finding text
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Assigning Access Rights

Assign access rights

User access rights can be defined for individual diagrams, a diagram and all lower levels, the entire process map
and a scope of diagrams. Note that default access rights are overwritten by any specific access rights that are
assigned to any diagrams within the selected scope.

More info on Access Rights...

 

1. From the Manage menu choose Diagram Access Rights.

2. Select the default access rights for all users.

Note: Specific access rights defined for users or user groups will override the default access rights.

Read and write allows the content to be modified.
Read only allows only change management information (feedback, change requests, etc) to be added but
the main content cannot be modified.
Access Denied prevents users from accessing the diagram(s).

3. Select the scope of diagrams to assign access rights to.

Note: See Diagram scope list files for more information on diagram scope lists.

4. To define access for specific users or user groups, click Add  and select a user or user group.

5. Click OK.

Related topics

Specific Access Rights Advanced Wizard

Diagram scope lists

System Options (Access)

Specific Access Rights Advanced Wizard

The Specific Access Rights Advanced Wizard allows diagram authors/owners and administrators to manage user
access rights across a scope of diagrams. Note that any default or specific access rights that exist for any
diagrams within the selected scope will not be overwritten.

Using the wizard you can:

· Copy access rights from one user or user group to another. This might be useful if a new user is temporarily
taking over the work from another user, but you don't want to remove the settings from the existing user.

· Replace user and user group access rights with another. This is useful if a new user is permanently taking
over the responsibilities of an existing user.

· Add and remove access rights for a user or user group. Use this option to update specific access rights
without overwriting the other access right settings that may have already been defined across the scope of
diagrams.

More info on Access Rights...
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1. From the Manage menu choose Diagram Access Rights.

2. Click Advanced Wizard .

3. Select one of the following options and click Next.

Pick Up and Apply Specific Rights will copy the user rights of a user or user group for a scope of
diagrams and copy them to another user or user group.
Replace Specific User or User Group will replace a user or user group and apply their access rights for a
scope of diagrams to another user or user group.
Add Specific User or User Group will assign specific access rights to a user or user group for a scope of
diagrams.
Remove Specific User or User Group will remove specific access rights of a user or user group for a
scope of diagrams.

4. Follow the steps in the wizard.

Note: If you have selected to replace the specific user or user group (second option) you must first select
the user or user group that you want to replace and then in the next step you then select the user or user
group that you want to replace them with.

Related topics

Assigning access rights

System Options (Access)

Reassigning Activity IDs

Reassign activity IDs

Activity IDs can be automatically reassigned, for example if activities have been moved to a new position in a
diagram, or if activities have been added/removed.

Note: If the IDs are not being reassigned correctly then check the alignment of the activities. For example, if an
activity on the top line is above the other activities then the operation will assume this is the first activity and
assign it ID 1, regardless of the order. For more information on aligning activities see Aligning Objects.

1. From the Diagram menu choose Reset ID Numbers.

2. From the Reset ID Numbers panel choose the direction of the resetting.

3. From the Scope panel choose the scope of diagrams to apply the ID resetting to.

Creating Language Variants

Creating Language Variants

TIBCO Nimbus allows process maps to be created in different languages. Specifically, diagram object text can be
defined in multiple languages. The object text that is displayed is dependent on the user's PC locale; the default
language will be displayed if a user's PC locale is set to a language that has not been defined for a particular
object. Some attachments and links can also be tagged for a particular language, for example you might have
two versions of the same document that are written in different languages, so you would tag each document with
the respective language and the version of the document that is made available to the user will depend on their
locale setting.

Note: The available languages are set by an administrator in the System Options. If a language appears in red
for a particular object then it is not supported in the current process repository.

To define a language variant for an object:
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1. Double-click the object to open the text editor for the object.

2. Select Show additional language text entry panel.

3. Choose the language that you want to define from the Language drop-down list.

4. In the bottom text box enter the text for the selected language.

5. Repeat steps 3 and 4 for other languages that you want to define.

6. Click OK.

To tag attachments and links with a language:

1. When adding an attachment or link, click the Advanced tab and from the Language Tag drop-down list
choose a language.

To tag an existing attachment or link

Right-click the object that has the attachment or link associated with it and choose Attachments/
Links. Right-click the attachment or link and choose Modify, then click the Advanced tab.

To view a diagram in a different language:

1. From the View menu choose Switch Language, then choose a language to view the diagram in.

Related topics

Translating languages



Maps and Diagrams

TIBCO Nimbus® User Guide Page 106

Translating Languages

There is an option to export diagram object text to a CSV file in order to allow external translators to translate
the text into other languages. The translated object text can then be imported back into TIBCO Nimbus.

Note: You must be an administrator or map administrator to export and import object text and only draft
diagrams can be modified, i.e. you cannot update master and scenario diagrams. Also, the import routine will
only update diagrams that the user has read/write access to.

Logs: A log file records who performed an export or import and what changes were made. This log file can be
found in <Installation directory>\TIBCO Nimbus\Process Repository\System\Logs\Translations.

Stage 1 - Exporting object text to file

1. From the Tools menu choose Reports.

2. In the Categories column select Diagrams.

3. In the Reports column select Object Language Text Variants.

4. In the Scope column select the scope of diagrams to export.

5. Click OK.

An Object Language Text Variants report will be displayed.

6. From the File menu choose Translators Export.

7. From the Language drop-down list choose the language that you want to export.

Note: The available languages are set by an administrator in the System Options.

8. Click Browse  and either select an existing CSV file, or enter a new file name to create a new file.

9. Click OK.

10. Click OK.

Stage 2 - Modifying object text

The exported translation file can be edited in any external CSV editor, however Excel is the recommended editor.
The format of the CSV file is as follows:

<Unique object ID>,<Default object text>,<Translated object text>,<Last modified>

Note: If an object has not been previously translated, the last two columns will be blank (e.g. <Unique object
ID>,<Default object text>,,)

Translating object text in Excel

1. Run Excel.

2. Choose Open and select Text Files as the File Type, then select the translation file to open.

The Text Import Wizard dialog opens.

3. In Step 1, choose Delimited, then click Next.

4. In Step 2, select Comma in the Delimiters panel, then click Finish.

5. Enter the translated text in the third column.

6. Save the file as type XML Spreadsheet 2003 (*.xml).



Maps and Diagrams

TIBCO Nimbus® User GuidePage 107

For external CSV editors, such as WordPad, open the file and edit the third 'column'. Click the image below
for an example.

Stage 3 - Importing object text into TIBCO Nimbus:

1. From the Tools menu choose Reports.

2. In the Categories column select Diagrams.

3. In the Reports column select Object Language Text Variants.

4. In the Scope column select the scope of diagrams to import text for.

5. Click OK.

An Object Language Text Variants report will be displayed.

6. From the File menu choose Translators Import.

7. From the Language drop-down list choose the language of the translated text that you are importing.

8. Click Browse  to select and open the file you want to import.

Note: Depending on the format of the file that you are importing, choose either CSV files or XML
Spreadsheet 2003 from the File Type options in the Open dialog.

9. Do one of the following:

· Select the row of object text that you want to add or update and click Apply.

Hint: Hold Ctrl to select multiple rows.

OR

· To apply all changes click Apply All.

The Result status will change to OK for any object text that has been updated.

Related topics

Creating Language Variants
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Formatting Diagrams

Backgrounds

Change the color

The background color of diagrams can be changed.

1. From the Map menu choose Backgrounds.

2. In the Scope panel choose the scope that you want to apply the background color to.

Note: Diagram Scope List File allows you to change the background for all diagrams in a diagram scope
list file.

3. In the Background Color panel click the color bar to access the color palette.

4. Choose a color and click OK.

5. Click OK.

Note: You can define your own custom colors to apply to backgrounds. See Adding custom colors for more
information.

Related topics

Adding background images

Add a background image

A background image can be added to diagrams.

1. From the Map menu choose Backgrounds.

2. In the Scope panel choose the scope that you want to apply the image to.

Note: Diagram Scope List Files allow you to change the background for all diagrams in a diagram scope
list file.

3. From the Image Display panel choose how the image will be displayed.

Scale To Fit Window will scale the image to fit the diagram

Tile will tile the image across the diagram (maintaining the dimensions)

Align Left will scale the image to fit down the left-hand side of the diagram

Center will display the image in the center of the diagram (maintaining dimensions)

Align Right will scale the image to fit down the right-hand side of the diagram

Tile Left will tile the image down the left-hand side of the diagram

Tile Right will tile the image down the right-hand side of the diagram

Note: You can change the background color when adding images.

Related topics

Remove background images
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Remove an image

1. From the Map menu choose Backgrounds.

2. Choose Clear Image.

3. Click OK.

Styles and Colors

Change a color

You can change the line and fill colors of objects.

To change the line color of an object:

1. Right-click on the object and from the Color And Style options choose Line Color.

2. Choose a color and click OK.

3. Click OK.

To change the fill color of an object:

1. Right-click the object and from the Color And Style options choose Fill Color.

2. Choose a color and click OK.

3. Click OK.

Note: If the color of an object does not change, right-click the object and from the Color And Style menu
choose Fill Settings to ensure that the Fill Style is not set to Transparent.

Custom Colors

You can define your own custom colors to use. See Adding a
custom color for more information.

Gradient Fills

A gradient can be applied to activity boxes, free text,
flowchart shapes, BMPN shapes and signposts. In the Fill
Settings dialog for a particular object, choose Gradient from
the Fill Style drop-down list. Then select the fill color and
style color and the gradient direction and click OK.

Related topics

Changing line styles

Modifying object shadows

Locking styles

Repositioning activity-associated logos
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Change a line style

You can change the line style, thickness and color of objects.

1. Right-click on the object and from the Color And Style menu choose Line Settings.

2. Choose your line settings and click OK.

Note: To choose a color, click the Line Color color band.

Custom Colors

You can define your own custom colors to use. See Adding a
custom color for more information.

Related topics

Changing colors

Modifying object shadows

Locking styles

Repositioning activity-associated logos

Define a custom color

Up to 16 custom colors can be defined and added to the color palette, which can then be  made available when
formatting objects.

1. From the color palette click Define Custom Colors.

2. Click a color on the color spectrum to select it. You can modify the luminescence using the slider to the right
of the color spectrum.

3. Click Add to Custom Colors.

Add object shadows

Shadows can be added to diagram objects and the settings can be modified, including the position and color.

To turn shadows on:

1. Right-click the object and from the Color And Style menu choose Shadow Visible.

Note: To turn shadows off repeat this step.

To modify shadow settings:

1. Right-click the object and from the Color And Style menu choose Shadow Settings.

Shadow Visible will display the shadow on the object if selected.
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2. To change the shadow color click in the Fill box and select a color.

3. To change the shadow position click and drag the lightbulb in the Preview box to a new position.

Related topics

Adding custom colors

Lock a style

Object styles can be locked, thereby preventing a different style sheet being applied. 

Important: If the selected object is a business control and a style sheet has been specified for it,
the object's style will not change once business control is breached provided the object's style is
locked.

 

1. Right-click the object and choose Style Locked.

Note: To unlock a style repeat this step.

Related topics

Changing colors

Changing line styles

Modifying object shadows

Repositioning activity-associated logos

Creating business controls

Modify an attachment logo

You can change the appearance of attachment and link logos. The default is .

1. Right-click the attachment logo and choose Display Options.

2. Choose the style and border as required.

Note: If you choose Drawing Pin, you can rotate the image by dragging the rotate slider.

3. Choose the line style and fill color as required.

Related topics

Repositioning activity-associated logos
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Reposition activity-associated logos

The position of activity logos, for example drill-downs, attachments, etc., can be positioned on the top (default) or
the bottom of an activity.

1. Right-click the activity and from the Color And Style menu choose Logos At Top to toggle the position.

Related topics

Changing colors

Changing line styles

Modifying object shadows

Locking styles

Modifying attachment logos

Style Sheets

About style sheets

Style sheets allow you to apply predefined styles (colors, fonts, attachment icon displays, free text styles, etc) to
certain objects within a diagram or across a scope of diagrams. By default, all users with read-write access to a
specific diagram can create a style sheet but only the user who created a style sheet can edit it (unless other
users or groups are granted specific access to do so by an administrator or the creator of the style sheet).

Create a style sheet

Style sheets define the styles (colors, fonts, sizes, etc) of a number of diagram objects and can be applied to
objects within a diagram or across a scope of diagrams.

1. From the Map menu choose Style Sheets.

2. Click New and enter a title for the style sheet.

3. Right-click the object and choose a style option to modify.

Font allows you to change the font, font size and color of associated text

Show Commentary as Hint Text displays or hides commentary text when users roll their mouse over
(activities and flow lines only)

Commentary Text Font allows you to change the font, font size and color of commentary text

Apply Style applies the last style setting applied (where applicable)

Border Visible displays a border around the object as defined by the line settings and line color

Line Settings allows you to modify the color and width of object lines

Line Colors allows you to specify the border color

Fill Settings allows you to specify the fill style and colors (for gradients choose the gradient fill style)

Fill Colors allows you to specify a single fill color

Shadow Visible displays a shadow on the object as defined by the shadow settings

Shadow Settings allows you to set the direction of shadows

Shadow Color allows you to modify the color of shadows

Logos At Top allows you to toggle between displaying the logos (attachments and links, drill downs,
notes, etc) on the top or bottom of an activity

Logos Height allows you to set the size of logos (attachments and links, drill downs, notes, etc)
displayed on activities

Toggle ID will toggle the activity ID on or off
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Arrow Heads allows you to change the way flow line links are displayed

Notation allows you to display crows feet arrows on the start and/or end of a flow line

Display Options allows you to modify the appearance of the attachment/link icon

4. From the File menu choose Save.

Free Text Style Tags

Ten styles can be defined to apply to free text boxes (right-
click a free text box and choose Style Tag). Right-click the
free text style tag and modify any of the style options.

The free text style tag names can be edited in the system
options by administrators.

Related topics

Applying style sheets

Editing style sheets

Assigning access rights to style sheets

Defining pop-up menu styles

Applying free text styles

Apply a style sheet

Styles can be applied to objects within a diagram or across a scope of diagrams. An object's style may be locked,
thereby preventing a style from being applied to a particular object.

To apply a style to an object within a diagram:

1. Right-click the object and from the Apply Style menu choose either Current, Default or Select.

Current will apply the last used style.

Default will apply the default style as defined by the administrator in the system options.

Select will allow you to choose a style from the current process repository or create a new style sheet.

2. If you choose Select then choose a style sheet from the list of available style sheets and click OK.

To apply a style to objects across a scope of diagrams:

Note: You must be an administrator to apply a style sheet to a scope of diagrams.

1. From the Map menu choose Style Sheets.

2. Select the style sheet from the list of available style sheets.

3. From the Sheet menu choose Apply.

4. Choose the scope of diagrams that you want to apply the style sheet to.

5. Select which objects to apply the style sheet to from the Options panel.

Update Version Numbers will update the version of all diagrams that the style sheet is applied to.
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6. Click OK.

Related topics

Creating style sheets

Editing style sheets

Assigning access rights to style sheets

Defining pop-up menu styles

Applying free text styles

Creating diagram scope lists

Assign access rights

As an administrator or creator of a style sheet you can define the access rights of users.

1. From the Map menu choose Style Sheets.

2. Select the style sheet that you want to define access rights to from the list of available style sheets.

3. From the Sheet menu choose Delegate Access Rights .

Default Access Rights

This defines the level of access that all users have (unless specified otherwise within the Specific User Access
Rights). 

Specific User Access Rights

This defines the user access rights for specific users or groups.

5. Click Add .

6. Select Search Users to display all users or Search Groups to display all groups, then click Find.

7. Click the user or group that you want to define access rights for and click Add. You can add as many users
and groups as you need to.

8. Click OK.

Note: By default, the user or user group will be assigned Read/write access to the style sheet. To change
the access rights double click the user or user group in the Style Sheet Access dialog.

Read and write access allows users to apply the style sheet to objects and edit the style sheet.
Read only allows users to apply the style sheet to objects but prevents them from editing it.
Access Denied prevents users from viewing, editing and applying the style sheet.

Related topics

Creating style sheets

Applying style sheets

Editing style sheets
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Defining pop-up menu styles

Applying free text styles

Edit a style sheet

Style sheets can be edited if you have been granted read/write access to a specific style sheet.

1. From the Map menu choose Style Sheets.

2. Select the style sheet that you want to edit from the list of available style sheets.

3. Right-click the object and choose a style option to modify.

Font allows you to change the font, font size and color of associated text

Commentary Text Font allows you to change the font, font size and color of commentary text

Apply Style applies the last style setting applied (where applicable)

Border Visible displays a border around the object as defined by the line settings and line color

Line Settings allows you to modify the color and width of borders

Line Colors allows you to specify the border color

Fill Settings allows you to specify the fill style and colors (for gradients choose the gradient fill style)

Fill Colors allows you to specify a single fill color

Shadow Visible displays a shadow on the object as defined by the shadow settings

Shadow Settings allows you to set the direction of shadows

Shadow Color allows you to modify the color of shadows

Logos At Top allows you to toggle between displaying the logos (attachments and links, drill downs,
notes, etc) on the top or bottom of an activity

Logos Height allows you to set the size of logos (attachments and links, drill downs, notes, etc)
displayed on activities

Toggle ID will toggle the activity ID on or off

Arrow Heads allows you to change the way flow line links are displayed

Notation allows you to display crows feet arrows on the start and/or end of a flow line

Display Options allows you to modify the appearance of the attachment/link icon

4. From the File menu choose Save to save the existing style sheet or Save As to create a new style sheet.

Related topics

Creating style sheets

Applying style sheets

Assigning access rights to style sheets

Defining pop-up menu styles

Applying free text styles

Package a style sheet

Style sheets can be packaged and unpackaged between process repositories.

To package a style sheet:

1. From the Map menu choose Style Sheets.

2. Select the style sheet that you want to package, and from the File menu choose Package.
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3. Choose the location to save the style sheet to and click OK.

4. Choose one of the following options by stating the intended use for the style sheet, then click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Send to TIBCO Nimbus for support purposes should be selected if you intend to send the content to
TIBCO Nimbus Support. All personal information will be maintained but will be removed from the content
by TIBCO once the requirements have been met.

· Send to another external company or organization should be selected if you intend to send the
content to an external company. All personal information will be removed from the content.

· Unknown should be selected if you are unsure how the content will be used. All personal information
will be removed from the content.

To unpackage a style sheet:

1. From the Map menu choose Style Sheets.

2. From the File menu choose Unpackage.

3. Choose the style sheet to unpackage and click Open.

4. Choose one of the following options and click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Received from TIBCO Nimbus for support purposes should be selected if the content was
originally sent from your company and received back from Nimbus®. All personal information will be
maintained. Do not select this option if you are not certain of the origin of the content.

· Received from an external company or organization should be selected if the content has been
received from an external company or organization. All personal information will be removed from the
content.

· Unknown should be selected if the source of the content is unknown. All personal information will be
removed from the content.

Define pop-up menu styles

Style sheets can be added to the Apply Style pop-up menu for quick access when applying styles to objects. A
maximum of five style sheets can be added at any one time.

 

1. From the Map menu choose Style Sheets.

2. From the Tools menu choose Popup Menu Setup.

3. Choose the style sheet to add to the pop-up menu and click Add To List .

Note: Hold Ctrl to select multiple style sheets.

Related topics

Creating style sheets

Applying style sheets

Editing style sheets

Assigning access rights to style sheets
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Applying free text styles

Apply a free text style

Ten styles can be defined and applied to free text boxes. See Creating style sheets for more information.

1. Right-click the free text box on the diagram and choose Style Tag.

2. Choose a free text style tag from the drop-down list and click OK.

Note: The free text style tag names can be edited in the system options by administrators.

Related topics

Creating style sheets

Applying style sheets

Editing style sheets

Assigning access rights to style sheets

Defining pop-up menu styles

Text

Format text

The font, text size and text color of object text can be modified.

1. Right-click the object and choose Edit Text.

2. Highlight the text in the Text box.

3. Format the text as required.

Note: The Tools menu contains tools to find and replace text, check the spelling and change the character
case.

Note: Style sheets can be created that include text formatting for certain objects, which can then be applied
to an object or group of objects easily.

Related topics

Creating style sheets

Applying style sheets

Editing style sheets

Defining pop-up menu styles

Applying free text styles
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Creating Attachments and Links

About links and attachments
Diagram objects (activities, free text, images and flow lines) can be linked to a variety of attachments and links,
such as files (video clips, sound files, etc), applications (run macros in Word or Excel for example), menu
functions within TIBCO Nimbus, diagrams, metrics, etc. It is also possible to attach embedded documents and
images, data tables and directories.

Note: You can change the appearance of attachment and link logos.

Language Variants

Multiple languages are supported which allows attachments and links to be available depending upon a user's
locale. For example, you may have a document that is written in both English and French. You can attach both
versions of the document but assign different languages to each one.

Viewing Access Rights

Default and specific viewing rights govern which users have access to a specific attachment or link. To modify the
access rights of a particular attachment, select it from the object's list of attachments and click View Rights.

More info on Access Rights...

Adding Links and Attachments

Document Registry Link

Link to any file in the Document Registry.

 

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Document Registry Link.

3. Find the document that you want to link to and click Accept and Close .

Hint: To select multiple documents, hold Ctrl.

Tagging attachments and links with a language

Attachments and links can also be tagged for a specific language, which will make an attachment or link
available in the attachment pop-up list only when a user is viewing a diagram in a particular language.
For example, you may have a document written in two languages; in this instance you would add the
document twice and associate the respective language to each document. If an attachment or link does
not exist for a particular users' locale then the default attachment or link will be made available.

Select the attached document, right click and select "Modify", click the Advanced tab and from the 
Language Tag drop-down list choose a language to associate with the attachment/link.

Web Link (URL)

Web links can be any URL or functionality in the Web Server. This feature is available if enabled in the system
options.

1. Right-click the object and choose Attachments/Links.
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2. Click New and choose Web Link (URL).

3. In the Web address (URL) text box enter the URL of the web page that you want to link to. External URLS
must be preceded with HTTP:// or HTTPS:// such as http://www.tibco.com/nimbus.

Note: To create a link to specific functionality in the Web Server, use the following format:

$WebServerURL/<web page> (for example: $WebServerURL/webmaps)

4. In the Link Text box enter a title for the link as it will appear to users.

Web Server: Launch link in same browser window will launch the URL in the same browser window
when users access the link in the Web Server.

5. To restrict access to specific users or groups, click the View Rights tab to access it and then click Add  to
add users.

Note: By default, the user or group is granted access to the link. To deny them access, double-click the user
or group and select Access Denied.  More info on Access Rights...

Tagging attachments and links with a language

Attachments and links can also be tagged for a specific language, which will make an attachment or link
available in the attachment pop-up list only when a user is viewing a diagram in a particular language.
For example, you may have a document written in two languages; in this instance you would add the
document twice and associate the respective language to each document. If an attachment or link does
not exist for a particular users' locale then the default attachment or link will be made available.

Click the Advanced tab and from the Language Tag drop-down list choose a language to associate with
the attachment/link.

6. Click OK.

Data Table

A data table is a flexible way of capturing data significant to a process and within the context of activities, for
example business requirements, system details used to perform activities, KPIs (Key Performance Indicators),
audit results, RACI charting (Responsibility, Accountability, Consult, Inform), etc.

For more information on creating and using data tables, see Data Tables.

Metric

Metrics are a system of parameters or ways of quantitative and periodic assessment of a process that is to be
measured. Metrics are used in business model, CMMI, ISM3 and knowledge management and metrics are used to
track trends, productivity, resources and much more. Typically, the metrics tracked are key performance
indicators (KPIs). Metrics are also important in IT Service Management (including ITIL) and they are used to
measure the effectiveness of the various processes at delivering services to customers.

In TIBCO Nimbus, metrics can be associated with activities, processes or viewed with related metric data. This
allows CSFs (Critical Success Factors) and KPIs (Key Performance Indicators) to be displayed within the context
of the process, or it allows simple variable data or information to be displayed and updated regularly.

Metric links can access data from a variety of sources, including:

· Excel spreadsheets (via SQL queries)

· SQL databases

You can also specify a target to launch when the metric link is clicked, including:

· A URL

· TIBCO Nimbus scorecard

Related topics
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Adding metric links

Modifying metric links

Scorecards

Using SQL queries to extract data directly from an Excel spreadsheet has the following benefits:

· There are no performance overheads with continually communicating with Excel.

· If the Key Performance Indicator (KPI) is moved to another cell the link is maintained.

· If the Excel file is relocated, you only need to update the file location in the SQL Query as opposed to
updating every metric link.

The first task is to name a range of cells in Excel which contains the metric data. The advantage of ranged cells is
that even if they are moved, for example if a new column is added, the range is maintained. SQL queries can then
be defined using the TIBCO Nimbus AdminUtil.

To define an Excel range:

1. Open a spreadsheet in Excel.

2. Select the cell, range of cells or non-adjacent selections that you want to name.

Note: There must be a cell that will be used as the field name. In the example below the cell that contains
'KPI' will be used as the field name.

3. Click in the Name Box and enter a name for the cells, then press Enter.

    

These ranges can then be referenced when creating SQL links in the AdminUtil. Refer to the Administration
Guide (Accessing Excel Data via a SQL Query link under Metrics Support Tools) for more information.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Metric Link.

3. Define the metric link in the following tabs:

Type

Additional

Data

Display

Launch
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Notification (for SQL metric links only)

View Rights

Actions

Related topics

Modifying metric links

Scorecards

Select the type of metric link. Depending on how TIBCO Nimbus is configured will depend on what metric link
types are available.

General metrics:

Non Data Link does not constitute an actual metric but is used as a placeholder for a future metric link.

SQL Query will use a SQL query to retrieve data (SQL queries are created by an Administrator using the
Admin Utility).

Fixed Value allows you to use a defined value as the metric data.

Data Table Field Value allows you to use a value from an associated data table as the metric data.

Costing Values allow you to use an associated costing-based value (duration, volume, delay, etc) as the
metric data. See About Costing for more information on defining activity-based costs.

Enter a description for the metric link as it will appear when a user hovers over it with the mouse. You can also
specify a different owner.

 

To specify a different owner:

1. Do one of the following:

· To select a user click Select User  and find a user.

· To use a predefined SQL query select the Use SQL Query data for the metric link's owner
check box and choose a SQL query from the drop-down list.

To enter a description:

1. Do one of the following:

· Click in the Metric Definition box and enter a description for the metric link.

· To use a predefined SQL query select the Use SQL Query data for the metric Overview field
check box and choose a SQL query from the drop-down list.

Tagging attachments and links with a language

Attachments and links can also be tagged for a specific language, which will make an attachment or link
available in the attachment pop-up list only when a user is viewing a diagram in a particular language.
For example, you may have a document written in two languages; in this instance you would add the
document twice and associate the respective language to each document. If an attachment or link does
not exist for a particular users' locale then the default attachment or link will be made available.
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Click the Advanced tab and from the Language Tag drop-down list choose a language to associate with
the attachment/link.

Choose source of data for the metric link.

Note: SQL queries must be defined by an administrator through the Admin Utility. See the Administration Guide
for more details.

Configure how the metric link is displayed. You can choose how to display the link elements, position, whether to
display certain elements, font, etc.

The first decision to make is how to display the metric link by choosing one of the following from the Style drop-
down list:

Traffic Lights

Traffic Lights (from SQL Queries)

Gauge

As Per Data

Threshold List

Icon

Traffic Lights allow you to display different colors depending upon defined threshold values. Values that lie
between the threshold values will appear as yellow. Values that lie outside of the threshold values will be
displayed as green or red.

1. From the Style drop-down list choose Traffic Lights.

2. Enter or choose a value for the two threshold values.

Note: You can define a low or high threshold value for green and a high or low threshold value for red,
depending on what is being measured.

If SQL statements exist for threshold values, choose Traffic Lights (from SQL Queries) from the Style
drop-down list, then select the SQL query that will define the high and low thresholds in the Threshold Values
panel.

See an example

A gauge will show a progress bar as determined by a percentage. The percentage is calculated from the lower-
based value of your data against a range, as determined by the start and end values.

Example 1

If the Excel data cell used for the metric link is 0.87 (or 87%), the start value is set to 0 and the end value is
set to 1, the gauge will display 87%. 

Example 2 

If the Excel data cell is 0.87, the start value is 0.8 and the end value 1.0, the gauge will display 35%.

Note: Select or deselect Display Percentage Value to display or hide the actual percentage figure on the
gauge.

The contents of the data will be displayed on the metric link. For example, if you are linking to an Excel cell, the
value of the cell will be displayed.
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This is an extension of the traffic lights style. It allows you to add as many thresholds as you need to and
configure the colors and shapes accordingly.

1. From the Style drop-down list choose Threshold List, then click on the Thresholds tab.

2. Click Add to add a new threshold.

3. Enter a threshold value in the Value box.

Example: If there are two threshold values defined, the first one is 0 and is set to green, the second is 10
and set to red. If the data value from the metric link is between 0 and 9 then the link will be displayed as
green. From 10 upwards the link will be displayed as red.

4. Choose a shape and color for the threshold value.

Display cell data will display the actual data value on the metric link.

Display text description will display the text that is defined in the Text box.

Display a custom field and a custom icon.

 

1. From the Style drop-down list choose Icon.

2. To change the icon, click Load in the Icon panel.

Note: To display no icon choose Clear.

3. To display a custom field, select the Include Custom field in display check box.

4. Enter the custom field in the Custom Display Field text box.

The following custom fields are available for use:

<OWNER> Display the metric link owner

<ACTUAL> Display the actual data value

<TARGETn> Display a target value

SQL Queries

To use a predefined SQL query that has been created by an Administrator, select the Use SQL Query
data for the metric link's custom field check box and choose a SQL query from the drop-down list.

See example

Allow users to access the source information for the metric link. For example, if a scorecard is used for the metric
link then you can allow the user to view the scorecard when they click on the metric link, therefore making the
metric link live.

Note: Certain options will only be available if they have been enabled and configured by an Administrator
(please refer to the Administration Guide that is include on the Install Media for more information). Managed
scorecards will only be available if they have been registered in TIBCO Nimbus (for more information on
scorecards click here).
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For SQL-based metric links you can automatically Email or SMS the diagram owner, or selected users, when the
defined threshold values are breached.

1. Select the Email and/or SMS check boxes.

Note: SMS and Email must be set up by an administrator for this function to work. Please refer to the
Administration Guide supplied on the Install Media for more information.

2. Specify the minimum and maximum threshold values.

Note: If traffic lights have been selected as the display type then those threshold values will be used.

3. Choose to notify users if the value crosses the threshold values ascending, descending or both.

4. In the Notifications should be sent to panel, choose to notify either the diagram owner or selected users
when the threshold is breached.

Note: If choosing Select Users then click + Users (at the bottom of the window) to add users or user
groups.

5. Add any relevant notes that will be added to the Email or SMS.

Restrict and grant access rights to individual users or user groups.

1. Choose the default access rights for all users.

Note: If you want to provide access to a small number of users, or a user group, then you can deny access
to all (default) users and grant access to specific users and user groups in the next step.

2. Click Add  to add users.

3. Click OK.

Actions can be assigned to metric links. See Actions for more information.

1. Right-click the metric link and choose Properties.
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Example 1 Defining Traffic Lights Display Metric Links

In this example the upper threshold (yellow to green) is 95% and the lower threshold (yellow to red) is 92%.

The above figure shows that the performance of the new client acquisition process is good. However, in the figure
below, the KPI has fallen below 92% of new clients being activated within 3 hours, therefore indicating a problem.

If a problem is being indicated, as demonstrated by a red traffic light, a user could drill down to review the
process in greater detail and work out why it is under-performing before deciding how to move forward with
addressing the issue.

For information on creating traffic light metric links see Traffic Lights Metric Link Display Type. 

Example 2 Defining Icon Display Metric Links

Where n is the target.  The <TARGETn> substitution field refers to any of the metric link's target values, which
can depend on the metric link's display type selected.  For example, for traffic light threshold values:

Target1 = Green to Yellow threshold value
Target2 = Yellow to Red threshold value

For example, a user may wish to specify the following custom display text string for their Metric Link:

A=<ACTUAL>, G=<TARGET1>, R=<TARGET2> 

Which, when displayed on the diagram may equate to something like:

A=27%, G=20, R=30

Note: For more information on creating Icon Metric Links see Icon Metric Link Display Type.
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Metric links that use the  Icon display  (Icon is a metric link display type that can be selected on the Display tab
when defining a metric link)can be updated for a selection of objects, a diagram or a scope of diagrams. Two
types of metric links exist; metric links that are associated with data and metric links that are not associated with
data.

Note: Only diagrams that you have read/write access to can be updated.

Any image can be used as the Icon to display on metric links. The default images for the two different metric link
types are:

 Metric link not associated with data

 Metric link associated with data

 

1. From the Map menu choose Metrics, then Update Metric Icons.

2. From the Metric Links to Update panel choose one of the following options:

Update non-data metric links will update all metric links that are not associated with data.

Update data metric links will update all metric links that are associated with data and which use the
Icon display type.

3. From the Scope panel choose the scope to update the metric links for.

Note: To update metric links for selected objects, you must first select the objects within the current diagram
first.

4. In the Icon panel do one of the following:

· To replace any icon-based metric link images with a different image, click Load and select the image
that you want to use.

· To replace any icon-based metric link images with the default image, select the Use Default Image
check box.

Note: If you do not select the default image or a different image, any metric links that are changed in this
process will be removed, although the metric link will still exist.

5. Click OK.

Metric data that is displayed in diagrams can be refreshed for all metric links in the current process map
(assuming the source of data is available).

1. From the Map menu choose Metrics, then Refresh Metric Links.
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TIBCO

Link to a AMX BPM process.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose TIBCO, then AMX BPM Process.

3. In the AMX BPM Process URL text box enter the URL for the process.

4. In the Link Text text box enter the link title.

Web Server: Launch link in the same browser will launch the link in the same browser window when
accessed by users in the Web. Disable this option to open the link in a different browser when accessed.

5. To restrict access to specific users or groups, click the View Rights tab and change the Default View Rights.
You can then add or remove users as required.

6. To associate the link with a specific language only, click the Advanced tab and choose an available
language.

7. Click OK to save the attachment.

Link to a Formvine item.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose TIBCO, then Formvine.

3. In the Formvine text box enter the Formvine URL.

4. In the Link Text text box enter the link title.

Web Server: Launch link in the same browser will launch the link in the same browser window when
accessed by users in the Web. Disable this option to open the link in a different browser when accessed.

5. To restrict access to specific users or groups, click the View Rights tab and change the Default View Rights.
You can then add or remove users as required.

6. To associate the link with a specific language only, click the Advanced tab and choose an available
language.

7. Click OK to save the attachment.

Link to a Spotfire report.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose TIBCO, then Spotfire Analytics.

3. In the Spotfire URL text box enter the URL for the report.

4. In the Link Text text box enter the link title.

Web Server: Launch link in the same browser will launch the link in the same browser window when
accessed by users in the Web. Disable this option to open the link in a different browser when accessed.
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5. To restrict access to specific users or groups, click the View Rights tab and change the Default View Rights.
You can then add or remove users as required.

6. To associate the link with a specific language only, click the Advanced tab and choose an available
language.

7. Click OK to save the attachment.

Applications

Links can be created that allows users to launch into SAP transactions, both in the SAP Application and the SAP
web-based environment.

Note: SAP integration must be enabled and configured in the Admin Utility to allow SAP links to be linked to
objects. Refer to the Administration Guide that is included on the Install Media for more information, or ask your
administrator.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Applications, then SAP Transaction Link.

3. In the SAP Transaction Link Title box enter a title for the link.

4. In the Transaction Code box enter the SAP transaction code.

Web Server: Launch link in the same browser - select this option to use the same browser to open
web-based SAP transaction links when users access the link in the web browser. If this option is not selected
then a new browser will be launched.

SAP Information Imported from ARIS or BPM-xchange

There are two fields of information in the Imported tab that relate to information that is imported from ARIS
or BPM-xchange relating to the status of the transaction in the SAP environment and how often it is used.

Activated is the status of the SAP transaction link in the SAP environment.

Frequency is how often the transaction is used.

5. Click the Advanced tab to select it.

6. If TIBCO Nimbus is configured to launch SAP transactions in a SAP web environment then you can choose a
SAP base URL to launch from the Base URL drop-down list. 

Note: If a SAP base URL is not specified then the system will first check Process Repository\System
\SAPSettings for SAPlogon.ini. If it does not exist in the System folder then it will check the user's PC for
SAPLogon.ini. If multiple URLs are defined in this file then the user will be prompted to select the URL to
launch; if only one URL is defined then it will automatically launch the transaction in that web environment.

7. If TIBCO Nimbus is configured to launch SAP transactions in a SAP GUI system then you can choose a SAP
system to launch from the SAP system drop-down list, or enter the SAP system name in the SAP system
text box (as it appears in the SAPlogon.ini file, that is, the system displayed in the SAP Client Logon
window).

Note: If a SAP base URL is not specified then the system will first check Process Repository\System
\SAPSettings for SAPlogon.ini. If it does not exist in the System folder then it will check the user's PC for
SAPLogon.ini. If multiple systems are defined in this file then the user will be prompted to select the system
to launch; if only one system is defined then it will automatically launch the transaction in that system.

8. Click OK to finish.

User Settings and Access Rights

Access Rights



Maps and Diagrams

TIBCO Nimbus® User GuidePage 129

Access rights can be defined for all users and specific users and user groups. By default, all users will be
able to launch the SAP transaction link. You can define the default access rights and also assign individual
rights to users and user groups.

1. Click the View Rights tab.

2. Select the default access rights for all users.

3. To define specific user or user group access rights click Add  to select a user or user group.

Note: Defining specific access rights will override the default access rights for those users or user
groups specified.  More info on Access Rights...

User Settings

SAP transactions can be launched in either the SAP GUI system, the SAP web interface, or both. If both
environments are defined for a single SAP transaction then the user will be given a choice of which
environment to launch when the link is accessed in the Web Server. 

There are two user settings that affect the launching of SAP transactions. By default, all users can launch in
both; however, individual user settings can be set to allow a user to launch in only one or the other - see 
User Account Details for more information.

There is user preference that will remember the last choice of SAP environment to launch in when a user
launches a SAP transaction that has both environments defined for it. Individuals can specify this setting in
their user preferences, or an administrator can enable or disable this option in the default user
preferences.

Link to a Salesforce.com URL.

 

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Applications, then Salesforce.com Link.

3. In the Salesforce.com URL text box enter the URL of the Salesforce.com page that you want to link to.

4. In the Link Text box enter a title for the link as it will appear to users.

Web Server: Launch link in same browser window will launch the URL in the same browser window
when users access the link in the Web Server.

5. To restrict access to specific users or groups, click the View Rights tab to view it and then click Add  to
add users. More info on Access Rights...

Note: By default, the user or group is granted access to the link. To deny them access, double-click the user
or group and select Access Denied.

Tagging attachments and links with a language

Attachments and links can also be tagged for a specific language, which will make an attachment or link
available in the attachment pop-up list only when a user is viewing a diagram in a particular language.
For example, you may have a document written in two languages; in this instance you would add the
document twice and associate the respective language to each document. If an attachment or link does
not exist for a particular users' locale then the default attachment or link will be made available.

Click the Advanced tab and from the Language Tag drop-down list choose a language to associate with
the attachment/link.

6. Click OK.
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Link to an Oracle URL.

 

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Applications, then Oracle Link.

3. In the Oracle URL text box enter the URL of the Oracle URL that you want to link to.

4. In the Link Text box enter a title for the link as it will appear to users.

Web Server: Launch link in the same browser window will launch the URL in the same browser window
when users access the link in the Web Server.

5. To restrict access to specific users or groups, click the View Rights tab to view it and then click Add  to
add users. More info on Access Rights...

Note: By default, the user or group is granted access to the link. To deny them access, double-click the user
or group and select Access Denied.

Tagging attachments and links with a language

Attachments and links can also be tagged for a specific language, which will make an attachment or link
available in the attachment pop-up list only when a user is viewing a diagram in a particular language.
For example, you may have a document written in two languages; in this instance you would add the
document twice and associate the respective language to each document. If an attachment or link does
not exist for a particular users' locale then the default attachment or link will be made available.

Click the Advanced tab and from the Language Tag drop-down list choose a language to associate with
the attachment/link.

6. Click OK.

Open any Windows file from an activity, flow line, image or free text using the Windows default application or a
user-defined application. It is also possible to define parameters to run when the file is launched.

 

To link to a file from an object:

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Applications, then File/Application Link.

3. In the File panel click File Browse  and locate the file.

4. Edit the file title name if required.

Note: This is the file name as it will appear in the list of attachments when the object is clicked if multiple
links or attachments exist.

To specify a different application to launch the file:

1. Deselect the Use Windows file association to determine application check box.
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2. Click Application Browse  to locate the executable of the application.

The following options are also available for launching a file:

Parameters can be specified for the application that is launched when the file is accessed (assuming
parameters are supported by the application). For example, Microsoft Word supports a number of command-
line parameters, including the /mMacroName parameter used to automatically run a macro in a file. See the
Hints below for additional TIBCO Nimbus-specific Word and Excel macros.

Global Options apply to all links from any diagram to the file.

Protect against overwrite during unloading of packaged maps will prevent the file from being
overwritten when a packaged map that contains the same file is unloaded. 

Deselect the Include when packaging option if you do not want to include the file when the map is
packaged (this is useful for large files).

Note: There is a system option that, if enabled, will override any application specified here with the default
Windows application.

Tagging attachments and links with a language

Attachments and links can also be tagged for a specific language, which will make an attachment or link
available in the attachment pop-up list only when a user is viewing a diagram in a particular language.
For example, you may have a document written in two languages; in this instance you would add the
document twice and associate the respective language to each document. If an attachment or link does
not exist for a particular users' locale then the default attachment or link will be made available.

Click the Advanced tab and from the Language Tag drop-down list choose a language to associate with
the attachment/link.

3. Click OK.

Macros

TIBCO Nimbus provides two additional Microsoft Word parameters - WordPage(x) allows
you to jump to a specific page in your document, where x is the page number. 
WordMacro(x) allows you to run a specify Word macro in your document, where x is the
macro name.

TIBCO Nimbus provides an additional Microsoft Excel parameter - ExcelMacro(x) allows you
to run a specific Excel macro in your spreadsheet, where x is the macro name.

Internal Image

Images can be attached to objects.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Internal Image.

3. Enter a title for the image.

You are presented with a drawing area to create the image in.

To import an image, click , then drag the crosshairs to create an area to insert the image into.

To insert free text, click  , then drag the crosshairs to create a text box to enter text into.

To add a free line (arrow), click  , then drag the crosshairs to create the line.
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4. Click OK .

Internal WP Document

An internal word-processed document is a document created through an internal word processor in TIBCO
Nimbus. It allows you to add textual notes, tables, images and OLE objects to an object and embed them into the
map.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Internal WP Document.

3. Enter a title for the document and click OK.

From the Insert menu you can add OLE objects, text (.txt, .rtf) and images.

To add a table, from the Table menu choose Insert.

To spell check the document, from the Tools menu choose Spelling.

4. Click OK  when you have finished to save and attach the document to the object.

Modifying Document Information

You can change the title, author and status of an internal WP document. You can also
associate a particular language with the document (see below). In an object's list of
attachments right-click the document and choose Access. In the document window, from the
File menu choose Document Information.

Tagging attachments and links with a language

Attachments and links can also be tagged for a specific language, which will make an attachment or link
available in the attachment pop-up list only when a user is viewing a diagram in a particular language.
For example, you may have a document written in two languages; in this instance you would add the
document twice and associate the respective language to each document. If an attachment or link does
not exist for a particular users' locale then the default attachment or link will be made available.

Click the Advanced tab and from the Language Tag drop-down list choose a language to associate with
the attachment/link.

Note: If a language appears in red then it is not supported in the current process repository.

Email Link

Create an email link and define the recipient (mandatory) and the subject and body (optional); when users
access the link, an email will be created automatically to the defined email recipient.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Email Link.

3. Enter the Email recipient in the To: field.

4. Enter the information for the other Email fields.
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Note: The Subject field is used as the title of the attachment link. If a subject is not defined then the email
recipient is used.

By default, all users have access to the link.

5. To restrict access to specific users or groups, click the View Rights tab and change the Default View Rights.
You can then add or remove users as required.

6. To associate the link with a specific language only, click the Advanced tab and choose an available
language.

Storyboard Link

For information on storyboards see About storyboards or Linking to a storyboard.

Scorecard Link

For information on scorecards see About scorecards or Attaching a scorecard.

Menu Function Link

You can add a link that executes a TIBCO Nimbus menu function. However, it should be noted that not all of
these functions are available in the web server. Note that Actions, New Action function is available.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Menu Function Link.

3. Choose the menu function from the Function drop-down list.

4. To restrict access to specific users or groups, click the View Rights tab to access it and then click Add  to
add users.

Note: By default, the user or group is granted access to the menu link. To deny them access, double-click
the user or group and select Access Denied. More info on Access Rights...

5. Click OK.

Removing Links and Attachments

Remove a link or attachment

1. Right-click the object and choose Attachments/Links.

2. Select the link or attachment, then click Delete.

Creating Swimlane Diagrams

Create a swimlane diagram
Swimlane diagrams are used to organize activities into separate visual categories in order to illustrate different
functional capabilities and responsibilities based on resources and resource groups. Activities are grouped by
placing them in a lane, with one lane assigned per resource or resource group. Lanes can be arranged horizontally
or vertically and are labeled with the resource or resource group name.

Note: Only administrators and authors with read/write access to the diagram can create swimlane diagrams. If the
resource library is updated, for example resources or resource group names are changed, then swimlane
diagrams will be updated automatically.
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1. From the Diagram menu choose Swimlane and Pool Properties.

2. Select Enable Swimlane Mode on this diagram.

Swimlane Pools

A swimlane pool is simply a collection of swimlanes. For example, you may have a pool
named 'Supplier', and within this pool are two swimlanes, 'Sales' and 'Distribution'. To create
a new swimlane pool click Add Pool. 

To remove a swimlane pool, select the pool and click Remove (this will also remove any
associated swimlanes).

Note: <No Pool> is used for swimlane objects that do not belong to any pools. A single
resource can only be associated with one pool.

Hint: You can click and drag resources and resource groups between pools.

3. Click a pool to select it, or click <No Pool> if you do not want to associate a resource with a pool, then do one
of the following:

· Click Add Resource. Find and select the resource(s) that you want to add to the swimlane diagram

and click Add Resources To List .

· Click Add Group. Select the resource group and click OK.

Note: To reorder the assigned resources and resource groups as they will appear in the swimlane pool, select
the resource or resource group and click Move Up or Move Down.

4. Modify any display options as required. See Formatting swimlane diagrams for more information.

5. Click OK.

You are now ready to design your swimlane diagram. If activities already exist then move the activities into
the correct swimlanes. If you are creating new activities, note that when you assign a resource it will be
automatically hidden. 

Assigning resources to activities in swimlanes

When assigning resources to activities that lie within a particular swimlane, the Activity
Resources dialog will automatically be filtered to display only the resource associated with
the swimlane. This is called the <SWIMLANE> resource group. To assign other resources you
must choose another resource group from the Group drop-down list.

If an activity that has been assigned a resource from the Swimlane group is moved to
another swimlane then the resource will not be automatically updated. This must be done
manually by right-clicking the activity and choosing Resources.

Resizing swimlanes

Width  (or height for vertical swimlanes) - move the cursor to the end of the swimlanes until
resizing handles appear, then click and drag the swimlanes.

Height (or width for vertical swimlanes) - move the cursor to the edge of the title area until
resizing handles appear, then click and drag the title areas. This will only resize one
swimlane at a time. To resize the height of all swimlanes you must define the height in the 
swimlane properties.

Integrity checking
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Running an integrity check will also report on any resource mismatches within swimlane
diagrams. When an integrity report has been generated, click the Swimlane tab to check for
problems.

Related topics

Formatting swimlane diagrams

Integrity checking

About resources

About resource libraries

Creating resources

Creating resource groups

Format a swimlane diagram
There are a range of formatting options that can be applied to swimlane diagrams to in order to enhance the
appearance.

 

To format all swimlanes:

1. From the Diagram menu choose Swimlane and Pool Properties.

Orientation
Choose to display the swimlanes vertically or horizontally.

Offset
Define the left and top starting coordinates (in pixels) of the swimlanes to compensate for diagram objects
such as templates.

Size
Define the length and height (or width for vertical orientations), in pixels, of the swimlanes.

Title Area
Define the width (or height for vertical orientations), in pixels, of the swimlane title areas. The Gap After
Title Area option allows you to set a gap between the title area and the swimlanes. If you are using
swimlane pools you can also define the width and the gap between the pools. The swimlane title(s) can be
rotated to 90 or 270 degrees. You can also change the font, font size and font color.

Appearance
Modify the swimlane border widths, border colors and fill colors.

To format individual pools:

1. Right-click the pool and choose Lane Properties.

2. To change any of the pool properties, select the respective Custom radio button to unlock the property.

To format individual swimlanes:

1. Right-click the swimlane and choose Lane Properties.

2. To change any of the swimlane properties, select the respective Custom radio button to unlock the property.
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Related topics

Creating swimlane diagrams

Creating BPMN Diagrams

Create a BPMN diagram
A BPMN diagram uses different symbols to represent objects within process diagrams, as defined by BPMN
standards.

Note: You cannot switch to a BPMN diagram type if objects already exist in the diagram, i.e. you can only create
BMPN diagrams from new.

 

To create a BPMN-style diagram:

1. From the Diagram menu choose Diagram Notation, then choose BPMN Diagram.

When you switch to a BPMN diagram type the following toolbar buttons will be added to the Drawing toolbar:

Toolbar Icon Description

Activity

Event

Gateway

Data Object

Text Annotation

Group Object

BPMN Diagram Creation Rules

Resources, drill downs, diagram sign post links, notes bubbles and statement links can only
be added to activities. Attachments can only be associated with activities and data objects.

Activities

Symbols can be associated with activities. Right-click an activity and choose BPMN Activity
Properties. Choose from the following symbols:

Activity Commentary Text

Commentary text provides additional information to users when they roll over an activity. To
define commentary text, right-click the activity or flow line and choose Commentary.
Commentary text can also be created for multiple language variants, as you can with activity
text. You can also define commentary text after defining the text for the activity. In the Text
window, from the File menu choose Save and Edit Commentary.

Events

The type of event and the associated symbol can be defined for events. Right-click an event
and choose BPMN Event Properties. 
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Choose from the following event types:

Choose from the following event symbols:

Gateways

Symbols can be used to represent gateways. Right-click a gateway and choose BPMN
Gateway Properties. Choose from the following symbols:

Connections (flow lines)

The type and style of connecting lines can be modified. Right-click a connecting line and
choose BPMN Connections Properties.

Choose from the following connection types:

You can also change the notation of the connection.

Connection Commentary Text

Commentary text provides additional information to users when they roll over a connection.
To define commentary text, right-click the connection and choose Commentary.
Commentary text can also be created for multiple language variants, as you can with activity
text. You can also define commentary text after defining the text for the connection. In the
Text window, from the File menu choose Save and Edit Commentary.

Related topics

Changing colors

Changing line styles

Creating style sheets
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Creating Diagram Levels

About drill downs
A drill down provides access from an activity to a lower-level diagram (also known as a child diagram). 

A single activity may involve a number of activities in order for the activity to be performed. These activities are
defined in a child diagram. Child diagrams provide a means of describing a process in as much detail as is
necessary for a user to easily undertake a specific task with the minimum amount of ambiguity.

When a child diagram is created, all links are maintained within the parent and child relationship. If a child
diagram is copied between diagrams or other process maps, all associated information and attachments are also
maintained.

Diagrams are uniquely hierarchically numbered. The top-level diagram is level 1, the second-level diagram is
1.x, where x is the activity number that the drill down links parent to child diagram (for example, if a child
diagram is accessed from activity 3 on the top-level diagram, the child diagram will be 1.3). The third-level
diagrams are 1.x.x, and so on.

Drill downs to lower levels appear as arrows on an activity box, as shown below. When these arrows are clicked
the user will be taken to the child diagram.

The example below demonstrates that in order to sell products and services there are four steps involved, which
are outlined in a lower-level diagram. In fact, it is possible that any of the four steps may themselves drill-down
to lower-level diagrams.
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Create a drill down
A drill down provides a link to a lower level (child) diagram. The completion of an activity within a process may
involve further steps (activities) so that the activity is described in more detail. Users can navigate to these via
drill downs from an activity. See About drill downs for more information.

1. Right-click the activity and from the Drill Down menu choose New.

A new diagram page will open, requiring you to define the child process for the activity. If input and output
lines were associated with the activity then these will form the inputs and outputs of the child diagram.

Related topics

Refreshing diagram titles

Updating activity input/output text

Hiding drill downs

Importing and exporting drill downs

Sending activities down a level

Inserting diagrams

Deleting drill downs

Hide a drill down
You can hide drill downs. The drill downs are still present however and users can access the lower level by clicking
the actual activity.

1. Right-click the activity and from the Drill Down menu choose Invisible.

Note: To unhide the drill down deselect Invisible.

Related topics

Creating drill downs

Refreshing diagram titles

Updating activity input/output text

Importing and exporting drill downs

Sending activities down a level

Inserting diagrams

Deleting drill downs
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Import a drill down
Maps can be imported as drill downs on activities. For example, you can import a previously exported drill down
from one area of a map and import it onto an activity in a new map, or new area of an existing map.

To import a process map as a drill down:

1. Right-click the activity and from the Drill Down menu choose Import.

2. Select the map that you want to import as a drill down and click OK.

To import a packaged map as a drill down:

1. Right-click the activity and from the Drill Down menu choose Import From Package.

2. Locate and select the packaged map and click Open.

3.    Choose one of the following options and click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Received from TIBCO Nimbus for support purposes should be selected if the content was
originally sent from your company and received back from Nimbus®. All personal information will be
maintained. Do not select this option if you are not certain of the origin of the content.

· Received from an external company or organization should be selected if the content has been
received from an external company or organization. All personal information will be removed from the
content.

· Unknown should be selected if the source of the content is unknown. All personal information will be
removed from the content.

Related topics

Creating drill downs

Refreshing diagram titles

Updating activity input/output text

Hiding drill downs

Sending activities down a level

Inserting diagrams

Deleting drill downs

Update activity input/output text
If the input or output flow-line text for a child or parent diagram is modified, you can automatically update any
parent or child diagrams to match.

1. From the Map menu choose Refresh Input/Output Text.

2. Select the scope that you want to refresh from the Select Scope panel.
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Current Diagram from Parent will update the current diagram's input and output text based on the
input and output text from the activity on the parent diagram.

Parent Diagram from Current will update the parent diagram's input and output text based on the
current diagram's input and output text.

Current Diagram and Lower Levels will update the current diagram and all lower levels either from
the lowest level(s) upwards or the current diagram downwards.

Current Process Map will update the entire map from the lowest level(s) upwards or the top level(s)
downwards.

3. If you have chosen to modify the current diagram and lower levels or the current process map then select
the direction in which you wish to refresh from the Hierarchical Direction panel.

4. Click OK.

Related topics

Create a drill down

Refresh diagram titles

Hiding drill downs

Importing and exporting drill downs

Sending activities down a level

Inserting diagrams

Deleting drill downs

Send activities down a level
Selected activities can be sent down a level, i.e. they will form a lower level diagram. A single activity will replace
all activities that have been sent down in the parent diagram and a drill down on the activity will provide access
to the sent down activities in the child diagram.

1. Select the activities that you want to send down a level.

2. From the Edit menu choose Send To Child.

You can now design the lower-level diagram using the activities you selected to send down.

Related topics

Create a drill down

Refresh diagram titles

Update activity input/output text

Hiding drill downs

Importing and exporting drill downs

Inserting diagrams

Deleting drill downs



Maps and Diagrams

TIBCO Nimbus® User Guide Page 142

Insert a diagram
Inserting a diagram will send the current diagram down a level and replace it with a single activity that displays a
drill down to the original diagram. For example, if you insert a diagram at level 1.3, the current diagram will be
sent to level 1.3.1 and a new diagram will appear at level 1.3 with an activity that drill downs to level 1.3.1.

Important: This operation cannot be undone.

1. From the Diagram menu choose Insert Diagram.

Related topics

Create a drill down

Refresh diagram titles

Update activity input/output text

Hiding drill downs

Importing and exporting drill downs

Sending activities down a level

Deleting drill downs

Delete a drill down
Delete all lower level diagrams associated with a drill down.

1. Right-click the drill down and choose Remove.

Related topics

Create a drill down

Refresh diagram titles

Update activity input/output text

Hiding drill downs

Importing and exporting drill downs

Sending activities down a level

Inserting diagrams

Creating Process Variants
A business process variant is a flow variant of a process that uses the same inputs and provides the same
outputs. You can create multiple drill down diagrams from single activities to facilitate process variants. When a
user clicks the drill-down on an activity, they will be given a choice of which variant to follow. Normal access
rights apply to process variants and if a user does not have access rights to a specific variant then the variant will
not be displayed.



Maps and Diagrams

TIBCO Nimbus® User GuidePage 143

One example of a process variant could be the process for booking holiday. You may have one standard process
but you want to define slightly different processes based on location. In this example you would create a
standard process for booking holiday and then a number of process variants based on country.

Create a process variant
You can create a number of business process variants for a specific process. A system option defines the identifier
used for process variant diagrams.

1. Right-click the activity and from the Drill Down menu choose Manage Variants.

The Manage Variants window will be displayed.

Note: This option is only available if at least one drill down has been created. See Create a drill down for
more information.

2. Click New.

3. Choose one of the following options:

· New Blank Diagram will create a new blank diagram with the inputs and outputs from the parent
diagram.

· Existing Variant will allow you to choose an existing variant diagram for that activity. The diagram
content will then be copied to the new variant diagram.

· Import Existing Map will allow you to import an existing map from the current process repository
(as you do when importing a drill down).

4. Click OK to create the process variant.

You are now ready to draw the process variant. If input and output lines were associated with the parent
activity then these will form the inputs and outputs of the new diagram.

Related topics

Managing process variants

Creating drill downs
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Manage process variants
A number of options are available in the Manage Variants window. To access the Manage Variants window, right-
click the drill down on the activity and choose Manage Variants.

To reorder process variants:

You can reorder the list of variants. This will change the order of variants presented to users when they access the
drill down.

1. In the Manage Variants window, select the variant that you want to move and click either Move Up or Move
Down.

To create a new map from a process variant:

You can create a new map in the current process repository from a process variant. 

1. Select the variant that you want to create a map from and click Export.

2. Choose a location in the process repository to save the exported map to.

3. In the Export Name text box enter the name for the new map, and then click OK.

Remove lower levels after export will delete the lower level diagrams from the map that you are
exporting from (these can be restored using the Deletion Recover Manager if required).

Redirecting Links
You may be asked if you want to redirect diagram links, depending on your user preferences. One thing to
consider when you export a process variant but choose not to remove the lower levels is where you want any
diagram links (sign posts, flow-line links and diagram link attachments) and users' To-do items to point to
after the export. An option in your user preferences - Show diagram link redirection prompt - allows you to
choose to redirect diagram links and move users' To-do items to the exported diagrams during the process. If
you do not enable this option then diagram links and To-do items will be maintained on the original diagrams.

Below is a table showing what happens to data when exporting a process variant. Note that metadata refers
to feedback, change requests, logs, users (authorizers, reviewers, acknowledgers) and access rights.

Remove Lower Levels
After Export

Redirect Diagram
Links*

Notes

Yes N/A
All metadata, To-dos and diagram links
moved to exported diagrams.

Yes N/A
All metadata, To-dos and diagram links
moved to exported diagrams.

No Yes
All metadata copied to exported diagrams.
To-dos and diagram links moved to
exported diagrams.

No No
All metadata copied to exported diagrams.
To-dos and diagram links maintained on
original diagrams.

* This option requires the Show diagram link redirection prompt to be enabled in your user preferences.

To create a packaged map from a process variant:

1. Select the variant that you want to create a packaged map from and click Export As Package.

2. In the Export Name field, enter a name for the packaged map.

Remove lower levels after export will delete all lower levels in the process variant.

Include attachments will include all file and document links.

3. Click Next.
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4. Choose a location to save the packaged map to and click Next.

5. Choose one of the following options and click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Received from TIBCO Nimbus for support purposes should be selected if the content was
originally sent from your company and received back from Nimbus®. All personal information will be
maintained. Do not select this option if you are not certain of the origin of the content.

· Received from an external company or organization should be selected if the content has been
received from an external company or organization. All personal information will be removed from the
content.

· Unknown should be selected if the source of the content is unknown. All personal information will be
removed from the content.

To change a variant type:

You can switch variant types. Note that only one standard process can exist, although you can have no standard
processes if you wish. If you switch a variant to a standard type, the existing standard process will be
automatically changed to a variant.

1. Select the variant that you want to change and click Change Type.

To delete a process variant:

1. Select the variant that you want to delete and click Delete.

Related topics

Create a process variant

Linking Diagrams

About diagram links
A diagram link allows users to navigate to a diagram in the same map or in a different map. You can link from an
activity, flow line, image or free text. You can also create a signpost or a flow-line link to other diagrams.

Link from an activity
Diagram links provide links from an activity to another diagram within the same process map or a different
process map.
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1. Right-click the activity and choose Link Diagram.

2. From the Process Maps panel choose the process map that holds the diagram that you want to link to.

3. From the Diagrams panel select the diagram that you want to link to.

Note: Choose from drafts, masters or scenarios from the Diagram drop-down list.

4. Modify the text in the Link Text box, if required.

Note: This is the text that will appear when users hover their mouse over the icon on the activity.

5. Click OK.

Linking Tips

In the Diagram Selector dialog you can jump to a specific level in a map by entering the
level number in the Level Select box and clicking Go.

You can cut, copy and paste diagram links between objects, or drag the link into a
space to create a signpost.

To add multiple diagram links, right-click the activity and choose Attachments/
Links. C lick New and choose Diagram Link.

Related topics

Editing diagram links

Adding signposts

Redirecting diagram links

Edit a diagram link
The diagrams that diagram links point to can be changed.

1. Right-click the diagram link and choose Set Up Diagram.

2. Select a diagram to link to and click OK.

Related topics

Redirecting diagram links
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Add a signpost
Signposts are free-standing objects that provide visual links to other diagrams.

 

1. Click Draw Sign Post  on the Drawing toolbar.

Note: To display the Drawing toolbar, from the View menu choose Toolbars & Panels. On the Toolbars
tab check the Diagram Button Bar check box.

2. With the crosshairs as your cursor, click and drag an area on the map to create the signpost, then release
the mouse button.

3. From the Process Maps panel choose the process map that holds the diagram that you want to link to.

4. From the Diagrams panel select the diagram that you want to link to.

Note: Choose from drafts, masters or scenarios from the Diagram drop-down list.

5. Modify the text in the Link Text box, if required.

Note: This is the text that will be displayed on the signpost.

6. Click OK.

Linking Tips

In the Diagram Selector dialog, jump to a specific level in a map by entering the level
number in the Level Select box and clicking Go.

Change the direction of a signpost by right-clicking it and choosing Direction Facing.

Change the color, line style or shadow.

Related topics

Link diagram from an activity

Redirect diagram links

Redirect diagram links
When a diagram is moved within the hierarchy of a map, for example when a diagram is sent to child, i.e. down a
level, any links to that diagram from other diagrams will be updated to reflect the new position. However, if a drill
down is exported (or copied and pasted) to another area of the map, any diagram links will remain pointing at
the original, i.e. they will not be directed to the copied diagram. A user preference option - 'Show diagram link
redirection prompt' allows any diagram links to be redirected to the exported/copied version of the diagram.
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Flow-line Links

About flow-line links

Flow-line links link the output of one diagram to one or more inputs of other diagrams, thereby supporting the
capture of end-to-end processes. If multiple diagram inputs are specified then users will be prompted to choose
which process to follow when the link is accessed. User access rights can also be defined to grant or restrict
access to the link.

Fig. The above diagram shows a flow-line link. Note: A preview of the linked-to-diagram can be displayed, as
shown in the above example where the activity of the next diagram is displayed in light gray. See Modifying flow-
line link properties for more information.

Add a flow-line link

A link from the output of one diagram to one or more inputs of other diagrams, thereby supporting the capture of
an end-to-end process. If multiple diagram inputs are specified then users will be prompted to choose which
process to follow when the link is clicked.

 

1. Right-click the flow line that you want to link to another diagram and choose Flow Line Connections.

2. Click New Link.

3. From the Process Maps panel choose the process map that holds the diagram that you want to link to.

4. From the Diagrams panel select the diagram that you want to connect to, then select the respective flow line
to connect to.

Note: You can only connect to a flow line that is an input to an activity. Available flow lines are highlighted
in light blue.

Choose from drafts, masters or scenarios from the Diagram drop-down list.

5. Modify the text in the Link Text box, if required.

Note: This is the text that will appear when users hover their mouse over the icon on the activity.

6. Click Finished/OK.

Related topics

Modifying flow-line links

Modifying flow-line link properties
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Building back links

Assigning flow-line link access rights

Removing flow-line links

Modify a flow line link

You can add a new link or change an existing link.

1. Right-click the flow-line link  and choose Access/Modify.

2. Click the flow-line link that you want to modify and click Modify.

3. If in single selection mode, select a different link to connect to and click OK, otherwise follow the steps in the
wizard.

 This toggles between the wizard mode and single selection mode.

Note: Choose to link to a master or draft diagram by choosing the relevant option from the Diagrams drop-
down list.

Note: You can navigate to a specific level in the diagram list by entering the number in the Level Select
box and clicking Go.

Related topics

Adding flow-line links

Modifying flow-line link properties

Building back links

Assigning flow-line link access rights

Removing flow-line links

Modify flow line link properties

The display of flow-line links can be modified, for example you can modify the color, size, enable previews of the
linked-to diagram, etc.

1. Right-click the flow-line link and choose Properties.

2. Make any changes in the following property tabs:

Display

Modify the fill and line color of the flow-line link. You can also change the size as it appears on the
diagram.

Previewing

Choose to display a preview of the linked-to diagram from the following options:

Disable preview will not display a preview of the linked-to diagram.



Maps and Diagrams

TIBCO Nimbus® User Guide Page 150

Preview connected activity will display only the activity that the flow line is connected to in the
linked-to diagram.

Preview entire diagram will display the whole linked-to diagram.

Note: If multiple diagrams have been linked to from a single flow-line link and you have selected to
display a preview of either the activity or the entire diagram, you must choose which diagram link to
preview from the To Preview drop-down list.

Advanced

You can build back links to target diagrams or maps if they have been deleted by another user. For
more information see Building back links.

Related topics

Adding flow-line links

Modifying flow-line links

Building back links

Assigning flow-line link access rights

Removing flow-line links

Fix broken flow line links

If another user has deleted a flow line link connection on a diagram, it is possible to fix the return link
automatically.

Note: To fix all links in a scope of diagrams click here.

1. Right-click the flow-line connection and choose Properties.

2. Click the Advanced tab.

3. Choose the link to restore from the Select Link drop-down list.

4. Click Build Back Link.

5. Click OK.

Related topics

Adding flow-line links

Modifying flow-line links

Modifying flow-line link properties

Assigning flow-line link access rights

Removing flow-line links
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Assign Access Rights

Grant or restrict user access to a flow-line link.

1. Right-click the flow-line link  and choose Access/Modify.

Note: The color of the flow-line link may vary. See Modifying flow line link properties for more information.

2. Select the flow-line link that you want to define access rights on and click View Rights.

Note: If you want to restrict access to all links then this is done in the next step.

3. Choose the scope of the access rights that you want to define.

Current Selected Attachment/Link in the List is the flow-line link that was highlighted when View
Rights was selected.

All Attachment Links in the List will modify the access rights of every attachment and link associated
with the object.

4. Choose the default access rights for all users.

Note: If you want to provide access to a small number of users, or a user group, then you can deny access
to all (default) users and grant access to specific users and user groups.

5. Click Add  to add users.

6. Click OK.

Note: By default, the user or user group is granted access to the flow-line link. To deny them access,
double-click the user or group and select Access Denied.

Related topics

Adding flow-line links

Modifying flow-line links

Modifying flow-line link properties

Building back links

Removing flow-line links

Remove a flow line link

Removing a flow-line link will not remove the flow-line link that it links to and flow-line links can be rebuilt.

1. Right-click the flow-line link and choose Access/Modify.

2. Select the link that you want to delete and click Delete.

Related topics

Adding flow-line links

Modifying flow-line links
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Modifying flow-line link properties

Building back links

Assigning flow-line link access rights

Creating Business Controls

About business controls
Business controls are used to provide visual awareness of specific activities within a process that, if they fail or
are not undertaken, will result in compliance failure and will be highlighted as non-conforming activities, usually
with respect to corporate governance and compliance. This permits an organization to comply with legislations
such as financial legislations, for example Sarbanes Oxley (SOX), Base II, audit points. They can also be used for
operational activities, for example schedules of authorizations to sign off on contracts, expense vouchers, etc., or
they can be used for compliance, for example import/export trade agreements, health and safety,
environmental.

Note: Business controls can only be created by administrators. Authorized users can attach business controls to
activities, flow lines and free text boxes. Style sheets can be created and used to highlight data tables or
statement links that breach a specific business control value. 

Related topics

Style sheets

Reporting

Create a business control
See About business controls for more information.

Note: Only administrators can create business controls.

 

1. From the Tools menu choose Business Controls.

2. From the File menu choose Add.

3. Enter a name for the business control.

4. Choose a business control type from the following:

Field value in a Data Table attachment will be based on a field value in a selected data table
attached to the object.

Statement Link will be based on a field value of a specific statement that is attached to the object.

Field value in a Statement's Link data table will be based on a field value defined in a statement
link's data table (this option requires knowledge of the statement set's functionality) Note: The
statement set must be defined to include additional custom fields for the statement link records (see 
Customizing a statement for more information).

Field value in a Statement's data table will be based on a field value held within the additional data
of a statement record that is linked to the object (this option requires knowledge of the statement set's
functionality) Note: The statement set must be defined to include additional custom fields for the
statement set records (see Customizing a statement for more information).

5. In the Settings panel select any options that you want to apply from the following:

Show data entry window on creation will display the business control's data entry window whenever
it is added to an object.

Preserve style locked objects will not update an object's style when the business control is applied
for objects that have their style locked.
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Allow business control field to be modified will allow users to change the business control data
table field value when attaching the business control to an object.

6. Click Next.

7. Do one of the following, depending upon your choice in step 4.

· If you selected Field value in a Data Table attachment, choose the data table and data table field
that you want to apply the business control point to, then enter a data table value that will be used to
identify the object as a control point.

· If you selected Statement Link, choose a statement set and then select a statement.

· If you selected Field value in a Statement's Link data table or Field value in a Statement's
data table, choose a statement set and a data table field, then enter a data table value that will be
used to identify the object as a control point.

8. Click Next.

9. From the Style Sheet drop-down list, choose a style to apply to the object.

Style Sheets

A style sheet should be created that is used solely for business controls. For more
information see Creating style sheets.

An object's style may be locked, thereby preventing a style sheet being applied.

10. To display an image on the object, in order to identify the object as a business control, click Select Image.
Locate the image and click Open.

Note: To remove the image click Clear.

11. Click Finish.

Related topics

Attaching business controls

Assigning business control access rights

Editing business controls

Removing business controls

Style sheets

Reporting

Attach a business control
A business control data table attachment acts in the same manner as a normal data table attachment, except that
one particular field is locked with a set value, as set in the business control properties, and this value defines the
business control point. See About business controls for more information.

Note: Business controls can only be attached to activities, flow lines and free text boxes.

1. Right-click the object and from the Business Controls menu choose Add Business Control.

2. Select the business control and click OK.
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3. If the business control references a data table attachment you can add information to the available data
table fields. Click OK when you have finished.

Note: The business control data table field value may be locked to prevent you from editing it. For more
information see Creating a business control or see your administrator.

Related topics

Attaching business controls

Assigning business control access rights

Editing business controls

Removing business controls

Style sheets

Reporting

Assign access rights
Business controls, by default, are viewable by all users. It is possible to assign specific access rights to a
business control, allowing you to grant and restrict access to certain users. See About business controls for more
information.

1. Right-click the attachment/link icon and choose Access/Modify.

2. Select the business control and click View Rights.

3. Choose the default access rights for all users.

Note: If you choose to deny access rights to all users you can assign specific viewing rights in the next step.

4. Click Add  to add users and/or user groups.

The user or user group will be granted access to the business control. To restrict access, double-click the
user or user group once added and select Access Denied.

More info on Access Rights...

Related topics

Attaching business controls

Assigning business control access rights

Editing business controls

Removing business controls

Style sheets

Reporting
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Edit a business control
Business controls can be modified.

Note: Existing business controls will not be updated until the business control is applied to an object. Only
administrators can edit business controls.

1. From the Tools menu choose Business Controls.

2. Select the business control and from the File menu choose Edit.

3. Click Next to step through the wizard, editing any options that are required, then click Finish on the last
step.

Related topics

Attaching business controls

Assigning business control access rights

Editing business controls

Removing business controls

Style sheets

Reporting

Remove a business control

1. Right-click the attachment/link icon and choose Access/Modify.

2. Select the business control and click Delete.

Related topics

Attaching business controls

Assigning business control access rights

Editing business controls

Removing business controls

Style sheets

Reporting
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Managing Maps

About map management
A map is a collection of diagrams that is stored in a process repository. A working map consists of at least one
draft copy, a master copy, which is a promoted draft, and possibly a number of scenario copies. Maps are created
by process authors with each map having at least one map administrator that manages the general map
properties.

A key element of TIBCO Nimbus is the ability to manage the process by which maps are created and developed.
The software provides a built-in work-flow environment for controlling the creation, authorization and ongoing
development of the content with full auditing capability.

Work-flow Principles

Every diagram has two components; a draft version and a published master version. When a new map is
created the initial work will done on the draft copy. For users to be able to view and use the map it must be
promoted to a master version through an authorization process. The master version is read only and any
amendments to a map, once it has been promoted, must be done on the draft copy.

As diagrams are part of a hierarchy that make up a map, the whole authorization and promotion to master
manages the integrity of the map and ensures that promotion can only occur when the structure is in the correct
state.

For traceability and audit purposes you can set an option to archive a current map in its entirety as diagrams are
promoted. Each diagram also has a number of additional items of information that are used in the management of
its life-cycle.

Users involved in the authorization work-flow

Authorizers

These assigned users are responsible for authorizing particular diagrams and documents

Draft Promoters

These assigned users are responsible for promoting particular diagrams and documents

Acknowledgers

These assigned users can be requested to acknowledge particular diagrams and documents.

Reviewers

These assigned users are responsible for reviewing particular diagrams and documents.
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Authorizing Diagrams

About diagram authorization

Draft diagrams need to be authorized before they can be promoted to master copies and made available to users
in the web server. Authorizers are assigned to specific diagrams and every authorizer must review a particular
diagram before it can be promoted to a master version.

Fig. A simplified authorization process

Assign authorizers

A diagram's author, owner or an administrator can assign authorizers. For a draft diagram to be promoted to a
master copy, the diagram must be authorized by all assigned authorizers.

Note: Users that are assigned as authorizers must have at least Read access to the diagrams.

1. From the Manage menu choose Authorization and then Authorizers.

2. Select the scope of the diagrams that you want to add authorizers to and click OK.

Current Diagram adds authorizers to the current diagram only.

Current Diagram and Lower Levels adds authorizers to the current diagram and all lower-level
diagrams.

Current Process Map adds authorizers to all diagrams in the current process map.

Diagram Scope List File adds authorizers to all diagrams in a diagram scope list file.

3. Click User or Resource to add users, user groups or resources.

Note: When you're assigning users, you can assign the owner, author and primary contact by clicking
Dynamic.

4. Click OK.

Sequence of authorizers

You can change the sequence of authorizers once they're assigned. For example, you may want one group to
authorize the diagram first before sending it to the next group. The requests will be sent by sequence
number, so all users assigned as sequence 1 will be requested to authorize the diagram first. Once those
users have authorized it, the request will be sent to the next set of users. 
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To change the sequence number of an existing authorizer, double-click the user, user group or resource.

Removing authorizers

Select the user, user group or resource and click Remove .

Related topics

About authorizing diagrams

Requesting authorization

Authorizing and rejecting diagrams

Canceling authorization

About promoting diagrams

System Options (Access)

System Options (Document Control)

Diagram scope lists

Request authorization

When a diagram is ready to be authorized, an authorization request is sent to the assigned authorizers.
Authorizers will be notified by Email, in order of sequence. When a diagram has been signed off by every
assigned authorizer then it can be promoted to a master copy and released to users.

Note: If one or more users do not have access to any of the diagrams that you are requesting an authorization
for, you will not be able to proceed. A dialog will list which users do not have access to which diagrams; you can
either remove them from the list of authorizers, or seek to provide access for these users.

1. From the Manage menu choose Authorization and then Request.

2. Specify the following options:

Date to be authorized by is the date in which the authorization should be completed by.

Scope is the scope of diagrams to request authorization for.

Current Diagram requests authorization for the current diagram only.

Current Diagram and Lower Levels requests authorization for the current diagram and all lower-
level diagrams.

Current Process Map requests authorization for all diagrams in the current process map.

Diagram Scope List File requests authorization for all diagrams in a diagram scope list file.

Additional Notes allows any supporting notes to be added to the request, which will appear in the
email that is sent to the authorizers.

3. Click Next to continue.

Reminders and escalation options

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

4. Specify any of the following options (if available):
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Enable email reminders will send reminder emails to assigned authorizers until they have signed the
diagram(s) off.

Enable SMS reminders will send reminder SMS messages to assigned authorizers until they have
signed the diagram(s) off.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

5. Click OK.

Related topics

About authorizing diagrams

Assigning authorizers

Authorizing and rejecting diagrams

Cancel authorization

About promoting diagrams

System Options (Access)

System Options (Document Control)

Diagram scope lists

Authorize or reject a diagram

Once a diagram is ready to be authorized, a request for authorization will notify the assigned authorizers and an
entry will appear in their Authorization To Do list. When all authorizers have authorized a diagram it is ready to
be promoted to a master copy.

Rejecting a diagram will Email the author, who will then decide whether to cancel the authorization request or
agree on a resolution with the authorizer. A diagram cannot be promoted until it has been authorized by all
assigned authorizers.

 

1. From the Manage menu choose Authorization and then To Do List.

The Authorization To Do List dialog displays all diagrams and files that you have been requested to
authorize. Holding Ctrl will allow you to select and authorize multiple diagrams and files.

2. Right-click the diagram and choose Authorize or Reject.

You can navigate to the diagram by double-clicking it. You can also right-click the diagram in order to view
the request notes, change log and associated feedback.

Related topics

About authorizing diagrams

Assigning authorizers
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Requesting authorization

Canceling authorization

About promoting diagrams

System Options (Document Control)

Cancel authorization

Canceling an authorization request will inform assigned authorizers and remove the request to authorize from
their authorization To-do list.

 

1. From the Manage menu choose Authorization and then Cancel Authorization.

Related topics

About authorizing diagrams

Assigning authorizers

Requesting authorization

Authorizing and rejecting diagrams

About promoting diagrams

Track authorization progress

You can view the authorization progress of a diagram or scope of diagrams.

1. From the Manage menu choose Authorization and then Progress Tracking.

2. Select the scope of diagrams that you want to view authorization for and click OK.

Note: Diagrams can be navigated to by double-clicking the diagram in the list. If a diagram has been rejected
you can view the reason why it was rejected by right-clicking the diagram in the list and choosing Rejection
Notes.

Related topics

About authorizing diagrams

Assigning authorizers

Requesting authorization

Authorizing and rejecting diagrams

About promoting diagrams
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Override an authorization cycle

Administrators can override an authorization cycle part-way through and authorize a scope of draft diagrams or a
process map. This is useful in cases where an authorizer is removed from an authorization cycle before they
have authorized it, thereby holding up the promotion of a diagram or map, for example if an authorizer is on
holiday or on sick leave.

Note: This option is only available to administrators.

 

1. From the Manage menu choose Authorization and then Override Authorization.

2. Enter your password and provide a reason for overriding the authorization cycle.

3. Select the scope of diagrams to override.

A Diagram Scope List is a user-defined list of diagrams within a process map or between process maps that
can be used when performing a number of operations. See Creating diagram scope lists.

4. Click OK.

Related topics

About authorizing diagrams

Assigning authorizers

Requesting authorization

Authorizing and rejecting diagrams

About promoting diagrams

Tracking authorization

Cancel authorization

Promoting Diagrams

About diagram promotion

Promoting a diagram will create a master copy of the diagram. Only authorized diagrams can be promoted and
once promoted, the draft copy is locked to prevent further editing. Only draft promoters can promote drafts and
they come in two forms; map draft promoters can promote an entire map whilst diagram draft promoters can
promote a specific diagram and all lower levels.

By default, a diagram and all child diagrams need to be promoted in one operation since the diagram is a
hierarchical structure and the child diagrams define the parent diagram. However, it is possible to promote only
the parent diagram without the child diagrams.

The top-level diagram of a promotion operation has to have a corresponding diagram in the master with the
same underlying ID in order to undertake the promotion (except in the case of the level 1 diagram for the first
time where the master does not exist). If the IDs do not match then it means a fundamental restructuring of the
draft diagrams has occurred since the last promotion. In this case a promotion should be performed from a
higher level. However, it is possible to resynchronize the IDs in the draft map to match the IDs in the master,
which can be useful if new sections of the map have been imported.

The draft promotion process will begin at the current diagram and include all lower level diagrams. If the entire
map is ready to be promoted then the process must be initiated at level 1. All promoted diagrams will then be
locked in draft mode and must be unlocked to make any edits. Placeholders will be created in the master for any
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child diagrams that are not being promoted, therefore when the child diagrams are promoted the relationship
between parent and child diagrams will be restored.

Assign draft promoters

Only assigned draft promoters can promote a draft to a master copy. There are two draft promoter accounts that
can be assigned to users; a map draft promoter is able to promote an entire map whereas a diagram draft
promoter can only promote a particular diagram and all associated lower level diagrams.

 

To assign a draft map promoter:

This will assign draft promoters to all diagrams within the process map.

1. From the Map menu choose Map Properties.

2. Click the Draft Promoters tab to select it.

3. Click Add Promoter  to add a user or group.

To assign a draft diagram promoter:

This will assign draft promoters to the current diagram level and all lower level diagrams.

1. From the Manage menu choose Diagram Information.

2. Click on the Promoters tab.

3. Click Add to add a user or group.

Related topics

About promoting diagrams

Assigning draft promoters

Selecting diagram placeholders

Resynchronizing diagram IDs

Promote a draft

Promoting a draft will create a master copy which then becomes accessible to authorized end-users. A diagram
can only be promoted if the diagram has been authorized and is ready for promotion, i.e., it has the status
'Promotion Ready'. Also, the parent diagram must exist in the master (unless this is the first time you are
promoting the map).
 

1. From the Manage menu choose Authorization and then Promote Draft Copy.

Scheduled Options

If the system is configured to use the Batch Server for promoting content, you will be prompted to select
when to promote the diagram(s).

Start as soon as possible will send the request to the Batch Server for immediate processing.
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Scheduled to start from allows you to schedule when to run the promotion from the Batch Server by
choosing defining an appropriate time frame. You must also choose a timezone from the drop-down options.

Overriding Promotion

If there are some diagrams in a map that are not ready for promotion then the Promotion
Results dialog will be displayed, listing all diagrams in the current map. You can promote
parent diagrams if any child diagrams are not ready for promotion - select the diagrams that
you want to promote (and that have the status Promotion Ready), then from the Override
menu choose Promote Diagram(s).

Unlocking Drafts

A draft can be unlocked if it is required to be edited again. See Unlocking drafts for more
information.

Integrity Checking

Consider running an integrity check before promoting a diagram to ensure that the diagram
adheres to best-practice mapping principles.

Related topics

About promoting diagrams

Assigning draft promoters

Selecting diagram placeholders

Resynchronizing diagram IDs

System Options (Document Control)

Promoting multiple maps (administrators only)

Select a diagram placeholder

Where a draft diagram is promoted to a master diagram but a child diagram is not promoted, a diagram
placeholder will replace any non-promoted child diagrams. All drill downs will exist and be accessible to users in
the master and users will see the diagram placeholder as opposed to the child diagram. A TIBCO Nimbus
administrator can take a snapshot of a current diagram (without drill-downs or data table links) to use as the
placeholder. Having placeholders also facilitates toggling between master and draft.

 

1. Right-click in a space on the diagram that you want to use as the master placeholder and choose Select
Current Diagram as Placeholder.

Related topics

About promoting diagrams

Assigning draft promoters

Resynchronize diagram IDs
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Resynchronize diagram IDs

Resynchronizing diagram IDs will synchronize, i.e. match up, the master and draft diagram IDs. This option is
only available to Administrators and diagram owners and authors and in most cases should never be required to
be manually performed as TIBCO Nimbus manages the draft and master diagram IDs automatically.

 

1. From the Manage menu choose Authorization and then Resynch Diagram IDS.

Related topics

About promoting diagrams

Assigning draft promoters

Selecting diagram placeholders

Resynchronize diagram IDs

Monitoring Batch Operations

Monitor batch operations

If the system is set to manage batch operations you can monitor these from within the Author Client. This allows
you to see if the Batch Server is running correctly by monitoring the current queue. The status of the Batch
Server is displayed in a single row at the bottom of the Author Client.

Note: This option is only available to administrators.

To monitor and manage batch operations:

1. Double-click the Batch Server Status row to open the Batch Server Status window.

Note: By default this panel is not displayed. To enable the panel, from the View menu choose Toolbars &
Panels, click the Panels tab and select Batch Server Status.

Reorder an operation (operations at the top are run first)

Cancel an operation

Updating Diagrams

Update a draft diagram

A draft becomes locked following its promotion to a master copy. This means that no editing can be undertaken
whilst locked. To make any edits the draft must first be unlocked. By default, map owners, map authors, map
administrators and administrators can unlock a draft. 

Note: There is a system option that will allow all process authors to unlock drafts and a system option that
automatically unlocks drafts following promotion.

1. Select the draft version of the map (choose Draft from the drop-down on the Scenario toolbar).

2. From the Manage menu choose Authorization and then Unlock Draft.
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3. Select the scope of the diagrams that you want to unlock and click OK.

Current Diagram unlocks the current diagram only.

Current Diagram and Lower Levels unlocks the current diagram and all lower-level diagrams.

Current Process Map unlocks all diagrams in the current process map.

Diagram Scope List File unlocks the diagrams defined in a diagram scope list file.

Related topics

Promoting diagrams

System Options (Document Control)

System Options (Advanced)

Updating Diagram Information

Update information for a single diagram

You can edit a diagram's information, such as title, description, owner, version, author, date, progress and status.
You can also assign and remove draft promoters and attach and remove documents and statement links.

Additionally, from the attachments tab you can change the order that documents appear by using the up and
down arrows, access the document, modify the attachment link and set the diagram access rights. 

Note: Modifying certain diagram information will create a change log.

Note: You must have the relevant diagram open to access the Diagram Information dialog and the diagram must
be a draft (the Authorization Status is Update Pending).

Update Diagram Information Details:

1. From the Manage menu choose Diagram Information.

Note: Additionally, you can access the Diagram Information panel by double-clicking on Title in the Diagram
Control Panel.

2. Modify any diagram details as required, then click OK.

Lock diagram title will prevent the diagram's title from being automatically updated when refreshing
diagram titles. When a child diagram is created, the diagram title is automatically derived from the parent
activity's description. From time to time, an administrator or map administrator may refresh the titles of a
scope of diagrams with any updates to parent activity descriptions. This option is useful if you have manually
edited the diagram title and you want to ensure it's not automatically updated with the parent activity's
description.

Displaying diagram titles in different languages

Diagram titles can be displayed in a number of different languages (depending upon which languages have
been specified by an administrator in the system options). The language that the title is displayed in will
depend on the locale of the user's machine; if a user's locale does not match any of the language variants
then it will display the default language.

To add a language variant, click Edit Language Variants  on the Details tab. For any language variant
that you want to add, click in the appropriate text box and enter the diagram title in the selected language.

Add Draft Promoters:

1. From the Manage menu choose Diagram Information.

2. Select the Promoters tab.
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3. Click Add in the Set Promoters sub-tab to assign users and user groups as draft promoters. See Assigning
draft promoters and Selecting Users and Groups for more information.

4. Click OK.

Remove Draft Promoters:

1. From the Manage menu choose Diagram Information.

2. Select the Promoters tab.

3. In the Set Promoters sub-tab select the promoter you wish to remove and click Remove. 

4. Click OK.

Add Attachments:

1. From the Manage menu choose Diagram Information.

2. Select the Attachments tab.

3. Click New  and then Document Registry Link.

4. From the Document Selector window search for the document you want to attach.  For further information
see Searching for Documents.

5. Double-click on the document to attach it.

6. Click OK.

Delete Attachments:

1. From the Manage menu choose Diagram Information.

2. Select the Attachments tab.

3. Select the document you want to delete and click Delete .

4. Click Yes to confirm.

5. Click OK.

Add Statement Links:

Note: Only Statement Managers, Statement Set Administrators, Statement Set Managers and Administrators are
permitted to add Statement Links via the Diagram Information dialog.

1. From the Manage menu choose Diagram Information.

2. Select the Statement Links tab, and click Add.

3. Locate the statement and select the check boxes of the links you want to add.

4. Click OK.

5. Click OK.

Delete Statement Links:

Note: Only Statement Managers, Statement Set Administrators, Statement Set Managers and Administrators are
permitted to delete Statement Links via the Diagram Information dialog.

1. From the Manage menu choose Diagram Information.
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2. Select the Statement Links tab.

3. Select the link you want to delete, and click Delete. 

4. Click Yes to confirm.

5. Click OK.

View Statement Link Properties:

1. From the Manage menu choose Diagram Information.

2. Select the Statement Links tab.

3. Select a statement link, and click Properties. For further information see Statement Link Properties.

Related topics

Updating information across a scope of diagrams

Replacing authors and owners across diagrams

Viewing diagram changes

Update information across diagrams

Basic diagram information such as version number, date, author and owner can be updated across a scope of
diagrams. When the owner or author is changed then a history audit log entry is automatically generated to
record the change.

1. From the File menu choose Version Manager.

2. From the Update panel select the check boxes of the updates that you want to make.

3. Choose the scope of diagrams to make the changes to.

Current Diagram allows you to change information for the current diagram only.

Current Diagram and Lower Levels allows you to change information for all lower-level diagrams.

Current Process Map allows you to change information for all diagrams in the current process map.

Diagram Scope List File allows you to change information for all diagrams in a diagram scope list file.

Include Internal WP Attachments and Include Internal Image Attachments will apply the
changes to any internal word-processed documents and images within the specified diagram scope.

4. Change any diagram information in the New Information panel.

Increment version number will automatically update the version number.

Set version number will allow you to define a version number manually.

5. Click OK.

Note: To replace owners and authors across a scope of diagrams click Advanced.

Related topics

Updating information for a single diagram

Replacing authors and owners across diagrams



Maps and Diagrams

TIBCO Nimbus® User Guide Page 168

Viewing diagram changes

Replace authors and owners across diagrams

The advanced options of the version manager allows you to replace specific authors and owners across a scope
of diagrams.

Note: Change requests assigned to any diagrams that are updated with respect to the author and/or owner are
also updated.

 

1. From the File menu choose Version Manager.

2. Click Advanced.

To replace authors across a scope of diagrams:

1. Select the Search and Replace on Authors check box.

2. In the Find text box, click Select User .

3. Search for the user that you want to replace.

4. Repeat steps 2-3 for the user that you want to replace with in the Replace text box.

Note: C lick Me if the existing or new author is you.

5. Select the scope of diagrams that you want to make the changes across.

Include Internal WP Attachments and Include Internal Image Attachments will replace the authors
on associated internal word-processed attachments and internal image attachments within the specified
diagram scope.

To replace owners across a scope of diagrams:

1. Select the Search and Replace on Owners check box.

2. In the Find text box, click Select User .

3. Search for the user that you want to replace.

4. Repeat steps 2-3 for the user that you want to replace with in the Replace text box.

Note: C lick Me if the existing or new owner is you.

5. Select the scope of diagrams that you want to make the changes across.

Include Internal WP Attachments and Include Internal Image Attachments will replace the owners
on associated internal word-processed attachments and internal image attachments within the specified
diagram scope.

Related topics

Updating information for a single diagram

Updating information across a scope of diagrams
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Viewing diagram changes

View diagram changes

It is possible to view all diagram changes for a particular diagram. You can also edit a specific change log if you
have the appropriate rights.

1. From the Manage menu choose Diagram Change Log.

To add a new change log:

1. Click Add.

2. Select the date and update the version number, if required.

Note: You can manually enter a version number by clicking in the box.

To edit an existing change log:

1. Select the change log and click Edit.

To delete a change log:

1. Select a change log and click Delete.

Related topics

Updating information for a single diagram

Updating information across a scope of diagrams

Replacing authors and owners across diagrams

Viewing Diagram Authorization Audit Trail

View the diagram authorization audit trail

The Diagram Audit Trail records any changes that are made relating to the authorization of a diagram, for
example when drafts have been promoted, if an author has changed, etc.

1. From the Manage menu choose Authorization and then Diagram Audit Trail.

The Current tab displays the current authorization status of the diagram.

Note: C lick the History Audit Log to view any authorization logs, then double-click a log entry to view the
details.

Managing Map Archives

Manage map archives

The Archive Manager is used to create and manage your map archives. A map archive is a compressed copy of a
map, including its associated attachments. If set in the system options, maps can be archived automatically upon
promotion.

TIBCO Nimbus Archive Utility
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The Archive Utility, which can be run by administrators only, compresses archived maps into archived packages
(.arc) and stores them in a specified location. Old archives can also be either moved or permanently deleted
after a certain time. For information on the Archive Utility see the Administration Guide - Maintenance/
Archiving Maps.

Archiving System Options

 

To archive the current map:

1. From the File menu choose Archive Manager.

2. From the File menu choose Archive Current Map.

To restore an archived map:

1. From the File menu choose Archive Manager.

2. Select the maps that you want to restore and click Restore.

To open an archived map:

1. From the File menu choose Archive Manager.

2. Select the map that you want to open and from the File menu choose Open Archive.

To rebuild an archived map:

Rebuilding a map archive will replace an existing map archive (.map) with the archived package (.arc). This
option is only available if an archived package of the map archive exists.

1. From the File menu choose Archive Manager.

2. Select the map that you want to rebuild and from the File menu choose Open Archive.

To delete an archived map:

1. From the File menu choose Archive Manager.

2. Select the archived map that you want to permanently delete and click Delete.

Creating Actions

Create an action

Actions can be created for diagrams. For information on actions please refer to the Action Management section.

1. In the Action Registry window (Actions>Action Registry), click New  and choose Diagram Action, and
then click Next.

2. Click Select to select the map and diagram to create an action for.

3. Choose the scope of diagrams to create the action for, and then click Next.

Current Diagram creates an action for the current diagram only.

Current Diagram and Lower Levels creates an action for the current diagram and all lower-level
diagrams.

Diagram Scope List File creates an action for all diagrams in a diagram scope list file.
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4. In the Properties step, define the properties of the action, and then click Next.

5. In the Assignees step, click Add to add users to undertake the action, and then click Next.

Require only 1 assignee to complete action will require only one of the assigned users to complete
the action before it can be closed.

Note: When you're assigning users, you can assign the owner, author and primary contact by clicking
Dynamic.

6. In the Editors step, click Add to add users that can edit the action, and then click Next.

Note: When you're assigning users, you can assign the owner, author and primary contact by clicking
Dynamic.

7. In the Viewers step, click Add to add users that can view the action, and then click Next.

Note: When you're assigning users, you can assign the owner, author and primary contact by clicking
Dynamic.

8. In the Description step, add any information about the action, such as the reason for requiring the action,
and then click Next.

9. In the Owner Category Data step, provide additional information based on the fields available (note that this
step may not be available).

10. In the Additional Data window, provide additional information based on the fields available (note that this
step may not be available).

11. In the Attachments window, add any attachments for additional support. Attachments can be file links,
application links, email links, SAP transaction links, document links, storyboard links and URL links. 

Click New  to add an attachment. To modify the access rights for a particular action, select the attachment

and click Set View Rights .

Reminders and Escalation

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue action. An
escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

12. In the Reminders and Escalation step, set the relevant reminder and escalation options.

Enable email reminders will send reminder emails to users until they have completed the action.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
completed the action.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalation of overdue items will escalate an overdue request by notifying users' line
managers by email.

Escalate after x days of being overdue is the number of days after the due date has passed before
notifying users' line managers.

13. Click Finish.

Contacting Users

Contacting users

You can contact the owner, author, acknowledgers, authorizers and subscribers of a diagram.

1. From the Diagram menu choose Send Message To, then select an option.
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Audit Trails

View diagram audit trails

The audit trail lists the current authorization state for diagrams and a history of changes to the authorization.

Note: Audit records are read-only.

1. From the Manage menu choose Authorization and then Diagram Audit Trail.

There are two tabs; Current Progress and History Audit Log.

Note: To view the details of an audit record double-click a record in the History Audit Log tab.

Change Logs

View the change log

When updating a diagram you can add a note to describe the change. These are recorded in the change log for a
specific diagram and can be viewed by users that have access to the diagram. 

Note: Only file owners, authors, creators, administrators and map administrators can add, edit and delete change
log entries.

1. From the Manage menu choose Diagram Change Log.

Adding, editing and deleting change logs

To add a new change log entry click Add. To edit an existing change log entry, select the change log entry
and click Edit. To delete an existing change log entry, select the change log entry and click Delete.

Viewing changes for a scope of diagrams

You can view all change log entries for a diagram, scope of diagrams or a selection of process maps. From
the Manage menu choose List Changes.

Diagram Scope Lists

Create a diagram scope list

A diagram scope list is a user-defined list of diagrams within a process map or between process maps that can be
used when performing a number of operations within TIBCO Nimbus, including:

· Assigning diagram access rights

· Setting authorizers

· Setting reviewers

· Setting acknowledgers

· Creating subscriptions

· Requesting authorization

· Requesting acknowledgement

· Requesting recurring reviews

· Unlocking draft/canceling authorization

· Applying a template

· Refreshing titles

· Updating diagram information in Version Manager

· Scheduling a review
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· Running a report

· Running an integrity check

· Adding backgrounds to diagrams

 

1. From the View menu choose Diagram List.

2. Select a scope of diagrams.

Note: If you are unsure choose Current Process Map.

3. Hold Ctrl and select the diagrams that you want to add to the list, then right-click and choose Save
Selected As Scope List.

Note: You can then view a diagram scope list from the Diagram List dialog.

Related topics

Managing diagram scope lists

Manage a diagram scope list

Diagrams can be added or removed from existing diagram scope lists.

To add a diagram to a scope list file:

1. From the Tools menu choose Diagram Scope Lists.

2. Click Open and locate the diagram scope list file (.dsl).

3. Click Add.

4. Select the process map in the left panel.

5. Click a diagram to select it and click OK. 

To remove a diagram from a scope list file:

1. Highlight the diagram that you want to remove. 

Note: Hold Ctrl to select multiple diagrams.

2. Click Delete.

Related topics

Creating diagram scope lists
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Collaborating on Diagrams

Requesting Acknowledgement

Assign acknowledgers

Acknowledgers are users or user groups that are required to acknowledge a diagram. When an author requests
acknowledgement for a diagram, acknowledgers will receive an Email and their To-do list will be updated in the
Web Server.

Note: Acknowledgers can only be assigned by administrators, diagram authors and diagram owners. If one or
more users do not have access to any of the diagrams that you are assigning them to then you will not be able to
proceed. A dialog will list which users do not have access to which diagrams; you can either remove them from
the list of acknowledgers, or seek to provide access for these users.

1. From the Manage menu choose Acknowledgers.

2. Select the scope of the diagrams that you want to assign users to.

Current Diagram displays the current diagram only.
Current Diagram and Lower Levels displays the current diagram and all lower-level diagrams.
Current Process Map displays all diagrams in the current process map.
Diagram Scope List File displays all diagrams in a diagram scope list file.

3. Click User to add users and user groups, or Resource to add resources.

Note: To dynamically assign the diagram's activity resources as the acknowledgers, click Dynamic and
choose <Based on Resources>.

Removing users
Select the user, user group or resource that you want to remove, then click Remove .

Resending Acknowledgement Requests to New Acknowledgers

If an acknowledgement request has been sent out for a scope of diagrams and new acknowledgers are assigned,
you can resend the acknowledgement request to these new users. See Requesting acknowledgement for further
information.

Related topics

About acknowledgement

Request acknowledgement

Acknowledging diagrams

Viewing the acknowledgement log

Request acknowledgement

Following the promotion of a diagram, selected users can be requested to acknowledge the new content. An
acknowledgement request will appear in their To-dos and they will be notified by email.

Note: If one or more users do not have access to any of the diagrams that you are requesting an
acknowledgement for, you will not be able to proceed. A dialog will list which users do not have access to which
diagrams; you can either remove them from the list of acknowledgers, or seek to provide access for these users.

Acknowledgement Reports

A number of acknowledgement-based reports are available. See Generating reports for more information.
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Acknowledgements displays a list of users that have acknowledged a scope of diagrams.

Acknowledgement Progress displays the acknowledgement progress for a scope of diagrams.

Acknowledgement Requests displays a list of acknowledgement requests for a scope of diagrams,
including status and the percentage complete.

Acknowledgement Summary displays a high-level overview of the acknowledgement progress for a
selected scope of diagrams. Double-click a row to view the Acknowledgement Progress report for a specific
diagram.

 

1. From the Manage menu choose Request Acknowledgement.
2. In the Acknowledgement Type options choose the type of acknowledgement that you want to create.

Standard allows you to create a single acknowledgement request for a scope of diagrams that must be
completed by a specific date. Once all acknowledgers have acknowledged then the status of  the request
will be set to Complete. Note that if new acknowledgers are added at a later date then they will be
assigned the same date, which may lead to past due (overdue) requests being assigned to new
acknowledgers.

Continuous allows you to create an open acknowledgement request for a scope of diagrams, which is
open indefinitely, and allows users to be added at any time. When a new acknowledgement request is
sent out, new acknowledgers will be assigned a due date in advance of the date the new request is sent,
thereby ensuring that they do not receive past due (overdue) requests.

3. Select either the Date to be acknowledged by or the Acknowledgement request due dates to (depending on
what you selected in the previous step).

Note: The Acknowledgement request due dates to setting (for continuous acknowledgement
requests) will automatically create due dates from the date a new acknowledger is assigned. For
example, if you set 2 weeks as the value and a new acknowledger is added on the 1st January, then the
due date for that user to acknowledge the content by will be the 15th January. 

4. Choose the scope of diagrams to request acknowledgement for.

Current Diagram requests acknowledgement for the current diagram only.

Current Diagram and Lower Levels requests acknowledgement for the current diagram and all
lower-level diagrams.

Current Process Map requests acknowledgement for all diagrams in the current process map.

Diagram Scope List File requests acknowledgement for all diagrams in a diagram scope list file.

5. Enter any additional notes that may be useful for a user when acknowledging the content.
6. Click Next to define the reminder and escalation options.

Reminders and escalation options

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

Enable email reminders will send reminder emails to assigned acknowledgers until they have signed
the diagram(s) off.

Enable SMS reminders will send reminder SMS messages to assigned acknowledgers until they have
signed the diagram(s) off.

Reminders to be sent every x days is the frequency of days in which email and SMS reminders are
sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalation of overdue items will escalate an overdue request by notifying users' line
managers by email.

Escalate after x days of being overdue is the number of days after the due date has passed
before notifying users' line managers.
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7. Click OK to finish.

Resending Acknowledgement Requests to New Acknowledgers

If an acknowledgement request has already been submitted for a selected scope of diagrams and new
acknowledgers are assigned, you can resend the acknowledgement request to these new users. This ensures that
a user is made aware of any new processes that relate to their new group membership. 

In the acknowledgers list for a particular diagram, choose the scope of diagrams to resend any acknowledgement
requests for, then select the new users in the list (hold Ctrl to select multiple users). Right-click a selected user
and choose Send Current Request. In the Request Acknowledgement dialog that opens you can deselect any
users, if required, then click OK to send the request(s).

See Assigning acknowledgers for further information.

Resending Acknowledgement Requests to New Group Members

When a user joins a new user group, you can resend them any previous acknowledgement requests that relate to
their new group membership. This ensures that users are made aware of any new processes, documents and
storyboards that relate to their new roles.

 This option is only available to TIBCO Nimbus administrators.

Note: If the user has joined a group that is a member of other groups, i.e. the group is a sub-group of one or
more parent groups, they will also receive any acknowledgement requests that exist for associated parent
groups. 

In the User Accounts window, right-click the user and choose Send Acknowledgements. Select the user
group(s) that you want to send current acknowledgement requests for, i.e. select the group(s) that the user has
recently joined. Automatically reactivate completed acknowledgements will reactivate the last completed
acknowledgement request (i.e. set it to 'active) and send it to the user. If this option is not selected then only
active requests will be sent to the user. Click Next to define the reminder and escalation details (see above for
information) and click OK.

Related topics

About acknowledgement

Assigning acknowledgers

Acknowledging diagrams

Viewing the acknowledgement log

Action Lists

System Options (Document Control)

Cancel and complete acknowledgement requests

Canceling and completing acknowledgement requests is undertaken through the Collaboration Console.

Acknowledge a diagram

Acknowledgers may be requested to formally acknowledge updates to a diagram. All acknowledgements are
recorded in the acknowledgement log to show that the changes have been reviewed and accepted.

If you do not understand what changes have been made or disagree with them, contact the requester. In a
quality system it is imperative that you understand any changes being made before acknowledging them.
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1. From the Manage menu choose Acknowledge Diagram(s).

2. Choose the scope of diagrams that you want to acknowledge.

Current Diagram will acknowledge the diagram that you are currently viewing.

Current Diagram And Lower Levels will acknowledge the diagram that you are currently viewing and
any lower level diagrams that require your acknowledgement.

Current Process Map will acknowledge all diagrams in the current process map that require your
acknowledgement.

My Actions

Your current acknowledgement requests are also listed in your My Actions in the Author
Client. From the Actions menu choose My Actions. To acknowledge a diagram double-
click the acknowledgement request.

Related topics

About acknowledgement

Assigning acknowledgers

Request acknowledgement

Viewing the acknowledgement log

System Options (Document Control)

Action Lists

View the acknowledgement log

All acknowledgements made against a diagram are stored in a log and a separate log is created for each
diagram.

1. From the Manage menu choose Acknowledgement Log.

Related topics

About acknowledgement

Assigning acknowledgers

Request acknowledgement

Acknowledging diagrams

Providing Feedback

Add feedback

1. From the Diagram menu choose Feedback.

2. Right-click Feedback (on the left) and choose Start New Topic.
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3. Enter a title, reference (optional) and subject (optional).

4. Click OK .

Hint: To spell check the feedback before submitting it, from the Tools menu choose Check Spelling.

Related topics

About feedback

Replying to feedback

Editing feedback

Deleting feedback

Printing feedback

Reply to feedback

1. From the Diagram menu choose Feedback.

2. Right-click the feedback that you want to reply to and choose Reply To Topic.

3. Enter a title, reference (optional) and subject (optional).

4. Click OK .

Hint: To spell check the feedback before submitting it, from the Tools menu choose Check Spelling.

Related topics

About feedback

Adding feedback

Editing feedback

Deleting feedback

Printing feedback

Edit feedback

1. From the Diagram menu choose Feedback.

2. Right-click the feedback and choose Edit.

Note: You can only edit your own feedback.

Related topics

About feedback
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Adding feedback

Replying to feedback

Deleting feedback

Printing feedback

Delete feedback

1. From the Diagram menu choose Feedback.

2. Right-click the feedback and choose Delete.

Note: You can only delete your own feedback. Administrators can delete all feedback associated with a
diagram. From the Feedback menu choose Delete All.

Related topics

About feedback

Adding feedback

Replying to feedback

Editing feedback

Printing feedback

Print feedback

1. From the Diagram menu choose Feedback.

2. Select the feedback topic that you want to print and from the Feedback menu choose Print Feedback.

Note: You can print all feedback associated with a diagram. From the Feedback menu choose Print All
Feedback.

Related topics

About feedback

Adding feedback

Replying to feedback

Editing feedback

Deleting feedback
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Requesting Reviews

Assign reviewers

Reviewers are users that are assigned to review diagrams by authors, owners or administrators.

Note: If one or more users do not have access to any of the diagrams that you are assigning them to then you
will not be able to proceed. A dialog will list which users do not have access to which diagrams; you can either
remove them from the list of reviewers, or seek to provide access for these users.

1. From the Actions menu choose Diagram Reviewers.

2. Select the scope of diagrams to assign the diagram reviewers to.

Current Diagram is the current diagram only.
Current Diagram and Lower Levels is the current diagram and all lower-level diagrams.
Current Process Map are all diagrams in the current process map.
Diagram Scope List File are all diagrams in a diagram scope list file.

3. Click Add  to add users.

Note: When you're assigning users, you can assign the owner, author and primary contact by clicking
Dynamic.

Related topics

About reviewing diagrams

Requesting reviews

Creating recurring reviews

Canceling recurring reviews

Editing recurring reviews

Removing recurring reviews

Manually triggering recurring reviews

Signing off reviews

Tracking the authorization process

Request a review

From time to time you may want to have a diagram reviewed by certain users (reviewers). Reviewers will be
notified by email and a new action will appear in their To-dos.

Note: If one or more users do not have access to any of the diagrams that you are requesting a review for, you
will not be able to proceed. A dialog will list which users do not have access to which diagrams; you can either
remove them from the list of reviewers, or seek to provide access for these users.

1. From the Actions menu choose Schedule Diagram Review.

2. Enter a user reference, if appropriate, and a note. Click Next to continue.

3. Choose the date that want the review to be completed by and the priority, then click Next.

Reminders and escalation options
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Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

4. Specify any of the following options (if available):

Enable email reminders will send reminder emails to assigned reviewers until they have signed the
diagram(s) off.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
signed the diagram(s) off.

Reminders to be sent every x days is the frequency of days in which email and SMS reminders are
sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalation of overdue items will escalate an overdue request by notifying users' line
managers by email.

Escalate after x days of being overdue is the number of days after the due date has passed
before notifying users' line managers.

5. Click Next.

6. To add an attachment click New  and choose an attachment type.

7. Click Next and select the scope of diagrams that you want to request a review for.

8. Click Next, if requested, enter your password and then click Finish.

Related topics

About reviewing diagrams

Assigning reviews

Creating recurring reviews

Canceling recurring reviews

Editing recurring reviews

Removing recurring reviews

Manually triggering recurring reviews

Signing off reviews

Tracking the authorization process

Diagram scope lists

Create a recurring review

Recurring reviews will automatically request a review of a diagram at specified time intervals. 

Note: Recurring reviewers must be set up separately to ad hoc reviewers, i.e. assigned ad hoc reviewers will not
be automatically defined as recurring reviewers. See Creating a recurring file review for further information. If
one or more users that you assign do not have access to any of the diagrams then you will not be able to create
a recurring review. A dialog will list which users do not have access to which diagrams; you can either remove
them from the list of reviewers, or seek to provide access for these users.
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1. From the Actions menu choose New Recurring Review.

2. Choose the first review date from the First Review date selector.

3. Define the recurrence of the review, i.e. the time delay between reviews.

4. Define the notification period, i.e. the time period that users will be reminded to review the diagram before
the actual review is due, then click Next.

Reminders and escalation options
Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

5. Specify any of the following options (if available):

Enable email reminders will send reminder emails to assigned reviewers until they have signed the
diagram(s) off.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
signed the diagram(s) off.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

6. Click Add to add the users and/or user groups who you want to review the diagram, then click Next.

Note: Any reviewers assigned to the diagram will be automatically added. These can be removed by
selecting the user(s) and clicking Remove. You can assign the owner, author and primary contact by
clicking Dynamic.

7. Enter some optional notes about the recurring review, e.g. the reason for the review, then click Next.

8. Select the scope of diagrams to request the recurring review against.

9. Enter your password and click OK.

Related topics

About reviewing diagrams

Diagram Scope Lists

Assigning reviews

Canceling recurring reviews

Requesting reviews

Editing recurring reviews

Removing recurring reviews

Manually triggering recurring reviews

Signing off reviews

Tracking the authorization process
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Edit a recurring review

Recurring reviews will automatically request a review of a diagram at specified time intervals. Recurring reviews
can be edited, for example to change the recurrence, notification or add/remove users.

Note: Recurring reviews have separate reviewers assigned to each recurring review.

1. From the Actions menu choose View Recurring Review.

2. Choose the scope of diagrams to view recurring reviews for.

Current Diagram is the current diagram only.

Current Diagram and Lower Levels is the current diagram and all lower-level diagrams.

Current Process Map are all diagrams in the current process map.

Diagram Scope List File are all diagrams in a diagram scope list file.

Map Selection allows you to select multiple diagrams from any maps within the process repository.

3. Right-click the recurring review and choose Edit.

4. Make any changes to the review settings, if required, then click Next.

5. Click Add to assign new users to the review or select users that you want to remove and click Remove.

6. Click Next and edit the note, if required.

7. Click Next, enter your password and click Finish.

Related topics

About reviewing diagrams

Assigning reviews

Requesting reviews

Creating recurring reviews

Canceling recurring reviews

Removing recurring reviews

Manually triggering recurring reviews

Signing off reviews

Tracking the authorization process

Cancel a review

Recurring reviews will automatically request a review of a diagram at specified time intervals. 

1. From the Manage menu choose Collaboration.

2. Right-click on the review you want to cancel and choose Cancel Review.

3. Click Yes.

Related topics

Assigning reviews

Requesting reviews
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Creating recurring reviews

Editing recurring reviews

Removing recurring reviews

Manually triggering recurring reviews

Signing off reviews

Remove a recurring review

Recurring reviews will automatically request a review of a diagram at specified time intervals.

 

1. From the Actions menu choose View Recurring Reviews.

2. Choose the scope of diagrams to view recurring reviews for and click OK.

3. Select the recurring review and from the File menu choose Delete.

Related topics

About reviewing diagrams

Assigning reviews

Requesting reviews

Creating recurring reviews

Canceling recurring reviews

Editing recurring reviews

Manually triggering recurring reviews

Signing off reviews

Tracking the authorization process

Diagram scope lists

Manually trigger a recurring review

The next review in a recurring review cycle can be manually triggered by administrators and action managers. All
reviewers of the recurring review will be notified and requested to review the diagram.

 

1. From the Actions menu choose View Recurring Reviews.

2. Select the scope of diagrams to view recurring reviews for.

3. Right-click the recurring review and choose Manually Trigger Next Cycle.

Related topics



Maps and Diagrams

TIBCO Nimbus® User GuidePage 185

About reviewing diagrams

Assigning reviews

Requesting reviews

Creating recurring reviews

Canceling recurring reviews

Editing recurring reviews

Removing recurring reviews

Signing off reviews

Tracking the authorization process

Diagram scope lists

Sign off a review

If you have been requested to review a diagram then it will appear in your Action List from where you can
approve or reject it.

 

1. From the Actions menu choose Action Registry.

2. Right-click the review item and choose Sign off.

3. Choose either Approve Review or Reject Review, enter your password and any relevant notes, then
click OK.

Note: Rejecting a diagram will automatically display the New Change Request window, allowing you to
create a change request based on the reasons why you have rejected the diagram.

Related topics

About reviewing diagrams

Assigning reviews

Requesting reviews

Creating recurring reviews

Canceling recurring reviews

Editing recurring reviews

Removing recurring reviews

Manually triggering recurring reviews

Tracking the authorization process
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Creating Change Requests

About change requests

As part of a quality management system, change requests can be raised against diagrams. When a change
request is created the diagram owner will be notified with a request to review it. Following successful
authorization by the owner, the diagram author will then be requested to review it.

Create a change request

Changes can be requested for diagrams in the form of change requests. New change requests will automatically
notify the Primary Email Contact (set as the diagram owner or author), who will decide to either progress the
change, request more information, or reject it.

1. From the Manage menu choose New Change Request.

2. Enter the relevant information for each stage, pressing Next to proceed to the next step.

Related topics

About change requests

Reviewing change requests

Completing change requests

Viewing change requests

Viewing change request logs

Changing the originator, owner or author

System Options (Document Control)

Edit a change request

If you are an administrator or the owner of a change request you can edit the details, such as the owner, author,
originator, reminder and escalation settings and attachments.

1. From the Manage menu choose View Change Requests.

Note: Alternatively, click the Change Requests indicator (bottom-right of the screen).

2. Select the scope that you want to view change requests for, and then click OK.

3. Right-click the change request that you want to edit and choose one of the options.

Related topics

About change requests

Reviewing change requests

Completing change requests

Viewing change requests

Viewing change request logs

Changing the originator, owner or author
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System Options (Document Control)

Review a change request

Following the submission of a change request, the primary email contact will be automatically notified with a
request to review it before it is passed on to the diagram author to review and complete. As the initial reviewer,
you can choose to accept or reject the change, or you can request further information from the originator, or
request that the diagram undergoes an impact assessment. Once the review stage has been confirmed then a
notification message is sent to the specified implementer and a To-Do is assigned them. If a change request is
rejected, or further information requested, then the change request is returned back to the originator, who can
then cancel it or resubmit the request with additional information.

Note: The owner may not necessarily be the diagram owner as in some cases the originator may have specified
a different user.

1. From the Manage menu choose View Change Requests.

2. Choose the scope of diagrams that you want to view any change requests for.

Current Diagram includes the current diagram only.

Current Diagram and Lower Levels includes the current diagram and all lower-level diagrams.

Current Process Map includes all diagrams in the current process map.

Diagram Scope List File includes all diagrams in a diagram scope list file.

Map Selection includes all diagrams in the current process map repository.

3. Click the change request from the list that you want to review to display it.

4. Click on the yellow box that states Owner.

Note: If you are not the owner or the change request is not in the review stage then you cannot review it.

5. Select an option and click Next.

Allocate Request will accept the change request and send it to the author to action (this option is not
available if the change request has already been approved and sent to the author but then returned for
more information).

Need More Information will return the change request to the originator with a request to provide
more information.

Reject Request will return the change request to the originator as rejected.

Impact Assessment will hold the change request to allow the impact on the diagram to be assessed.

6. Enter the relevant information relating to the option you have chosen. For example, why the change request
is being rejected, what kind of information you require from the originator, etc.

Note: You can find any change requests that await your input in your Action List.

Related topics

About change requests

Creating change requests

Completing change requests

Viewing change requests

Viewing change request logs

Changing the originator, owner or author



Maps and Diagrams

TIBCO Nimbus® User Guide Page 188

Complete a change request

When a change request has been approved by the owner, the author is requested to action the change request.
Once the change request has been actioned the author is required to set the status to complete. The author can
also request further information from the owner or originator to provide clarification of the change request if
required.

Note: The author may not necessarily be the diagram author as a different user may have been specified to
action the change request.

1. From the Manage menu choose View Change Requests.

2. Choose the scope of diagrams that you want to view any change requests for.

Current Diagram includes the current diagram only.

Current Diagram and Lower Levels includes the current diagram and all lower-level diagrams.

Current Process Map includes all diagrams in the current process map.

Diagram Scope List File includes all diagrams in a diagram scope list file.

Map Selection includes all diagrams in the current process map repository.

3. Click the change request from the list that you want to review to display it.

4. Click on the yellow box that states Author.

Note: If you are not the author or the change request is not in the completion stage then you cannot
complete it.

5. Select an option and click Next.

Need More Information (From The Originator) will return the change request to the originator with
a request to provide more information.

Confirm Completion states that the change request has been fulfilled and sets the status to complete.

Need More Information (From The Owner) will return the change request to the owner with a
request to provide more information.

6. Enter the relevant information relating to the option you have chosen. For example, what kind of information
you require from the originator or owner.

Note: You can find any change requests that are assigned to you and that await your input in your Action
List.

Related topics

About change requests

Creating change requests

Reviewing change requests

Viewing change requests

Viewing change request logs

Changing the originator, owner or author
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View change requests

The Change Requests dialog lists all change requests for a selected scope of diagrams or documents. When a
change request is highlighted in the list the stage at which the change request is at will be highlighted in yellow.
The appropriate user can then click on the stage that they're associated with to complete it and progress the
change request to the next stage.

 

1. From the Manage menu choose View Change Requests.

2. Choose the diagram scope that you want to view the change requests for.

Current Diagram includes the current diagram only.

Current Diagram and Lower Levels includes the current diagram and all lower-level diagrams.

Current Process Map includes all diagrams in the current process map.

Diagram Scope List File includes all diagrams in a diagram scope list file.

Map Selection includes all diagrams in the current process map repository.

3. Click the change request from the list to view the route map.

Hint: You can group columns by dragging a column header onto the gray area just above the list of change
requests.

Related topics

About change requests

Creating change requests

Reviewing change requests

Completing change requests

Viewing change request logs

Changing the originator, owner or author

View change request log

A log of all notes is kept with the change request, allowing any interested users to collaborate by adding new
topics or replying to existing topics.

 

1. From the Manage menu choose View Change Requests.

2. Choose the diagram scope that you want to view the change requests for.

Current Diagram includes the current diagram only.

Current Diagram and Lower Levels includes the current diagram and all lower-level diagrams.

Current Process Map includes all diagrams in the current process map.

Diagram Scope List File includes all diagrams in a diagram scope list file.

Map Selection includes all diagrams in the current process map repository.

3. Right-click the change request from the list and choose Change Log/Notes.
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4. To add a note do one of the following:

· From the Feedback menu choose Start New Topic.

· Right-click an existing note and choose Reply To Topic.

Related topics

About change requests

Creating change requests

Reviewing change requests

Completing change requests

Viewing change requests

Changing the originator, owner or author

Change the originator, owner or author

By default the change request originator is the user that creates the change request and the owner and author is
the diagram owner and author. It is possible to specify different users as the originator, owner and author.

Note: Change request owners and authors are automatically updated when diagram owners and/or authors are
changed.

1. From the Manage menu choose View Change Requests.

2. Choose the diagram scope that you want to view the change requests for.

Current Diagram includes the current diagram only.

Current Diagram and Lower Levels includes the current diagram and all lower-level diagrams.

Current Process Map includes all diagrams in the current process map.

Diagram Scope List File includes all diagrams in a diagram scope list file.

Map Selection includes all diagrams in the current process map repository.

3. Right-click the change request from the list and choose either Change Owner, Change Author or Change
Originator.

4. Click Select user  to specify a user, or click Me if you want to assign yourself.

5. Click OK.

Related topics

About change requests

Creating change requests

Reviewing change requests

Completing change requests

Viewing change requests

Viewing change request logs
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Subscribing to Diagrams

About subscriptions

Subscriptions are used to notify subscribed users via Email of any changes to diagram and document versions.
Users can subscribe themselves to diagrams and documents, and subscribe other users. A system option can
force diagram and document version numbers to increment automatically upon promotion from a draft to a
master. Alternatively, users can manually increment a version number.

For diagrams, a different set of subscribers can be defined for the draft and master versions. Subscribed users
will not be copied over when a draft diagram is promoted. However, when assigning subscribers to a document,
both draft and master versions will contain the same subscription list. If you remove a subscribed user from the
draft version then they will also be removed from the master version, and vice-versa.

Note: Contributors cannot add or remove other users from a subscription list, however they can add or remove
themselves (if they have the Change Subscription user account setting enabled).

Add a subscription

Add subscriptions to users:

1. From the Diagram menu choose Subscriptions.

2. Click Add Subscriptions.

3. Search for and add users:

a. Select Search Users in the list (top-left).

b. In the Criteria panel select to search against Account, First Name, Last Name or Group by selecting the
relevant radio button.

c. Enter the search text in the relevant text box or select the user group from the group drop-down list.

Hint: You can enter part of the text. For example, entering 'Jo' as the first name will return names
beginning with 'Jo', such as John, Joanne, etc.

Note: You can retrieve all users by leaving the fields blank.

d. Click Find.

e. Select the user from the list of users that is returned and click Add.

Hint: Hold Ctrl to select multiple users.

Note: Click Me to add yourself or Dynamic to add the Owner, Author or Primary Contact.

f. Click OK.

4.    C lick Next.

5.     Select the scope of diagrams to apply the subscriptions to.

Diagram Scope List Files

A diagram scope list file is a list of diagrams within a process map, or across multiple process maps.
See Creating diagram scope lists for more information.

6.    C lick Next.

7. Click Apply.

Add subscriptions to groups:

1. From the Diagram menu choose Subscriptions.

2. Click Add Subscriptions.

3. Search for and add groups:
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a. Select Search Groups in the list (top-left).

b. Enter the name of the group in the Name text box and click Find.

Note: You can retrieve all groups by leaving the field blank. 

c. Select the group from the list that is returned and click Add.

Hint: Hold Ctrl to select multiple groups.

Note: Click Me to add yourself or Dynamic to add the Owner, Author or Primary Contact.

d. Click OK.

4. Click Next.

5.     Select the scope of diagrams to apply the subscriptions to.

Diagram Scope List Files

A diagram scope list file is a list of diagrams within a process map, or across multiple process maps.
See Creating diagram scope lists for more information.

6. Click Next.

7. Click Apply.

Related topics

Removing subscriptions

Replacing subscriptions

Remove a subscription

1. From the Diagram menu choose Subscriptions.

2. Select the user or user group and click Remove Subscriptions.

Note: Hold Ctrl to select multiple users and user groups.

If the list of subscribers is long and you know the user(s) and/or user group(s) that you want to unsubscribe,

don't select any user or user group and click Remove Subscriptions. C lick Add  to find the user or user
group that you want to unsubscribe.

3. Click Next.

4. Select the scope of diagrams to remove the user(s) or user group(s) from.

Diagram Scope List Files

A diagram scope list file is a list of diagrams within a process map, or across multiple process maps.
See Creating diagram scope lists for more information.

5. Click Next.

6. Click Apply.

Related topics
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Adding subscriptions

Replacing subscriptions

Replace subscriptions

You can replace subscriptions for a diagram or across a scope of diagrams.

1. From the Diagram menu choose Subscriptions.

2. From the File menu choose Replace.

3. In the Search For panel do one of the following:

· Select the User option and click  to select a user.

· Select the Group option and choose a group from the drop-down list.

4. In the Replace With panel do one of the following:

· Select the User option and click  to select a user.

· Select the Group option and choose a group from the drop-down list.

5. Choose the scope of diagrams to replace the subscriptions for.

Diagram Scope List Files

A diagram scope list file is a list of diagrams within a process map, or across multiple process maps.
See Creating diagram scope lists for more information.

6. Click OK.

Related topics

Adding subscriptions

Removing subscriptions

Importing and Exporting Maps

About importing and exporting maps
Maps can be exported in order to work on them off-line, for example, or to transfer them to another process
repository. Drafts, scenarios and attachments can be included or excluded when packaging a map. Maps can also
be imported from and exported to third-party software.

Exporting

Export a map

Maps can be packaged and worked on off-line or transferred to another process repository. This function can also
be used to back-up a map before making any changes that you may want to undo. Packaged maps have a .ck
file extension.

1. From the File menu choose Package Map.

2. Select the map that you want to export and click Next.
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Note: If the map is located in a folder within the process repository then select the folder from the Path
panel.

3. Select to include or exclude the draft copy, any scenario copies, attachments and storyboards links, then
click Next.

Note: If a master copy of the map does not exist then the draft will be automatically packaged.

Include Storyboards will include all storyboards that have links in the map. If this option is not selected
then the storyboard links will remain in the map when it is unpacked into another Process Repository,
however they may become broken links or point to the wrong storyboards.

4. Choose one of the following options by stating the intended use for the map, then click Next:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Send to TIBCO Nimbus for support purposes should be selected if you intend to send the content to
TIBCO Nimbus Support. All personal information will be maintained but will be removed from the content
by TIBCO once the requirements have been met.

· Send to another external company or organization should be selected if you intend to send the
content to an external company. All personal information will be removed from the content.

· Unknown should be selected if you are unsure how the content will be used. All personal information
will be removed from the content.

5.    Select a folder to save the packaged map in and click Next.

6. Click Next and then Close.

Note: To view the location of the packaged map, or to email it, select the relevant option and click Next.

Related topics

Importing (unpackaging) maps

Export a drill down

Exporting a drill down will create a new map for all child diagrams under the activity that you are exporting from.
Exporting a drill down is useful if you want to restructure a process map, i.e. if you want to move child diagrams to
a new area of a map. It is also useful functionality if you want to create a copy of a set of child diagrams, for
example if you are drawing a similar set of processes elsewhere in the hierarchy of the map. There are a number
of options to consider when exporting a drill down, dependent upon the reason for doing so.

Redirecting Links

One thing to consider when you export a drill down but choose not to remove the lower levels is where you want
any diagram links (sign posts, flow-line links and diagram link attachments) and users' To-do items to point to after
the export. An option in your user preferences - Show diagram link redirection prompt - allows you to choose to
redirect diagram links and move users' To-do items to the exported diagrams during the process. Note that this
option also applies when copying and pasting drill downs. If you don't enable this option then diagram links and To-
do items will be maintained on the original diagrams.

Below is a table showing what happens to data when exporting or copying a drill down. Note that metadata refers
to feedback, change requests, logs, users (authorizers, reviewers, acknowledgers) and access rights.

Remove Lower Levels
After Export

Redirect Diagram Links* Notes

Yes N/A
All metadata, To-dos and diagram links
moved to exported diagrams.

Yes N/A
All metadata, To-dos and diagram links
moved to exported diagrams.

No Yes
All metadata copied to exported diagrams.
To-dos and diagram links moved to exported
diagrams.
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No No
All metadata copied to exported diagrams.
To-dos and diagram links maintained on
original diagrams.

* This option requires the Show diagram link redirection prompt to be enabled in your user preferences.

To export a drill down as a new map:

1. Right-click the drill down and choose Export. Note that is option is not possible if there are drill down
variants.

2. Select the Process Repository or a folder within the Process Repository.

3. In the Export Name text box enter the name for the new map.

Remove lower levels after export will delete the lower level diagrams from the map that you are
exporting from (these can be restored using the Deletion Recover Manager if required).

4. Click OK.

To export a drill down as a packaged map:

1. Right-click the activity and from the Drill Down menu choose Export as Package.

2. In the Export Name text box enter the name for the packaged map.

3. Select any of the following options:

Remove lower levels after export will delete the lower level diagrams from the map that you are
exporting from (these can be restored using the Deletion Recover Manager if required).

Include Attachments will include all file and Document Registry links. Note: If there are many
attachments, or the attachments are large, then the process will be slow and a large packaged map will be
created.

4. Click Next.

5. Select the folder to save the packaged map to and click Next.

Note: To create a new child folder, select the parent folder to create it in and click New Folder.

6. Choose one of the following options by stating the intended use for the map, then click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Send to TIBCO Nimbus for support purposes should be selected if you intend to send the content to
Nimbus® Support. All personal information will be maintained but will be removed from the content by
TIBCO once the requirements have been met.

· Send to another external company or organization should be selected if you intend to send the
content to an external company. All personal information will be removed from the content.

· Unknown should be selected if you are unsure how the content will be used. All personal information
will be removed from the content.

Related topics

Creating drill downs

Refreshing diagram titles

Updating activity input/output text
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Hiding drill downs

Sending activities down a level

Inserting diagrams

Deleting drill downs

Refer to Importing and exporting a drill down for more information.

Export to MS Project

You can export project-related data (tasks, durations, resources, etc) from diagrams which can then be imported
into MS Project. High level tasks can be shown graphically with the ability to drill down to view more detail, i.e.
sub-tasks. Supporting information such as forms, templates and staffing hints and tips can then be attached to
the specific task. Exporting to MS Project allows you to view the day-to-day tracking and monitoring of a project
and you can include resources and costing information.

Note: Microsoft Project must be installed on your PC.

Preparing to export to MS Project

· Ideally a standard map should exist which is specific to the project approach, methodology or framework.
This map should set out the standard tasks, durations and resources.

· Open the standard map and save as a new map which can then be tailored to meet the specific needs and
approach of the project.

· If necessary, modify the resources, durations, etc., until you are happy. Alternatively, create a new map
with tasks, durations and resources.

1. From the File menu choose Import/Export and then choose one of the following options:

· Export to MS Project (MPX) for MS Project 2000 and earlier.
· Export to MS Project (XML) for MS Project 2003 and later.

2. Click Choose Location  to specify the location where you want to create the MS Project file.

3. Choose the start date for the project from the Project Start Date selector.

4. Choose the scope of diagrams to export.

5. Select or deselect Export default work periods and Export activity dates, as required.

6. To change the language and include resources from the parent activity, click the Advanced tab.

7. Click Export.

Conversion Rules

The following rules and principles are applied for the conversion to a MS Project format:

TIBCO Nimbus MS Project

Activity boxes and titles Tasks (name truncated to 200 characters)

Activity ID numbers Task WBS number

Activity text Task name

Activity bubble notes Task notes

Activity durations Task duration if lowest level task, otherwise
calculated automatically from totals of lower
level tasks
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Task start and finish dates Calculated automatically based on duration
and project start date

Resources on tasks (including % allocated,
even if hidden)

Added as resources to task

Resource rates and information fields Added to resource library with rates and notes

Flow lines between activities Task dependencies (all converted as Finish-to-
Start type links)

Child activities, e.g. Activity 8 on diagram 1.1
has child activities on diagram 1.1.8

Sub tasks

Free text (no drill downs) Ignored

Images (no drill downs) Ignored

Free text (with drill downs) Ignored

Images (with drill downs) Ignored

Calendars MS Project standard (8 hours/day, 5 days/
week, no public holidays, week commencing
Monday)

The project may need tweaking in MS Project. Note, however, that it is not backward compatible, i.e. you
cannot import it back into TIBCO Nimbus. Use the map as the project repository and attach all project
documentation to it, i.e. the project scope document to the tasks called Scope Project. You can even create a
link from the top level of the map to the MS Project plan.

The entire project is the map. The methodology/approach that the team can follow, a MS Project plan,
project documentation and correspondence attached to the relevant step. You can also package the entire
project and send it to a colleague. At the end of the project you can simply package the map to archive it as
one file.

Unpackaged Maps

If you have unpackaged the map then the resources will not have been added to the Resource Library,
meaning that the export will not be complete. To remedy this, open the map in TIBCO Nimbus and double-
click each resource to transfer the resources into the Resource Library. Then you can update the resource
rates and any information fields.

Export to MS PowerPoint

You can create PowerPoint files based on a map, whereby each separate diagram is converted into a single
PowerPoint slide. Slides are hierarchically ordered based on the diagram level numbers.

Note: Microsoft PowerPoint must be installed on your PC.

1. From the File menu choose Import/Export and then Export to MS PowerPoint.

2. Click Choose Location  to specify the location where you want to create the MS PowerPoint file.

3. Choose the scope of the diagrams that you want to export as PowerPoint slides.

4. Click OK.

Export to MS Word

Word documents can be created for a scope of diagrams and a number of options can be included or excluded.

Note: Microsoft Word must be installed on your PC.

1. From the Import/Export menu choose Export to MS Word.

2. In the General tab select the following options:
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Output File is the location and file name of the Word document that will be created. To change the

default location and file name, click Browse .

What Word styles are used?

The table displays the Word styles that are used for particular TIBCO Nimbus items when you
export a diagram to Word:

Item Word Style

Diagram title Heading 1

Diagram information Normal

Activity number List Bullet + Bold

Activity text List Bullet

Activity properties List Bullet 2 + Bold

Activity Properties Data List Bullet 2

Table Titles Heading 3

Tables Table Grid

You can edit any of the Word styles for a particular template and these will be adopted by the
corresponding TIBCO Nimbus items upon export.

Scope allows you to specify the scope of diagrams that you want to export. See Creating diagram
scope lists for information on scope list files.

Orientation allows you to choose between portrait and landscape display.

Options

In the Options tab you can select what to include in the generated document.

Diagram Title Format will appear on the first page of each diagram that is exported. You can remove any
of the elements, for example if you don't want the Map name to appear then remove <map>. You can also
add words, for example:

Map: <map> - Level: <level> - Title: <title>

Diagram and Activity Options

Include snapshot includes a snapshot image of each diagram.

Display activity notes displays activity notes on each snapshot (if the option to include snapshots
is selected).

Display activity details includes details of all activities for each diagram.

Include Inputs (When) includes all activity inputs for each diagram.

Include Outputs (Why) includes all activity outputs for each diagram.

Include resources (Who) includes all activity resources for each diagram.

Include document control includes the document control information for each diagram.

Include authorizers includes a list of authorizers for each diagram.

Include acknowledgers includes a list of acknowledgers for each diagram.

Include reviewers includes a list of reviewers for each diagram.

Include change log includes the change log details for each diagram.

Include audit history log includes the audit history details for each diagram.

Include lines without text includes input and output lines that have no line text in the activity text
items (they will be labeled as MISSING in the exported document).

Include hidden resources lists all activity resources for each diagram.

Include notes includes the associated activity notes for each diagram.

Include attachments includes a list of attachments for each diagram.

Include statement links includes a list of statement links for each diagram.

Include statement details includes the descriptions and details of any additional data table
information for linked statement records (the 'Include statement links' option must also be selected).

Record export in audit log creates an audit log entry for each diagram that is exported.

Page break between diagrams starts a new page for each new diagram that is exported.

Include commentary text includes all activity and line commentary text.
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Include free text includes any diagram free text objects as rich text items in the Additional
Information section.

Include flow line links includes all flow line links for each diagram.

Include Resource Info Field 1 includes resource field 1 information for all resources.

Include Resource Info Field 2 includes resource field 2 information for all resources.

Map Options

Include abbreviations includes a list of process map abbreviations in a table.

Include references includes the list of process map references in a table.

Include responsibilities summary includes a list of resources and their associated activities in a
table.

3. Click OK to export.

Export as XML

Diagram information can be exported as XML, which is based on an XMI structured schema. A new folder is
created with the same name as the map.

Note: Exporting as XML can be run from the command line prompt and setup as a scheduled task. Please see the
Administration Guide that is included on the CD for more information.

1. From the File menu choose Import/Export and then Export to XML.

2. Click Choose Location  to specify the location where you want to create the XML files.

3. Select the type of export from the following:

Standard XML export includes all diagrams within the specified scope, drill downs, activities,
resources, attachments (including data tables), costing information, activity inputs/outputs, flow-line
links, free text, commentary text, change logs, authorizers, reviewers, acknowledgers, history audit
logs, acknowledgement logs, subscribers, feedback and change requests. A single file is created for
each diagram.

Simplified XML export includes all diagrams within the specified scope, diagram URLs, the parent
folder structure, user access rights (default and specific), drill downs, activities, notes, keywords, activity
inputs/outputs, commentary text, attachments (including data tables), statement links and statement
data. A single file is created for a scope of diagrams.

Note: The Simplified XML export includes the respective TIBCO Nimbus Web Server URLs for the
following attachment types - diagram links, internal WP documents, internal images, storyboard
links, file/Document Registry links and scorecards. These URLs are useful, for example, when
integrating with external search systems if you want to include process content in search indexes.
Data table information is also included in the exported XML, including all field values.

4. Select any export options, as required:

Leaf diagrams only exports all diagrams except diagrams that have drill downs (standard XML export
only).

Record export in diagram's history audit log records the export in the diagram history audit log.

Export a separate XML file for each diagram exports each diagram as a separate XML file
(simplified XML export only)

Note: From the Manage menu choose Authorization and then Diagram Audit Trail to view the history
audit log).

5. Choose the scope of diagrams to export.

Current Process Map exports the currently displayed map.

Current Diagram exports the currently displayed diagram.

Current Diagram And Lower Levels exports the currently displayed diagram and all lower level
diagrams.
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Diagram Scope List File exports all diagrams within a diagram scope list file.

6. Click Export.

Export to BPM-Xchange

The BPM-Xchange is a tool that facilitates data exchange between applications such as SAP Solution Manager,
ARIS, Microsoft Visio and TIBCO Nimbus. When a diagram or scope of diagrams is exported to BPM-Xchange
format, a single XML file is created that contains a list of all the objects and properties and which is compatible with
BPM-Xchange.

Note: This method should not be used to backup a diagram or scope of diagrams. To backup a diagram or scope
of diagrams see Exporting maps.

1. From the File menu choose Import/Export and then Export to BPM-Xchange.

2. Click Browse  to select a different location and specify a different file name, if necessary.

Include object style properties will include object styles, for example fonts, colors, line styles, etc
when converting the data into different formats using the BPMC tool. If this option is not selected then the
objects will be unformatted when importing into BPMC, which is useful for importing data into a work flow
system or into a technical definitions system. It should be noted that if many styles have been applied, the
XML output file may be large if this option is selected.

Exporting Resources allows you to choose whether to export the resources as separate elements, or as
properties within the activity elements. 

3. Select the scope of diagrams to export.

4. Click OK.

Export to Simul8

Business processes within TIBCO Nimbus can be used as the basis for running process simulations in Simul8. A
scope of diagrams can be exported as CSV from TIBCO Nimbus and then imported into Simul8.

1. From the File menu choose Import/Export, and then Export to Simul8.

2. In the Output File field you can change the default output file.

Note: C lick Browse  to change the file name and/or the file path or to select an existing CSV file to export
to.

3. In the Scope panel, choose the scope of diagrams to export.

4. (Optional) Click the Data Tables tab and select any data tables that you want to include in the export.

5. Click OK.

Importing

Import a map

Packaged maps can be imported (unpacked) into any process repository.

1. From the File menu choose Unload Packaged Map.

2. Click Select Packages  to locate and select the packaged (.cpk) map.

3. Select or deselect any of the following import options:

Overwrite existing templates will overwrite any existing templates in the process repository that have
the same name.
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Overwrite existing storyboards will overwrite any existing storyboards in the process repository that
have the same name (if storyboards are included in the package). If this option is not selected then
duplicate storyboards will not be unpacked.

Unload differences in existing data table definitions will create copies of data tables and pop-up
lists with the same names but which have structural differences (such as additional data table fields or
additional pop-up list items).

Overwrite existing data tables will overwrite any existing data tables and pop-up lists in the process
repository that have the same name.

4. Choose the location to import the packaged map into from either the root of the process repository or a
folder contained within it and click OK.

5.    Choose one of the following options and click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Received from TIBCO Nimbus for support purposes should be selected if the content was
originally sent from your company and received back from Nimbus®. All personal information will be
maintained. Do not select this option if you are not certain of the origin of the content.

· Received from an external company or organization should be selected if the content has been
received from an external company or organization. All personal information will be removed from the
content.

· Unknown should be selected if the source of the content is unknown. All personal information will be
removed from the content.

Note: You can create a new folder within the process repository by clicking New Folder. If the system
settings do not permit web links or file attachments to be added to objects, you will be prompted to choose
whether to add any web links and/or file attachments in the packaged map to the Document Registry, or to
remove the attachments entirely.

Related topics

Exporting (packaging) maps

Redirecting unloaded attachments

Import a drill down

Refer to Importing and exporting a drill down for more information.

Import from MS Visio

Microsoft Visio diagrams (VSD files) can be imported and converted into TIBCO Nimbus diagrams. Import rules
govern how Microsoft Visio shapes are converted. Unknown shapes are converted to metafile images.

Note: Microsoft Visio must be installed on the PC and should not be open when attempting an import.

To import a single Microsoft Visio diagram:

1. From the File menu choose Import/Export and then Import from Visio.

2. Click Browse to select the Microsoft Visio file that you want to import.

3. In the TIBCO Nimbus Map Name box enter a name for the new map, if appropriate.

4. If you want to use a different import rules file, click Browse (adjacent to the Rules File text box).

5. Select or deselect any of the following import options:

Import custom properties as data table attachments will convert any custom properties on Visio
objects into fields within a data table attachment on imported activity-type objects in TIBCO Nimbus.
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Import cost and duration values as costing values will convert the custom properties 'cost' and
'duration' on Visio objects into an activity's cost and duration values in TIBCO Nimbus.

Import the resources property as activity resources will covert any text defined in the 'resources'
custom property on Visio objects into an activity's resource in TIBCO Nimbus.

Import as BPMN diagrams will convert all Visio objects into BPMN-style objects. Note: You must
specify a BPMN style rule file that contains BPMN objects only (Nimbus® provides a style rule file for
BPMN objects, which will be automatically selected when this option is selected).

Note: If you choose not to import costing values and resources, these values will be included in the data
table attachment if Import custom properties as data table attachments is selected.

6. Click Convert.

To import multiple Microsoft Visio diagrams:

You can convert multiple Microsoft Visio files that are stored in a single folder.

1. From the File menu choose Import/Export, then Import from Visio.

2. Select the All Files in Folder tab.

3. Click Browse to select the folder that contains the Microsoft Visio files that you want to import.

4. If you want to use a different import rules file, click Browse to select the rules file.

5. Click Convert.

Principles of importing a Microsoft Visio diagram

Microsoft Visio shapes are complex shapes, built from simpler shapes in a hierarchical fashion, as too are
grouped Microsoft Visio objects that form a single, more complex object. Each shape in Microsoft Visio has a
name as defined in the Microsoft Visio stencil libraries. When importing into TIBCO Nimbus, these shape names
define how the various shapes are imported into a TIBCO Nimbus diagram. For example, you might specify that
the Microsoft Visio Paper Tape shape is imported as a rectangular activity box, or the Office Chair and Table
shape is imported as a metafile image.

The default Microsoft Visio import rules that are installed with TIBCO Nimbus provide sufficient rules for all of the
basic flowchart shapes available in Microsoft Visio. However, it is possible to define your own set of import rules if
required. The default import rules convert Microsoft Visio shapes as follows:

Microsoft Visio Shape TIBCO Nimbus Shape

Process Rectangle

Predefined Process Rectangle

Data Data

Document Document

Decision Decision

Sequential Data Magnetic Disk

Stored Data Stored Data

Internal Storage Rectangle

Card Manual Input

Direct Data Direct Access Storage

Manual Input Manual Input

Manual Operation Manual Operation

Paper Tape Rectangle

Display Alternate Process

Loop Limit Rectangle

Preparation Preparation
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Parallel Mode Rectangle

Off-page Reference Pentagon

Terminator Terminator

On-page Reference Ellipse

Property Reporting Image/Metafile

Flowchart Shape Rectangle

Auto-height Box Rectangle

Control Transfer Chevron

Dynamic Connector Straight/Dog-leg Line

Line-curve Connector Straight/Dog-leg line

Annotation Image/Metafile

To edit a specific Visio rules file:

1. From the File menu choose Import/Export, then Import from Visio.

2. If not already selected, click Browse to specify the Visio rules file that you want to edit.

3. Click Rules.

4. Select the Visio shape that you want to edit and click Modify.

5. Select the conditions for the Visio shape conversion.

Note: You can select multiple conditions to apply to the rule.

6. Select the actions for the Visio shape conversion.

7. In the Rule Description box you can modify the underlined values if required by clicking on them.

8. In the Name of the rule box you can change the name of the Visio rule.

9. Click OK.

10. Click Save to save the changes to the current Visio rules file or Save As to save a new Visio rules file.

To create a new Visio rule:

1. From the File menu choose Import/Export, then Import from Visio.

2. If not already selected, click Browse to specify the Visio rules file that you want to add a new rule to.

3. Click Rules.

4. Click New.

5. Select the conditions for the Visio shape conversion.

Note: You can select multiple conditions to apply to the rule.

6. Select the actions for the Visio shape conversion.

7. In the Name of the rule box enter a name for the Visio rule.

8. Click OK.

9. Click Save to save the changes to the current Visio rules file or Save As to save a new Visio rules file.
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To delete a Visio rule:

1. From the File menu choose Import/Export, then Import from Visio.

2. If not already selected, click Browse to specify the Visio rules file that you want to edit.

3. Click Rules.

4. Select the Visio shape that you want to delete and click Remove.

5. Click Save to save the changes to the current Visio rules file or Save As to save a new Visio rules file.

To build rules graphically:

The Graphical Rules Builder allows you to view and edit the objects used in a selected Visio diagram graphically,
then save it as a new rule.

1. From the File menu choose Import/Export, then Import from Visio.

2. Click Browse to select the Microsoft Visio file that you want build Visio rules from.

Note: If you want to add new rules to an existing file based on the selected Visio diagram then you must
select the Visio rules file.

3. Click Rules.

4. Click Build Rules Graphically.

Building Rules Automatically

You can create a rule set automatically, based on the object
shapes in the selected Visio file, by clicking Build
Automatically. New rules will be automatically created in the
selected Visio rules file for all objects that are not currently
defined. Note: TIBCO Nimbus rectangle shapes are used for any
Visio shapes that are not defined in the specified Visio rule file -
to edit a particular rule please follow the steps outlined below.

5. Select the Visio object that you want to create a rule from.

6. Right-click the object and choose Create new rule.

7. Select the conditions for the Visio shape conversion.

Note: You can select multiple conditions to apply to the rule.

8. Select the actions for the Visio shape conversion.

9. In the Name of the rule box, modify the name for the Visio rule if required.

10. Click OK.

11. Click Show Rules Editor .

12. Click Save.

Import from iGrafx

Data captured in iGrafx (.igx) can be imported into TIBCO Nimbus.

Note: iGrafx must be installed on your PC.
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1. From the File menu choose Import/Export and then Import from iGrafx.

2. Locate the iGrafx file that you want to import and click Open.

For information on using this feature correctly log in to TIBCO Support Central (TSC)  support.tibco.com.

Import from ARIS

Import an ARIS XML export file into TIBCO Nimbus to create a new map.

The following rules are applied when importing:

· The name of the ARIS database will become the map name.

· RADs (Resource Allocation Diagrams) are ignored.

· PSDs (Process Selection Diagrams) are ignored.

· EPC (Event Process Chain) diagrams are imported.

· FADs (Function Allocation Diagrams) are imported.

· Data table attachments are created for any data entity objects (blue and green rectangles on FADs).

· Document-type ARIS objects are converted into data table attachments on the activity that is connected to
the document object via a flow line.

Note: Diagrams within ARIS that are not linked to any other ARIS diagrams are placed within the Orphaned
Diagrams box on level 1 of the map.

1. From the File menu choose Import/Export and then Import from ARIS.

2. In the ARIS XML File click  File Browse to locate the ARIS diagram to import.

3. In the Options panel select to import the ARIS diagram based on the TIBCO Nimbus map style or the ARIS
style (see the example below of how these two styles differ).

4. To specify what elements to include in the import, click the Advanced tab and select or deselect the following
options:

SAP transaction links enables direction connection to the relevant SAP transaction (screen) using the
SAP user-interface.

Include inactive transactions includes inactive SAP transactions.

Data table attachment for data attributes converts relationships between data objects and
functions into activity data tables.

Data table attachment for function objects converts functional objects into activity data tables.

Generate one data table definition for all imported attributes converts all attributes into a single
activity data table.

Import descriptions as: allows you to specify how object function descriptions are imported. Choose to
convert them to notes bubbles, internal WP documents or ignore them completely.

Internal WP documents

If there are less than 250 characters in the object
description then the text will be stored in an Object
Description field in the object's data table. This requires
the Data table attachment for data attributes option
to be enabled; if it is not then the text will be imported as
an internal WP document, regardless of the number of
characters.

5. Click OK.

https://support.tibco.com/login.htm
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Example

Original ARIS Diagram (EPC)

Imported map based on ARIS style: Imported map based on TIBCO Nimbus style

Function Allocation Diagrams (FADs)
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FADS are diagrams that drill down from a function (activity). They contain the supporting relationships, such as
roles, resources, data, documents and they are equivalent to TIBCO Nimbus data tables. When importing into
TIBCO Nimbus using the TIBCO Nimbus style, these diagrams are not generated but the information is
converted into resources and data tables associated with the parent activity. If the ARIS style of import is
selected then the FAD is generated as a child diagram, as shown below.

Structural Differences

Multiple drill downs to child diagrams from one activity are supported in ARIS but not TIBCO Nimbus. In most
cases, an EPC diagram will drill down to an EPC column diagram, a FAD and a RAD. RAD diagrams are ignored in
TIBCO Nimbus. This is handled by creating the normal EPC diagram drill down to the FAD which then drills down
to the other EPC column diagram.

Any orphan diagrams that exist in an ARIS database are imported as new diagrams which are accessible under a
single Orphan Diagrams activity on level 1 of the new map, thereby maintaining the original map structure.

Import from BPM-Xchange

The BPM-Xchange is a tool that facilitates data exchange between applications such as SAP Solution Manager,
ARIS, Microsoft Visio and TIBCO Nimbus. BPMC converts diagrams into single XML files which can then be
imported into TIBCO Nimbus. 

1. From the File menu choose Import/Export and then Import from BPM-Xchange.

2. Click Browse  to select the source file that you are importing, then click Next.

3. From the Data Language box select the language of the data, then click Next.

Note: The language is the regional setting of the PC that the file was imported from. If you select <NONE>
then any text in the file, for example activity text, will not be imported.

6. Select a folder within the Process Repository to save the map to.

Note: To create a new folder click Create Folder.

7. Modify the map name, if required, choose a template and enter a title for the first level diagram.

Hint: C lick Edit Language Variants  to define the title in multiple languages (language variants must have
been specified by an administrator).
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8. Click OK.

What if a map of the same name already exists?

You will be prompted with the following options:

Create New will create a new map with a number added to the existing map name (for example, if
'Process Map' already exists, a new map will be created called 'Process Map 1'.

Replace will replace the existing map in the Process Repository.

Skip will skip the import process if a map of the same name exists in the Process Repository already.

How are activity resources handled?

Resources can either be imported from the actual activity elements, or from any separate resource
elements that exist (resource elements take precedence over resources associated with activity elements
if a resource is defined in both).

Splitting Maps

Split a map
You can move a drill down on an object (activity, free text box or image) to an object in another map. This
essentially allows you to split large maps into smaller maps. All data will be transferred, including current
authorizations, reviews, acknowledgements, actions, change requests, recurring reviews. Diagram links will also be
updated by the system to point to the new location and all audit trails, templates and style sheets will be
preserved. 

Important Note: This operation will delete the drill down and all associated diagrams from the map that you are
importing from. Since this operation cannot be undone, it is important that you proceed with caution.

Preparation

To ensure data consistency when running this operation, it is advised that you run the following reports on the
‘current diagram and lower levels’ of the diagram where you are importing from before proceeding. 

· Diagrams
· Attachments
· Links
· Authorizations
· Reviews

Before running the import, you should make sure that no other users are accessing the diagrams that you are
importing. The map you are importing from must also be closed before proceeding.

1. Navigate to the diagram where you want to move the drill down to, i.e. the target diagram.

Note: You can either create a new object or select an existing one. If you select an existing object which
already has a drill down on it then a process variant will be created.

2. Right-click on the object and choose Drill Down > Import and Remove Original.

3. In the Import and Redirect Drilldown window, select the map which contains the drill down that you want to
move, and then click Next.

4. Navigate to the required diagram level and click the object that contains the drill down to select it, and then
click Finish.

After the operation has successfully completed, check the log file for any issues. The log file is created in the
following directory:

{Nimbus Installation}\Process Repository\System\Logs

Finally, run the same reports listed in the Preparation section on the ‘current diagram and lower levels’ of the
diagram which you have imported the drill down into in order to compare the data for consistency.
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Diagram Tools

Compare and update
The Compare and Update tool allows you to compare two diagrams and update specific elements.

Compare
This is useful if a section of a map has been worked on off-line, or if there are two projects being worked on at
the same time. It is also useful to show the differences between a draft and master map, or between a master
map and a scenario.

Update
Data in a target map can be updated from a source map following a comparison report. The following information
can be updated:

· Non-visual data - feedback, change requests and keywords

· Document control data - author, owner, version number and diagram date

· Access rights - diagram and print access rights

· Assigned users - authorizers, acknowledgers, reviewers and subscriptions

To compare and update two diagrams:

1. From the Tools menu choose Compare and Update.

2. Next to the Source Diagram box click Select to select the source diagram that you want to compare to.

3. Next to the Target Diagram box click Select to select the target diagram. 

Note: The target diagram is the diagram that will be updated with the differences from the source diagram.

4. In the Comparison Includes panel, select or deselect any options that you want to compare the two diagrams
against.

Objects will highlight any changes to visual drawing objects such as activities, flow lines, resources, free
text, note bubbles, file links, drill down arrows, hint text, signpost links, etc.

Title will highlight any differences in the titles.

Author and Owner will highlight changes in authors and owners.

Version Number will highlight updates to the diagram version numbers.

Object Display Order will highlight changes made to the order of objects displayed on the screen (the Z
order). For example, if an activity box is sent behind another activity so that the overlap is in a different
location, this will be flagged if this option is selected.

Assigned Templates will highlight any changes in the template name.

Non-visual Data will highlight feedback, change requests and keywords.

Assigned Users will highlight changes in authorizers, acknowledgers, reviewers and subscriptions.

Advanced Tab

Force list window to stay on top of TIBCO Nimbus allows you to work outside of the compare and update
tool whilst keeping the comparison window open. If this option is not selected then when you click outside of
the window, for example to access a drill down, the window will be lost.

Ignore costing update changes will ignore any changes to activity costs, volumes and durations.

Allow for link redirection changes will treat all diagram links as the same. For example, if diagram 1.4 in
the source map is linked to diagram 1.8.2 in the source map, this will be considered the same if the diagram
1.4 in the target is linked to diagram 1.8.2 in the target map.

5. Click OK.



Maps and Diagrams

TIBCO Nimbus® User Guide Page 210

Comparison Report

Once you have run the compare and update tool you will be presented with a report, highlighting the
differences between the source and target diagrams. The source diagram(s) are presented on the left, the
target diagram(s) on the right and the differences are displayed in the middle. Diagrams that are the same
are displayed in black with the status OK and diagrams that differ are displayed in red with the status
Changed. If corresponding diagrams cannot be found in either the source or target then these diagrams will
be highlighted in blue.

The source's corresponding target diagrams are based on the level number, for example:

Source Map Target Map
Level 1 Level 1
Level 1.1 Level 1.1
Level 1.4 Level 1.4
Level 1.4.1 Level 1.4.1

However, if the starting levels of the source and target maps are different, the corresponding levels will be
based on the last level, for example if the target is an exported drill down from a larger map.

Source Map Target Map
Level 1.3.8 Level 1
Level 1.3.8.1 Level 1.1
Level 1.3.8.4 Level 1.4
Level 1.3.8.4.1 Level 1.4.1

Note: If any of the source or target diagrams have been restructured then the comparison report will be
unable to find and match the corresponding diagrams, for example if the level numbers have changed due to
a change to the activity ID numbers.

Export to Excel

Save the report as a Microsoft Excel spreadsheet. From the File menu choose Export to
MS Excel.

 

To view and update the differences between two diagrams:

Any differences may be due to more objects in the target diagram, for example if a new activity has been
added, or it could be more detailed, for example if the fill settings or shadow colors of any activities have
changed. Internal word-processed and image attachments will also be compared and highlighted if any
changes are present.

There are a number of options available to view differences between maps (highlighted in red). 

1. Right-click the row and choose one of the following options:

Go to source will navigate to the source diagram.

Go to target will navigate to the target diagram.

Side By Side View will display both the source and target diagrams side by side to allow you to
physically view the changes.

Difference Log will display a list of changes between the source and target diagrams.

Update will allow you to update the target diagram (see below for details).

Updating

When you choose to update target diagrams you have a number of options. You can update non-visual data,
document control data, access rights and assigned user information (see above for details). The following
update options are available:

Keep target's data will not change the information in the target diagram.
Overwrite target's data will update the information in the target diagram with the differences from the
source diagram.
Merge data will add new information from the source diagram to the target diagram.
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You can update specific information for all areas by clicking Show Advanced Options and selecting or
deselecting the various options within each tab and choosing an update option.

Integrity check
The Integrity Check tool will report on objects that do not adhere to best-practice mapping principles (as defined
by Nimbus®). It is a good idea to run an integrity check before authorizing, promoting or releasing a diagram to
users. Any resource mismatches in swimlane diagrams will also be reported on.

1. From the Tools menu choose Integrity Check.

2. From the Options tab select the scope of diagrams that you want to check.

Diagram Scope List Files

A diagram scope list file is a list of diagrams within a process map, or across multiple process maps.
See Creating diagram scope lists for more information.

3. From the Object Check Options tab select the objects that you want to check.

Activities Have Text will report on any activities that do not have any associated text.

Resources Assigned to Activities will report on any activities that do not have any assigned
resources.

Flow Lines Have Text will report on any flow lines that do not have any associated text.

Disconnected Lines will report on any flow lines that are not connected to an activity.

Input/Output Lines Without Flow Line Links will report on any input or output lines that are not
connected to other diagrams through a flow line link.

Broken Diagram Links will report on any broken diagram links.

Broken File Links will report on any broken file links.

Broken Flow Line Links will report on any broken flow line links.

4. From the Diagram Check Options tab select any other options that you want to check.

Input and Output Flows Match Parent Activity will compare the number of input and output flow
lines between parent and child diagrams.

Check Template Can Be Found will report on any deleted templates that have been previously
applied.

Check Size of Diagram will report on any diagrams that have objects outside of the screen view.

5. Click OK to generate the report.

Swimlane Integrity Checking

Once the report has been generated, click the Swimlane tab to view any resource mismatches that are present in
any swimlane diagrams.

Attachment analysis
A report can be generated that lists the location of all external files referenced in a process repository.

1. From the Tools menu choose Attachment Analysis.

The folders paths of the current process repository will already be defined. You can add, remove and modify
folder paths.

2. Click OK.
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Refresh input and output text
The input and output line text can be automatically updated for a scope of diagrams.

1. From the Map menu choose Refresh Input/Output Text.

2. Select the scope of diagrams.

Note: The Current Diagram from Parent and Parent Diagram from Current options are not available
from level 1 of a map.

Current Diagram from Parent will update the current diagram based on the input and output lines of
the parent activity.

Parent Diagram from Current will update the parent activity based on the input and output lines of
the current diagram.

Current Diagram and Lower Levels will update all lower levels based on the input and output lines
from the current diagram (from the lowest level upwards or the highest level downwards).

Current Process Map will update all diagrams within the process map (from the lowest level upwards
or the highest level downwards).

3. Select the hierarchical direction of the refresh operation. 

Note: These options only apply if you have selected Parent Diagram from Current or Current Diagram
and Lower Levels as the scope.

Refresh from lowest levels upwards will update the parent activity's input and output line text based
on the child diagrams.

Refresh from top level downwards will update the child diagram's input and output line text based
on the parent activities.

Highlighting

Define a highlight rule

Rules can be defined to highlight data table values and resources in a map. Highlight rules become centrally
available upon creation, i.e. a highlight rule library stores the rules and makes them accessible to any map within
the process repository.

The following rules can be defined and applied:

Data Table allows you to highlight data tables that contain values within a specific criteria (for example,
Less Than 10, Not Equal To 15, etc).

Resource allows you to highlight any activities that have a specific resource or resource group attached to
it.

Multi-Rules Logic allows you to combine up to three highlight rules in a single highlight rule using AND
logic.

Note: Only Administrators and Rule Managers can add, modify and delete highlight rules. Highlight rules are
not supported in the web server.

To create a data table highlight rule:

Note: You cannot create highlight rules against alpha fields in a data table.

1. From the Tools menu choose Highlight and then Highlight Rules.

2. From the File menu choose Add.
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3. In the Name text box enter a name for the highlight rule.

4. From the Type drop-down list choose Data Table and click Next.

5. From the Data Table drop-down list choose the data table.

6. From the Field drop-down list choose the data table field.

7. From the Criteria drop-down list choose the criteria for the data table value.

8. In the Value text box enter a data table field value and click Next.

9. Modify any style settings and click Finish.

To create a resource highlight rule:

1. From the Tools menu choose Highlight and then Highlight Rules.

2. From the File menu choose Add.

3. Enter a name for the highlight rule in the Name text box.

4. From the Type drop-down list choose Resource and click Next.

5. Select either Resource or Resource Group and choose a resource or resource group from the respective
drop-down list.

6. Click Next.

7. Modify any style settings and click Finish.

To create a combined highlight rule:

1. From the Tools menu choose Highlight and then Highlight Rules.

2. From the File menu choose Add.

3. Enter a name for the highlight rule in the Name text box.

4. From the Type drop-down list choose Multi-Rules Logic and click Next.

5. From the Rules drop-down lists choose the highlight rules that you want to combine with AND logic.

Note: All rules selected must be true for a particular activity to be highlighted.

6. Click Next.

7. Modify any style settings and click Finish.

Related topics

Applying highlight rules

Editing highlight rules

Deleting highlight rules

Displaying swimlane views (storyboards)
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Apply a highlight rule

Highlight rules that are applied will apply to all maps in a process repository. Multiple highlight rules can be
applied and the rules will be evaluated in the order in which they appear in the list. For example, if an activity
matches three highlight rules then the style of the first rule that it applies to in the list will be used.

1. From the Tools menu choose Highlight Rules and then Apply Highlight Rules.

2. From the Rules To Apply list (right-hand side) select the rules that you want to apply.

Note: To add a rule from the Rules Library (left-hand side), select the rule and click Add Rule to Apply

List .

3. Select Apply selected highlighting rules.

4. Click OK.

Note: To remove a highlight rule deselect the highlight rule, or to remove all highlight rules deselect Apply
selected highlighting rules.

Related topics

Defining highlight rules

Editing highlight rules

Deleting highlight rules

Edit a highlight rule

1. From the Tools menu choose Highlight and then Highlight Rules.

2. Select a highlight rule and from the File menu choose Edit.

Related topics

Defining highlight rules

Applying highlight rules

Deleting highlight rules

Delete a highlight rule

1. From the Tools menu choose Highlight and then Highlight Rules.

2. Select the highlight rule and from the File menu choose Delete.

Related topics

Defining highlight rules
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Applying highlight rules

Editing highlight rules

Displaying swimlane views (storyboards)

Costing Processes

About costing
Validating and ranking potential business process improvements requires further analysis. One of the powerful
analysis tools can be understanding the costs of running a process. TIBCO Nimbus offers a process-based
activity-costing functionality where basic costing can be gathered. This is particularly helpful with exploring costs
around simple volume changes, decisions points, resource replacements or alternatives and process
simplification improvement projects.

For detailed costing analysis, TIBCO Nimbus should be used in conjunction with other cost analysis and simulation
or resource scheduling and loading analysis tools.

When can a process be costed?

1. When the process has been captured down to task level.

Processes in TIBCO Nimbus are captured from the top level to the bottom level, allowing a business to
understand the core process in simple terms and then drill down to lower levels for granularity. Process
costing in TIBCO Nimbus is captured from the lower level to the top level after the process has been fully
captured. This requires that the lower levels have captured detail at a task level so that the average
durations may be attached. Lower-level costings can be 'rolled' upwards to higher levels.

2. When the process has integrity.

The process diagrams need to have been integrity checked to ensure that no input or output arrows are
missing or unattached, that resources are allocated, if the volume is changing frequently or if there are too
many feedback loops (a high number of feedback loops indicates that the process has not been defined
accurately or the loops need to be moved down to lower levels).

Principles and Definitions

Costing assumptions

TIBCO Nimbus makes certain assumptions when calculating process costs.

· If multiple resources are attached to a single activity, all resource costs will be calculated (unless a
resource is specifically set not to be included in any costing calculations). For example, if 3 resources are
attached to an activity that takes 4 hours to complete, the total work hours for the activity is 12 hours.

· If no resources are associated with a map, TIBCO Nimbus will assume that one resource is associated
with each activity, thereby allowing durations and volumes to be calculated in order to obtain the FTEs.

· If probabilities are introduced, TIBCO Nimbus will assume that multiple paths are exclusive. For example,
if two paths exist, A and B, it is assumed that the process will take either path but not both paths. Therefore
probabilities may need to be adjusted to account for this. 

For example, the probability that the process will take path A is 20% and path B is 40%.

The probability of the process taking path A OR path B is 20% + 40% = 60%.

The probability of the process taking path A AND path B is 20% x 40% = 8%.

To account for this you can split the extra probability of the process taking path A AND path B, i.e. the
8%, between the probability between path A and path B. Therefore, the probabilities of the process
taking path A then becomes 24% and path B 44%.
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Note: If you are working out the probabilities from a study of volumes of transactions along different
paths, these volumes will account for any possible effect of passing along both or all of the various paths
at the same time.

TIBCO Nimbus also allows the probabilities of a path to be more than 100% to reflect manual
interpretations of the AND possibilities; however the probability of any given activity occurring is capped
at 100%.

· TIBCO Nimbus uses predefinable working periods to translate a working day into hours, a working
week into days and a working year into weeks. The defaults are set at a 8 hour day, 5 days per week and 48
weeks per year. For instructions on modifying these values see Setting costing defaults.

· If feedback loops are implemented, TIBCO Nimbus requires users to identify the feedback loop
probabilities. Multiple feedback loops that terminate at a single activity cannot be calculated as TIBCO
Nimbus does not know which feedback loop to calculate first. This requires a business understanding of the
diagram in order to make the decision. Therefore, feedback loops need to be broken up by feedback breaks,
which is achieved by creating 2 activities (an input and an output) and manually updating the volume of the
output activity based on the calculated volume of the input activity. The output value will need to be adjusted
as this will affect the value in the input box. 

The rules for tuning multiple feedback breaks in a diagram are as follows:

· Ensure the Perform Calculations flag is set on the Basic Costing panel (see  TIBCO Nimbus
Interface for more information).

· Ensure both pairs of activities in all feedback breaks are approximately equal (+/1 100).

· Identify the largest feedback break (or the one that has the most impact on the map) and set
them to within +/- 10. Then look at the other feedback breaks and get them within +/- 10.
Once this is done, modify the feedback breaks to get them exactly correct.

See Probability feedback loops for more information.

Level costing

Most activity-based costing will be executed from the lowest level upwards; therefore for each parent activity
involved in costing, the cost should be updated from the child level and repeated as you move up to the highest
level. This ensures that activity cost contributions are reflected accurately at each level of detail.

However, when a cost report is generated, all costing information is returned for all levels within a specified
scope of diagrams. This might result in inaccurate costing information as the lowest level cost information and the
higher levels, which already include the lower level costs, are calculated. For this reason, costing reports can be
exported into a third-party spreadsheet application, for example Microsoft Excel, and manipulated further.

For example, the costing of a process comes from 3 levels in a map and these diagram references are as
follows:

1.1.1  1.2.1  1.3.1

1.1.2  1.2.2  1.3.2

1.1.3  1.2.3  1.3.3

If this report was exported to Excel as a CSV file, the rows relating to the higher level diagrams (for example 1,
1.1, 1.2, 1.3, etc) can be deleted. The remaining columns can then be calculated to obtain the total process costs,
durations and FTEs, or manipulate the data to calculate other measures, produce charts and statistical analysis with
rich reporting features in third-party software. You can also take the reports in full, or configured, and import into
project management applications such as MS Project.

Related topics

Exporting costing as CSV
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Full Time Equivalent (FTE)

The FTE is a measure of the resource requirement for a given process over a defined period, for example the
number of account clerks required to deal with 200 invoices per week following a given process. The FTE is
obviously dependent on the volume and duration of associated activities.

FTE = (Number of resource types for activity x Volume through activity x Duration of activity) /
Working period

In this example, the accounts clerk in the third activity (highlighted in green) deals with 7 invoices per day, each
taking 10 hours. The costing defaults have been set as a 7 hours per day and 5 days per week. The FTE is
worked out as follows:

FTE = (1 resource x 7 invoices x 10 hours each) / 7 hrs per day = 10

This calculated FTE implies that 10 account clerks are required to deal with the workload based on the current
working day settings. If you consider the total FTE for the account clerk in the diagram:

Total FTE = 1.43 + 10 + 0.02 = 11.45

Running a resource-based costing report can list the FTEs for a given resource across a specific diagram or scope
of diagrams.

Related topics

Displaying activity costs

Volumes

The volume of transactions occurring along a given path can be calculated and is defined as the volume of
transactions of a given activity over a working period (per day or per week, for example). By establishing the
volume of transactions of an activity, you can establish the cost, resource loading and FTE values across a given
period. The total cost and duration is calculated by adding together the activity costs and multiplying them by the
activity volume. The total diagram cost is, therefore, the total activity volume costs, i.e. the total of all activity
costs x total activity volumes.

You must first enter the starting volume in the first (start) activity. Then, all subsequent activity volumes are
calculated based on the starting volume and the probability that the activity will occur.
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Related topics

Displaying activity costs

Basic Costing

About basic activity costing

The total cost of an activity is calculated by taking two costs into account: resource (cost of resources involved in
the activity) and volume (additional costs incurred when the activity occurs). This provides the following equation:

Cost of resources carrying out the activity  +   Custom volume cost   =   Total Activity Cost 

If a costed resource is attached to an activity, TIBCO Nimbus will calculate the cost of the activity using the
costed rate of the resource, the percentage allocation of the resource and the specified duration of the activity. 

Resource Cost    =    rate   x   duration   x   percentage

This would result in a resource cost of £40 if the resource costs £20 per hour (rate), the activity takes 2 hours to
complete (duration) and the resource is allocated to the activity 100% (percentage).

Multiple resources can be allocated to an activity and these will also be costed.

Resource Cost    =    (rate 1  x  percentage 1  +  rate 2  x  percentage 2  +...+  rate n  x 

percentage n) x duration

TIBCO Nimbus assumes that all resources work in parallel on an activity and not consecutively. Resources can be
marked as 'not costed' on a particular activity and therefore will not be included in the costing.

Scenarios

Scenarios are an effective way of experimenting with cost analysis without having
to commit the changes to a current diagram or process map.

Related topics

Defining activity costing values

Updating costs from child diagrams

Turning off resource costs

Example of basic costing

Setting costing defaults

Displaying activity costs

Viewing activity costs

Scenarios
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Define activity costing values

When calculating process costs, the activity values and volumes need to be defined. These values can be 
displayed on activities.

Hint: Activity-based costing values can be used to define metric links. See Adding metric links for more
information.

 

1. Right-click the activity that you want to display or edit the costing values for and choose Costing, then
Values.

The following details can be defined for the cost of the activity:

Activity Values

Obtain Duration values from a data source will obtain values for the duration from an
external data source via SQL query links (note that these are created by administrators through
the Admin Utility, please see the Administration Guide for information on creating SQL queries).

Duration is how long the activity lasts on a single run-through.

Late is the latest possible start time without increasing the overall duration of the process.

Start is the date and time that the activity commences.

Volume

Obtain Volume from a data source will obtain values for the volume from an external data
source via SQL query links (note that these are created by administrators through the Admin
Utility, please see the Administration Guide for information on creating SQL queries).

Override Volume will override the volume that is automatically inherited from the first activity in
the process.

Ignore Feedback Calcs will ignore any probability feedback loops that are in place. See
Overriding a volume for more information.

Volume is the starting volume of material or number of units (e.g. 10 kg of carbon or 100 bolts),
which will be inherited by subsequent activities (unless overridden).

Custom Volume Cost is the price per weight or unit (e.g. if you have 10 kg as the volume you
would state the cost of 1 kg).

Override Activity Calculations

Override Cost will override the total cost of the activity.

Override Volume Cost will override the total volume cost of the activity. 

Note - by overriding the volume cost you can use an activity's volume cost in the cost per
period calculation for a particular diagram (otherwise the total cost and volume of an activity
is used in the calculation of the diagram's cost per period value). To achieve this, click the
Calculated Information tab and select the Use overridden volume cost when calculating
the diagram's cost per period check box.

Override Volume Duration will override the volume duration value (Volume x Duration)

Override FTE will override the calculated full-time equivalent (FTE) value.

Completion Status

You can define the completion status of each activity in a process with respect to costing.

Incomplete will display an X for the activity completion status. 

Complete will display Done for the activity completion status.

Ignore Status will not display a completion status.

Activity Timing



Maps and Diagrams

TIBCO Nimbus® User Guide Page 220

In the Custom Properties tab you can specify activity timing information, such as the frequency of
an activity (for example, twice a month or the last week of every quarter, etc).

Related topics

About basic activity costing

Updating costs from child diagrams

Turning off resource costs

Example of basic costing

Setting costing defaults

Displaying activity costs

Viewing activity costs

Scenarios

Use volume cost to calculate cost per period

Usually the total cost of activities and the volume is used to calculate the cost per period (day, week, etc) for a
specific diagram. You can choose to use the volume cost of activities to calculate the diagram cost for a period
instead.

Note: This method requires the Override Volume Cost to be defined and selected for a particular activity.

 

1. Right-click the activity and choose Costing and then Values.

2. Click the Calculated Information tab.

3. Select the Use overridden volume cost when calculating the diagram's cost per period check box.

4. Click OK.

Example

Activity 1 - Volume = 10 per day, Total Cost = £80
Activity 2 - Volume = 10 per day, Total Cost = £240
Activity 3 - Volume = 10 per day, Total Cost = £160

Diagram's Cost Per Day = (£80 x 10) + (£240 x 10)
+ (£160 x 10) = £4800

However, if we use the overridden volume cost of activity 2 as part of the diagram's cost per day calculation:

Activity 1 - Volume = 10 per day, Total Cost = £80
Activity 2 - Volume = 10 per day, Total Cost = £240
(Overridden Volume Cost = £5000)
Activity 3 - Volume = 10 per day, Total Cost = £160

Diagram's Cost Per Day = (£80 x 10) + £5000 +
(£160 x 10) = £7400
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Update a cost from a child diagram

Activity costs can be updated based on the total cost of a child diagram.

 

1. Right-click the activity and choose Costing, then Values.

2. Click Refresh From Drill Down.

Note: The Override Cost check box must be selected for an activity cost to be overridden.

Related topics

About basic activity costing

Defining activity costing values

Turning off resource costs

Example of basic costing

Setting costing defaults

Displaying activity costs

Viewing activity costs

Scenarios

Turn off a resource cost

You can specify if you do not want a specific resource to be included when undertaking costing.

 

1. Right-click the activity and choose Resources.

2. From the list of resources attached, deselect the Costed check box.

3. Click OK.

Related topics

About basic activity costing
[****]
Defining activity costing values

Updating costs from child diagrams

Example of basic costing

Setting costing defaults

Displaying activity costs

Viewing activity costs
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Scenarios

Example of Basic Costing

This example demonstrates a process of dealing with invoices within a company and the associated costs.

The cost values on display are activity duration and activity cost. The cost display on each activity display the
activity duration and the cost of the activity.

The total cost of this example process is £237.50 and the total duration is 17hrs 30mins. This will be displayed on
the Basic Costing panel (to display the Basic Costing panel, from the View menu choose Toolbars and Panels.
Select the Panels tab and select the Basic Costing Panel check box).

Default Costing Settings

Set costing defaults

Costing default values such as working periods, the working day start time and the currency display can be
defined. Modifying working day values will affect costing calculations when, for example, the duration of an
activity is defined in days, weeks or years.

1. From the Map menu choose Costing and then Costing Defaults.

2. Modify the costing default settings, as required.

Time

These settings allow you to modify the working day periods and the working day start time.

Display

These settings allow you to modify the default currency.

Calculations

The option to Include Late values in duration and FTE calculations will include late values when
calculating the total duration and FTE. Note: The Late values will always be included when calculating the
critical path analysis.

Note: When creating an Excel-based metric link there is an option (Map Currency) to use the currency
format set here.
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4. Click OK.

Displaying Costs

Display activity costs

An activity can be configured to display up to nine calculated cost fields.

Note: Costing values are visible in the web interface. If you don't want users to see diagram costs, consider
using scenarios. Alternatively, the Basic Costing Panel will display the total cost of each costed diagram and
activity costs can be hidden so that when a map is promoted the values will not be displayed.

 

1. Right-click the activity and from the Costing menu choose Display Layout.

2. Click on a cell in the display layout grid and choose a cost field from the pop-up list.

Visible will toggle the field display on and off.

Font allows you to modify the font, font color, font size, etc of displayed fields.

Displaying Field Labels

To display the field label of a particular costing field, select
the relevant check box in the Display Field Labels panel.

3. Click OK.

Related topics

Viewing activity costs

Hiding activity costs

Defining activity costing values

Setting costing defaults

View activity costs

You can view activity-associated calculated information, for example the probability of the activity occurring if
probabilities have been defined, the feedback factor, critical path information, etc.

1. Double-click on the costing display layout of the activity (see Displaying costs for more information).

2. Click the Calculated Information tab.

Related topics

Displaying activity costs

Defining activity costing values

Setting costing defaults
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Hiding activity costs

If activity costs are displayed when a map is promoted then activity costs will be visible to all users in the web
interface (except central resource costs unless specific users have this option enabled in their user settings).
Activity costs can be hidden for a scope of diagrams before promoting.

Note: Total diagram costs can still be viewed in the client through the Basic Costing Panel.

 

1. From the Map menu choose Costing and then Costing Visibility.

2. Deselect the Visible check box and choose a scope of diagrams to hide costing values over.

Note: To display activity costing values select the Visible check box.

Probabilities

About probabilities

Probabilities can be defined for particular activities. The probability is the percentage chance that the process
progresses along a certain path, i.e. the chance that a particular activity will occur in a process. You can model
possible real-world simulations by assigning probabilities to various paths in a diagram. Probabilities affect the
cost of a process, multiplying each activity cost by the probability that it will occur before adding all costs in order
to calculate the total cost of the diagram. 

Note: It is possible for the sum of the different paths to add up to more than 100%. By default, TIBCO Nimbus
assumes the paths to be exclusive. However, this is not always the case and multiple probabilities will be
calculated for a given activity but capped at 100%. Also, if you are working out the probabilities from a study of
volumes of transactions along different paths, these volumes will account for any possible affect of passing along
both or all of the various paths at the same time.

Example

In an organization, on average 3 out of 10 invoices that come in relate to MOD contracts. Therefore the
probability that an invoice is passed from activity 1 to activity 2 is 30%, i.e. the probability of action 2 occurring is
30%. Out of this 30% of invoices referring to MOD, on average 5% are returned to the supplier, i.e. the
probability of action 5 occurring is 5%. 

Therefore, the chance that an MOD contract is returned to the supplier is:

30% x 5% = 1.5%

Putting this in terms of diagram cost, the cost of activity 2 is £30 (£100 x 30%) and the cost of activity 5 is £0.15
(£10 x 1.5%).
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Define a probability

Probabilities can be defined for particular activities. For more information on probabilities see About probabilities.

1. Right-click the flow line that enters the activity that you want to define the probability of and from the
Costing menu choose Probability.

2. Enter the probability value and click OK.

Scenarios

Scenarios are an effective way of experimenting with cost analysis without having
to commit the changes to a current diagram or process map.

Related topics

About probabilities

Defining probabilities

Modifying probabilities

Hiding probabilities

Probability feedback loops

Costing assumptions

Modify a probability

Assigned probability values can be modified.

1. Double-click the probability and define a new value.

Related topics



Maps and Diagrams

TIBCO Nimbus® User Guide Page 226

About probabilities

Defining probabilities

Modifying probabilities

Hiding probabilities

Probability feedback loops

Costing assumptions

Hide a probability

Probabilities can be hidden from view.

1. Right-click the probability and from the Costing menu choose Display Probability.

Note: Repeat this step to display a probability. Hold Shift to select multiple probabilities.

Related topics

About probabilities

Defining probabilities

Modifying probabilities

Hiding probabilities

Probability feedback loops

Costing assumptions

Probability feedback loops

When an activity feeds back to a previous activity, a recursive feedback loop is created and a probability that this
feedback loop occurs must be defined.

Note: A start and end box must be present when working with feedback calculations and they must exist outside
of the feedback loop.

Example

The probability of the first activity (Start) occurring is p(Start)=100%.
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The probability of Step 2 occurring is p(Step 2)=100%.

Therefore, the probability of Step 3 occurring is 100% x 50%=50%.

Now, there is a 10% chance that Step 3 feeds back to Step 2. Therefore the chance of Step 2 occurring a second
time is 50% x 10%=5%.

So the effects of this feedback loop are as follows:

The probability of Step 2 occurring remains at 100%, although there is an affect on the volume of transactions. In
this example, there is a 5% chance that Step 2 will need to be repeated. This means that the volume of Step 2 of
one pass through the feedback loop is 105% of the original volume. Simply put, 100 forms may be passed to
Step 2, 5 may have to be redone, therefore the volume becomes 105 forms in total, accounting for the
probability of one loop back to Step 2.

If the loop is encountered a second time, i.e. Step 2 is repeated a third time, the probability is 5% x 50% x
10% = 0.25%. The chance that it feedbacks again and Step 2 is repeated a fourth time is 0.25% x 50% x
10% = 0.0125%, fifth time is 0.0125% x 50% x 10% = 0.000625%.

So we now have a series of probabilities that Step 2 occurs:

One = 100%
Two = 5%
Three = 0.25%
Four = 0.0125%
Five = 0.000625%

If we set the number of feedback iterations at 5 to cover the chance that one of the above situations will arise,
the recursive feedback factor is the sum of all probabilities.

Feedback factor = 105.26%

To set the number of feedback iterations:

Note: By default, TIBCO Nimbus automatically sets the number of iterations at 20.

1. Right-click the feedback loop line and from the Costing menu choose feedback iterations.

2. Increase or decrease the number of Iterations (minimum is 1, maximum is 20).

3. Click OK.

n loops

In the unlikely event that a feedback loop has a probability of 99.99%, the feedback factor still needs to
be calculated. TIBCO Nimbus calculates the probability of Step 2 occurring enough times for the
feedback factor to be greater than 4 decimal places, since probabilities of less than 0.01% are ignored
by TIBCO Nimbus.

Multiple feedback loops

These are handled in the same way as the above example.

Related topics

About probabilities
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Defining probabilities

Modifying probabilities

Hiding probabilities

Probability feedback loops

Costing assumptions

Volumes

Define the starting volume

For information on volumes see About volumes.

1. Right-click the start activity (i.e. the first activity in a process diagram) and choose Costing and then
Values.

2. In the Volume box enter the starting volume.

3. From the Per drop-down list choose a time period.

4. In the Custom Volume Cost text box enter the cost per weight or unit (for example, if you have 10kg as
the volume you would define how much 1kg costs).

5. Click OK.

Scenarios

Scenarios are an effective way of experimenting with cost analysis without having
to commit the changes to a current diagram or process map.

Related topics

Volumes

Overriding volumes

Displaying activity costs

Override a volume

To calculate volume-based costing, the initial volume is entered for the starting activity (i.e. the first activity in a
diagram) and carried through the process, taking into account probabilities and feedbacks.

However, for some processes it may not be suitable to have the same volume type running throughout the
process. For example, a process may involve envelopes, but half-way through a process the volume type may
change to boxes of envelopes. In this case, the volume type will need to be changed for the relevant activities.

Note: If you refresh the costing data from a drill down and the start volume has been overridden, the volume is
also refreshed in the activity that you are refreshing from a lower level.

1. Right-click the activity and choose Costing and then Values.

2. In the Volume panel select the Override volume check box.
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Note: This option will not be available for the first activity in a diagram. You can only override the volume on
the first activity by obtaining the volume from the drill down.

3. In the Volume text box enter a new value for the volume cost and, if required, choose a new time period
from the Per drop-down list.

4. If the volume cost has changed then enter a new value in the Custom Volume Cost text box.

5. Click OK.

Note: If you want to override the volume on the first activity in a process, it must be obtained from the child
diagram. To do this, right-click the first activity and select Obtain volume from drill down.

Ignore feedback calculations

Complications can arise if the volume is overridden midway through a probability feedback
loop, for example where envelopes change to boxes of envelopes and a feedback loop is
present later that feeds back to a part of the process before the volume type was changed. In
this case you can ignore the feedback volume by selecting the Ignore feedback
calculations check box. However, due to the potential problems, it is recommended that
overriding the volume is avoided when a feedback loop is in place.

Related topics

Volumes

Defining start volumes

Hierarchical Costing

Display costs from a drill down

Activity-based costing is calculated on a single diagram basis, however it is possible to refresh the cost of a
diagram from the child diagrams.

Note: This is not a live process and will therefore need to be repeated every time any child diagram costs are
updated.

1. Right-click the activity and from the Costing menu choose Values.

2. Click Refresh From Drill Down.

Note: This will only work if the Override Cost option is enabled.

Related topics

Refreshing data hierarchically

Refresh data hierarchically

Activity-based costing is calculated on a single diagram basis; however it is possible to refresh the costing data
either from the lowest levels upwards or from a high level downwards.

Note: It is good practice to backup your map before refreshing costing-based data. Alternatively you can use
scenarios to preview any changes.
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1. From the Map menu choose Costing and then Refresh Hierarchically.

2. Select any options to apply from the Activity Data To Refresh panel.

Volume (only start boxes will be updated) will update the volumes of all start activities.

Dates and times will update the start date and times of activities.

Duration (only applicable when refreshing upwards) will update the duration of activities from
lower levels upwards.

Overridden costs (only applicable when refreshing upwards) will update the total costs of
activities from lower levels upwards. Note: The Override Cost must be enabled - see Displaying activity
costs for more information.

Overridden FTE (only applicable when refreshing upwards)

3. Select the hierarchical direction to refresh the costing data.

Refresh from lowest levels upwards will update the activities from the lower levels upwards.

Refresh from top level downwards will update the lower levels from the top level.

4. Click OK.

Related topics

Displaying costs from drill downs

Critical Path Analysis

About critical path analysis

The critical path is the route that takes the longest time to complete in a diagram and identifies which route to
focus on. By identifying the activities in a critical path, you can focus your efforts on reducing their durations in
order to improve the overall performance of the process. These efforts may involve examining the process
model itself, or performing process instance resource allocation analysis to investigate whether costs and
durations can be reduced by adjusting resource levels.

Note: For the critical path to be analyzed, durations must be specified for all activities in a given diagram. Use
scenarios to modify diagrams in order to improve a process and make it more efficient before making changes to
the original diagram or process map.

Principles of critical path analysis

TIBCO Nimbus sets the start activity on each path to a start time of zero. The Early/Late Start, Early/Late Finish
and Float times are then calculated for each subsequent activity in the diagram.

Early Start (ES) - the earliest possible start time of an activity, relative to the start time of the first activity
(i.e. zero).

Late Start (LS) - the latest possible start time without increasing the overall duration of the process

Early Finish (EF) - the finish based on the early start plus the activity duration

Late Finish (LF) - the finish based on the late start plus activity duration

Float - the late start minus the early start (i.e. flexibility on activity duration without increasing the overall
process duration)

Example
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In the diagram above, the critical path includes activities A, B, C and D. Activity E is not the route of the critical
path as it takes less time (2 hours) than activity C (10 hours). Therefore there is some flexibility for activity E in
terms of start times and duration, which is defined by the Float value. In this example:

Float = Duration of activity C - Duration of activity E = 8 hours

The total duration of activities A and B is 10 hours, therefore the Early Start for activities C and E is 10 hours.

The Late Start of activity E is 18 hours since it has a float of 8 hours. The Late Start of activity C must be the
same as the Early Start, i.e. 10 hours, since activity C is on the critical path.

The Early Finish for activity E is 12 hours and the Late Finish is 20 hours.

As activity C is on the critical path, the Early Finish is the same as the Late Finish, i.e. 20 hours.

TIBCO Nimbus allows for a process map to represent a live project or situation, so you can enter Late values if,
for example, an activity is running late. In the example above, activity C may be running 2 hours late. This would
impact activity E by increasing its Late Start and float by 2 hours. Late values affect the total duration of the
activity and therefore also the diagram cost and FTE values.

Display the critical path

For information about critical path analysis see About critical path analysis.

 

1. On the Basic Costing Panel select Highlight Critical Path.

Note: To display the Basic Costing Panel, from the View menu choose Toolbars & Panels. Access the
Panels tab and then select the Basic Costing Panel check box.

Related topics

About critical path analysis

Example of a critical path
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Example of a critical path

This is an example diagram with activity cost displays set to show the critical path analysis values.

Early Start (ES) - the earliest possible start time of an activity, relative to the start time of the first activity (i.e.
zero).

Late Start (LS) - the latest possible start time without increasing the overall duration of the process

Early Finish (EF) - the finish based on the early start plus the activity duration

Late Finish (LF) - the finish based on the late start plus activity duration

Float - the late start minus the early start (i.e. flexibility on activity duration without increasing the overall
process duration)

Related topics

About critical path analysis

Displaying the critical path

Exporting

Export costing data

Costing-based data can be exported as a CSV file from a storyboard. The data can then be imported into MS
Excel, for example, in order to generate and calculate costs for end-to-end processes.

1. From the Tools menu choose Storyboards.

2. Double-click the storyboard that you want to export the costing data from.

3. From the File menu choose Costing Based Export.
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4. Choose the duration time unit to export the cost data in.

5. Click OK.

6. Choose a location to save the file in and enter a file name, then click Save.

Related topics

Exporting costing data from storyboards

Scenarios

About scenarios

Scenarios are copies of whole maps that allow you to create and test 'what-if' scenarios. A good example where
scenarios can be effective is when conducting cost analysis. Scenarios allow you to reconfigure a process by
moving resources about, reducing the probability of feedbacks to reflect the effects of improved systems, change
the percentages on paths or remodel parts of the process completely. The results of these amendments are
immediately apparent in the cost, duration and FTE information on the costing panels at the bottom of the screen.

One other obvious use of scenarios is when you have identified the end process goal of a Business Process Re-
engineering Project you can create map-wide scenarios representing the phases over a period of months or
years to take you from the 'current state' to a 'future state' in manageable and clearly-defined stages.

You can also convert a scenario into a draft, either to copy over the existing draft or to create a new draft.

Create a scenario

This creates a map that is a parallel named copy to the current map. If you look at the title bar at the top of your
screen you will see the map name and level as [MAPNAME - Level 1.2.3 (Scenario name)]. This also appears on
the Diagram Control panel.  The original remains simply as [MAPNAME - Level 1.2.3]. There is no practical limit to
the number of scenarios, however you should remember that each scenario is a copy of the map and not simply
the diagram.

1. From the Map menu choose Scenarios, then click Add .

2. Enter a name for the scenario and click OK.

Related topics

About scenarios

Replacing drafts with scenarios

Creating new draft maps from scenarios

Renaming scenarios

Accessing scenarios

Deleting scenarios

Replace a draft with a scenario

You can replace an existing draft with a scenario. This operation will replace the current draft with the scenario
and keep the scenario.

Note: You must be viewing the scenario to replace the draft with a scenario.
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1. From the Map menu choose Scenarios, then click Copy Scenario To Draft .

2. Select the Replace the existing draft map radio button.

3. Select the scope that you want to replace the existing draft with.

Current Diagram and Lower Levels will replace the current level and all lower levels in the draft.

Current Process Map will replace the whole process map in the draft.

Save existing draft as a separate scenario before overwriting will create a new scenario based
on the existing draft before updating the draft.

4. Click OK when prompted to run a check on the current process map for the status of all diagrams. If a
diagram has a status Update Pending then it may have been updated recently and you may want to keep it.
Otherwise, to continue to replace the draft with the scenario, double-click the diagram(s) that you want to
overwrite to change the Action status to Overwrite.

5. Click Continue .

Related topics

About scenarios

Creating scenarios

Creating new draft maps from scenarios

Renaming scenarios

Accessing scenarios

Deleting scenarios

Create a new draft map from a scenario

You can create a new draft map with a scenario. This operation will not update the existing map but create a new
map and uses the scenario name as the name of the map.

Note: You must be viewing the scenario to create a new draft map.

1. From the Map menu choose Scenarios, then click Copy Scenario To Draft .

2. Select the Create a new draft map radio button.

3. Select the scope that you want to create a new draft map with.

Current Diagram and Lower Levels will replace the current level and all lower levels in the draft.

Current Process Map will replace the whole process map in the draft.

4. Click OK.

Related topics

About scenarios

Creating scenarios

Replacing drafts with scenarios
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Renaming scenarios

Accessing scenarios

Deleting scenarios

Rename a scenario

Scenarios can be renamed.

1. With the scenario in view, from the Map menu choose Scenarios and then Rename.

2. Enter a new name for the scenario and click OK.

Related topics

About scenarios

Creating scenarios

Replacing drafts with scenarios

Creating new draft maps from scenarios

Accessing scenarios

Deleting scenarios

Access a scenario

A map may have several scenarios.

1. From the Map menu choose Scenarios and then Select.

2. Choose the scenario from the drop-down list and click OK.

Related topics

About scenarios

Creating scenarios

Replacing drafts with scenarios

Creating new draft maps from scenarios

Renaming scenarios

Deleting scenarios

Delete a scenario

Deleting a scenario will delete the entire process map for a selected scenario.

Note: You must have the scenario in view when deleting it.

1. From the Map menu choose Scenarios, then choose Remove .
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Related topics

About scenarios

Creating scenarios

Replacing drafts with scenarios

Creating new draft maps from scenarios

Renaming scenarios

Accessing scenarios

Navigating Maps

Activity Details Panel
The Activity Details Panel displays information about a selected activity, including the input/output text, resources,
commentary text, links, notes bubbles, etc.

1. From the View menu choose Activity Details Panel.

Note: You can undock and dock the Activity Details Panel by double-clicking the top of the panel. To show a
single activity or all activities, right-click in the Activity Details Panel and select or deselect Show all
activities. If viewing all activities, clicking an input/output or activity in the Activity Details Panel will
highlight it in the diagram.

Diagram list
A diagram list allows you to view a list of diagrams within a particular scope and then navigate to a particular
diagram.

 

1. From the View menu choose Diagram List.

2. Select the scope of the diagrams that you want to view and click OK.

Current Diagram displays the current diagram only.

Current Diagram and Lower Levels displays the current diagram and all lower-level diagrams.

Current Process Map displays all diagrams in the current process map.

Diagram Scope List File displays all diagrams in a diagram scope list file.

Map Selection allows you to select diagrams from any process maps in the repository.

3. Double-click a diagram to navigate to it.

Diagram Viewing Tips

To filter the columns click the filter button  on the column that you want to filter and select
the filter criteria.

To add or remove columns choose Column Customizing from the View menu. Drag
columns from the Customize dialog on to the Diagram List dialog to add them and drag
columns from the Diagram List dialog on to the Customize dialog to remove them.

To group columns, drag the column header onto the gray area above the column headers.
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Related topics

Creating diagram scope lists

Managing diagram scope lists

Hierarchical list

Object list

Information list

Zooming

Hierarchical diagram list
Viewing diagrams as a hierarchical list provides a management overview of the process map by displaying all
diagrams at their representative levels. You can navigate to particular diagrams by double-clicking them.

1. From the View menu choose Hierarchical Diagram List.

2. Double-click a diagram to navigate to it.

Diagram Viewing Tips

To add or remove columns choose Column Customizing from the View menu. Drag
columns from the Customize dialog on to the Diagram List dialog to add them and drag
columns from the Diagram List dialog on to the Customize dialog to remove them.

Related topics

Diagram list

Object list

Information list

Zooming

Object list
View a list of activity boxes within a selected scope of diagrams and then navigate to a particular diagram.

 

1. From the View menu choose Object List.

2. Select the scope of the diagrams that you want to view and click OK.

Current Diagram displays the current diagram only.

Current Diagram and Lower Levels displays the current diagram and all lower-level diagrams.

Current Process Map displays all diagrams in the current process map.

Diagram Scope List File displays all diagrams in a diagram scope list file.

Map Selection allows you to select diagrams from all process maps in the repository.
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3. Double-click a diagram to access it.

Object Viewing Tips

To filter the columns click the filter button  on the column that you want to filter and select
the filter criteria.

To add or remove columns choose Column Customizing from the View menu. Drag
columns from the Customize dialog on to the Diagram List dialog to add them and drag
columns from the Diagram List dialog on to the Customize dialog to remove them.

To group columns, drag the column header onto the gray area above the column headers.

Related topics

Diagram list

Hierarchical list

Information list

Zooming

Information list
Display a report of the functions that you are assigned to within a selected scope of diagrams, including group
memberships and associated functions within diagrams.

 

1. From the View menu choose My Information List.

2. Select the scope of the diagrams that you want to view and click OK.

Current Diagram displays the current diagram only.

Current Diagram and Lower Levels displays the current diagram and all lower-level diagrams.

Current Process Map displays all diagrams in the current process map.

Diagram Scope List File displays all diagrams in a diagram scope list file.

Map Selection allows you to select diagrams from any process maps in the repository.

3. Double-click a diagram to access it.

Object Viewing Tips

To filter the columns click the filter button  on the column that you want to filter and select
the filter criteria.

To add or remove columns choose Column Customizing from the View menu. Drag
columns from the Customize dialog on to the Diagram List dialog to add them and drag
columns from the Diagram List dialog on to the Customize dialog to remove them.

To group columns, drag the column header onto the gray area above the column headers.

Related topics
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Diagram list

Hierarchical list

Object list

Zooming

Zooming
You can zoom in and out of a diagram as well as zooming to fit the whole diagram on the screen.

1. From the View menu choose from the following:

Zoom In will zoom in on the diagram

Zoom Out will zoom out on the diagram

Reset Zoom will reset the zoom that has been applied

Zoom To Fit will zoom in or out to fit the entire diagram on the screen

Draw Zoom in Area  allows you to zoom in on an area in the diagram in order to edit the diagram at
close range.

Related topics

Diagram list

Hierarchical list

Object list

Information list
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About the Document Regsitry
The Document Registry is a document management system that allows the control and management of external
files, such as MS Office files, drawings, multimedia files, etc., that support your organization's processes.
Documents are accessible in both the author client and in the web server.

Cached Records Mode

Cached Records Mode allows all documents in the Document Registry to be cached in memory. By enabling this
option, you can filter, sort and group column data in the Document Registry, and navigation is smoother (since
the documents are preloaded). If Cached Records Mode is disabled, memory is saved as documents are loaded
as required, however the navigation experience may not be as smooth.

To enable Cached Records Mode, from the View menu in the Document Registry choose Cache All Records
Mode.

Access the Document Registry
For information about the Document Registry see About the Document Registry.

1. From the Documents menu choose Document Registry.

Document Details
The Document Details window displays the details about a selected document in the Document Registry. The
following tabs are available:

Details

This tab displays the majority of information about the document, including title, version number, author,
owner, categories, authorization status, etc. If a master version of the document exists then you can switch
between draft and master version.

Controlled Copyholders

This tab displays which users currently have controlled copies of the document. Controlled copyholders can be

added by clicking . To remove a copyholder, select the user and click .

Related Documentation

This tab displays any related documents (within the Document Registry). Documents can be linked by clicking 

.

Usage

This tab displays the process maps where the document is linked (i.e. where the document is attached to one
or more diagram objects within a process map).

Find a document

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. Select any filters that you want to search by and click Search. For more information see Searching and
filtering files.

Show withdrawn items will also retrieve any files that have been withdrawn.

Preview Field allows one field to be displayed in between each row of the report. Choose a field from
the Preview Field drop-down list (located on the right of the toolbar). To toggle the preview field on/
off, from the View menu choose Preview.

Note: Leaving the search filters empty will return all documents in the Document Registry. This may take a
considerable amount of time if there are lots of files in the Document Registry.
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You can enter the full title of the file or part of the title in the Title must include text box.

You can reorder columns by clicking and dragging a column header to a new position (indicated by green
arrows).

Related topics

Opening files

Editing file details

Searching and filtering files

Customizing the Document Registry view

Search and filter documents
You can search for and filter on Document Registry files. Filters can also be saved. 

Note: The Display Filter Options panel can be toggled on or off by clicking Filter Panel .

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

To search or filter files:

1. From the filter drop-down boxes, select the check boxes of the options that you want to search against. If
multiple options are selected then files with any of the associated categories will be returned.

To save a filter:

1. Once the filters have been selected click the Filter Panel drop-down arrow  and choose Save Current
Filter Settings.

To manage filters:

1. Click the Filter Panel drop-down arrow  and choose Manage Saved Filters.

Related topics

Customizing the Document Registry view

Exporting the Document Registry

Launch a document

 How to access the Document Registry

From the Documents menu choose The Document Registry,

or click .
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1. Find the file that you want to open.

2. Right-click the file and choose either Launch Master or Launch Draft.

Note: If you know the Document Registry document number you can open the file directly. From the
Documents menu choose GoTo Document Number.

Related topics

Editing file details

Updating file categories

Changing file access rights

Customizing the View

About Document Registry customization

The Document Registry view can be customized with respect to what data is displayed and how it is displayed.

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

Add and remove columns

Columns can be added, removed and reordered.

1. From the View menu choose Column Customizing.

2. Do one of the following:

· Click and drag columns from the Customize window into a position in the Document Registry.

· To remove a column from the Document Registry, click and drag the column header from the Document
Registry into the Customize window.

· To reorder columns in the Document Registry, click and drag the column header to a new position.

Note: Green arrows will appear to indicate where a column can be added.

Related topics

Filtering column data

Sorting column data

Grouping data

Saving and applying layouts
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Filter column data

Data within columns can be filtered.

Note: The cached records mode must be enabled to filter column data. From the View menu choose Cache All
Records Mode.

1. Click the respective filter button  for the column that you want to filter and choose a filter option.

Note: The Custom option allows you to define an And or Or filter.

Related topics

Adding and remove columns

Sorting column data

Grouping data

Saving and applying layouts

Sort column data

Data within columns can be sorted alphabetically.

Note: The cached records mode must be enabled to sort column data. From the View menu choose Cache All
Records Mode.

1. Click the column header that you want to sort to toggle sorting.

Related topics

Adding and remove columns

Filtering column data

Grouping data

Saving and applying layouts

Group data

Grouping provides a way of hierarchically structuring the display of Document Registry files in the list.

Note: The cached records mode must be enabled to group data. From the View menu choose Cache All
Records Mode.

 

1. Drag the column header into the grouping panel area.

To turn the grouping panel on, from the View menu choose Grouping Panel. The grouping panel is indicated
by the gray area above the column headers that states 'Drag a column header here to group by that column'.

You can group by multiple columns by repeating step 1 and the order of the columns determines which
columns are grouped first.
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Grouped columns can also be sorted by clicking the column header to toggle the sort direction.

Grouped nodes can be expanded by clicking  adjacent to the group that you want to expand.

To expand or collapse all group nodes click one of the toolbar buttons  .

Related topics

Adding and remove columns

Filtering column data

Sorting column data

Saving and applying layouts

Save and apply a layout

Once you have configured the view of the Document Registry you can save it as either the system default layout
or a personal layout.

Note: Only administrators can save the system default layout.

 

To apply a layout:

1. From the View menu choose Layouts, then Apply Personal Default Layout or Apply System Default
Layout.

To save a layout:

1. From the View menu choose Layouts, then Save Layout as Personal Default or Save Layout as
System Default.

Related topics

Adding and remove columns

Filtering column data

Sorting column data

Grouping data

Adding Documents and Web Links

Register a document
Depending upon the Document Registry system options, registering a file will either leave the file where it is and
link to it, make a copy of the file in the Document Registry or move the file into the Document Registry.

Note: A Document Registry system option allows default draft promoters to be automatically assigned when files
are registered.
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 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. From the File menu choose Add Single File.

2. Locate the file and click Open.

3. In the Details tab provide any related information.

Note: The seven category drop-down fields are defined by an administrator. For more information see
Defining category drop downs.

The following document registration tabs are also available:

Controlled Copyholders
Users who have controlled copies of the document should be listed here. To add a copyholder click Add

New Copyholder . Then click Select User  to add a user.

To remove a controlled copyholder, select the user and click Remove Copyholder(s) .

Related Documentation
Related files that exist in the Document Registry should be listed here. To add a file click Add Related

Document . Search for the file(s) in the Document Registry and click Accept and Close .

Usage

All maps that link to the Document Registry file are listed here.

Related topics

Acknowledging files

Reviewing files

Authorizing files

Promoting files

Registering files in a folder

Registering web links

Changing file access rights

Editing file details

Withdrawing files

Deleting files

Register a document folder
Depending upon the Document Registry system options, registering files will either leave the files where they are
and link to them, make a copy of the files in the Document Registry or move the files into the  Document
Registry.

 How to access the Document Registry
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From the Documents menu choose Document Registry, or

click .

1. From the File menu choose Add Files From Folder.

2. Locate the folder and click OK.

3. Enter the file details. The details specified will be used for all files in the folder.

Note: The category drop downs are defined by an administrator. For more information see Defining
category drop downs.

Related topics

Editing file details

Acknowledging files

Reviewing files

Authorizing files

Promoting files

Registering files

Registering web links

Changing file access rights

Withdrawing files

Deleting files

Register a web link
Web links can be registered in the Document Registry; links are saved as CWL files.

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

Note: You can also import multiple web links from a CSV file - see Importing web links for more information.

1. From the File menu choose Create and Add Web Link.

2. Enter the URL for the web link.

Note: Ensure the URL is preceded by http://

For example: http://www.tibco.com/nimbus

3. In the Title box enter a name for the file.

4. Click Save.

Associated File Types
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You can assign a file type to a URL. This will display the associated file-type icon to users in both the Author
Client and in the web so that users can easily identify the format of the web link. To assign a file type to a
web link after registering it, right-click the web link in the Document Registry and choose Details, then
choose the associated file type from the File Type drop-down list.

Related topics

Editing file details

Acknowledging files

Authorizing files

Promoting files

Registering files

Registering files in a folder

Changing file access rights

Withdrawing files

Deleting files

Change a draft document
It is possible to change a draft file once it has been registered and before it has been promoted to a master
version. For example, if a user rejects a document in an authorization cycle, you can edit the document externally,
change the draft file and resubmit it for authorization.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to edit.

3. Right-click the file and choose Details.

4. From the File menu choose Change Draft File Not Details.

5. Locate the file that you want to replace the existing document with.

6. Select the document and click Open.

7. Click Close.

Modify document access rights
User access to files in the Document Registry can be modified for draft and master versions of a document. By
default, when a file is registered, all users will have read-only access.

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. Find the file that you want to redefine access rights for.

2. Right-click the file and choose Details.

3. Select either the draft or master tab, if appropriate.
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4. From the Manage menu choose either Change Master file access rights or Change Draft file access
rights.

5. If appropriate, reselect the default access rights. This setting applies to all users not defined in the next step.

6. To define specific user access rights, click Add  to add a user or user group.

More info on Access Rights...

Managing Documents

About document management
The Document Registry is a lightweight document management system, used to store or reference external
documents and files (Microsoft Office-based files,  multimedia images, drawings, etc). A variety of information
can be stored against each file (division, department, document type, level of confidentiality, etc), providing
users with an advanced search facility for files and documents in both the client and web server. Management of
documents and files includes version control, authorization, sign-offs, creation and management of drafts,
archiving and automatic notification to subscribers and responsible parties. Access rights are used to govern who
has access to particular files.

Users involved in the authorization workflow

Authorizers

These assigned users are responsible for authorizing particular diagrams and documents

Draft Promoters

These assigned users are responsible for promoting particular diagrams and documents

Acknowledgers

These assigned users can be requested to acknowledge particular diagrams and documents.

Reviewers

These assigned users are responsible for reviewing particular diagrams and documents.

Authorizing Documents

About authorizing documents

Draft files need to be authorized before they can be promoted to master copies. Authorizers are defined for
specific files and every authorizer must review a particular file before it can be promoted to a master copy.
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Assign authorizers

A document's author, owner or an administrator can assign authorizers. For a draft file to be promoted to a
master copy, the document must be authorized by all assigned authorizers.

Note: Users that are assigned as authorizers must have at least Read access to the draft documents.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to assign authorizers for.

3. Select the file and from the Manage menu choose Authorization and then Authorizers.

4. Choose the scope of documents (files) to assign authorizers to.

Selected Documents will assign authorizers to the selected files.
All Documents will assign authorizers to all files in the Document Registry.

5. Click User or Resource to find and add users, user groups or resources.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.

6. Click OK.

Sequence of authorizers

You can change the sequence of authorizers once they're assigned. For example, you may want one group to
authorize the document first before sending it to the next group. The requests will be sent by sequence
number, so all users assigned as sequence 1 will be requested to authorize the document first. Once those
users have authorized it, the request will be sent to the next set of users. 

To change the sequence number of an existing authorizer, double-click the user, user group or resource.

Removing authorizers

Select the user, user group or resource and click Remove .

Related topics

Requesting authorization

Authorizing and rejecting files

Canceling authorization

Request authorization

When a document is ready to be authorized, an authorization request is sent to the assigned authorizers.
Authorizers will be notified by Email, in order of sequence. When a document has been signed off by every
assigned authorizer then it can be promoted to a master copy and released to users.

Note: If one or more users do not have access to any of the documents that you are requesting authorization
for, you will not be able to proceed. A dialog will list which users do not have access to which documents; you can
either remove them from the list of authorizers, or seek to provide access for these users.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to request authorization for.

3. Select the file(s) and from the Manage menu choose Authorization and then Request.

4. Specify the following options:
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Date to be authorized by is the date in which the authorization should be completed by.

Scope is the scope of documents to request authorization for.

Selected Documents will request authorization for files that you have selected, which are
highlighted.
All Documents will request authorization for all documents in the Document Registry (assuming a
file has at least one assigned authorizer).

Additional Notes allows any supporting notes to be added to the request, which will appear in the
email that is sent to the authorizers.

5. Click Next to continue.

Reminders and escalation options

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

6. Specify any of the following options (if available):

Enable email reminders will send reminder emails to assigned authorizers until they have signed the
document(s) off.

Enable SMS reminders will send reminder SMS messages to assigned authorizers until they have
signed the document(s) off.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

7. Click OK.

Related topics

Assigning authorizers

Authorizing and rejecting files

Cancel authorization

Authorize or reject a document

Once a file is ready to be authorized, a request for authorization will notify the assigned authorizers and an entry
will appear in their Authorization To Do list.

Rejecting a file will Email the author, who will then decide whether to cancel the authorization request or agree on
a resolution with the authorizer. A file cannot be promoted until it has been authorized by all assigned
authorizers.

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose Authorization and then To Do List.

3. Right-click the file and choose Authorize or Reject.

Note: Double-click the file to launch it.
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Related topics

Assigning authorizers

Requesting authorization

Canceling authorization

Promoting files

Creating change requests

Edit a draft document

Once a file has been submitted for authorization, you can change the draft file. For example, if a user rejects a
document that you have submitted, you can edit the document outside of TIBCO Nimbus and resubmit it for
authorization.

Note: This option is not available for documents that are currently promoted and locked.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to edit.

3. Right-click the file and choose Details.

4. From the File menu choose Change Draft File Not Details.

5. Locate the file that you want to replace the existing document with.

6. Select the document and click Open.

7. Click Close.

Cancel authorization

Canceling an authorization request will inform the assigned authorizers and remove the request to authorize the
file from their Authorization To Do list.

 

1. From the Documents menu choose Document Registry.

2. Find the document that you want to cancel authorization for.

3. Right-click the file and choose Details.

4. From the Manage menu choose Authorization and then Unlock Draft.

Related topics

Assigning authorizers

Requesting authorization

Authorizing and rejecting files
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Override an authorization cycle

It is possible for administrators to override an authorization cycle part-way through and authorize selected
documents or all documents in the Document Registry. This is useful in cases where an authorizer is removed
from an authorization cycle before they have authorized it, thereby holding up the promotion of a document or
set of documents, for example if an authorizer is on holiday or on sick leave.

Note: This option is only available to administrators.

 

1. From the Documents menu choose Document Registry.

2. Find the document that you want to override the authorization.

3. Click the document(s) to select it.

4. From the Manage menu choose Authorization and then Override Authorization.

5. Enter your password and provide a reason for overriding the authorization cycle.

6. Select the scope of documents to authorize.

All Documents will override all documents in the Document Registry (if they are awaiting authorization).

7. Click OK.

Related topics

Assigning authorizers

Requesting authorization

Cancel authorization

Promoting files

Promoting Documents

About promoting documents

Promoting a file will create a master copy of the file. Only authorized files can be promoted and once promoted,
the draft copy becomes locked to prevent further editing. Draft promoters are responsible for promoting a draft
file and only administrators and Document Registry administrators can assign draft promoters.

Note: A Document Registry system option allows a default draft promoter to be automatically assigned when
documents are registered.

Assign draft promoters

Only assigned draft promoters can promote a draft to a master copy. A Document Registry system option allows
a default user to be automatically assigned as the draft promoter upon registration of files in the  Document
Registry.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to assign draft promoters for.

3. Select the file and from the Manage menu choose Authorization and then Draft Promoters.
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4. Click Add  to add a user or user group.

5. Select the scope of files that the users will be draft promoters of.

Selected Documents includes only files that you have selected in the Document Registry.

All Documents includes all files in the Document Registry.

Related topics

Promoting draft files

Promote a draft document

Promoting a draft will create a master copy of the file. A file can only be promoted if the file has been authorized
and is ready for promotion, i.e. it has the status Promotion Ready. When a file has been promoted, the Details
page for the file will display two tabs, one for the master and one for the draft. If a master version of a file
already exists then any subsequent promotions will archive the current master files.

Note: A system option can automatically promote a draft following authorization.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to promote.

3. Right-click the file and choose Details.

4. From the Manage menu choose Authorization and then Promote Draft Copy.

Promoting Multiple Documents

Multiple files/documents can be promoted in one operation if they are ready to be
promoted.

1. From the Documents menu choose Document Registry.

2. Find the documents that you want to promote.

3. Select the files (hold Ctrl to select multiple documents) and from the Manage menu
choose Authorization  and then Promote Draft Copy.

4. Select the scope of documents to promote.

Note: You may be required to specify the location to save the master copies in.

5. Click OK.

6. Select the documents that you want to promote (documents that are ready for
promotion will have a value of 'YES' in the OK column). Hold Ctrl to select multiple
documents to promote.

7. Click Continue.

Unlocking Drafts

Once a document has been promoted, if any edits are required the draft document must
be unlocked. See Unlocking drafts for more information.
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Quick Promotion Of Documents

Administrators and Registry administrators can promote registered documents without
putting them through an authorization cycle.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to promote.

3. Select the document and from the File menu choose Administration and then
Quick Promotion.

Related topics

Assigning draft promoters

Authorizing files

Updating Documents

Update a draft document

A draft becomes locked following its promotion to a master copy and further editing is prevented. To update a
promoted file the draft must be unlocked. By default only authors, owners and administrators can unlock a draft.

Note: A system option will automatically unlock drafts upon promotion.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to unlock.

3. Select the file and from the Manage menu choose Authorization and then Unlock Draft.

Managing Document Versions

Document authorization audit trail

The Documentation Authorization Audit Trail records any changes to a file with respect to the authorization cycle,
for example if the list of authorizers change, if an authorization has been accepted or rejected, etc.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to view the authorization audit trail for.

3. Select the file and from the View menu choose Details.

4. From the Manage menu choose Authorization and then Authorization Report.

The Current Process tab displays the authorizers of the file and their current status. The History Audit Log
tab displays all changes made to the file with respect to its authorization. 

Double-click a log entry to view the details.

Note: You can view the authorization audit trail for multiple documents by selecting the documents in the
Document Registry, then from the Manage menu choose Authorization and then Authorization Report.
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Update information across documents

Basic file information such as version number, date, author and owner can be updated across a scope of files.
When the owner or author is changed, a history audit log entry is automatically generated to record the change.

1. From the Documents menu choose Document Registry.

2. Find the documents that you want to update.

3. Select the documents that you want to update, if updating a selection.

4. From the Manage menu choose Version Manager.

5. From the Update panel select the check boxes of the updates that you want to make.

6. From the Scope panel choose the scope of files to make the changes to.

7. Change any diagram information in the New Information panel.

Increment version number will update the version number to the next version number (e.g. version
1.2 will become version 1.3). 

Set version number will allow you to manually define a version number.

Replacing document authors and owners

To search and replace on authors and owners for selected files or all files within the Document Registry, click 
Advanced.

Restoring Archived Documents

Restore an archived document

Files are archived automatically when a draft or master copy is overwritten with a new version. Archived files can
be restored in the Document Registry Archive Manager.

1. From the Documents menu choose Document Registry.

2. From the File menu choose Archive Manager.

3. Select the document that you want to restore and from the File menu choose Restore File.

4. Choose a location to save the file in and click Save.

Viewing Audit Trails

View a document's audit trail

The audit trail lists the current authorization state for documents and a history of changes to the authorization,
including any updates to a document's categories.

Note: Audit records are read-only.

1. In the Document Registry, right-click the document and choose Details.

2. From the Manage menu choose Authorization, then Authorization Report.

There are two tabs; Current Progress and History Audit Log.

Note: To view the details of an audit record double-click the record in the History Audit Log tab.
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Viewing the audit trail for multiple documents

To view the audit trail of multiple documents at once, search and retrieve the documents that you want to
view, then from the Manage menu choose Reports and then Audit Trail List.

Managing Change Logs

View and add change log records

Changes to documents are recorded in the change log for a specific file. Change logs can be viewed by users that
have access to the diagram.

Note: Only file owners, authors, creators, administrators and Registry administrators can add, edit and delete
change log entries.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to add a change log entry to.

3. Right-click the file and choose Details.

4. From the Manage menu choose Change Log.

Adding, editing and deleting change logs

To add a new change log entry click Add. To edit an existing change log entry, select the
change log entry and click Edit. To delete an existing change log entry, select the change
log entry and click Delete.

Creating Actions

Create an action

Actions can be created for documents. For information on actions please refer to the Action Management section.

1. In the Document Registry window (Documents>Document Registry), search for the document(s) that you
want to create an action for.

Note: If you are creating an action for all documents in the Document Registry, it does not matter which
document you select. 

2. Click a document to select it.

Note: You can create an action for multiple documents. Hold Ctrl when selecting documents.

3. From the Manage menu choose New Action for Document(s).

4. In the Scope step, select one of the following options and click Next:

· Selected Documents will create an action for all of the documents that you have selected.

· All Documents will create an action for all documents in the Document Registry.

5. In the Properties step, define the properties of the action, and then click Next.

6. In the Assignees step, click Add to add users to undertake the action, and then click Next.

Require only 1 assignee to complete action will require only one of the assigned users to complete
the action before it can be closed.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.

7. In the Editors step, click Add to add users that can edit the action, and then click Next.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.
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8. In the Viewers step, click Add to add users that can view the action, and then click Next.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.

9. In the Description step, add any information about the action, such as the reason for requiring the action,
and then click Next.

10. In the Owner Category Data step, provide additional information based on the fields available (note that this
step may not be available).

11. In the Additional Data window, provide additional information based on the fields available (note that this
step may not be available).

12. In the Attachments window, add any attachments for additional support. Attachments can be file links,
application links, email links, SAP transaction links, document links, storyboard links and URL links. 

Click New  to add an attachment. To modify the access rights for a particular action, select the attachment

and click Set View Rights .

Reminders and Escalation

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue action. An
escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

13. In the Reminders and Escalation step, set the relevant reminder and escalation options.

Enable email reminders will send reminder emails to users until they have completed the action.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
completed the action.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

14. Click Finish.

Collaborating on Documents

Requesting Acknowledgement

Assign acknowledgers

Acknowledgers are users that are requested to acknowledge changes to files, or new content relevant to their
role.

Note: If one or more users do not have access to any of the documents that you are assigning them to then you
will not be able to proceed. A dialog will list which users do not have access to which documents; you can either
remove them from the list of acknowledgers, or seek to provide access for these users.

1. From the Documents menu choose Document Registry.

2. Find the file(s) and select it.

3. From the Manage menu choose Acknowledgers.

4. Select the scope of diagrams to add acknowledgers to.

All Documents will assign acknowledgers to all files within the Document Registry.

5. Click User or Resource to find and add users, user groups or resources.

6. Click OK.
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Resending Acknowledgement Requests to New Acknowledgers

If an acknowledgement request has been sent out for a scope of documents and new acknowledgers are
assigned, you can resend the acknowledgement request to these new users. See Requesting acknowledgement
for further information.

Related topics

Request acknowledgement

Acknowledge a file

View the acknowledgement log

Request acknowledgement

Following the promotion of a document, selected users can be requested to acknowledge the new content. An
acknowledgement request will appear in their To-dos and they will be notified by email.

Note: If one or more users do not have access to any of the documents that you are requesting
acknowledgement for, you will not be able to proceed. A dialog will list which users do not have access to which
documents; you can either remove them from the list of acknowledgers, or seek to provide access for these
users.

Reporting

A number of acknowledgement-based reports are available. In the Document Registry, from the Manage menu
choose Reports, and then one of the  following: See Generate a report for more information.

Acknowledgement Log List displays a list of users that have acknowledged a scope of documents.

Acknowledgement Progress displays the acknowledgement progress for a scope of documents.

Acknowledgement Requests List displays a list of acknowledgement requests for a scope of documents,
including status and the percentage complete.
Acknowledgement Summary displays a high-level overview of the acknowledgement progress for a
selected scope of documents. Double-click a row to view the Acknowledgement Progress report for a specific
document.

1. In the Document Registry, right-click the file(s) that you want to request acknowledgement for and choose 
Details.

2. From the Manage menu choose Request Acknowledgement.
3. In the Acknowledgement Type options choose the type of acknowledgement that you want to create.

Standard allows you to create a single acknowledgement request for a scope of documents that must
be completed by a specific date. Once all acknowledgers have acknowledged then the status of  the
request will be set to Complete. Note that if new acknowledgers are added at a later date then they will
be assigned the same date, which may lead to past due (overdue) requests being assigned to new
acknowledgers.

Continuous allows you to create an open acknowledgement request for a scope of documents which is
open indefinitely. When a new acknowledgement request is sent out, new acknowledgers will be
assigned a due date in advance of the date the new request is sent, thereby ensuring that they do not
receive past due (overdue) requests.

4. Select either the Date to be acknowledged by or the Acknowledgement request due dates to
(depending on what you selected in the previous step).

Note: The Acknowledgement request due dates to setting (for continuous acknowledgement
requests) will automatically create due dates from the date a new acknowledger is assigned. For
example, if you set 2 weeks as the value and a new acknowledger is added on the 1st January, then the
due date for that user to acknowledge the content by will be the 15th January.



Documents

TIBCO Nimbus® User GuidePage 259

5. Choose the scope of documents to request acknowledgement for.

Selected Documents will request acknowledgement for files that you have selected, which are
highlighted.

All Documents will request acknowledgement for all files in the Document Registry (assuming a file has
at least one assigned acknowledger).

6. Enter any additional notes that may be useful for a user when acknowledging the content.
7. Click Next to define the reminder and escalation options.

Reminders and escalation options

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

Enable email reminders will send reminder emails to assigned acknowledgers until they have signed
the document(s) off.

Enable SMS reminders will send reminder SMS messages to assigned acknowledgers until they have
signed the document(s) off.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

8. Click OK to finish.

Resending Acknowledgement Requests to New Acknowledgers

If an acknowledgement request has already been submitted for a selected scope of documents and new
acknowledgers are assigned, you can resend an acknowledgement request to these new users. 

In the acknowledgers list for a particular document, choose the scope of documents to resend any
acknowledgement requests for, then select the new users in the list (hold Ctrl to select multiple users). Right-
click a selected user and choose Send Current Request. In the Request Acknowledgement dialog that opens
you can deselect any users, if required, then click OK to send the request(s).

See Assigning acknowledgers for further information.

Resending Acknowledgement Requests to New Group Members

When a user joins a new user group, you can resend them any previous acknowledgement requests that relate to
their new group membership. This ensures that users are made aware of any new processes, documents and
storyboards that relate to their new roles.

 This option is only available to TIBCO Nimbus administrators.

Note: If the user has joined a group that is a member of other groups, i.e. the group is a sub-group of one or
more parent groups, they will also receive any acknowledgement requests that exist for associated parent
groups. 

In the User Accounts window, right-click the user and choose Send Acknowledgements. Select the user
group(s) that you want to send current acknowledgement requests for, i.e. select the group(s) that the user has
recently joined. Automatically reactivate completed acknowledgements will reactivate the last completed
acknowledgement request (i.e. set it to 'active) and send it to the user. If this option is not selected then only
active requests will be sent to the user. Click Next to define the reminder and escalation details (see above for
information) and click OK.
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Related topics

Assigning acknowledgers

Acknowledge a file

View the acknowledgement log

Cancel and complete acknowledgement requests

Canceling and completing acknowledgement requests can achieved through the Collaboration Console.

Acknowledge a document

If a file has changed and you are an assigned acknowledger for the file, you will receive a request to
acknowledge the change. Acknowledgement requests will appear in your Email and in your action list.

 

1. In the Document Details window for the document, from the Manage menu choose Acknowledge File.

2. Right-click the acknowledgement request entry and choose Sign Off.

3. Enter your password and click OK.

Related topics

Assigning acknowledgers

Request acknowledgement

View the acknowledgement log

Action lists

View the acknowledgement log

All acknowledgements made against a Document Registry file are stored in a log, with a separate log created for
each file.

1. From the Documents menu choose Document Registry.

2. Find the document, right-click it and choose Details.

3. From the Manage menu choose Acknowledgement Log.

Providing Feedback

Add feedback

When a new feedback is submitted the Primary Email Contact for the diagram will be notified.

1. From the Documents menu choose Document Registry.

2. Find the document that you want to add a feedback to.
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3. Right-click the file and choose Details.

4. From the File menu choose feedback.

5. Right-click feedback (on the left) and choose Start New Topic.

6. Enter a title, reference (optional) and subject (optional).

7. Click OK .

Hint: To spell check the feedback before submitting it, from the Tools menu choose Check Spelling.

Related topics

Replying to feedback

Editing feedback

Deleting feedback

Printing feedback

Subscriptions

Reply to feedback

1. From the Documents menu choose Document Registry.

2. Find the document.

3. Right-click the file and choose Details.

4. From the File menu choose feedback.

5. Right-click the feedback that you want to reply to and choose Reply To Topic.

6. Enter a title, reference (optional) and subject (optional).

7. Click OK .

Hint: To spell check the feedback before submitting it, from the Tools menu choose Check Spelling.

Related topics

Adding feedback

Editing feedback

Deleting feedback

Printing feedback

Subscriptions
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Edit feedback

1. From the Documents menu choose Document Registry.

2. Find the document.

3. Right-click the file and choose Details.

4. From the File menu choose feedback.

5. Right-click the menu and choose Edit.

Note: You can only edit your own feedback.

Related topics

Adding feedback

Replying to feedback

Deleting feedback

Printing feedback

Subscriptions

Delete feedback

1. From the Documents menu choose Document Registry.

2. Find the document.

3. Right-click the file and choose Details.

4. From the File menu choose feedback.

5. Right-click the menu and choose Delete.

Note: You can only delete your own feedback. Administrators can delete all feedback associated with a
document. From the Feedback menu choose Delete All.

Related topics

Adding feedback

Replying to feedback

Editing feedback

Printing feedback
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Print feedback

1. From the Documents menu choose Document Registry.

2. Find the document.

3. Right-click the file and choose Details.

4. From the File menu choose Feedback.

5. Select the feedback topic and from the Feedback menu choose Print Feedback.

Note: You can print all feedback associated with a document. From the Feedback menu choose Print All
Feedback.

Related topics

Adding feedback

Replying to feedback

Editing feedback

Deleting feedback

Requesting Reviews

Assign reviewers

Reviewers must be defined for a review cycle to be undertaken. When a review is initiated for a particular file,
the assigned reviewers will be notified and an action will appear in their action list.

Note: If one or more users do not have access to any of the documents that you are assigning them to then you
will not be able to proceed. A dialog will list which users do not have access to which documents; you can either
remove them from the list of reviewers, or seek to provide access for these users.

To assign reviewers to selected files:

1. From the Documents menu choose Document Registry.

2. Find the document that you want to assign reviewers to.

3. Select the file(s) and from the Manage menu choose Reviewers.

4. Select Selected Documents as the scope.

5. Click Add  to add users.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.

6. Click OK.

To assign reviewers to all documents:

1. From the Documents menu choose Document Registry.

2. Search for a file.

Note: Since you are assigning reviewers to all documents it does not matter which file you retrieve.
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3. From the Manage menu choose Reviewers.

4. Select All Documents as the scope.

5. Click Add  to add users.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.

6. Click OK.

Related topics

Requesting reviews

Creating recurring reviews

Signing off reviews

Request a review

From time to time you may want to have a document reviewed by certain users (reviewers). Reviewers will be
notified by email and a new action will appear in their To-dos.

Note: If one or more users do not have access to any of the documents that you are requesting a review for,
you will not be able to proceed. A dialog will list which users do not have access to which documents; you can
either remove them from the list of reviewers, or seek to provide access for these users.

1. From the Documents menu choose Document Registry.

2. Find the document(s) that you want to request a review for.

Note: If you want to request a review for multiple documents, hold Ctrl to select each file.

3. From the Manage menu choose Schedule Review.

4. Enter a user reference, if appropriate, and a note. Click Next to continue.

5. Choose the date that you want the review to be completed by and the priority, then click Next.

Reminders and escalation options

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

6. Specify any of the following options (if available):

Enable email reminders will send reminder emails to assigned reviewers until they have signed the
document(s) off.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
signed the document(s) off.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.
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7. Click Next.

8. To add an attachment click New  and choose an attachment type.

9. Click Next and select the scope of diagrams that you want to request a review for.

10. Click Next, enter your password and then click Finish.

Related topics

Assigning reviewers

Creating recurring reviews

Manually triggering recurring reviews

Signing off reviews

Create a recurring review

Recurring reviews will automatically request a review of a file at specified time intervals. 

Note: When a recurring review is setup you must specify separate reviewers than those that may be already
assigned as ad hoc reviewers. If one or more users that you assign do not have access to any of the documents
then you will not be able to create a recurring review. A dialog will list which users do not have access to which
documents; you can either remove them from the list of reviewers, or seek to provide access for these users.

1. From the Documents menu choose Document Registry.

2. Find the document(s) that you want to create a recurring review for.

3. Select one or more documents (hold Ctrl to select multiple documents).

4. From the Manage menu choose New Recurring Review.

5. Choose the first review date, the recurrence of the review and the notification period (after which users will
be reminded to review the documents), then click Next.

Reminders and escalation options
Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

6. Specify any of the following options (if available):

Enable email reminders will send reminder emails to assigned reviewers until they have signed the
document(s) off.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
signed the document(s) off.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

7. Click Add to add the users and/or user groups who you want to review the file, then click Next.

Note: Any ad-hoc reviewers assigned to the document will be automatically added. These can be removed
by selecting the user(s) and clicking Remove. You can assign the owner and author by clicking Dynamic.

8. Enter any additional notes about the recurring review, for example the reason, then click Next.

9. Choose the scope of documents to create the recurring review against, then click Next.
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10. Enter your password, then click Finish.

Related topics

Assigning reviewers

Editing recurring reviews

Removing recurring reviews

Manually triggering recurring reviews

Signing off reviews

Edit a recurring review

Recurring reviews will automatically request a review of a file at specified time intervals. Recurring reviews can
be edited, for example to change the recurrence, notification or add/remove users. Recurring reviews can only
be edited by the originator, a system administrator or a Document Registry administrator.

Note: Recurring reviews have separate reviewers assigned to each recurring review.

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose View Recurring Reviews.

Note: If you want to edit the recurring review of a specific file or files then they must be selected before
following step 2.

3. Choose the scope of files to view.

Selected Documents will display the recurring reviews for the selected files only (if a recurring review
exists).

All Documents will display the recurring reviews for all documents with an assigned recurring review
within the Document Registry.

4. Right-click the recurring review and choose Edit.

5. Make any changes to the review settings, if required, then click Next.

6. Click Add to assign new users to the review or select users that you want to remove and click Remove.

7. Click Next and edit the note, if required.

8. Click Next, enter your password and click Finish.

Note: You can also edit a document's recurring review from the Document Details window for a specific document.
From the Manage menu choose View Recurring Reviews, then right-click the recurring review and choose
Edit).

Related topics

Assigning reviewers

Creating recurring reviews

Removing recurring reviews

Manually triggering recurring reviews



Documents

TIBCO Nimbus® User GuidePage 267

Signing off reviews

Remove a recurring review

Recurring reviews will automatically request a review of a file at specified time intervals.

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose View Recurring Reviews.

3. Choose the scope of files to view recurring reviews for.

Selected Documents will display recurring reviews for only the selected documents.

All Documents will display recurring reviews for all files within the Document Registry.

4. Select the recurring review and from the File menu choose Delete.

Related topics

Assigning reviewers

Creating recurring reviews

Editing recurring reviews

Manually triggering recurring reviews

Signing off reviews

Manually trigger a recurring review

The next review in a recurring review cycle can be manually triggered. All reviewers of the recurring review will
be notified and requested to review the diagram.

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose View Recurring Reviews.

3. Select the scope of documents to view recurring reviews for and click OK.

4. Right-click the recurring review and choose Manually Trigger Next Cycle.

Related topics

Assigning reviewers

Creating recurring reviews

Editing recurring reviews

Removing recurring reviews

Signing off reviews
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Sign off a review

If you have been requested to review a file then it will appear in your action list from where you can sign it off.

1. From the Actions menu choose Action List.

2. Right-click the review item and choose Sign off.

3. Choose either Approve Review or Reject Review, enter your password and any relevant notes, then
click OK.

Note: Rejecting a document will automatically display the New Change Request window, allowing you to
create a change request based on the reasons why you have rejected the document.

Related topics

Assigning reviewers

Creating recurring reviews

Editing recurring reviews

Removing recurring reviews

Manually triggering recurring reviews

Creating Change Requests

About change requests

As part of a quality management system, change requests can be raised against Document Registry. When a
change request is raised, the document owner will be notified with a request to review it. Following successful
authorization by the owner, the document author will then be requested to review it.

Create a change request

You can submit a change for a document at any point in its authorization cycle. For more information see About
change requests. 

1. From the Documents menu choose Document Registry.

2. Find the document that you want to create a change request for.

3. Right-click the file and choose Details.

4. From the Manage menu choose New Change Request.

5. Enter the relevant information for each stage, clicking Next to proceed through the steps.

Related topics

Reviewing change requests

Completing change requests

Viewing change requests
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Viewing the change request log

Changing the originator, owner or author of change requests

Edit a change request

If you are an administrator or the owner of a change request you can edit the details, such as the owner, author,
originator, reminder and escalation settings and attachments. For more information see . 

1. From the Documents menu choose Document Registry.

2. Find the document that you want to edit a change request for.

3. Click the document to select it and then from the Manage menu choose View Change Requests.

4. Right-click the change request that you want to edit and choose one of the options.

Related topics

About change requests

Reviewing change requests

Completing change requests

Viewing change requests

Viewing the change request log

Changing the originator, owner or author of change requests

Review a change request

Following the submission of a change request, the owner is notified with a request to review it before it is passed
on to the document author to review and complete. As a reviewer you can accept or reject the change request,
or you can request further information from the originator or request that the document undergoes an impact
assessment. Once the review stage has been confirmed then a notification message is sent to the specified
implementer and an action is created in their action list. If a change request is rejected, or further information
requested, then the change request is returned back to the originator, who can then cancel it or resubmit the
request with additional information.

Note: The owner may not necessarily be the document owner as in some cases the originator may have
specified a different user.

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose View Change Requests.

3. Click the document that you want to view the change request for in the list of change requests.

4. Click on the yellow box that states Owner.

Note: If you are not the owner or the change request is not in the review stage then you cannot review it.

5. Select the relevant option and click Next.

Allocate Request will accept the change request and send it to the author to action (this option is not
available if the change request has already been approved and sent to the author but then returned for more
information).
Need More Information will return the change request to the originator with a request to provide more
information.
Reject Request will return the change request to the originator as rejected.
Impact Assessment will hold the change request to allow the impact on the document to be assessed.



Documents

TIBCO Nimbus® User Guide Page 270

6. Enter the relevant information relating to the option that you have chosen. For example, why the change
request is being rejected, what kind of information you require from the originator, etc.

Change Request Notes will allow you to view existing notes in the Feedback dialog that
have been submitted against the change request. You can also add notes from here.

You can find any change requests that await your input in your Action List.

Related topics

Creating change requests

Completing change requests

Viewing change requests

Viewing the change request log

Changing the originator, owner or author of change requests

Complete a change request

When a change request has been approved by the owner, the author is requested to action the change request.
Once the change request has been fulfilled the author will then complete it. The author can also request further
information from the owner or originator to provide clarification of the change request if required.

Note: The author may not necessarily be the document author as a different user may have been specified to
action the change request.

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose View Change Requests.

3. Click the document that you want to view the change request for in the list of change requests.

4. Click on the yellow box that states Author.

Note: If you are not the author or the change request is not in the completion stage then you cannot review
it.

5. Select the relevant option and click Next.

Need More Information (From The Originator) will return the change request to the originator with a
request to provide more information.
Confirm Completion states that the change request has been fulfilled and sets the status to complete.
Need More Information (From The Owner) will return the change request to the owner with a request to
provide more information.

6. Enter the relevant information relating to the option you have chosen. For example, what kind of information
you require from the originator or owner if you are requesting further information.

Note: You can find any change requests that await your input in your Action List.

Related topics

Creating change requests

Reviewing change requests
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Viewing change requests

Viewing the change request log

Changing the originator, owner or author of change requests

View change requests

The Change Requests dialog lists all change requests that exist for documents in the Document Registry. When a
change request is highlighted in the list, the stage at which the change request is at will be highlighted in yellow.
The appropriate user can then click on the stage that they're associated with to complete it and progress the
change request to the next stage.

 

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose View Change Requests.

3. Click the document that you want to view the change request for in the list of change requests.

Note: You can group columns by dragging a column header onto the gray area just above the list of change
requests.

Related topics

Creating change requests

Reviewing change requests

Completing change requests

Viewing the change request log

Changing the originator, owner or author of change requests

View change request log

A log of all notes is stored with the change request, allowing any interested users to collaborate by adding new
topics or replying to existing topics.

 

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose View Change Requests.

3. Right-click the change request from the list and choose Change Log/Notes.

4. To add a note do one of the following:

· From the Feedback menu choose Start New Topic.

· Right-click an existing note and choose Reply To Topic.

Related topics

Creating change requests
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Reviewing change requests

Completing change requests

Viewing change requests

Changing the originator, owner or author of change requests

Change the originator, owner or author

By default the change request originator is the user that creates the change request and the owner and author is
the document owner and author. You can specify a different originator, owner and author of a document.

Note: Change request owners and authors are automatically updated when document owners and/or authors are
changed.

1. From the Documents menu choose Document Registry.

2. From the Manage menu choose View Change Requests.

3. Right-click the change request from the list and choose either Change Owner, Change Author or Change
Originator.

4. Click Select user  to assign a new user.

Related topics

Creating change requests

Reviewing change requests

Completing change requests

Viewing change requests

Viewing the change request log

Subscribing to Documents

About subscriptions

Subscriptions are used to notify subscribed users via Email of any changes to a document version. Users can
subscribe themselves to documents and users can subscribe other users. A system option can force the version
number to increment automatically upon promotion from a draft to a master. Alternatively, users can manually
increment a version number.

For diagrams, a different set of subscribers can be defined for the draft and master versions. Subscribed users
will not be copied over when a draft diagram is promoted. However, when assigning subscribers to a document,
both draft and master versions will contain the same subscription list. If you remove a subscribed user from the
draft version then it will also be removed from the master version, and vice-versa.

Note: Contributors cannot add or remove other users from a subscription list, however they can add or remove
themselves (if they have the Change Subscription user account setting enabled).



Documents

TIBCO Nimbus® User GuidePage 273

Add a subscription

1. From the Documents menu choose Document Registry.

2. Find the document that you want to add subscriptions to.

3. Right-click the file and choose Details.

4. From the File menu choose Subscriptions.

5. Click Add Subscriptions.

6. Select a user or user group.

Note: To remove a user once assigned, select the user and click Remove .

7. Click Next.

8. Click Next.

9. Click Apply.

Related topics

Removing subscriptions

MFeedbackemos

Remove a subscription

1. From the Documents menu choose Document Registry.

2. Find the document that you want to add a subscription to.

3. Right-click the file and choose Details.

4. From the File menu choose Subscriptions.

5. Select the user or user group and click Remove Subscriptions.

Note: Hold Ctrl to select multiple users and user groups.

If the list of subscribers is long and you know the user(s) and/or user group(s) that you want to unsubscribe,

do not select any user or user group before clicking Remove Subscriptions. C lick Add  to find the user
or user group that you want to unsubscribe.

6. Click Next.

7. Click Apply.
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Editing Documents

Edit a document's details

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. Find the file that you want to edit.

2. Right-click the file and choose Details.

Related topics

Opening files

Updating file categories

Changing file access rights

Update a document's categories
Document categories can be updated. You can choose to update the categories of selected files or all files in the
Document Registry.

Note: You must have the relevant access rights to update a file's categories.

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. Right-click the file and choose Update Categorizations.

2. Select the drop-down check boxes for the categories that you want to update.

3. Choose a new category from the associated drop-down list.

4. Choose the scope of the operation.

Selected Documents will re-categorize the files that have been highlighted.

All Documents will re-categorize all documents in the Document Registry.

6. Click OK.

Related topics

Defining document category drop down lists

Changing file access rights
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Removing Documents

Withdraw a document
File authors, file owners and administrators can withdraw a file from the Document Registry. Withdrawn files are
not removed from the Document Registry and can still be searched for, however withdrawn files cannot be
accessed. Files will be withdrawn from the date that is specified, so for example you can mark a file to be
withdrawn in a week.

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. Find the file that you want to withdraw.

2. Right-click the file and choose Details.

3. Select a date in the Withdrawn drop-down calendar. Click here to locate the Withdrawn drop-down
calendar.

Note: To reinstate a withdrawn file you must clear the withdrawn field.

Related topics

Delete a file

Delete a document
There are two stages when deleting a document. Deleting a document for the first time will gray it out and
prevent access to it, although it will still be visible in searches. Note that these files can be undeleted. Deleting a
file for the second time will permanently remove the document link. It is also possible to delete the file document
link and the actual file itself.

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

To delete a document link:

1. Find the file that you want to delete.

2. Right-click the file and choose Delete Document Link.

Note: Hold Ctrl to select multiple files.

To permanently delete the document link (if the Keep deleted records system option is enabled), repeat this
process.

To delete a document link and the actual document:

1. Find the file that you want to delete.

2. Right-click the file and choose Delete Document Link and File(s).
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Note: Hold Ctrl to select multiple files.

Deleted files will be moved to one of the following Process Repository folders:

· Master files ...\Process Repository\Deleted\Registry Documents

· Draft files ...\Process Repository\Deleted\Registry Documents\Draft

To restore a document link:

1. Find the file that you want to undelete.

2. Right-click the file and choose Undelete.

Related topics

Withdraw a file

Importing and Exporting Documents

About importing and exporting from the Document Registry
You can import files that are used in maps but have not yet been registered in the Document Registry. A list of all
files in the Document Registry can be exported as TXT, XLS and XML formats.

Import document links from a map
Documents that are linked to maps but are not in the Document Registry can be imported and automatically
registered.

1. From the File menu choose Import Links from Map.

2. Select the map that you want to import files into the Document Registry from and click OK.

Note: Once all files have been imported you should then consider editing the files' details.

Importing web links
You can import web links (URLs) from a CSV file. The format of the CSV file must include the URL, however all
other headings are optional:

URL,Title, Author, Owner, Comment, User Ref, Drop Down 1, Drop Down 2, Drop Down 3, Drop Down
4, Drop Down 5, Drop Down 6, Drop Down 7

For example: http://www.tibco.com/nimbus,TIBCO Nimbus

Note: The title is the title of the web link as it appears in the Document Registry. If the title is left blank for a
particular URL then the actual URL will be used.

  Available to administrators only

1. In the Document Registry, from the File menu choose Administration, then Import Web Links.

2. Find and select the CSV file, then click Open.
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Export the Document Registry
You can export a list of documents in the Document Registry to either TXT, XLS,HTML and XML format.

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. Search and filter to display the documents that you want to export.

Note: If you want to export the whole Document Registry then click Search without applying any filters.

2. From the File menu choose Export Grid As Shown To and then select a format.

3. Specify a location to save the exported file in and click Save.

Note: If you select HTML format, select from the following options:

Master documents only will create a list of master documents in HTML format.

Master and draft documents will create a list of master and draft documents in HTML format.

Copy files for HTML version will export the included registry documents to a separate folder named

'Attach'.  This folder can be found adjacent to the HTML file. 

Click OK.

Adding Documents to User's Favorites

Add documents to users' favorites
You can add a selection of files to one or more user groups' Web favorites though the Document Registry.

  Administrators only

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. Conduct a search in the Document Registry to display the documents that you want to add to user groups'
favorites.

2. Select the desired documents, then right-click one of the selected documents and choose Add to User
Group Favorites.

3. Select the user group(s), then click OK.
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Reporting on the Document Registry

Report on the Document Registry
A number of document-based reports can be run from the Document Registry.

 How to access the Document Registry

From the Documents menu choose Document Registry, or

click .

1. If you are running a report against a selected scope of documents, hold Ctrl and select the documents that
you want to report against.

2. From the Manage menu choose Reports, then select a report.

Feedback List builds a list of all feedback within a specified scope of documents, and includes information
such as feedback title, user, date, diagram, etc. 

Change Log List builds a list of all diagram change log entries across a specified scope of documents.

Keywords Report builds a list of all the keywords that are associated across a scope of documents.

User Group Associations Report builds a report to show all the user groups that are associated across a
scope of diagrams or documents. 

Subscriptions List builds a list of subscriptions within a specified scope of documents. 

Acknowledgement Log List builds a list of acknowledgement logs for a specified scope of documents.

Acknowledgement Progress builds a list of the acknowledgement statuses for each acknowledger on each
document within a specified scope of documents. This can help to show where any delays exists in the
acknowledgement cycle.

Acknowledgement Requests List builds a list of acknowledgement requests across a scope of documents.

Acknowledgement Summary builds a high-level overview of the acknowledgement progress for a selected
scope of documents.

Access Rights List builds a list to show the default access rights and specific user access rights for all
documents across a specified scope of documents. 

Actions Audit Trail builds an actions audit trail for a specified scope of diagrams.

Review Progress Report builds a report of the current review statuses of documents across a scope of
documents. 

Audit Trail List builds a list of audit trail entries for all documents within a specified scope of documents. 

My Information List builds a report showing all different functions within the scope of documents where your
user account is assigned, e.g. where you are an authorizer, acknowledger, subscriber, author, owner,
reviewer, etc. 

Assigned Users List builds a list of all authorizers, acknowledger, reviewers, subscribers, owners and
authors for a specified scope of diagrams. 

Document Registry Files List builds a list of all documents in the Document Registry.

Document Usage Report builds a list of all maps and diagrams where documents are referenced as
attachments.

Unused Documents List builds a list of all documents that are not referenced by any diagrams.
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Templates provide the means to customize and standardize the look and feel of diagrams for example to
incorporate corporate colors, a logo etc.  They also show attachments and links contained within a diagram in a
single view, instead of the user having to navigate through the process. The ideal time to create a template is at
the beginning of a project, however you can apply a template to an existing diagram.

Templates can be applied to an individual diagram, a scope of diagrams and to an entire process map. Diagrams
can also be protected to prevent them from having a template assigned to them.

Note to Administrators: You can specify a default template to be assigned when new maps are created, see
System Options for more information.

Create a Template
1. From the Map menu choose Templates, then click New.

2. Enter the name of the new template and click OK.

You are now ready to design the template using the Drawing toolbar (from the View menu choose Toolbars
& Panels and select the Diagram Button Bar check box if it is not displayed).

Hint: You should initially define the boundaries of your template by drawing a free text box. To show the

border of the free text box, right-click in the text box and from the Color And Style menu choose Border
Visible. Good practice dictates that the width of the template should be equivalent to the width of your
screen.

Hint: Additionally you can enrich the content of a template by adding menu function links and inserting fields
from within a free text box.

3. To save the template and exit the template designer, choose File and then Close.

Related topics

Edit a Template

Apply a Template

Package a Template

Import a Template

Define Access Rights on a Template
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Page Set Up

Add a Menu Function Link
You can add a link to a template that executes a TIBCO Nimbus menu function. However, it should be noted that
not all of these functions are available in the web server. 

1. From the Map menu choose Templates.

2. Select the template you want to add a Menu Function Link to, and click Edit.

3. Right click from within a free text field, and choose Attachments/Links.

4. Click New and then Menu Function Link.

5. Select a Function Link from the drop-down list, and then click OK.

Menu Function Links available:

Actions, Action Registry
Actions, Diagram Reviewers
Actions, My Actions
Actions, New Action
Actions, Schedule Diagram Review
Diagram, Add Feedback
Diagram, Feedback
Diagram, Input Titles
Diagram, Inputs
Diagram, Linked Statement Links
Diagram, Master and Draft Documents
Diagram, Master Documents
Diagram, Output Titles
Diagram, Outputs
Diagram, Refresh Metric Links
Diagram, Reviewers
Diagram, Send Message To,
Acknowledgers
Diagram, Send Message to, Author
Diagram, Send Message to,
Authorizers
Diagram, Send Message to, Owner
Diagram, Send Message to,
Subscribers
Diagram, Statement Links
Diagram, Subscribe
Diagram, Subscriptions
Diagram, Unsubscribe
Documents, Document Registry
File, Archive Manager
File, Close
File, Close All
File, Exit
File, Print
File, Save
File, Version Manager
Help, About
Help, Administrators
Help, On-line Manual
Help, Registration
Help, Tutorial
Manage, Acknowledge Diagram(s)
Manage, Acknowledgment Log
Manage, Authorization, Authorize
Diagram
Manage, Authorization, Reject Diagram

Manage, Authorization, Report
Manage, Change Log
Manage, Diagram Information
Manage, New Change Request
Manage, View Change Requests
Map, Abbreviations
Map, Backgrounds
Map, Go To Level 1
Map, Go To Level
Map, Next Diagram
Map, Previous Diagram
Map, Previous Diagram List
Map, Properties
Map, References
Map, Refresh Titles
Map, Scenarios, Select
Map, Style Sheets
Map, Templates
Map, Toggle View
Map, Up a Level
Map, Where Am I?
Minimize TIBCO Nimbus
Search, Add Keywords To Diagram
Search, Find
Search, Keyword Search
Search, Keywords Library
Tools, Compare and Update
Tools, Reports
Tools Resources, Resource Library
Tools, Statement Sets
Tools, Users, Change Password
Tools, Users, Preferences
View, Diagram List
View, Feedback List
View, Hierarchical Diagram List
View, Hierarchy Diagram
View, My Information List
View, Object List
View, Subscription List
View, Whole Screen View
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Note: To restrict access to specific users or groups, click the View Rights tab and then click Add  to add

users.

Note: By default, the user or group is granted access to the menu link. To deny them access, double-click
the user or group and select Access Denied. 

6. Click Close to exit the Attachments window.

Related topics

Create a Template

Insert a Field

Edit a Template

Apply a Template

Package a Template

Import a Template

Define Access Rights on a Template

Page Set Up

Insert a Field
Inserting chosen fields into free text boxes on templates will show the information contained within the diagram in
a single view, instead of the user having to navigate through the process.  For example, inserting the <Author>
field will  show the diagram author

Note:  The template will not show duplicates. 

1. From the Map menu choose Templates.

2. Select the template you want to insert a field into, and click Edit.

3. From within a free text box, right-click and choose Edit Text.

4. Click Tools and then Insert Field.

5. From the list select the field that you require.
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      The following fields are available:

<AUTHOR> Diagram author.
<OWNER> Diagram owner.
<AUTHORIZATION> Diagram authorization status.
<AUTH DATE> Date the diagram was authorized.
<DATE> Date the diagram was created.
<TITLE> Diagram title.
<REVIEW DATE> Diagram review date.
<VERSION> Diagram version number.
<PERCENT DONE> Percentage complete.
<STATUS> Status.
<MODIFIED> Date the diagram was last modified.
<MODIFIED BY> User who modified the diagram last.
<MAP TYPE> Map type which could be draft or master.
<USER_FIELD 1> User name 1.
<USER_FIELD 2> User name 2.
<USER_FIELD 3> User name 3.
<YEAR> The current year.
<LEVEL> Diagram level.
<MAP> Name of the map.
<LEVEL_TITLES> Diagram level title.
<AUTHORIZERS LIST> List of authorizers.
<FEEDBACK_COUNT> Feedback count.
<CR_COUNT> Change request count.
<ACTIONS_COUNT> Actions count.
<DOC_COUNT> Number of master documents on the diagram.
<STMTLINK_COUNT> Either a single Statement Link, or a subset of Statement Links from a

Statement Set folder.
<STMLINKED_COUNT> Linked statement links.
<INPUT_COUNT> Number of flow line inputs on a diagram.
<OUTPUT_COUNT> Number of flow line outputs on a diagram.
<DIAINPUT_COUNT> Diagram inputs.
<DIAOUTPUT_COUNT> Diagram outputs.
<DIAG_DESC> Diagram description.
<AUTHORIZERS_GROU
P>

Authorization group/s.

<DOCS_COUNT> Number of draft and master documents on the diagram.
<REVIEWERS_GROUP> Reviewer groups applied to the diagram.

6.    Click OK .

Related topics

Create a Template

Add a Menu Function Link

Edit a Template

Apply a Template

Package a Template

Import a Template

Define Access Rights on a Template

Page Set Up
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Edit a Template
1. From the Map menu choose Templates.

2. Select a template and click Edit.

Note: To rename a template, select a template and click Rename.

3. When you have finished making your edits, from the File menu choose Close to save the template and exit
the template designer.

Related topics

Create a Template

Add a Menu Function Link

Insert a Field

Apply a Template

Package a Template

Import a Template

Define Access Rights on a Template

Page Set Up

Apply a Template
1. Open the map you wish to apply a template to, and from the Map menu choose Templates. 

2. Select a template and click Apply.

3. Choose the scope that you want to apply the template to, and click OK.

Note: You can prevent a diagram from having a template applied to it by clicking Mark as None when in the
Templates dialog of a particular diagram. To allow a template to be applied to the diagram, choose Clear
Template.

Related topics

Create a Template

Add a Menu Function Link

Insert a Field

Edit a Template

Package a Template

Import a Template

Define Access Rights on a Template

Page Set Up
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Package a Template
Package a template to share with colleagues or you can transfer it to another process repository.

1. From the Map menu choose Templates.

2. Select a template, and from the File menu choose Package.

3. Select the location to save the template to, and click OK.

4. Choose one of the following options by stating the intended use for the template, then click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Send to TIBCO Nimbus for support purposes should be selected if you intend to send the content to
TIBCO Nimbus Support. All personal information will be maintained but will be removed from the content
by TIBCO once the requirements have been met.

· Send to an external company or organization should be selected if you intend to send the content
to an external company. All personal information will be removed from the content.

· Unknown should be selected if you are unsure how the content will be used. All personal information
will be removed from the content

5.    C lick Next to see where the packaged file is located, or Close to exit the Packages Created window.  

Related topics

Create a Template

Add a Menu Function Link

Insert a Field

Edit a Template

Apply a Template

Import a Template

Define Access Rights on a Template

Page Set Up

Import a Template
1. From the Map menu choose Templates.

2. From the File menu choose Unload Package, locate the template file (.tpk) and click Open.

3.    Choose one of the following options and click Yes:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Received from TIBCO Nimbus for support purposes should be selected if the content was
originally sent from your company and received back from Nimbus®. All personal information will be
maintained. Do not select this option if you are not certain of the origin of the content.

· Received from an external company or organization should be selected if the content has been
received from an external company or organization. All personal information will be removed from the
content.

· Unknown should be selected if the source of the content is unknown. All personal information will be
removed from the content.
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Related topics

Create a Template

Add a Menu Function Link

Insert a Field

Edit a Template

Apply a Template

Package a Template

Define Access Rights on a Template

Page Set Up

Define Access Rights on a Template
Access rights can be defined for templates to govern who can view, edit and apply a specific template.

1. With the template open, from the Manage menu choose Template Access Rights.

2. Select the default access rights for all users.

Read and write allows users to view, edit and apply the template.

Read only allows users to view and apply the template.

Access Denied prevents users from viewing, editing and applying the template.

3. If required, add access rights for specific users and/or user groups by clicking Add . For more information
on adding specific users or Groups see select a user or user group.

Related topics

Create a Template

Add a Menu Function Link

Insert a Field

Edit a Template

Apply a Template

Package a Template

Import a Template

Page Set Up
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Page Set Up
Template page setup options can be defined, including page scaling, orientation, print margins and header and
footer font sizes, and will define how diagrams are printed. Template page setup options can be overridden when
printing a diagram or scope of diagrams.

1. With the template open, from the File menu choose Page Setup.

2. In the Print Scaling tab you can choose how to scale the diagrams.

Always scale diagram to fit page will scale diagrams up or down to fit the page.

Scale diagram to fit, only when larger than page will only scale down diagrams that are too large
for the page. Diagrams that are smaller than the page will not be scaled up.

Scale diagram to fit user defined area allows you to define a printable area. If this option is selected
then resizing handles will be present when you exit Page Setup for all diagrams within the specified scope
that are too large to fit on the page. You can also enter specific dimensions for the print area by clicking 
Adjust Manually.

Note: The Scale diagram to fit user defined area option is pixel based and not true page size. TIBCO
Nimbus will compress or expand the diagram to fit the standard page size of the printer that it is being sent
to. A4/A3, for example, is determined by your printer and what you see on the screen is literally what you
get when the page is printed.

3. Click the Orientation and Size tab to change the print orientation, margins and header and footer font sizes.

Note: The print margins define the distance from each edge of the printable area (the printable area is
between the bottom of the title area at the top and the document control panel at the bottom). The Header
And Footer panel allows you to change the font point sizes of the control panel and title.

Related topics

Create a Template

Add a Menu Function Link

Insert a Field

Edit a Template

Apply a Template

Package a Template

Import a Template

Define Access Rights on a Template
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About storyboards
Storyboards provide a means of guiding users through series of activities that constitute end-to-end processes.

Storyboards are useful for:

· System implementation support testing

· Training aids

· Highlighting process changes

· Highlighting relevant areas to users within a large process.

For information on managing storyboards, such as authorizing, promoting, 

Storyboard Roles

Assign a storyboard manager
The role of a storyboard manager allows users to create, delete and modify storyboards. Note that storyboard
managers can only view storyboards that they have access to. Administrators are storyboard managers by default.

1. From the Tools menu choose Users and then User Accounts.

2. Double-click the user.

3. In the Settings tab select the Storyboard Manager check box.

Related topics

About storyboards

Creating Storyboards

Create a storyboard folder
Storyboard folders can be created and used to organize storyboards. Storyboards can be dragged and dropped
into folders. Note: Only administrators and storyboard managers can create storyboard folders.

1. From the Tools menu choose Storyboards.

2. From the Edit menu choose Create Folder.

3. In the Folder Name box enter the name of the folder.

Hide folder in Web Server tree view will hide the folder, all sub-folders and all storyboards within these
folders in the web server. This is useful for training storyboards.

Folder Access

This tab allows you to define the default user access rights and specific user and user group rights of a

storyboard folder. To add a specific user or user group click . Once assigned, double-click the user or
user group to change the access rights if necessary.

Read and write allows users to view and edit a storyboard folder.

Read only allows users to view but not edit a storyboard folder.

Access Denied prevents users from viewing and editing a storyboard folder.

Related topics
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About storyboards

Creating storyboards

Storyboard preferences

Record a storyboard
Storyboards provide a means of guiding users through series of activities that constitute end-to-end processes. 
Note: Only administrators and storyboard managers can create storyboards.

1. From the Tools menu choose Storyboards.

2. From the Edit menu choose New.

Note: If you want to create a storyboard in a folder then ensure you select the folder first.

The Storyboard Properties window opens.

3. Define the storyboard through the following tabs:

Properties

Title is the name of the storyboard. You can define the title in different languages if additional language

variants have been configured in the system. Click Edit Language Variants  to open the Language
Variants window and then enter the title for the desired language in the Text field.

Available for offline players will allow users to download the storyboard to a mobile device for offline
viewing. 

Notify primary contact when integrity of storyboard is broken will email the primary contact
assigned to the storyboard if a user deletes an activity or diagram that is referenced by the storyboard.
See Defining a Primary Email Contact for more information.

Expiry Period is the number of weeks that the storyboard is available for download. After this time the
storyboard will expire. Users will be required to download the storyboard again once it has expired. To
disable the expiry period, enter 0 as the value.

Common Details
Owner is the user that is responsible for maintaining the storyboard. This will default to you. To

change the owner click Select User .
Author is the author of the storyboard. This will default to you. To change the author click Select

User .
Acknowledgement text allows you to modify the default text that is sent to users when the

storyboard is sent out for acknowledgement. Click Edit acknowledgement text  to modify the
text.

Change Log

Any change to the owner of a storyboard will be automatically logged in the change log. If you want to add a
change log, for example if a step has been added or removed, click Add and enter the details.

Cover Image

Change the storyboard cover image that appears in users' mobile players.

4. Click OK.

The Storyboard Edit window opens. 

5. From the Action menu choose Record, or click .

You are now in record mode.

Note: You can hide the list of steps when recording a storyboard. From the View menu choose Hide List
When Recording.

6. Click each activity that you want to appear in the storyboard. 
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Each activity will be sequentially recorded, i.e. the first activity you select will be step number 1 and so on.

You can navigate to other diagrams in the current map or to diagrams in other maps within the current
process repository.

7. When you have finished recording the storyboard, from the Action menu choose Stop, or click Stop .

Assigning Access Rights

Access rights govern which users can view the storyboard. To define access rights see Defining access rights
on storyboards.

Editing Storyboards

After creating a storyboard you can add step commentary text, define key steps and reorder steps. See 
Editing storyboards for more information.

Related topics

About storyboards

About My Searches

Editing storyboards

Storyboard preferences

Redirecting storyboard steps

Linking a storyboard to an object

Linking two storyboards

Performing an integrity check

Assigning roles to storyboards

Importing and exporting storyboards

Assigning Primary Email Contacts

Create a storyboard from a report
New storyboards can be created from existing storyboards through the Storyboard Dependency report. Any
column sorting or filtering in the report will be reflected in the generated report, i.e. the order of steps will be
reflected in the new storyboard and any rows that have been filtered out will not appear in the storyboard.

1. From the Tools menu choose Storyboards.

2. Select the storyboard(s) or storyboard folder that you want to create a new storyboard from.

Note: If you are creating a storyboard from all storyboards, or a storyboard scope list file, then you do not
need to select any storyboards.

3. From the Tools menu choose Storyboard Dependency.

4. Choose the scope of storyboards that you want to create a new storyboard from, and then click OK.

The Storyboard Dependency report will be generated from the selected scope of storyboards.

5. In the report, from the Tools menu choose Generate Storyboard.

6. Select a folder (if required) to create the storyboard in, and then click OK.

Note: You can create a new folder if required. From the Edit menu choose Create Folder.

7. Define the storyboard properties and add a cover image (if required), and the click OK.

Related topics

About storyboards

Editing storyboards

Storyboard preferences
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Redirecting storyboard steps

Linking two storyboards

Performing an integrity check

Assigning roles to storyboards

Assigning Primary Email Contacts

Edit a storyboard
Storyboards can be edited, for example to add, remove or reorder steps, add step commentary, define key
steps, etc. Note: Users must have the correct access rights in order to edit a particular storyboard.

To access the storyboard edit dialog:

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the Edit menu choose Edit.

To add step commentary text:

Step commentary text provide context to a step in order to assist users in completing an activity.

1. Right-click the step and choose Step Commentary Text.

2. Select one of the following options:

Use activity commentary text as step commentary displays the commentary text from the
activity.

Reuse existing step commentary already defined on the activity allows you to use the
commentary text from any step that references the same activity, either in the same storyboard or in
another storyboard. Select a storyboard step from the drop-down list.

Override activity commentary text and enter custom step commentary allows you to define
and display custom step commentary text. Click in the text box below this option and enter the
commentary text. If additional languages have been configured in the system you can also define
commentary text for multiple languages (the text that is displayed to users will be dependent upon their
chosen language).

To define commentary text for multiple languages:

1. From the Language drop-down list choose a language.

2. Click in the bottom text box and enter the commentary text for the selected language.

Note: Repeat this process for all languages that you want to define. Choosing a new language
will save the previous commentary text for the last language.

3. Click OK .

Note: To spell check, from the Tool menu choose Check Spelling.

To define key steps:

Indicating that a step is a key step will highlight the step when users play the storyboard in the web server.

1. Right-click the step and choose Key Step.

To create a storyboard branch:

You can create branch points within a storyboard that point to other storyboards. This is useful if you want to
provide users with options when following a storyboard depending on the situation. Multiple branches can also be
added to a single storyboard step.

1. Click the step in the storyboard that you want to create a branch point at.

Note: You can create the same branch for multiple steps in one operation by holding Ctrl to select the steps.

2. Click Add a storyboard branch .

3. Click Select and choose the storyboard that you want to create a branch to.

4. Select which version (master or draft) of the storyboard you want to branch to.

5. Choose to use either the existing storyboard title for the branch or a Custom title.
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Note: You can define the branch title in multiple languages using the Custom option by clicking Edit

Language Variants .

6. Click OK.

Editing Storyboard Branches

Storyboard branches can be edited by right-clicking on them and choosing Edit.

Deleting Storyboard Branches

Storyboard branches can be deleted by selecting the branch and pressing Delete.

To reorder steps:

Steps can be reordered in a storyboard.

1. Select a step and from the Edit menu choose Move Up or Move Down.

To add a change log:

When making edits to a storyboard, change logs can be manually added for audit purposes.

1. From the Tools menu choose Storyboards.

2. Right-click the storyboard and choose Properties.

3. Click the Change Log tab to access it.

4. Click Add.

Related topics

About storyboards

Storyboard Preferences

Copying storyboards

Deleting storyboards

Storyboard preferences
Storyboard viewing preferences can be set to define how the storyboard appears when it is played.

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the File menu choose Preferences.

Options

Interval is the pause, in seconds, between each step when the storyboard is played.

Always reset notes for each step will only display the notes window for steps that have associated
notes. If this option is not selected then the notes window will remain visible for all steps, even if they do
not have associated steps.

Include diagram steps when recording will include all navigation steps in the recording of a
storyboard, for example steps that relate to accessing a lower level. If this option is not selected then only
steps involving activities will be included.

Colors

The colors tab allows you to change the playback and step commentary colors. Click Select color  for
each respective option that you want to modify.

Related topics

About storyboards

Creating storyboards
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Creating storyboard folders

Add a change log
When making edits to a storyboard, change logs can be manually added for audit purposes.

1. From the Tools menu choose Storyboards.

2. Right-click the storyboard and choose Properties.

3. Click the Change Log tab to access it.

4. Click Add.

Defining Storyboad Access Rights

Define access rights on storyboards
User access rights can be defined on both the draft and master versions of a storyboard.

More info on Access Rights...

To modify user access rights on storyboards:

1. From the Tools menu choose Storyboards.

2. Select the storyboard or storyboard folder and choose one of the following options:

· Manage>Manage Draft Storyboard>Draft Access Rights

· Manage>Manage Master Storyboard>Master Access Rights

Note: You can select multiple storyboards to assign access to by holding Ctrl.

3. Select the Default Access Rights.

Read and write allows users to view and edit a storyboard.
Read only allows users to view but not edit a storyboard.
Access Denied prevents users from viewing and editing a storyboard.

4. If required, add access rights for specific users and/or user groups by clicking Add . For more information
on adding specific users, see select a user or user group.

5. In the Scope panel, select the scope of storyboards to apply the access rights to.

Selected Storyboards will apply the access rights to any storyboards that you have selected.
All Storyboards will apply the access rights to all storyboards.
Current Folder will apply the access rights to all storyboards in a selected folder.
Current Folder and Child Folders will apply the access rights to all storyboards in a folder and all
child folders.
Storyboard Scope List will apply the access rights to all storyboards within a selected storyboard
scope list file.

6. Click OK.

Managing Storyboards

About storyboard management
Storyboards are managed and controlled in the same way as process maps and diagrams.

Draft Storyboards

Draft storyboards are directly linked to the activities and diagrams in live process maps (these can be either draft
or master diagrams). If changes are made to the live diagrams then these will be updated in related draft
storyboards until authorization is requested, at which point the first snapshot is taken.

Master Storyboards
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Master storyboards are 'locked down' and any changes to corresponding diagrams will not be reflected in a master
storyboard until the storyboard is promoted again.

Publishing Storyboards

There are two ways to publish a storyboard, either manually or through an authorization cycle. When a storyboard
is published, a 'locked down' snapshot of the storyboard is created. This snapshot includes copies of all of the data,
such as diagrams, data table attachments, document attachments, etc.

Storyboards in the Web

Only published storyboards can be viewed in the web. Both draft and master storyboard versions are viewable if
available and the user has sufficient access rights to view both copies.

Mobile Storyboard Players

When a new snapshot is created, it will be automatically made available to download in the Nimbus players too (for
all of the supported languages and devices). During the publishing process, the existing draft snapshot and existing
Nimbus player packages are deleted and replaced with the new snapshots. Note that a storyboard will only be
available to download in a mobile device if the Available for offline viewers option is selected in the properties
of the storyboard. Only master storyboards are available for download.

Migrating Storyboards

When migrating data from a previous major version (prior to v9.3), draft snapshots will be created for all existing
storyboards. This means that the storyboards will still be accessible as they were in the previous version.  Any
storyboards previously published for the Nimbus Players will still be available to download on mobile devices.

Data Table Attachments

There are two options in data table attachments that relate to storyboards. You can either maintain live links of a
data table attachment. In this option, any updates to an associated data table will be reflected in the storyboard.
The alternative option is to store a static copy of the data table attachment, in which case a copy of the data table
is made accessible and any updates to the data table will not be reflected in the storyboard. See Creating data
tables for more information.

Statement Links

Statement links in storyboard snapshots are live links, meaning copies of statement links are not stored and
therefore any changes to associated statements will be reflected in the storyboard.

Primary Email Contacts

Define a Primary Email Contact

Primary Email Contacts are notified when draft storyboards are unlocked. Primary Email Contacts can be set to
either the owner or author of a storyboard.

1. In the Storyboard Management window (Tools > Storyboards), select the storyboard that you want to
assign a Primary Email Contact to.

Note: You can assign a Primary Email Contact to multiple storyboards in one operation by holding Ctrl to
select storyboards. Note that this will replace the existing Primary Email Contact on the selected storyboards.
Alternatively, you can assign a Primary Email Contact to all storyboards within a specific folder by selecting
the folder.

2. From the Manage menu choose Primary Email Contact.

3. In the Primary Email Contact panel, select either Owner or Author as the Primary Email Contact.

4. In the Scope panel, choose the scope of storyboards to assign the Primary Email Contact to from the
following options:

Selected Storyboards will assign the contact for all selected storyboards..
All Storyboards will assign the contact to all storyboards.
Current Folder will assign the contact to all storyboards in a selected folder.
Current Folder and Child Folders will assign the contact to all storyboards in a folder and all child
folders.
Storyboard Scope List will assign the contact to all storyboards within a selected storyboard scope list
file.

5. Click OK.
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Authorizing Storyboards

Assign authorizers

Users must be assigned to storyboards in order to authorize them. All authorizers must authorize a storyboard
before it can be promoted and released to users.

Note: Users that are assigned as authorizers must have at least Read access to the draft storyboards.

1. In the Storyboard Management window (Tools>Storyboards), select the storyboard.

Note: You can assign the same set of authorizers to multiple storyboards in one operation by holding Ctrl
when selecting storyboards. Note that this will replace any existing authorizers on the selected storyboards.
Alternatively, you can assign authorizers to all storyboards within a specific folder by selecting the folder.

2. From the Manage menu choose Authorization and then Authorizers.

3. Choose the scope of storyboards to assign authorizers to.

Selected Storyboards will assign authorizers to all selected storyboards..
All Storyboards will assign authorizers to all storyboards.
Current Folder will assign authorizers to all storyboards in a selected folder.
Current Folder and Child Folders will assign authorizers to all storyboards in a folder and all child
folders.
Storyboard Scope List will assign authorizers to all storyboards within a selected storyboard scope list
file.

4. Click User to add users and/or user groups or Resource to add resources.

5. Click OK.

Sequence of authorizers

You can change the sequence of authorizers once they're assigned. For example, you may want one group to
authorize the storyboard first before sending it to the next group. The requests will be sent by sequence
number, so all users assigned as sequence 1 will be requested to authorize the storyboard first. Once those
users have authorized it, the request will be sent to the next set of users.

To change the sequence number of an existing authorizer, double-click the user, user group or resource.

Removing authorizers

Select the user, user group or resource and click Remove .

Related topics

About storyboard management

Requesting authorization

Promoting storyboards

Storyboard scope lists

Request authorization

Users must be assigned to storyboards in order to authorize them. All authorizers must authorize a storyboard
before it can be promoted and released to users.

Note: Users that are assigned as authorizers must have at least Read access to the draft storyboards.

1. In the Storyboard Management window (Tools>Storyboards), click the storyboard to select it.
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Note: You can request authorization for multiple storyboards in one operation by holding Ctrl when selecting
storyboards. Alternatively, you can assign draft promoters to all storyboards within a specific folder by
selecting the folder.

2. From the Manage menu choose Authorization and then Request.

3. From the Date to be authorized date picker, choose the date for the storyboard(s) to be authorized by.

4. Choose the scope of storyboards to request authorization for.

Selected Storyboards will request authorization for all selected storyboards..
All Storyboards will request authorization for all storyboards.
Current Folder will request authorization for all storyboards in a selected folder.
Current Folder and Child Folders will request authorization for all storyboards in a folder and all child
folders.
Storyboard Scope List will request authorization for all storyboards within a selected storyboard scope
list file.

5. In the Additional Notes field, enter any additional notes to support the request. These notes will be sent to the
authorizers.

6. Click Next.

Reminders and escalation options

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options. If
you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

7. Specify any of the following options (if available):

Enable email reminders will send reminder emails to assigned authorizers until they have signed the
storyboard off.

Enable SMS reminders will send reminder SMS messages to assigned authorizers until they have
signed the storyboard off.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

8. Click OK.

Related topics

About storyboard management

Assign authorizers

Promoting storyboards

Storyboard scope lists

View authorization progress

An authorization report for a storyboard will report on the status of authorizers for an authorization request, i.e.
who has and who hasn't authorized a storyboard.

1. In the Storyboard Management window (Tools>Storyboards), click the storyboard to select it.

Note: You can request authorization for multiple storyboards in one operation by holding Ctrl to select
multiple storyboards.

2. From the Manage menu choose Authorization and then Authorization Report.
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Promoting Storyboards

Assign draft promoters

Draft promoters for a storyboard are responsible for promoting the storyboard following its authorization. Only one
draft promoter is required to promote a given storyboard.

1. In the Storyboard Management window (Tools>Storyboards), click the storyboard to select it.

Note: You can select multiple storyboards to assign draft promoters to by holding Ctrl. Alternatively, you
can assign draft promoters to all storyboards within a specific folder by selecting the folder.

2. From the Manage menu choose Authorization and then Draft Promoters.

3. Choose the scope of storyboards to assign draft promoters to.

Selected Storyboards will assign the draft promoters for all selected storyboards..
All Storyboards will assign the draft promoters to all storyboards.
Current Folder will assign draft promoters to all storyboards in a selected folder.
Current Folder and Child Folders will request authorization for all storyboards in a folder and all child
folders.
Storyboard Scope List will request authorization for all storyboards within a selected storyboard scope
list file.

4. Click User to add a user or user group.

5. After adding users, click OK.

Related topics

About storyboard management

Assigning authorizers

Requesting authorization

Promoting storyboards

Storyboard scope lists

Promote a storyboard

Once a draft storyboard has been authorized by all assigned authorizers it can be promoted to a master version.

1. In the Storyboard Management window (Tools>Storyboards), click the storyboard to select it.

2. From the Manage menu choose Authorization and then Promote Draft Copy.

Related topics

About storyboard management

Assigning authorizers

Requesting authorization

Assign draft promoters

Publishing storyboards

Storyboard scope lists
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Publishing Storyboards

Publish a draft storyboard to the web

To allow users to view a draft version of a storyboard in the web interface, it must be published. Note that only
storyboards with an authorization status of 'Update Pending' can be published.

1. In the Storyboard Management window (Tools>Storyboards), select the storyboards or folder that you
want to publish.

Note: Hold Ctrl to select multiple storyboards to publish. To publish all storyboards then you only need to
select one storyboard. If you want to publish all storyboards in a folder then select the folder.

2. From the File menu choose Publish for Web Server.

3. Select the scope of storyboards to publish.

Selected Storyboards will publish all selected storyboards.
All Storyboards will publish all storyboards.
Current Folder will publish all storyboards in a selected folder.
Current Folder and Child Folders will publish all storyboards in a folder and all child folders.
Storyboard Scope List will publish all storyboards within a selected storyboard scope list file.

4. Click OK.

Publish a storyboard to mobile players

To make a storyboard available for download to an offline mobile player, an option must be selected for the
storyboard in the properties of the storyboard.

Note: Only storyboards that have been authorized and promoted to master versions and then published will be
available to download.

1. In the Storyboard Management window (Tools>Storyboards), right-click the storyboard that you want to
publish and choose Properties.

2. In the Common Details panel, select Available for offline players.

3. Click OK.

Updating Storyboards

Update a storyboard

To update a master version of a storyboard you must unlock the draft to make any changes to the storyboard.
After you have edited the storyboard, it must undergo another authorization cycle and then be promoted to replace
the current published version.

1. In the Storyboard Management window (Tools>Storyboards), click the storyboard to select it.

Note: You can select multiple storyboards to unlock by holding Ctrl. Alternatively, you can unlock all
storyboards within a specific folder by selecting the folder.

2. From the Manage menu, choose Authorization and then Unlock Draft.

3. Enter your password and the reason for unlocking the draft.

4. Choose the scope of storyboards to unlock.

Selected Storyboards will unlock all selected storyboards.
All Storyboards will unlock all storyboards.
Current Folder will unlock all storyboards in a selected folder.
Current Folder and Child Folders will unlock all storyboards in a folder and all child folders.
Storyboard Scope List will unlock all storyboards within a selected storyboard scope list file.
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5. Click OK.

You can now edit the draft version of the storyboard.

Related topics

About storyboard management

Requesting authorization

Promoting storyboards

Creating Actions

Create an action

Actions can be created for storyboards. For information on actions please refer to the Action Management section.

1. In the Action Registry window (Actions>Action Registry), click New  and choose Storyboard Action,
and then click Next.

2. Click Select and select a storyboard or a storyboard folder.

Note: Hold Ctrl to select multiple storyboards.

3. Choose the scope of storyboards to create an action for and click Next.

Selected Storyboards will create the action for all selected storyboards..
Current Storyboard Folder will create the action for all storyboards in a selected folder.
Current Storyboard Folder and Child Folders will create the action for all storyboards in a folder
and all child folders.
Storyboard Scope List File will create the action for all storyboards within a selected storyboard
scope list file.

4. In the Properties step, define the properties of the action, and then click Next.

5. In the Assignees step, click Add to add users to undertake the action, and then click Next.

Only Require 1 assignee to complete action will require only one of the assigned users to complete
the action before it can be closed.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.

6. In the Editors step, click Add to add users that can edit the action, and then click Next.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.

7. In the Viewers step, click Add to add users that can view the action, and then click Next.

Note: When you're assigning users, you can assign the owner and author by clicking Dynamic.

8. In the Description step, add any information about the action, such as the reason for requiring the action,
and then click Next.

9. In the Owner Category Data step, provide additional information based on the fields available (note that this
step may not be available).

10. In the Additional Data window, provide additional information based on the fields available (note that this
step may not be available).

11. In the Attachments window, add any attachments for additional support. Attachments can be file links,
application links, email links, SAP transaction links, document links, storyboard links and URL links. 

Click New  to add an attachment. To modify the access rights for a particular action, select the attachment

and click Set View Rights .

Reminders and Escalation

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue action. An
escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.



Storyboards

TIBCO Nimbus® User GuidePage 299

12. In the Reminders and Escalation step, set the relevant reminder and escalation options.

Enable email reminders will send reminder emails to users until they have completed the action.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
completed the action.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

13. Click Finish.

Storyboard Change Logs

View a storyboard change log

The change log for a storyboard lists the current changes made to a storyboard. You can add, edit and delete
existing change logs.

1. In the Storyboard Management window (Tools>Storyboards), select the storyboard that you want to view
the storyboard change log for.

2. From the Manage menu choose Storyboard Change Log.

Collaborating on Storyboards

Requesting Acknowledgement

Assign acknowledgers

Acknowledgers are users that are assigned to storyboards in order to request their acknowledgement of a
storyboard in the Web Server.

Note: When creating a new storyboard, the storyboard must first be saved before acknowledgers can be
assigned. If one or more users do not have access to any of the storyboards that you are assigning them to then
you will not be able to proceed. A dialog will list which users do not have access to which storyboards; you can
either remove them from the list of acknowledgers, or seek to provide access for these users.

1. From the Tools menu choose Storyboards.

2. Select the storyboard(s) that you want to assign acknowledgers to.

Hint: Hold Ctrl to select multiple storyboards.

3. From the Manage menu choose one of the following options:

Manage Draft Storyboard>Draft Acknowledgers

Manage Master Storyboard>Master Acknowledgers

4. Select the scope of storyboards to assign acknowledgers to.

Selected Storyboards will assign acknowledgers to any storyboards that you have selected.
All Storyboards will assign acknowledgers to all storyboards.
Current Folder will assign acknowledgers to all storyboards in a selected folder.
Current Folder and Child Folders will assign acknowledgers to all storyboards in a folder and all child
folders.
Storyboard Scope List will assign acknowledgers to all storyboards within a selected storyboard scope
list file.



Storyboards

TIBCO Nimbus® User Guide Page 300

5. Click User or Resource to add users, user groups or resources.

6. Search for and add the required users, user groups and/or resources.

7. Click OK.

To remove acknowledgers:

Click the user(s) or user group(s) to select them and click Remove.

Resending Acknowledgement Requests to New Acknowledgers
If an acknowledgement request has been sent out for a scope of storyboards and new acknowledgers are
assigned, you can resend the acknowledgement request to these new users. See Requesting acknowledgement
for further information.

Related topics

About managing storyboards

Editing the acknowledgement sign-off text

Requesting acknowledgement

Edit the acknowledgement sign-off text

The acknowledgement sign-off request text can be modified for specific storyboards, i.e. the text that is displayed
to users when they are prompted to acknowledge a storyboard.

1. From the Tools menu choose Storyboards.

2. Right-click the storyboard and choose Properties.

3. In the Common Details panel click Edit acknowledgement text .

4. Make any edits to the text, then click OK .

5. Click OK.

Related topics

About managing storyboards

Assign acknowledgers (acknowledgers)

Request acknowledgement

Users can be requested to acknowledge either draft or master storyboards. An acknowledgement request will
appear in their To-dos and they will be notified by email.

Note: To request acknowledgement for a particular storyboard at least one acknowledger must be assigned. If
one or more users do not have access to any of the storyboards that you are requesting acknowledgement for
then you will not be able to proceed. A dialog will list which users do not have access to which storyboards; you
can either remove them from the list of acknowledgers or seek to provide access for these users.

Reporting
A number of acknowledgement-based reports are available from the Tools menu in the Storyboard Management
window.

Acknowledgement Log Report displays a list of users that have acknowledged a scope of storyboards.

Acknowledgement Progress Report displays the acknowledgement progress for a scope of storyboards.

Acknowledgement Requests Report displays a list of acknowledgement requests for a scope of
storyboards, including status and the percentage complete.

Acknowledgement Summary Report displays a high-level overview of the acknowledgement progress for
a selected scope of storyboards. Double-click a row to view the Acknowledgement Progress Report for a
specific storyboard.
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1. In the Storyboard Management window, select the storyboards that you want to request acknowledgement
for.

2. From the Manage menu choose one of the following options:

Manage Draft Storyboard>Request Draft Acknowledgement

Manage Master Storyboard>Request Master Acknowledgement
 
3. In the Acknowledgement Type panel choose the type of acknowledgement that you want to create.

Standard allows you to create a single acknowledgement request for a scope of storyboards that must
be completed by a specific date. Once all acknowledgers have acknowledged then the status of  the
request will be set to Complete. Note that if new acknowledgers are added at a later date then they will
be assigned the same date, which may lead to past due (overdue) requests being assigned to newly
assigned users.

Continuous allows you to create an open acknowledgement request for a scope of storyboards which is
open indefinitely. When a new acknowledgement request is sent out, new acknowledgers will be
assigned a due date in advance of the date the new request is sent, thereby ensuring that they do not
receive past due (overdue) requests.

4. Select either the Date to be acknowledged by or the Acknowledgement request due dates to
(depending on what you selected in the previous step).

Note: The Acknowledgement request due dates to setting (for continuous acknowledgement
requests) will automatically create due dates from the date a new acknowledger is assigned. For
example, if you set 2 weeks as the value and a new acknowledger is added on the 1st January, then the
due date for that user to acknowledge the content by will be the 15th January.

5. Choose the scope of storyboards to request acknowledgement for.

Selected Storyboards will request acknowledgement for any storyboards that you have selected.
All Storyboards will request acknowledgement for all storyboards.
Current Folder will request acknowledgement for all storyboards in a selected folder.
Current Folder and Child Folders will request acknowledgement for all storyboards in a folder and all
child folders.
Storyboard Scope List will request acknowledgement for all storyboards within a selected storyboard
scope list file.

6. Enter any additional notes that may be useful for a user when acknowledging the content.

7. Click Next to define the reminder and escalation options.

Reminders and escalation options

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue To-do item.
An escalation date can also be set which will send an email notification to users' line managers if they fail to
action a particular To-do item. Default notification and escalation options are defined in the system options.
If you have the privileges to do so, you can modify these settings for individual actions requests before
submitting them.

Enable email reminders will send reminder emails to assigned acknowledgers until they have signed
the storyboard(s) off.

Enable SMS reminders will send reminder SMS messages to assigned acknowledgers until they have
signed the storyboard(s) off.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

8. Click OK to finish.

Resending Acknowledgement Requests to New Acknowledgers
If an acknowledgement request has already been submitted for a selected scope of storyboards and new
acknowledgers are assigned, you can resend the acknowledgement request to these new users. 

1. In the Storyboard Management window (Tools>Storyboards), from the Manage menu choose one of the
following options:
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Manage Draft Storyboard>Draft Acknowledgers

Manage Master Storyboard>Master Acknowledgers

2. In the Scope panel, choose the scope of storyboards to resend acknowledgement requests for.
3. Select the new users in the list (hold Ctrl to select multiple users).
4. Right-click a selected user and choose Send Current Request.
5. In the Data to be acknowledged by field, choose a date for when you want the storyboard to be

acknowledged by.
6. In the Required users section, select/deselect the users that you want to resubmit the acknowledgement

request for and click Next.
7. Select the appropriate reminder and escalation details and click OK.

See Assigning acknowledgers for further information.

Resending Acknowledgement Requests to New Group Members
When users join a new user group, you can resend previous acknowledgement requests for storyboards that
relate to the group. This ensures that users are made aware of any new processes, documents and storyboards
that relate to their new roles. 

 This option is only available to TIBCO Nimbus administrators.

Note: If the user has joined a group that is a member of other groups, i.e. the group is a sub-group of one or
more parent groups, they will also receive any acknowledgement requests that exist for associated parent
groups. 

1. In the User Accounts window (Tools>Users>User Accounts), right-click the user and choose Send
Acknowledgements.

2. Select user groups for that the selected user that you want to send current acknowledgement requests for,
i.e. select the group(s) that the user has recently joined, and then click Next.

Automatically reactivate completed acknowledgements will reactivate the last completed
acknowledgement requests, i.e. set them to 'active' and send them to the user. If this option is not
selected then only active requests will be sent to the user.

3. Define the reminder and escalation details and click OK.

Related topics

Assigning acknowledgers

Acknowledge a file

View the acknowledgement log

Cancel and complete acknowledgement requests

Canceling and completing acknowledgement requests can achieved through the Collaboration Console.

View acknowledgement logs

Whenever an assigned acknowledger acknowledges a storyboard it is recorded in an acknowledgement log. You
can view the acknowledgement log for both draft and master storyboards.

1. From the Tools menu choose Storyboards.

2. Select the storyboard that you want to view the acknowledgement for.

3. From the Manage menu choose one of the following options:

Manage Draft Storyboard>Draft Acknowledgement Log

Manage Master Storyboard>Master Acknowledgment Log
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Linking Storyboards

Link a storyboard to an object
You can link an object to a storyboard so that when a user accesses the link the storyboard will run. You can also
specify a storyboard step for the storyboard to start at.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Storyboard Link.

3. Click Select to choose the storyboard to link to.

4. From the Step drop-down list choose a storyboard step to begin at.

Note: This step is optional. You can also click Select to view more details and select storyboard steps.

5. Enter a title for the storyboard link.

User Viewing Rights

You can define who has access to the storyboard link. Click the View Rights tab. Define the default user

access rights. To add specific users or user groups click Add  and then select a user or user group.

Related topics

About storyboards

Linking two storyboards

Associating keywords

Creating storyboards

Link two storyboards
Storyboards can be incorporated into other storyboards and this operation will copy all steps from one storyboard
to another.

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the Edit menu choose Edit.

3. Right-click the step at the point where you want to import the storyboard steps into and choose Insert
Storyboard Link.

4. Select the storyboard that you want to insert and click OK.

Related topics

About storyboards

Linking a storyboard to an object

Associating keywords
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Assigning Roles to Storyboards

Assign a role to a storyboard
Roles can be associated with storyboards. This will allow users to search for storyboards related to specific roles
in the web server.

1. From the Tools menu choose Storyboards.

2. Right-click the storyboard and choose Properties.

3. Click Roles.

4. In the Select Roles dialog find the resource that you want to add.

Note: You can enter the resource name directly if you know it. You can also filter the search to the Central
Resource Library or to a specific local resource library. If you want to retrieve all resources within the
Process Repository then ensure the <ALL CENTRAL> group is selected and click Find.

5. Select a role and click Add Resources To List .

Note: Select multiple roles by holding Ctrl.

6. Click OK.

To remove roles from storyboards:

Select the role from the list of associated roles (on the right) and click Remove Resources From List .

Related topics

About storyboards

About roles

Associating Keywords

Associate keywords
Keywords allow users to search for storyboards in the web server that are associated with specific keywords.

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the Edit menu choose Edit.

3. From the Search menu choose Add Keywords to Storyboard.

4. Select the keyword and click Add Keyword .

Note: Select multiple keywords by holding Ctrl.

To remove keywords:

Select the associated keywords from the right-hand pane and click Remove Keyword .
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Related topics

About storyboards

My Searches

Assigning roles to storyboards

Copying keywords

Playing Storyboards

Play a storyboard
Storyboards can be played back in the client. There are two playback modes - manual and automatic. Manual
playback requires a user to manually step through the storyboard. Automatic playback will automatically proceed
to the next step after a specified time interval.

To automatically play a storyboard:

1. From the Tools menu choose Storyboards.

2. Double-click the storyboard to open it.

3. Click Play.

To manually play a storyboard:

1. From the Tools menu choose Storyboards.

2. Double-click the storyboard to open it.

3. Click Play next step to step through the storyboard.

Note: To hide the list of steps when playing a storyboard, from the View menu choose Hide List When
Playing.

Related topics

About storyboards

Displaying swimlane views
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Displaying Swimlane Views

Display a swimlane view
Swimlanes provide a graphical representation of a storyboard, either in the context of workflow responsibilities,
i.e. assigned resources, or by selected highlight rules. Each resource or highlight rule will be presented in a
separate 'lane'. Associated notes, attachments and links can be accessed as normal in the web server.

To display swimlanes for a storyboard:

1. From the Tools menu choose Storyboards.

2. Select the storyboard from the list of storyboards.

3. From the Tools menu choose Swimlane View.

4. Select one of the following options:

Based on the various resources used on the activities displays the activity resources in
swimlanes.

Based on a selection of highlight rules displays selected highlight rules in swimlanes. Note: If an
activity complies with more than one highlight rule then it will be displayed in all of the highlight-based
swimlanes that it complies with.

5. If you selected to generate the swimlanes based on highlight rules, select the highlight rule(s) from the list

and click Add Rule to Apply List , otherwise proceed to Step 6.

Note: Hold Ctrl to select multiple highlight rules.

To reorder the highlight rules as they will appear in the swimlane view, select a highlight rule from the

applied rules and click Move Up  or Move Down .

6. Select or deselect any of the following options:

Include the activity resources with the activities will display the activity resources in the
swimlane view.

Include the notes bubbles with the activities will display, and allow users to access, any
associated activity notes in the swimlane view.

Hide metric links will hide any associated metric links from the swimlane view. Note: Metric links
cannot be accessed from a swimlane view.

7. Click OK.

Note: The Other swimlane holds activities that do not have resources assigned to them or that do not fulfill
the criteria of a highlight rule.

To configure the swimlane view:

The View menu allows you to modify the swimlane caption font, color and divider. You also have a number of
zoom options.

To print the swimlane view:

1. From the File menu choose Print.

Related topics
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About storyboards

Playing storyboards

Importing and Exporting Storyboards

Import or export a storyboard
Storyboards can be exported and then imported into a different process repository and storyboards can also be
exported to XML to be used in other applications.

To package a storyboard to use in another Process Repository:

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the File menu choose Package Storyboard.

3. Choose a location to save the storyboard to and click OK.

4.    Choose one of the following options by stating the intended use for the storyboard, then click Next:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Send to TIBCO Nimbus for support purposes should be selected if you intend to send the content to
TIBCO Nimbus Support. All personal information will be maintained but will be removed from the content
by TIBCO once the requirements have been met.

· Send to another external company or organization should be selected if you intend to send the
content to an external company. All personal information will be removed from the content.

· Unknown should be selected if you are unsure how the content will be used. All personal information
will be removed from the content.

Note: You can email the storyboard to a colleague by clicking Next and then selecting Email the
packaged storyboards to a colleague.

To export a storyboard to XML:

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the File menu choose Export Storyboard to XML.

3. Browse to a location to save the storyboard to and click Save.

To export costing-based data:

For more information see Export costing as CSV.

To import a storyboard:

1. From the Tools menu choose Storyboards.

2. From the File menu choose Unpackage Storyboard.

3.    Choose the storyboard to unpackage and click Open.

4.    Choose one of the following options and click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Received from TIBCO Nimbus for support purposes should be selected if the content was
originally sent from your company and received back from Nimbus®. All personal information will be
maintained. Do not select this option if you are not certain of the origin of the content.

· Received from an external company or organization should be selected if the content has been
received from an external company or organization. All personal information will be removed from the
content.
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· Unknown should be selected if the source of the content is unknown. All personal information will be
removed from the content.

Related topics

About storyboards

Redirecting Storyboard Steps

Redirect storyboard steps
Storyboard steps can be redirected to a different master map. For example, if a map is copied and the steps
need to point to the new map.

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the Edit menu choose Edit.

3. From the Edit menu choose Redirect Storyboard Steps.

4. For the Old Map Path click Select Path Name To Search  and locate the source map.

5. For the New Map Path click Select Path Name For Replace  and locate the destination map.

6. Click OK.

Related topics

About storyboards

Performing an integrity check

Performing Integrity Checks

Perform an integrity check
An integrity check will highlight any issues arising from a change to a particular map that is referenced in a
storyboard, for example if an activity has been removed.

1. From the Tools menu choose Storyboards.

Note: If you are running an integrity check against storyboards in a folder or selected storyboards, select
the storyboard folder or hold Ctrl and select the storyboards respectively.

2. From the Tools menu choose Check Integrity

3. Choose the scope of storyboards to run the integrity check against.

Note: To create a storyboard scope list file see Create a storyboard scope list file.

4. Click OK.

Any steps that are invalid will be reported in the Storyboard Integrity Check window. Invalid steps can be
removed by selecting the step and choosing Remove Steps From Storyboard from the Edit menu (hold
Ctrl to select multiple steps).

Related topics

About storyboards

Creating storyboard scope list files
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Copying Storyboards

Copy a storyboard
Storyboards can be copied. This is useful if you want to create a variant of an existing storyboard without having
to create it from scratch.

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the Edit menu choose Copy.

3. To rename the storyboard, right-click it and choose Properties.

Related topics

About storyboards

Hiding Storyboards in the Web

Hiding storyboards in the web
It is possible to hide selected storyboards in the web, which is useful for training storyboards. This is achieved by
hiding a storyboard folder. When you hide a folder, all storyboards in that folder and sub-folders will not be
displayed in the web interface, regardless of what access rights have been applied to the folder. Note that
storyboards in hidden folders can still be accessed in the web via a direct URL to the storyboard.

1. From the Tools menu choose Storyboards.

2. Right-click the folder that you want to hide and choose Edit Folder.

3. Select Hide folder in Web Server tree view and click OK.

Deleting Storyboards

Delete a storyboard
Deleting a storyboard will permanently remove it from the Process Repository.

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the Edit menu choose Delete.

Related topics

About storyboards
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Reporting on Storyboards

Storyboard usage report
This report will list any storyboard that the current storyboard is linked to. For example, you might run a usage
report on storyboard B and find that storyboard D links to it. This information is useful if you want to know what
other storyboards will be affected before making any changes to a storyboard.

1. From the Tools menu choose Storyboards.

2. Click the storyboard that you want to run the report against to select it. 

3. From the Tools menu choose Usage Report.

Related topics

About storyboards

Other storyboard reports
There are a number of reports that can be run against a scope of storyboards, including:

Feedback List displays a list of all feedback for a scope of storyboards.

Usage Report displays a list of other storyboards where a selected storyboard is linked in.

Statements Report displays a list of statements that are linked to activities referenced in a scope of
storyboards.

Acknowledgement Log Report displays a list of users that have acknowledged a scope of storyboards.

Acknowledgement Progress Report displays a list of acknowledgement statuses for all assigned
acknowledgers across a scope of storyboards.

Acknowledgement Requests Report displays a list of acknowledgement requests across a scope of
storyboards.

Acknowledgement Summary Report displays a high-level overview of the acknowledgement progress
across a scope of storyboards.

Publishing and Downloads Log displays a list of storyboards that have been published and downloaded by
users.

Storyboard Dependency displays a list of all diagrams which are referenced by a scope of selected
storyboards. (You can create a new storyboard from this report. See Creating a storyboard from a report).

1. From the Tools menu choose Storyboards.

Note: If you want to report on a selection of storyboards or a storyboard folder then select the storyboards or
storyboard folder before proceeding to the next step.

2. From the Tools menu choose a report to run.

3. Select the scope of storyboards to report on, then click OK.

Related topics

About storyboards

Storyboard usage report

Creating storyboard scope list files
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Exporting Costing Data

Export costing data
Costing-based data can be exported as a CSV file from a storyboard. The data can then be imported into MS
Excel, for example, in order to generate and calculate costs for end-to-end processes. See Exporting costing data
for more information.

Printing Storyboards

Print a storyboard
Individual storyboards can be printed, including a screenshot of each activity with the accompanying
commentary.

1. In the Storyboard Management window (Tools>Storyboards) select the storyboard that you want to print
and from the File menu choose Print Storyboard.

2. Change any of the print settings, as required, then click OK.

Storyboard printing options

The font of the header, footer and step details can be modified when storyboards are printed. In the
Storyboard Management dialog, from the File menu choose Administration and then Storyboard Print
Settings.

Creating Storyboard Scope List Files

Create a storyboard scope list file
A storyboard scope list file is a list of selected storyboards that can be used to run integrity checks and reports
against. You can create a scope list file for selected storyboards, all storyboards, all storyboards within a folder
and all storyboards within a folder and all child folders.

1. From the Tools menu choose Storyboards.

2. If you are creating a scope list for selected storyboards, a storyboard folder or a storyboard folder and all
storyboards, select the storyboards or storyboard folder. Otherwise, if you are creating a storyboard list for all
storyboards, proceed to the next step.

3. From the View menu choose Storyboard List.

4. Select the scope of storyboards to create a scope list file for and click OK.

The Storyboard List window opens.

5. Select the storyboards that you wish to include in the scope list file.

Hint: Hold Shift or Ctrl to select storyboards (only selected rows will be included in the storyboard scope list
file).

6. From the File menu choose Save Selected As Scope List.

The Create a Scope List window opens.

7. In the File Name field enter a name for the storyboard scope list.

Hint: Use a meaningful name that clearly indicates what storyboards are included.

Note: You can change where to save the file to by clicking Browse Folders.

8. Click Save.
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Related topics

About storyboards

Performing integrity checks
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About statement sets
Statement sets are a hierarchical set of regulatory and auditable statements that, if followed, ensure compliance
to specific business and legal requirements, such as ISO 9000/14001/17799, CMMi, internal company policies,
etc. Individual statements can be linked to related activities and reports can be run that identify which processes
relate to which statements.

Compliance relates to a company being able to demonstrate that documented processes and procedures support
the statements and that the processes are followed. Statement sets allow companies to demonstrate what they
do to support a particular statement as well as allowing companies to discover if changing a process breaks a
specific compliance.

Using TIBCO Nimbus you can:

· Link any statement to any activity on a process diagram (and maintain the link the other way)  

· Link statements to other statements

· Support user-definable fields

· Maintain audit records (with user-definable fields) on the statements and the links

· Provide reports on the link relationships, etc.

· Specify the status of a statement / statement set 

· Create statement sets in a hierarchy relevant to your business.

Statement Roles

Statement set administrators
Statement set administrators have full access to all statement sets, regardless of access rights.

Note: Only process authors can be statement set administrators and this role can only be assigned by
administrators.

1. From the Tools menu choose Users and then User Accounts.

2. Double-click the user.

3. In the Settings tab select the Statement Set Administrator check box.

Related Topics:

User Accounts

Statement set managers
Statement set managers can assign statement managers for specific statement sets, as well as being able to
create, edit and delete statement sets and associated statements.

Note: Statement set managers are bound by access rights on both the statement set and statement set folder (if
applicable). Only process authors can be statement set managers and this role can only be assigned by
administrators.

1. From the Tools menu choose Users and then User Accounts.

2. Double-click the user.

3. In the Settings tab select the Statement Set Manager check box.

Related Topics:
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User Accounts

Audit managers
Audit managers can create, modify and delete audit records within a statement set.

Note: Only process authors and contributors with either the Action or Change module can be assigned as audit
managers. This role can only be assigned by statement set managers and administrators.

1. From the Tools menu choose Statement Sets.

2. From the Tools menu choose Audit Managers.

3. Click Add to select a user.

Related Topics:

User Accounts

Statement managers
Statement managers can create, delete and modify statements for statement sets that they are assigned to as
statement managers. Statement managers can also create, view, edit and delete activity statement links for
statements within the statement sets that they are statement managers.

Note: Statement managers can only be assigned to process authors or contributors with the Change or Action
module by administrators and statement set managers.

1. From the Tools menu choose Statement Sets.

2. Right-click the statement set where you want to assign a statement manager and choose Statement
Managers.

3. Click Add to select a user.

Note: To remove a user as a statement manager, select the user and click Remove.

Related Topics:

User Accounts

Statement Sets

Create a statement set folder
Statement sets can be organized in folders. This not only helps to facilitate the management of statement sets,
especially if you have many statement sets in your repository, but it also provides additional statement set
security as access rights can be assigned to folders. Note that users must have access to both a statement set and
the folder that it resides in to view and/or edit the statement set. Only administrators, statement set administrators
and statement set managers can create, edit and delete statement set folders.

1. From the Tools menu choose Statement Sets.

2. From the Edit menu choose Create Folder.

Note: Folders can be nested within other folders. To create a sub-folder of an existing folder, you must select
the parent folder first.

3. In the Folder Name text field, enter a name for the statement set folder.

4. Click the Folder Access tab to define access rights.

Default Access Rights
By default, all authors will have read/write access to a statement set folder. You can change this to provide
read only or access denied to all users not specified in the Specific User Access Rights panel.
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Specific User Access Rights
You can specify separate access rights on the statement set folder for specific users and/or user groups.
Access rights defined here will override the default access rights. 

To define access for specific users or user groups, click Add  and select a user or user group. Note that
the order of users and user groups is important. You can move users and user groups up or down by
selecting them and clicking the respective arrow. For more information see More info on Access Rights...

5. Click OK.

Note: To add a statement set to a folder, simply click and drag the statement set on to the folder. To edit or
delete a statement set folder, right-click the folder and choose either Edit Folder or Delete Folder.

Related Topics:

Creating statement sets

Create a statement set
See About statement sets for information.

Note: Only administrators and statement set managers can create statement sets.

1. From the Tools menu choose Statement Sets.

2. From the File menu choose New.

3. Enter a name and description and specify the owner for the statement set.

Allow statement links to be added via the web

Include Risk Items allows you to assign a risk factor to a particular statement within a statement
set.

Show statement level numbers will display the number, hierarchically ordered, of each
statement when the statement set is viewed.

Allow statement attachments to be accessible from Activities will allow statement
attachments to be directly accessible as an attachment/link when a statement set is associated with
an activity.

Include statement set name in SAP transaction link titles will automatically append the
statement set name onto transaction link titles for statement attachments that are accessible from
activities. For example, 'Statement Set x - Create Sales Order (VA03)'. Note: The Allow statement
attachments to be accessible from Activities option must be enabled.

Auto select child statements when adding a statement link will automatically select any
associated child statements that exist for particular statements when linking statements with
activities.

The following tabs are also available:

Access

Access rights can be defined for a statement set. 

Default Access Rights
By default, all authors have read/write access to a statement set. You can change this to provide read only or
access denied to all users not specified in the Specific User Access Rights panel.

Specific User Access Rights
You can specify separate access rights on the statement set for specific users and/or user groups. Access rights
defined here will override the default access rights. 

To define access for specific users or user groups, click Add  and select a user or user group. Note that the
order of users and user groups is important. You can move users and user groups up or down by selecting them
and clicking the respective arrow. For more information see More info on Access Rights...
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Data Tables

You can allow users to add extra information to statement records by associating statement sets with data tables.
For more information see Storing additional information for statement records.

Advanced

Automatically create activity statement links based on associated statements will automatically add
any linked statements to an activity when creating a statement link. For more information on linking statement
records see Link a statement to another statement.

The Linked Statements vs. Activity Links report displays the difference between activity statement links and
the other statements from associated statement sets. See Generating a report for more information.

Show statement's parent structure in details window will display a statement's parent statements in the
Statement Properties window (Author Client) and the Statement Details page (Web Server). Users can click a
parent statement to navigate to a particular statement.

Related Topics:

Creating statements
Creating statement set folders
Creating statement statuses
Creating statement links
Data tables

Copy a statement between statement sets
A statement can be copied to another statement within the same statement set or between statement sets. When a
statement is copied to another statement it will become a sub-statement of the target statement, i.e. a level down.

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set that includes the statement that you want to copy.

3. Select the statement and from the Tools menu choose Duplicate.

4. Select the statement set and the statement that you want to copy the statement to.

5. Click OK.

Store additional information for statement records
Statement sets can be customized to allow additional information to be stored against any of the four main
aspects of a statement set framework, i.e. additional fields can be added to statements, statement links and
associated audit records for both statements and statement links. Linking to existing data tables allows the
storage of a considerable amount of extra information, ensuring that statement sets are relative within the
context of the business.

Note: Only administrators and statement set managers can create or customize statement sets.

1. From the Tools menu choose Statement Sets.

2. Right-click a statement set and choose Properties.

3. Click the Data Tables tab.

4. Choose a data table for the required statement set functions from the respective drop-down lists.

Statement allows additional information to be added to statements.

Statement audit allows additional information to be added to statement audit records.

Link allows additional information to be added to statements when linked to an activity.

Link audit allows additional information to be added to statement links' audit records.

Related Topics:

Creating statement styles
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Package a statement set
Statement sets can be packaged to include all statement records, file attachments, data table records and
statement style rules and then transferred to another process repository. If you want to transfer a process map
and its linked statements then you first have to transfer the appropriate statement sets before transferring the
process map (i.e. unpack the statement sets before unpacking the process map).

1. From the Tools menu choose Statement Sets.

2. Click the statement set to highlight it.

3. From the File menu choose Package.

4. Enter a name for the statement set and click Save.

Note: You can choose a different folder to save the statement set package to by clicking Browse Folders.

5.    Choose one of the following options by stating the intended use for the statement set, then click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Send to TIBCO Nimbus for support purposes should be selected if you intend to send the content to
TIBCO Nimbus Support. All personal information will be maintained but will be removed from the content
by TIBCO once the requirements have been met.

· Send to another external company or organization should be selected if you intend to send the
content to an external company. All personal information will be removed from the content.

· Unknown should be selected if you are unsure how the content will be used. All personal information
will be removed from the content.

Related Topics:

Unpacking statement sets

Unpackage a statement set
Statement sets can be packaged to include all statement records, file attachments and data table records and then
transferred to another process repository. If you want to transfer a process map and its linked statements then you
first have to transfer the appropriate statement sets before transferring the process map (i.e. unpack the
statement sets before unpacking the process map).

Note: Linked file attachments are stored in the Process RespositoryATTACH folder.

1. From the Tools menu choose Statement Sets.

2. Click the statement set to highlight it.

3. From the File menu choose Unpack.

4.    Choose one of the following options and click OK:

· Internal backup or transfer should be selected if the content is only for re-use or for an internal
backup. All personal information will be maintained. This option should not be selected if you intend the
content to be transferred to a third party as doing so will breach data-privacy regulations.

· Received from TIBCO Nimbus for support purposes should be selected if the content was
originally sent from your company and received back from Nimbus®. All personal information will be
maintained. Do not select this option if you are not certain of the origin of the content.

· Received from an external company or organization should be selected if the content has been
received from an external company or organization. All personal information will be removed from the
content.

· Unknown should be selected if the source of the content is unknown. All personal information will be
removed from the content.

Related Topics:

Package a statement set
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Comparing statement sets

Import a statement set from CSV
Existing statement sets in CSV format can be imported into TIBCO Nimbus in order to centralize all compliance
records and link them directly to the business processes. New statement sets can be created and existing
statement sets updated. When updating an existing statement set, you can automatically schedule the import to
occur at regular defined intervals.

Note: For information on how the CSV file should be constructed, see the examples below.

To create a new statement set:

Create a new statement set from a CSV import file.

1. From the Tools menu choose Statement Sets.

2. From the File menu choose Import from CSV file.

3. From the File menu choose New.

4. In the Import Name field, enter a name for the statement set import routine.

5. In the CSV Filename field, click Browse and select the CSV file that you want to import.

6. In the Statements panel, specify the number of statement name columns and the number of data table field
columns.

Number of statement name columns is the maximum number of columns in the data set that are used
for hierarchical statement names. Essentially, this is the maximum number of levels that exist in the
statement set that you are importing.

Number of data table field columns is the number of additional data field columns that exist within the
data set.

7. In the Options panel, select any of the following options (if appropriate).

Populate each statement record's data table will create an associated data table containing the
additional data (Data1, Data2 and Data3 in Example 1 below) for each statement record generated in the
statement set.

Include statement descriptions will import any statement descriptions that are defined in the imported
CSV file (see Example 2 below for information on how to include statement descriptions).

8. Select Create new statement set.

9. Click OK.

The statement set import will appear in the Statement Set CSV Imports window. This window lists all of the
available statement set imports from CSV.

10. To import the statement set, select the statement set import and from the File menu choose Run Now.

To update an existing statement set:

Update an existing statement set from a CSV import file. You can also schedule the import process to run at
defined intervals.

1. From the Tools menu choose Statement Sets.

2. From the File menu choose Import from CSV file.

3. From the File menu choose New.

4. In the Import Name field, enter a name for the statement set import routine.

5. In the CSV Filename field, click Browse and select the import file that you want to import.

6. In the Statements panel, specify the number of statement name columns and the number of data table field
columns.

Number of statement name columns is the maximum number of columns in the data set that are used
for hierarchical statement names. Essentially, this is the maximum number of levels that exist in the
statement set that you are importing.

Number of data table field columns is the number of additional data field columns that exist within the
data set.

7. In the Options panel, select any of the following options (if appropriate).
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Populate each statement record's data table will create an associated data table containing the
additional data (Data1, Data2 and Data3 in Example 1 below) for each statement record generated in the
statement set.

Include statement descriptions will import any statement descriptions that are defined in the imported
import file (see Example 2 below for information on how to include statement descriptions).

8. Select Update Existing Statement Set and then choose the statement set that you want to update.

Note: You can choose to backup the original statement set prior to the statement set being updated by
selecting Backup statement set before update.

9. Click the Advanced tab.

Advanced

This tab allows you to specify which fields in the existing statement set to update and what action to take for
unmatched statements.

Import key / ID is used to match the data in the import file to the statement set. This can either be the
statement name or a selected data table field in a data table that is associated with the statement set.

Fields to update allows you to select which fields in the existing statement set to update with the
information in the CSV file.

Ignore Blank Fields from the CSV File will not update any fields in the existing statement set if the
corresponding fields in the import file are blank. If this option is not selected then any blank fields will
remove the data in the corresponding fields in the statement set.

Unmatched Statements

In the Unmatched Statements panel, you can specify what action to take for statements that are missing in
the original statement set compared to the import file.

Delete Statement will remove any statements in the original statement set that are not present in the
import file. In such cases, you must specify what action the system will take from the following choices:

Do Nothing will simply remove any statements that do not match up with the import file.

Send Notification allows you to notify selected users and/or user groups of any deleted statements.
Click Configure to add users and/or user groups.

Note: You must specify what to do with orphaned statements that may be created when deleting
unmatched statements (see Orphaned Statements below).

Do Nothing will not remove statements from the original statement set that do not match up with the import
file. In such cases, you must specify what action the system will take from the following choices:

Do Nothing will leave any statements that do not match up with the import file.

Send Notification will send a notification to selected users and/or user groups, notifying them of any
unmatched statements. Click Configure to add users and/or user groups.

Raise Statement Action will automatically create a preconfigured action and assign it to selected
users. Click Configure to define the action and assign users and/or user groups.

Orphaned Statements

If you have selected to delete any unmatched statements in the existing statement set, you must specify
what to do in cases where statements are linked to activities, as this will create broken activity statement
links.

Delete Statement will remove any statements in the original statement set that are not present in the import
file. In such cases, you must specify what action the system will take from the following choices:

Do Nothing will not remove broken activity statement links.

Send Notification will send a notification to selected users and/or user groups, notifying them of any
broken activity statement links. Click Configure to add users and/or user groups.

Raise Process Action will automatically create a preconfigured action and assign it to selected users. Click
Configure to define the action and assign users and/or user groups.

Raise Change Request will automatically create a preconfigured change request and assign it to selected
users. Click Configure to define the change request and assign users and/or user groups.
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Note: If you select to send a notification, raise an action or raise a change request, you must specify what
map type(s) it applies to from the Apply this action to the following map types drop-down list.

Scheduling and Logging

This tab allows you to automatically schedule the import to run on a regular basis. Note that this is optional
and if you do not set up automatic scheduling then you must run the import manually from the Statement
Set CSV Imports window each time you want to update the existing statement set.

To enable scheduling and logging, select Schedule Enabled.

First Due Date is the date at which the first import will run.

Recurrence Pattern is how often to run the import. Choose from daily, weekly, monthly, yearly or on
custom dates.

Email Log File To Statement Set Owner will send an import log to the owner of the statement set each
time the import is performed.

To edit an existing statement set CSV import:

Update an existing import.

1. From the Tools menu choose Statement Sets.

2. From the File menu choose Import from CSV file.

3. Double-click the import that you want to edit.

4. Make any changes, as required, and then click OK.

To manually start a CSV import:

Manually start an ad hoc or scheduled CSV import.

1. From the Tools menu choose Statement Sets.

2. From the File menu choose Import from CSV file.

3. Select the statement set import and from the File menu choose Run Now.

Example 1 - Importing statement sets without statement information

The format of a 3-tier statement set is:

Level 1,Level 2,Level 3,Data 1,Data 2,...,Data n.

The first row of the file constitutes the names of the statements and data columns within the statement.
Proceeding rows are treated as the actual statement names and corresponding data.

The following is an example of the structure of a CSV file relating to a statement set:

Level1,Level2,Level3,Data1,Data2,Data3  
Example1,,,s1 d1,s1 d2,s1 d3  
,Example1.1,,s1.1 d1,s1.1 d2,s1.1 d3  
,,Example1.1.1,s1.1.1 d1,s1.1.1 d2,s1.1.1 d3  
,Example1.2,,s1.2 d1,s1.2 d2,s1.2 d3  
Example2,,,s2 d1,s2 d2,s2 d3  
,Example2.1,,s2.1 d1,s2.1 d2,s2.1 d3  
,,Example2.1.1,s2.1.1 d1,s2.1.1 d2,s2.1.1 d3  
,Example2.2,,s2.2 d1,s2.2 d2,s2.2 d3  
,Example2.3,,s2.3 d1,s2.3 d2,s2.3 d3
,,Example2.3.1,s2.3.1 d1,s2.3.1 d2,s2.3.1 d3

Example 2 - Importing statement sets with statement information

Statement descriptions can be included in the CSV file.
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The format of a 3-tier statement set is:

Level1,Level1Description,Level2,Level2Description,Level3,Level3Description,Data1,Data2,Data3

The following is an example of the structure of a CSV file relating to a statement set that incorporates information
about the statements:

Level1,Level1Description,Level2,Level2Description,Level3,Level3Description,Data1,Data2,Data3
Example1,Example1 Statement Description,,,,,s1 d1,s1 d2,s1 d3
,,Example1.1,Example1.1 Statement Description,,,s1.1 d1,s1.1 d2,s1.1 d3
,,,,Example1.1.1,Example1.1.1 Statement Description,s1.1.1 d1,s1.1.1 d2,s1.1.1 d3
,,Example1.2,Example1.2 Statement Description,,,s1.2 d1,s1.2 d2,s1.3 d3
Example2,Example2 Statement Description,,,,,s2 d1,s2 d2,s2 d3
,,Example2.1,Example2.1 Statement Description,,,s2.1 d1,s2.1 d2,s2.1 d3

.....and so on

Click the image below to see an example
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Example 3 - Importing statement sets with attachments

Attachments, including URL links, file links and SAP transaction links, can be included in the CSV import. The
following rules apply:

1. URL Links. If the text begins with either http:, https: or file: then it will be imported as
a URL link.

2. File Links. If the text begins with a drive letter or backslash, for example \\ or C:\,
then it will be imported as a file link.

3. SAP Transaction Links. All other text will be imported as SAP transaction links. Here
the first part of the text will be imported as the transaction code and the text following
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the first space will be imported as the title of the transaction link. For example, 'VA03
Create Sales Order' - 'VA03 is the transaction code and 'Create Sales Order' is the
title. 

The format of a 3-tier statement set is:

Level1,Level1Description,Level2,Level2Description,Level3,Level3Description,Data1,Data2,Data3,Att1,Att2,Att
x

The following is an example of the structure of a CSV file relating to a statement set that incorporates statement
information and a number of attachments:

Level1,Level1Description,Level2,Level2Description,Level3,Level3Description,Data1,Data2,Data3,Att1,Att2,Att
x
Example1,Example1 Statement Description,,,,,s1 d1,s1 d2,s1 d3,http://www.tibco.com,VA03 Create
Sales Order
,,Example1.1,Example1.1 Statement Description,,,s1.1 d1,s1.1 d2,s1.1 d3,C:\My documents\ISO
Guidelines.PDF
,,,,Example1.1.1,Example1.1.1 Statement Description,s1.1.1 d1,s1.1.1 d2,s1.1.1 d3,https://
salesforce.com
,,Example1.2,Example1.2 Statement Description,,,s1.2 d1,s1.2 d2,s1.3 d3,http://www.tibco.com

.....and so on

Commas within the text

If there are commas within the text that you are importing, please ensure that you enclose them within quotation
marks, otherwise the text will not be imported correctly. Also, there must be no space after the comma.

The following will work:

Example"," comma,text,text

The following will not work (due to the space after the comma):

Example", " comma,text,text

Import a statement set from BPM-Xchange
Statement sets can be imported and updated from BPM-Xchange (XML) files that have been exported from other
applications. Any associated properties will be imported as data table fields and connections will be imported as
statement links.

Note: This option is only available to administrators and statement set managers.

1. From the Tools menu choose Statement Sets.

2. From the File menu choose Import from BPM-Xchange.

3. Click Browse  to locate the XML file that you want to import as a statement set.

4. Select one of the following options:

Import Diagram Structure from XML file will use the diagram structure IDs as the statement names.

Import Folder Structure from XML file will use the folder structure IDs as the statement names.

5. Select Create new statement set or Update existing statement set.

Updating Statement Sets

If you are updating an existing statement set then choose the statement set to update from the Statement
Set drop-down list. If statements exist in the current statement set that you are updating but do not exist in
the XML file, you can choose to keep these statements by selecting Keep statements that don't exist in
the XML file. If this option is deselected then any extra statements in the statement set will be deleted.

Advanced Options

Click the Advanced tab to access more options. In the Advanced tab you can specify a different property to
be used for the statement names (the default is PT_NAME) and specify a different default language.

Name Property allows you to change the property that is used for the statement names.

Default Language allows you to specify a different default language.
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Read statement descriptions from the Property elements allows you to populate the statement
description field with the information from a specified property.

6. Click OK.

Import a statement set from SAP Solution Manager
Importing statement sets from SAP Solution Manager can be run as both a scheduled operation and manually by
users with the appropriate access rights. When updating an existing statement set, an XML file will be created that
can contain URL links back to any master and/or draft diagrams that are linked to any of the statements. When
this file is read back into SAP Solution Manager the URL links are added to the respective nodes. You can choose
whether to export diagram URLs to either the Project Documentation tab, the General Documentation tab or both
the Project and General Documentation tabs in SAP Solution Manager.

Styles applied to SAP Transaction Type Nodes

A statement set style - SAP Transaction Nodes - will be created and applied to all SAP Transaction type nodes
upon import. By default, SAP Transaction type nodes will be highlighted in green, however this can be modified
by editing the style.

  TIBCO Nimbus administrators and statement set managers only.

Reports based on SAP transaction links

Reports can be run to show which SAP systems and transactions are based on business processes, and
which are not. You can also identify areas of the business processes that are not covered by any installed
SAP systems and transactions. See Generating reports for more information.

Comparing statement sets

Two statement sets can be compared in TIBCO Nimbus. This is useful if you want to view the changes that
have occurred in specific  project structures when compared against the original business blueprint
structure. See Comparing statement sets for more information.

To create a new statement set:

1. From the Tools menu choose Statement Sets.

2. From the File menu choose Import from SAP Solution Manager.

3. Click Browse  to locate the XML file that you want to import as a statement set.

4. In the Options panel, click in the Statement Set Name text box and enter a name for the statement set.

Import SAP Transaction Links as child nodes will import SAP transaction links as separate child
nodes in the statement set. If disabled, SAP transaction links will be imported as attachments on the
corresponding parent statement record.

Include statement set name in SAP transaction link titles on diagrams will automatically append
the statement set name onto transaction link titles for statement attachments that are accessible from
activities. For example, 'Statement Set x - Create Sales Order (VA03)'. Note: The Allow statement
attachments to be accessible from Activities option must be enabled for a specific statement set -
see Automatically linking SAP transaction links for more information.

Create / Update Solution Manager End User Roles will create a statement set called SAP End User
Roles statement set (assuming the Organizational Unit information is available). This is essentially a list of
user names with links to the SAP Solution Manager-type statement set nodes.

5. Click OK.

To update an existing statement set:

Existing statement sets in TIBCO Nimbus can be updated from a data exported from SAP Solution Manager.
Any document and URL attachments will be overwritten with attachments from the SAP data. If specific
document and URL attachments are absent in SAP data but present in the statement set, i.e. they have been
removed in SAP Solution Manager, then the corresponding attachments in the statement set will be removed.
This applies only to attachments that have originated from SAP Solution Manager. Attachments created by
users in TIBCO Nimbus will not be removed if absent in the SAP data that's being imported.

1. From the Tools menu choose Statement Sets.
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2. From the File menu choose Import from SAP Solution Manager.

3. Click Browse  to locate the XML file that you want to import as a statement set.

4. In the Options panel, select Update an existing statement set and choose a statement set from the
Statement Set drop-down list.

Keep a copy of the existing version will create a backup of the existing statement set before applying
the changes.

Import SAP Transaction Links as child nodes will import SAP transaction links as separate child
nodes in the statement set. If disabled, SAP transaction links will be imported as attachments on the
corresponding parent statement record.

Include statement set name in SAP transaction link titles on diagrams will automatically append
the statement set name onto transaction link titles for statement attachments that are accessible from
activities. For example, 'Statement Set x - Create Sales Order (VA03)'. Note: The Allow statement
attachments to be accessible from Activities option must be enabled for a specific statement set -
see Automatically linking SAP transaction links for more information.

Create / Update Solution Manager End User Roles will create or update the 'SAP End User Roles'
statement set (assuming the Organizational Unit information is available). This is essentially a list of user
names with links to the SAP Solution Manager-type statement set nodes.

Export Options

These options allow you to create a XML file that can be imported back into SAP Solution Manager in order to
update diagram (URL) links.

Select Export usage data to XML file and click Browse  to select the XML file to update.

Activity Statement Links allows you to choose to export activity statement links from either master
diagrams, draft diagrams or both master and draft diagrams.

Solution Manager Tab allows you to choose whether to export diagram URLs to either the Project
Documentation tab, the General Documentation tab or both the Project and General Documentation tabs in
SAP Solution Manager.

5. Click the Advanced tab and define viewing rights for document, transaction and blueprint links.

Document View Rights apply to all imported document and URL link attachments.

Transaction View Rights apply to all imported transaction link attachments.

Blueprint View Rights apply to blueprint-style SAP transaction links (these are automatically generated
during the Solution Manager Statement Set import routine).

6. Click the Defaults tab and specify the default Base URLs and SAP Systems for the SAP transaction links and
SAP blueprint transaction links, if appropriate.

Note: These will apply to all SAP transaction links that are automatically created during the SAP Solution
Manager import routine. If no values are specified then the settings defined in individual users' SAPLogon.ini
files will be used to launch related transaction links.

7. Click OK.

To schedule importing from SAP Solution Manager:

The import routine can be run as a Windows scheduled task, such as overnight or once a week, following the
completion of the export from SAP Solution Manager.

In the Statement Sets dialog, from the File menu choose Scheduled Import from SAP Solution Manager.

Click New Schedule . Define the scheduled task from the following:

Scheduled Item includes the details of the import task. You can either define a scheduled task for
creating a new statement set or updating an existing one (see above).

Scheduled Item Name is the name as it appears in the Scheduled Tasks Manager.

Scheduled item description is the description as it appears in the Scheduled Tasks Manager.

Send Notification To allows you to define a user or user group to notify upon completion or failure of
the scheduled task. Click Select to find a user.

Schedule Information requires you to define the schedule details, such as start time, occurrence, etc.
Click Configure to define the import schedule.
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Import Logs

An import log is generated and stored in ...Process Repository\System\Logs folder. This will report on any issues
with an import or export.

Related Topics:

Automatically linking SAP transaction links to statements
Comparing statement sets
Importing SAP Usage Data

Export a statement set to CSV
Existing statement sets and attached data tables can be exported to a CSV format. The export format is the same
format used for the statement set import.   

Note: Only administrators, statement set managers and statement set administrators are permitted to export a file
to CSV.

1. From the Tools menu choose Statement Sets.

2. From the File menu choose Export to CSV File.

3. Select a location to save the CSV file to, and click Save.

An information dialog will be displayed confirming the file path and the number of statements that have
successfully been exported.

Note: The statement set export file will include the statement name, description and where applicable any
attached data table information. 

The exported file can be used to make updates. Once complete, the file including the changes can be imported. 
For further information on importing a statement set from CSV click here.

Delete a statement set
Administrators and statement set managers can delete a statement set and all associated statements will be
deleted. Any activity statement links related to the statement set will be removed.

1. From the Tools menu choose Statement Sets.

2. Right-click the statement set that you want to delete and choose Delete.

Statements

Create a statement
See About statement sets for information.

Note: Only administrators, statement set managers, statement managers and audit managers have rights to
create statements.

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set that you want to add a statement to.

Note: If you are adding a child statement to an existing statement then you must select the parent
statement.

3. From the File menu choose Add.

4. Enter a name for the statement.

5. Choose a status and style for the statement.

Note: You can create a new status or style for a particular statement.
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6. Enter a description for the statement.

7. Select a risk factor if appropriate.

Note: Risk factors will only be available if the statement set was setup to include risk factors.

To add additional information:

8. Select the Additional tab and enter any additional information that defines the statement.

Note: Additional information refers to a data table that was associated with the particular statement set
when it was created. If a data table was not associated then this tab will be blank.

To add attachments:

9. Select the Attachments tab and click New , then choose to attach a file or application, document link, web
link, email link or SAP R/3 transaction link.
Note: You can define viewing rights for statement attachments. Select the attachment in the Attachments

tab and click Set View Rights . The Scope panel allows you to define viewing rights for the selected

attachment only or all attachments associated with the statement. Click Add  to add users.

More info on Access Rights...

To link statements:

10. Select the Linked Statements tab and click Add a linked statement .

11. Select the statement set on the left, then select the check boxes of the statements that you want to link to.

Note: To unlink statements, select the statement(s) and click Remove selected links .

Hint: You can show or hide linked statements in the Statements window for a particular statement set. From
the View menu select or deselect Show Linked Statements.

Related Topics:

Creating statement sets

Creating statement styles

Creating statement statuses

Automatically linking SAP transaction links

Defining statement managers

Linking statements to other statements

Customizing and editing statements

Searching for statements

Adding statement change logs

Adding statement audit records

Adding statement link audit records

Create a statement status
You can apply a status to statements within a statement set, for example Active, In Progress, Ignore, Complies,
etc.

1. From the Tools menu choose Statement Sets.

2. Select the statement set that you want to define a status for and from the Tools menu choose Statement
Statuses.

3. From the File menu choose New and enter the status name.

Related Topics:

Creating statement styles
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Link a statement record with an action
Actions can be linked to statement records (statements, statement links, statement audits and statement link
audits). Recurring actions templates can also be created; these will generate an action at defined intervals and
assign the action to the nominated assignees.

Create an action or action template for:

Statements

Statement Links

Statement Audits

Statement Link Audits

To create and link an action to a statement:

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set to open it.

3. Right-click the statement and choose Properties.

4. Click the Actions tab, then click New Action.

5. Progress through the wizard to define the action (see below for details of the various steps).

Recurring Action Templates

To create a recurring action, i.e. an action that is automatically generated at regular intervals, click the
Recurring Actions tab and click New Action. For information on editing and deleting recurring action
templates click here.

To create and link an action to a statement link:

1. Right-click the activity statement link and choose Access/Modify.

2. Double-click the linked statement to open it.

3. Click the Actions tab, then click New Action.

4. Progress through the wizard to define the action (see below for details of the various steps).

Recurring Action Templates

To create a recurring action, i.e. an action that is automatically generated at regular intervals, click the
Recurring Actions tab and click New Action. For information on editing and deleting recurring action
templates click here.

To create and link an action to a statement audit record:

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set to open it.

3. Right-click the statement and choose Audits.

4. Double-click the statement audit record.

5. Click the Actions tab, then click New Action.

6. Progress through the wizard to define the action (see below for details of the various steps).

Recurring Action Templates

To create a recurring action, i.e. an action that is automatically generated at regular intervals, click the
Recurring Actions tab and click New Action. For information on editing and deleting recurring action
templates click here.
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To create and link an action to a statement link audit record:

Note: Statement link audit records can only be accessed in master diagrams.

1. Right-click the activity statement link and choose Access/Modify.

2. Select the statement link and from the Tools menu choose Audits.

3. Double-click the statement link audit record.

4. Click the Actions tab, then click New Action.

5. Progress through the wizard to define the action (see below for details of the various steps).

Recurring Action Templates

To create a recurring action, i.e. an action that is automatically generated at regular intervals, click the
Recurring Actions tab and click New Action. For information on editing and deleting recurring action
templates click here.

Hint: You can also access statement link audit records from reports that display statement audit links for a
statement set, for example the Activity Statement Link Audits report. Right-click an activity statement link
audit record and choose Open Audit Record.

Properties

Enter the details of the action, including subject, owner, due date and associated categories.

Recurrence

Enter the details of how frequently the action should recur. Note: This applies only if you are creating a
recurring action.

Assignees

Add users and user groups to complete the action.

Only require 1 assignee to complete action will allow the action owner to close the action after only
one of the assignees has completed it.

Editors

Add users that are able to modify the action (editors cannot complete the action unless they are an
assignee).

Viewers

Add users that are able to view the action (by default all users can view the action through Action
Registry).

Description

Add any information about the action, such as the reason for carrying out the action.

Attachments

Add any attachments to further support the action, if applicable. Attachments can be file links, application

links, email links, SAP transaction links, document links, storyboard links and URL links. Click New  to
add an attachment. To modify the access rights for a particular action, select the attachment and click 

Set View Rights .

Reminders and Escalation

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue action.
An escalation date can also be set which will send an email notification to users' line managers if they fail
to action a particular To-do item. Default notification and escalation options are defined in the system
options. If you have the privileges to do so, you can modify these settings for individual actions requests
before submitting them.

Enable email reminders will send reminder emails to users until they have completed the action.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
completed the action.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.
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Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

Related Topics:

Creating and managing recurring actions

Search for a statement
Search within a statement set for statements based on a word or phrase within the statement title, description
and associated data fields. This allows you to search across all statement sets for a particular term before adding
a statement link to an activity, for example.

 

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set that you want to search.

3. From the Tools menu choose Find.

4. Enter the search term or phrase.

Note: Check the Whole words only check box to ensure that only exact matches are searched for.

Delete a statement
Administrators, statement set managers and statement managers can delete a statement . Any activity statement
links relating to a deleted statement will be removed.

1. From the Tools menu choose Statement Sets.

2. Right-click the statement set that you want to delete and choose Delete.

Related Topics:

Purging statement records (based on data table field data)

Purge statement records
Administrators and statement set managers can delete statements from a statement set based on defined data
table values that are associated with statements.

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set that you want to purge statements from.

3. From the Tools menu choose Purge.

4. Choose the field, criteria and enter a value from the respective fields.

Note: TIBCO Nimbus will create a backup of the statement set prior to purging by default. Before
committing the purge you will be asked where to save the backup. If you need to retrieve the backup then
you can do so by unpacking it. If you are certain of your action then deselect Backup statement set
before purge.

5. Click OK.

Related Topics:

Delete a statement
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Statement Styles

Create a statement style
Different styles can be used to differentiate statements within a statement set, for example you may want to
underline the more important statements or highlight them in a different color.

1. From the Tools menu choose Statement Sets.

2. From the Tools menu choose Styles.

3. From the File menu choose New.

4. Enter a name to describe the style.

5. Choose any effects that you want to define the text by from bold, italic, underline or strike-through.

6. Choose a color from the color palette.

Related Topics:

Creating statement statuses

Defining custom colors

Defining statement style rules

Define statement style rules
Style rules can be defined for specific statement sets that will automatically apply a particular style to a
statement based on a statement's status or an associated data table field value. Statement style rules will
override existing statement styles that have been applied.

Note: Only administrators, statement set managers and statement managers (of a particular statement set) can
define and edit statement style rules.

 

1. From the Tools menu choose Statement Sets.

2. Select the statement set that you want to define a style rule for.

3. From the Tools menu choose Style Rules.

4. From the File menu choose New.

5. Enter a name to describe the statement style rule.

Active will make the statement style rule active. Deselect this check box to prevent the rule from being
applied, i.e. to render it inactive.

6. Choose a style from the Style drop-down list.

Note: See Creating statement styles for more information on creating statement styles.

7. Enter a description for the style rule, if required.

8. Click the Filter tab.

9. From the Criteria drop-down list choose an operator.

10. From the Value panel select either Status or Data Table Field.

11. From the respective drop-down list (for the option selected above) choose a status value or data table field.

Note: If you are using a data table field then choose a value, date or enter a value (in the box below the
drop-down list) that will define the style rule.

12. Click OK.

To disable a statement style rule:
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1. From the Tools menu choose Statement Sets.

2. Select the statement set that you want to disable the style rule for.

3. From the Tools menu choose Style Rules.

4. Right-click the statement style rule that you want to disable and choose Properties.

5. Deselect the Active check box.

6. Click OK.

To delete a statement style rule:

1. From the Tools menu choose Statement Sets.

2. Select the statement set that you want to delete the style rule for.

3. From the Tools menu choose Style Rules.

4. Right-click the statement style rule that you want to delete and choose Delete.

Hint: To delete multiple style rules, hold Ctrl and select the style rules, then from the File menu choose
Delete.

Related Topics:

 

Creating statement statuses

Creating statement styles

Defining custom colors

Statement Links

Create a statement link
Statements can be associated with activities by administrators, statement set managers and statement managers.
Process authors can also add statements to activities in the web server to activities that are currently unlinked to
any statements (see Linking To Statements In The Web Server below).

Note: If an activity is copied that has is linked to a statement, the statement link is also copied. However,
associated audit records are not copied as they are only valid in the original context in which they were created.

1. Right-click the activity and choose Statement Links.

2. From the File menu choose New.

3. Select the statement set (on the left).

4. Select the check boxes for the statements that you want to link the activity to.

Note: You can only add statements from a single statement set at a time. If a statement record is linked to
another statement record in a different statement set, and the option Automatically create activity
statement links based on associated statements is enabled for the statement set, then an activity
statement link will be automatically created for the linked statement.

5. Click OK.

Statement Link Properties

If you have linked a single statement then the Statement Link Properties dialog is displayed. If you have
selected multiple statements then you will return to the Statement Links dialog - to access the properties of a
statement link, right-click the statement and choose Properties.

The Additional tab allows you to provide additional information relating to the statement link. Note: A data
table must be associated with the statement set in order to allow additional information to be added to the
statement link.

When viewing the properties of a statement link, you can view the details of the statement by clicking 
Statement Details.

Statement Linking Tips
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You can open and edit a statement set by selecting the statement and clicking Statements.

Create a new statement in a statement set by selecting the statement set and clicking Add.

Statement links can be copied from one activity to another. Hold Alt and select the statement link, then press
Ctrl-C to copy it to your clipboard. Then, select the activity that you want to copy it to and press Ctrl-V to
paste it.

Click Find to find a specific statement within a statement set.

Related Topics:

Linking statements to other statements

Automatically linking SAP transaction links

Remove a statement link
Statements can be unlinked from activities by administrators, statement set managers and statement managers.

 

1. Right-click the activity and choose Statement Links.

2. Right-click the statement that you want to remove and choose Delete.

Link a statement to another statement
Statements can be linked to other statements in the same statement set or a different statement set. These links
work bi-directionally, i.e. when you link Statement A to Statement B, Statement B also becomes linked to
Statement A. If the option Automatically create activity statement links based on associated
statements is enabled for a particular statement set, when a statement is linked to an activity, any linked
statements will also be linked to the activity automatically. See Create a statement set for more information.

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set that includes the statement that you want to link to another statement.

3. Right-click the statement and choose Properties.

4. Click the Linked Statements tab to select it.

5. Click Add a linked statement .

6. Select the statement set on the left, then select the check box or check boxes of the statement(s) that you
want to link to.

7. Click OK.

Note: To find a specific statement click Find. You can also add a new statement to a statement set by
selecting the statement set and clicking Add.

Removing Statement Links

In the Linked Statements tab, select the

statement and click Remove Statement .

Related Topics:

Creating statement links
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Add Statement Links via a SIPOC report
Add a Statement Link to either a Diagram Activity or a Process Diagram from within a SIPOC report.

Note: You must have the relevant map open to run the SIPOC report. Additionally, only Statement Managers,
Statement Set Administrators, Statement Set Managers and Administrators are permitted to add Statement Links
via a SIPOC report.

Add a Statement Link to an Activity via a SIPOC Report:

1. From the Tools menu choose Reports.

2. From the Categories column choose Diagrams.

3. From the Reports column choose Activities (SIPOC).

4. From the Scope column choose the scope of diagrams to include in the report.

5. Click OK.

6. From within the report right-click on the Activity you want to add a Statement Link to, and select Add
Statement Links to Activities.

7. Locate the statement set and select the check boxes of the statement/s you want to add.

Note: It is only possible to add multiple Statements from a single Statement Set.  Repeat steps 6 and 7 to
add Statements from other Statement Sets.

8. Click OK.

Note: The selected statement/s are displayed in the report and on the activity box in the process diagram.

Add a Statement Link to a Process Diagram via a SIPOC report:

1. From the Tools menu choose Reports.

2. From the Categories column choose Diagrams.

3. From the Reports column choose Activities (SIPOC).

4. From the Scope column choose the scope of diagrams to include in the report.

5. Click OK.

6. Right-click anywhere in the report, and select Add Statement Links to Diagrams.

7. Locate the statement set and select the check boxes of the statement/s you want to add.

8. Note: It is only possible to add multiple Statements from a single Statement Set.  Repeat steps 6 and 7 to
add Statements from other Statement Sets.

9. Click OK.

Note: The selected statements are displayed in the report and on in the diagram information.

Remove Statement Links via a SIPOC report
You can remove a Statement Link from either a Diagram Activity or a Process Diagram from within a SIPOC
report.

Note: You must have the relevant map open to run the SIPOC report. Additionally, only Statement Managers,
Statement Set Administrators, Statement Set Managers and Administrators are permitted to remove Statement
Links via a SIPOC report.

Remove a Statement Link from an Activity via a SIPOC Report:

1. From the Tools menu choose Reports.

2. From the Categories column choose Diagrams.
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3. From the Reports column choose Activities (SIPOC).

4. From the Scope column choose the scope of diagrams to include in the report.

5. Click OK.

6. From within the report right-click on the Activity you want to remove a Statement Link from, and select 
Remove Statement Links from Activities.

7. Select one or more statements to remove.

Hint: Hold Ctrl to select multiple links.

8. Click OK.

9. Click Yes.

Note: The statement/s are removed from the report and the activity box in the process diagram.

Remove a Statement Link from a Process Diagram via a SIPOC Report:

1. From the Tools menu choose Reports.

2. From the Categories column choose Diagrams.

3. From the Reports column choose Activities (SIPOC).

4. From the Scope column choose the scope of diagrams to include in the report.

5. Click OK.

6. Right-click anywhere in the report, and select Remove Statement Links from Diagrams.

7. Select one or more statements to remove. 

Hint: Hold Ctrl to select multiple links.

8. Click OK.

9. Click Yes.

Note: The statement/s are removed from the report and the process diagram.

Automatically link SAP transaction links
Statements can be automatically linked to SAP transaction links. This supports, for example, the use of
implementing a 'SAP Business Process Master List' statement set within a process. If the statement set has the 
Allow statement attachments to be accessible from Activities option enabled then SAP transaction links
will be associated with activities as attachments when statements are linked to activities, thereby providing users
with direct access to the SAP transaction links.

Note: SAP R/3 integration must be enabled to create SAP transaction links. Refer to the Administration Guide that
is included on the CD for more information.

Prerequisites: 

1. A data table must exist which contains a data table field that allows the input of a transaction code. See 
Creating a data table for more information.

2. A statement set must exist that is linked to the data table that includes a transaction code field (as defined
above). The data table is selected from the Statement drop-down list in the Data Table properties of the
statement set. See Customizing or editing statements for more information.

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set that you want to automatically associate SAP transaction links with.

3. Double-click a statement that you want to associate with SAP transaction links.
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4. Click the Additional tab and enter a transaction code in the relevant field.

5. Click OK and repeat for all statements that you want to associate with SAP transaction links.

6. From the Tools menu choose Build Transaction Links.

7. Choose the data table field that contains the specified transaction links and click OK.

Related Topics:

Creating a data table

Creating a statement set

Creating statement links

Rolling up statement links
Activity statement links can be automatically rolled up and copied to all parent activities from child activities.

Note: This operation cannot be undone once completed.

1. From the Tools menu choose Statement Links, then Rollup Statement Links.

2. Select one of the following options:

· Rollup to the current diagram

This will copy all statement links from child activities to all parent activities up to the diagram that you
are currently viewing.

· Rollup to the level 1 diagram

This will copy all statement links from child activities to all parent activities up to the level 1 diagram.

3. Click OK.

Running the process from the command line

The process can be run from the command line through the use of a Control Script File (.csf). Note: This method
will always roll up statements to the level 1 diagram. Any issues will be reported in a log file, which is created in
the same location as the CSF file.

Example
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C:\TIBCO Nimbus\Client\Ctrl.exe "E:\TIBCO Nimbus\Process Repository" "C:
\StatementRollup.csf"

What is a Control Script File?

This file defines the parameters to automate a task using TIBCO Nimbus. To create a CSF, you must
create a new text file and change the file extension to .csf, for example StatementRollup.csf.

Then include the following line in the file:

ROLLUP_STMT_LINKS "<relative map path>"

For example:

ROLLUP_STMT_LINKS "C:\TIBCO Nimbus\Process Repository\MY PROCESSES.MAP"

Related Topics:

Creating statement links

Copy statement links across statement sets
Following a statement set comparison, statement links can be copied from one statement set to the other. As an
organization, you may have multiple hierarchical project structures within Solution Manager, all of which can be
imported into TIBCO Nimbus as separate statement sets. TIBCO Nimbus allows you to copy activity statement
links between the various projects.

Note: Activity statement links will only be copied between matching statements in the source and target
statement sets. Data table field values are also copied, but only if the source and target statement sets are linked
to the same data table definition.

1. Generate a comparison report between the two statement sets that you want to copy the activity links
between.

2. In the Statement Comparison window, from the Tools menu choose either Copy Activity Links (Source to
Target) or Copy Activity Links (Target to Source).

Related Topics:

Comparing statement sets

Importing statement sets from SAP Solution Manager

Importing statement sets from CSV

Importing statements sets from BPM-Xchange

Copy data table values to statement links
Data held within selected data table attachment fields can be copied from activities to any linked statements across
a scope of diagrams for a nominated statement set.

Note: This operation is available to administrators and statement set managers only.

1. From the Tools menu choose Statement Links, then Copy Activity Data Tables to Statement Links.

2. Choose the statement set and data table to work with.

Note: The data table assigned to statement links for the selected statement set must be the same as the
data table that you are working with. If no data table is currently assigned then the selected data table will be
automatically assigned to the selected statement set (as the data table associated with its statement links)
before copying the data over.

3. Choose the scope of diagrams for the operation, then click OK.

Related Topics:
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Copy statement links

Copy statement link data to activities

Store additional information with statement records

Copy statement link data to activities
Data table values from statement links (for a nominated statement set) can be copied to all linked activities across
a specified scope of diagrams. New data table attachments are created on any activities related to the statement
links. 

Note: This operation is only available to administrators and statement set managers.

1. From the Tools menu choose Statement Links, then Copy Statement Link Data to Activities.

2. Choose the statement set to copy data from.

3. Choose the scope of diagrams for the operation.

4. Click OK.

Related Topics:

Copy statement links

Copy data table values to statement links

Store additional information with statement records

Statement Set Tools

Compare statement sets
Statement sets can be compared for differences. This is particularly useful for statement sets imported from SAP
Solution Manager, for example, as it allows you to view the differences between a current project structure and
the original blueprint structure.

Statement names are compared by default and the following criteria can be compared:

· Statement Descriptions

· Statement Attachments

· Statement Statuses

· Statement Styles

To compare two statement sets:

1. From the Tools menu choose Statement Sets.

2. Select the statement set that you want to compare, then from the Tools menu choose Compare.

3. Ensure that Compare Statement Sets is selected. 

4. Click Select  for the Target Statement Set.

5. Click the Criteria tab and select or deselect any of the statement set criteria to compare.

6. Click OK.

To compare two statements:

1. From the Tools menu choose Statement Sets.

2. From the Tools menu choose Compare.

3. Select Compare Individual Statements.

4. Click Select  and select the source and target statements from the relevant statement sets.
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5. Click OK.

Comparison Report

A report is generated that displays any differences between the two statement sets. Right-click any row to
view a difference log, the properties of the source or target statement, or to expand or collapse any child
statements belonging to a particular parent statement.

Color codes

No change

Changed

Target/source statement not found

Related Topics:

Copying statement links between statement sets

Importing statement sets from SAP Solution Manager

Importing statement sets from CSV

Importing statements sets from BPM-Xchange

Import SAP usage data
SAP Solution Manager-based statement sets can be updated with information on SAP transaction usage by users.
This information can be captured from a SAP profiling service and used to supplement an existing SAP Solution
Manager statement set. Two fields will be added to the statement set's associated data table - Used (indicates
whether or not a SAP transaction has been used) and Monthly Frequency (displays the total monthly usage
across all instances of the SAP transaction).

Note: The SAP profiling service is provided by TIBCO Nimbus' partners ECL and HRW. Profiling involves
analyzing the SAP system audit trail data and generating reports to meet customers' needs. A data file can also
be generated and imported into TIBCO Nimbus.

SAP End User Roles (Actual) Statement Set

When SAP usage data is first imported, an additional statement set will be created - 'SAP End User Roles (Actual)
- <Statement Set>. This statement set is essentially a list of SAP user names derived from the import file. The
statements will be linked to the appropriate SAP transaction-type statements in the specified SAP Solution
Manager-type statement set. For subsequent data imports, the statement set will be updated.

Reporting

A report is available which is based on activity statement links to the selected SAP Solution Manager-type
statement set, including any linked statements, i.e. the SAP End User Roles (Actual) - <Statement Set>
statements. When viewing the SAP Solution Manager-type statement set, from the Tools menu choose Reports,
then choose SAP End User Roles (Actual).

1. In the Statement Sets dialog, from the File menu choose Import from SAP Usage.

2. Click Browse  to select the data file to import.

3. Choose the SAP Solution Manager statement set to apply the SAP usage data to.

4. Click OK.
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Creating Maps from Statements Sets

Create a map from a statement set
Maps can be created from all statements in a statement set or from a subset of statements. Activity statement
links, flow lines between activities and activity data table attachments can be included in the generated map.
First-level statements will form the first-level map and sub-statements will create child diagrams from the
respective activities.

1. From the Tools menu choose Statement Sets.

2. Double-click the statement set that you want to create a map from.

3. From the Tools menu choose Build Map.

4. Select the options on the General tab that are to be included in the map.

Create statement links on each activity links each activity directly to the corresponding statement in
the map (use the Additional tab to set the initial values for the statement link data fields).

Create flow lines between activities will link all activities with flow lines in the order that they appear in
the list.

Create a data table attachment on each activity will create data table attachments on each activity for
any data tables associated with statements.

Create SAP transaction links for transaction nodes will convert transaction node statements into
transaction links on the parent activity. If this option is disabled then transaction node statements will be
created as individual activities in lower-level diagrams.

5. Choose the scope of statements to create the map from.

All child statements of selected statement will create a map from the child diagrams of the statement
that was highlighted when the Build Map option was selected (but does not include the actual highlighted
statement).

All statements will create a map from all statements in the statement set.

6. From the Style panel, choose the style sheet and template to apply to the map. Note: These are optional.

7. If you have chosen to create statement links on each activity then you can set the values for the statement
link data fields in the Additional tab.

Related Topics:

Creating a statement set from a map

Creating Statement Sets from Maps

Creating Statement Sets from Maps
Statement sets can be created and updated from process maps.

Business Rules:

· You must have a map open at the top-level source diagram (i.e. the diagram that will be level 1 of the
statement set)

· When creating a new statement set, activities in child diagrams will be created as child nodes in the
statement set (for example, the first activity in the child diagram to the current top-level diagram will be
statement number 1.1)

· Statement names must be unique, therefore if duplicate text exists on activities, incremental numbers are
appended onto duplicate statement names

· The activity's list of resources and information in any notes bubbles are imported into the statement's
descriptions

· When updating a statement set, all existing imported attachments will be removed in the statement set and
replaced by the attachments in the map

· A backup of the existing statement set is taken and stored in ...\System\Statements\Backup\
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To create a new statement set from a map:

1. From the Tools menu choose Statement Sets.

2. From the File menu choose Import from Map.

3. Click in the Statement Set Name text box and enter a name for the statement set that you are creating.

4. Select or deselect the following options:

Copy attachments from Activities to Statements will copy attachments from the activities in the map
to the related statements

Create statement links on imported activities will create statement links between the imported
activities and their corresponding statement nodes

5. Choose the scope of diagrams to create a statement from, then click OK

To update an existing statement set from a map:

1. In the Statement Sets window, from the File menu choose Import from Map.

2. Select Update existing statement set.

3. From the Statement Set drop-down list choose the statement set that you want to update.

4. Select or deselect the following options:

Keep deleted statements will keep any statements in the existing statement set that don't correspond
to an activity in the map

Keep a copy of the existing version will make a backup of the existing statement set before updating
it

Copy attachments from Activities to Statements will copy attachments from the activities in the
map to the related statements

Create statement links on imported activities will create statement links between the imported
activities and their corresponding statement nodes

5. Choose the scope of diagrams to update the statement set from, then click OK

Related Topics:

 

Creating a map from a statement set

Auditing and Reporting

Add a statement change log
Statements are tracked using change logs. Statement managers and administrators can also manually add,
delete and modify manual change log records. Records are automatically created for the following actions:

· Statement creations

· Statement name changes

· Statement status changes

· Data table field value changes

1. From the Tools menu choose Statement Sets.

2. Double-click the relevant statement set, then select the statement that you want to create a log against.

3. From the Tools menu choose Change Log.

4. Click Add.



Statement Sets

TIBCO Nimbus® User Guide Page 342

5. Enter the details of the change and click OK.

Add a statement audit record
Audit records can be associated with statements to track information relating to compliance audits. Only
administrators and statement set managers can add statement audit records.

Two types of audit records exist:

· Statement audit records (these relate directly to a statement)
· Activity/statement link audit records (these relate to the activity in which a statement is linked

1. From the Tools menu choose Statement Sets.

2. Double-click the relevant statement set, then select the statement that you want to create an audit record
for.

3. From the Tools menu choose Audits.

4. Click New statement audit .

5. In the General tab choose a status and enter a description for the statement audit.

6. In the Additional tab enter, or select, any further information relating to the audit record.

7. In the Attachments tab attach any documents that provide further information relating to the audit record.

8. Click OK.

Audit Logs

When any field in an audit record is changed, an audit log is automatically generated. Audit logs cannot be
modified by any user and logs will store the date, time and description of the change. To view the audit log
for a particular statement audit record, right-click the statement link audit record and choose Properties,
then click the Audit Log tab.

Add a statement link audit record
Audit records can be added to statement links to ensure that all related information is stored in the context of the
statement link.

Important Note: You can only add audit records to statement links in master maps.

1. Right-click the statement link on the activity and choose Access/Modify.

2. Select the statement link and from the Tools menu choose Audits.

3. From the File menu choose New.

4. Choose an audit status from the Status drop-down list.

5. Enter any details of the audit record in the Description text box.

Accessing statement link audit records

Audit records can be quickly accessed from reports that display statement audit links for a particular
statement set, for example the Activity Statement Link Audits report. After generating the report, right-click an
activity statement link audit record and choose Open Audit Record.

 
Audit Logs

When any field in an audit record is changed, an audit log is automatically generated. Audit logs cannot be
modified by any user and logs will store the date, time and description of the change. To view the audit log for
a particular statement link audit record, right-click the statement link audit record and choose Properties,
then click the Audit Log tab.
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Create an audit status
You can apply a status to statement audit records and statement link audit records.

1. From the Tools menu choose Statement Sets.

2. From the Tools menu choose Audit Statuses.

3. From the File menu choose New.

4. Enter a name for the audit status and click OK.

Related Topics:

Adding statement link audit records

Adding statement audit records

Creating statement statuses

Viewing audit records
A quick way to view statement audit records and activity statement link audit records is through the Statement
Compliance Report and the Statement Link Audits reports.

1. Run a Statement Compliance Report or a Statement Link Audits report.

See Generating a report for more information.

2. Do one of the following:

· If you ran a Statement Compliance Report, right-click a statement and choose Statement Audits.

OR

· If you ran a Statement Link Audits report, right-click an activity statement link record and choose 
Open Audit Record.

Related Topics:

Adding statement link audit records

Adding statement audit records

Generating a report

Run a statement set report
There are a number of reports that can be run against a particular statement set.

To run a statement set report:

1. From the Tools menu choose Statement Sets.

2. Double-click a statement set to open it.

3. Do one of the following:

· If you are reporting on all statements in the statement set, from the Tools menu choose Reports.

· If you are reporting on a single statement, or a statement and associated child statements, first click
the statement to select it, then from the Tools menu choose Reports.

4. Select the report criteria from the following:
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Report requires you to select the report type to run (Hint: click a report type to display a description of
the report in the Report Description field below).

Status allows you to specify a particular statement style to report on, i.e. only statements with a
selected statement will be returned in the report.

Scope allows you to report on all statements in the statement set, a selected statement or a selected
statement and associated child statements (Note: If you did not select a statement in Step 3, you can
only report on all statements within the statement set).

5. Click OK to run the report.

Note: If the statement set is associated with one or more data tables, a Data Report Wizard dialog will be
displayed. This allows you to filter any of the data table fields in the generated report. Double-click a field
that you want to filter, then choose a filter operator and enter a filter value. Click OK to apply the filter.
Repeat this process for other fields, as required, then click Generate Report.

Statement and Statement Link Audit Records

You can view all audit records for a particular statement from certain reports by right-clicking the statement and
choosing Statement Audits. For reports that include information about audit records, such as the Statement
Audits report, you can open and edit an audit record by double-clicking it.
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About data tables
A data table is a flexible way of capturing data significant to a process and within the context of activities, for
example business requirements, system details used to perform activities, KPIs (Key Performance Indicators),
audit results, RACI charting (Responsibility, Accountability, Consult, Inform), etc. Values within data tables can
also be used to define business control points and data tables can also be used to provide additional information
for action items and change requests.

Creating Data Tables

Manage data table folders
Data tables can be organized in folders. To create and edit data table folders you must either be an administrator
or a data tables manager. 

To create a data table folder:

1. From the Tools menu choose Data Tables > Data Tables.

2. From the File menu choose Add New Folder.

Note: To create a sub-folder, ensure the parent folder is selected before creating the new folder.

3. In the Folder Name field, enter a name for the folder.

Note: By default, all users will have read/write access to the data table folder. This means that all users will
be able to view and edit the data table folder.

To modify access rights on the folder:

4. Click the Folder Access tab.

5. In the Default Access panel, select the default access rights for all users.

Read and write allows users to view and edit a data table folder (note that only data table managers, data
table administrators and administrators can edit data table folders).

Read only allows users to view but not edit a data table folder.

Access Denied prevents users from viewing and editing a data table folder.

In the Specific User Access panel you can assign access rights for specific users and/or user groups.

6. Click Add  to find and add users and/or user groups. For more information on adding users, see Selecting
Users.

7. After you have assigned users/user group permissions, click OK.

To edit a data table folder:

If you have read/write access to a folder you can rename a folder and update the access rights.

1. From the Tools menu choose Data Tables>Data Tables.

2. Select the folder that you want to edit and from the File menu choose Edit Selected Folder.

To delete a data table folder:

You must have read/write access to a folder to be able to delete it. Note that you can only delete empty folders so
if any data tables exist within the target folder they must either be moved or deleted first.

1. From the Tools menu choose Data Tables>Data Tables.

2. Select the folder that you want to delete and from the File menu choose Delete Selected Folder.

Related topics

Creating data tables
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Create a data table
To create data tables you must be an administrator or data tables manager.

Note: Any changes to a data table definition are recorded in the Data Table audit log.

To create a data table:

1. From the Tools menu choose Data Tables>Data Tables.

2. Click Add.

Note: To create a data table within a data table folder, you must first select the folder before clicking Add. 

3. Enter a name for the table and a comment to describe it.

To add data table fields:

4. To add a data table field click Add .

5. Enter a name for the field and choose a data type, then click OK.

Note: See Data Formats below for more information on the available data types.

To assign data table definition access rights:

Data table definition access rights govern who can view and edit the data table definition.

6. Click the Definition Access tab.

7. In the Default Access panel, select the default access rights for all users.

Read and write allows users to view, edit and delete a data table definition (note that only data table
managers, data table administrators and administrators can edit and delete data table definitions).

Read only allows users to view but not edit a data table definition.

Access Denied prevents users from viewing and editing a data table definition.

In the Specific User Access panel you can assign access rights for specific users and/or user groups.

8. Click Add  to find and add users and/or user groups. For more information on adding users, see Selecting
Users.

9. After you have assigned users/user group permissions, click OK.

To assign attachment update rights:

Attachment update rights govern who can view, edit and add records to the data table definition when it is
attached to an object (such as an activity).

10. Click the Attachment Update Rights tab

11. In the Set Access Rights for this Data Table's Attachments panel, select one of the following options:

Duplicate will assume the same access rights as defined for the data table definition in the Definition Access
tab.

Custom will allow you to assign custom access rights for users and/or user groups. If this option is selected,
you can specify the default access rights and also specific access rights for users and/or user groups.

Read and write allows users to view, add, edit and delete records for the data table attachment.

Read only allows users to view data table attachments.

Access Denied prevents users from viewing and editing a data table attachment.

To define storyboard playback behavior:

The options on this tab allow you to choose whether to create a live link to the data table in storyboards
(thereby allowing users to add and edit data in the data table definition) or to store a cached copy
(preventing users from adding and editing data in the data table definition).

12. Click the Storyboard Playback Behaviour tab and choose one of the following options:

Maintain live links to attachments of this data table for published storyboards will allow users
with the required access rights to edit and update the data table attachment from storyboards.
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Store a static copy of any attachments of this data table for published storyboards will store a
static copy of the data table attachment. Users will not be able to update or edit the data table attachment
from storyboards.

13. Click OK when you have finished defining the data table.

Data Formats

The data type is the format of the data that users can enter for a particular field. The following data formats
are available:

Alpha is any format.

Calculated displays a calculation between the values of two specified data table fields (integer, decimal
or other calculated field) within the same data table (see below for more details).

Date allows date values to be entered (see below for more details).

Decimal allows numerical values to be entered (see below for more details).

Integer allows whole numbers to be entered.

On or Off allows On or Off values to be selected.

Popup List allows a value from a predefined list to be selected.

Resource allows central resources to be selected.

Resource Group allows resource groups to be selected.

Short Alpha allows up to 50 character strings to be entered.

Time allows time values to be entered.

True or False allows True or False to be selected.

URL web address allows URLs, i.e. web addresses, to be entered.

User allows user accounts to be selected (see below for more details).

User Group allows user groups to be selected.

Yes or No allows Yes or No to be selected.

Decimals and integers require you to specify a unit and  the position of the unit (for example, a £
integer should appear on the left of the value, whereas a % should appear on the right). You can also
enter your own unit symbol by typing in the Units Of drop-down list.

For calculated data types you can set the unit of measurement and which side of the value to display
the unit on, as well as the number of decimal places to display. The expression box is where you define
the value that you want to obtain. Arithmetic operators that can be used are Add (+), Subtract (-),
Multiply (*) and Divide (/). For example, <Field A> + <Field B> or <Field C> * <Field D> or <Field E> /
<Field F>. A number of Jscript functions/methods can also be used to build expressions. In the Field To
Insert box you can select an existing data table field (only integers, decimals and other calculated fields
will be displayed) to add to the expression - place the cursor in the position of the expression where you
want to add the field, then click a field from the Field To Insert list to select it and click Insert.

Date fields can be set to automatically populate with the current date when users add a data table
attachment record in the Client or Web Server (Default to Current Date).

User fields can be set to automatically populate with the current user when users add a data table
attachment record in the Client and Web Server (Default to Current User).

Mandatory Field requires users to enter data for the data field when data is added to the table. If a data
table is displayed on a diagram then checking the Visible In Display Box check box will display the data
field.

Resource fields can only be made mandatory fields when at least one central resource exists in the process
repository. The same applies for resource group fields.

Popup Lists are predefined lists. See defining pop-up lists for more information.

Related topics

Manage data table folders

Defining pop-up lists

Attaching data tables to diagrams

Entering data in to a data table
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Displaying data tables on diagrams

Popup Lists

Define a popup list

This is a data table field type that allows users to select a value from a predefined list. Nested pop-up lists can be
created, for example, you might have a parent data field listing the different departments within an organization,
then a second child data field listing the different roles within each department.

Note: Data table managers and administrators can add items to a pop-up list when adding data table records to
a data table.

1. From the Tools menu choose Data Tables, then Data Tables.

2. From the File menu choose Popup List Definitions.

3. Click Add New List and enter a name for the list.

Note: To define a child pop-up list you must have the parent list highlighted when you click Add New List.
Then select the Depends on Parent check box.

4. Click  Add Item to add items to the pop-up list.

5. Enter a value for the item and click OK.

6. Repeat steps 4-5 for each item that you want to add.

Popup Lists

If the list is long, consider sorting it to allow users to find items more easily. Click Sort  to toggle the list.

You can import a pop-up list (.csv or .txt) by clicking Import items from file .

Related topics

About data tables

Creating data tables

Creating data table records

Editing pop-up lists

Deleting pop-up lists

Edit a popup list

1. From the Tools menu choose Data Tables, then Data Tables.

2. From the File menu choose Popup List Definitions.

3. You can edit the following:

· To rename the pop-up list click the list to select it and click Edit.

· To add an item select it and click  Add Item.

· To remove an item select it and click   Remove Item.

Note: Data table managers and administrators can add items to a pop-up list when adding data table
records to a data table.

Related topics
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Deleting pop-up lists

Creating data tables

Delete a popup list

 

1. From the Tools menu choose Data Tables, then Data Tables.

2. From the File menu choose Popup List Definitions.

3. Select the pop-up list and click Delete List.

Attaching Data Tables

Attach a data table to a diagram object
Attach a data table to an activity, for example, to allow users to record captured data associated with a particular
activity.

1. Right-click the object and choose Attachments/Links.

2. Click New and choose Data Table.

3. Click the data table to select it and then click OK.

If you have the required access rights you can add data records to the data table attachment. See Add or edit
a data table record for more information.

4. Click Close.

Related topics

About data tables

Creating data table records

Copying data table records

Displaying data tables on diagrams

Display a data table on a diagram
The data from the first data field of a data table can be displayed on a diagram.

1. Right-click the object and choose Attachments/Links

2. Double-click the data table to access it.

3. From the Options menu choose Display on Diagram.

Note: Only one data table can be displayed at any one time.

Related topics
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About data tables

Creating data tables

Attaching data tables to diagram objects

Creating data table records

Copying data table records

Display or hide a data table
A specific data table can be displayed or hidden in a scope of diagrams.

1. From the Tools menu choose Data Tables, then choose Show/Hide.

2. From the Data Tables drop-down list choose a data table.

3. Choose a scope of diagrams to show or hide the data table for.

4. Choose Show or Hide, then click OK.

Rename a data table

1. From the Tools menu choose Data Tables > Data Tables.

2. Select the System Tables Folder.

3. Double-click the data table you want to amend.

4. On the definition tab click in the Table Name field and edit as required.

5. Click OK.

Adding and Editing Data Records

Add or edit a data table record
Data table records can be added and edited in the client and web server, in both draft and master diagrams.

! If all records in the data table are marked with a ! then the data table has been removed from

the draft version and will therefore be deleted upon promotion. Adding or editing records in the
master version will reattach the data table in the draft version, therefore please contact the
process author before adding or editing records.

Note: Data table values can also be edited from a data table report. See Generate a data table report for more
information.

Note: In order to add a resource to the data table they must exist in the resource library.  For more information
see Add a resource.

1. Right-click the object and choose Attachments/Links

2. Double-click the data table to access it.

3. Either click Add to add a new record, or double-click an existing record to edit it.
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To view who created the data table record, and who last modified it, click Show record information
(Process Authors only).

4. Enter or modify any of the fields, as required.

Display this record when table is shown on the diagram will display the first field's data, or as much
as possible, if the data table is selected to be displayed on the diagram. See Displaying a data table on a
diagram for more information.

5. Click Save & Close, Save & Copy or Save & New.

The order of records can be altered by selecting a record and clicking  or .

Mandatory fields are denoted by * following the field name. These fields must be completed.

Adding Popup Items 'On The Fly'

Data table managers and administrators can add and remove items in pop-up lists when entering data into a
data table, i.e. without having to edit the data table directly.

1. When creating a data table record (as above), in the Data Entry dialog click .

2. Select the popup list that you want to edit from the Popup Lists.

3. Do one of the following:

· Click Add Item  to add an item to the pop-up list.

· Select an item and click Remove Item  to remove an item from the pop-up list.

Related topics

About data tables

Attaching data tables to diagram objects

Copying data table records

Displaying data tables on diagrams

Copy data table records
Data table records can be copied and pasted between data table attachments on different objects.

Note: The data table that you are copying to must contain the same data table field that you are copying from.

1. Right-click the attachment/link icon and choose Access/Modify.

2. Select the data table attachment and click Access.

3. Right-click the data table record that you want to copy and choose Copy.

4. Access the data table attachment for the data table that you want to paste the record into.

5. Right-click in the data table attachment and choose Paste.

Related topics

About data tables

Creating data tables

Attaching data tables

Displaying data tables
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Editing Data Tables

Edit a data table
Data tables can be edited, for example to add new fields or to change access rights. To edit a data table you must
be a data tables manager and have read/write access rights to the data table. Alternatively, administrators and
data table administrators have full access to all data tables, irrespective of access rights.

1. From the Tools menu choose Data Tables>Data Tables.

2. Right-click the data table and choose Edit.

Deleting Data Tables, Fields and Attachments

Delete a data table
You can delete a data table definition. There are two methods; the first will create a soft deletion which can be
recovered if required. The second method will permanently delete a data table. To delete data tables you must be
a data tables manager and have read/write access rights to the data table. Alternatively, administrators and data
table administrators have full access to all data tables, irrespective of access rights.

To delete a data table:

This method will provide a soft deletion and prevent the data table from being accessed. Note that any data table
attachments that point to the deleted data table will no longer work. Data tables deleted using this method will not
be permanently deleted and can be recovered. See Recover a deleted data table for more information.

1. From the Tools menu choose Data Tables > Data Tables.

2. Click the data table that you want to delete, and then click Delete.

To permanently delete a data table:

This method will permanently delete a data table. Data tables deleted through this method cannot be retrieved,
except via a system restore from a previous backup.

1. From the Tools menu choose Data Tables > Data Tables.

2. From the File menu choose Data Table Recovery Manager.

3. Click the data table that you want to permanently delete, and then click Delete.

Delete a data table field
When data table fields are deleted from a data table definition, the system will perform a soft deletion. This allows
the field to be recovered from the Data Table Recovery Manager. You can permanently delete a data table field
from a data table if required.

To permanently delete a data table field:

This method will permanently delete a data table field. Data table fields deleted through this method cannot be
recovered.

1. From the Tools menu choose Data Tables > Data Tables.

2. Double-click the data table to view it.

3. Click the Deleted Fields tab to select it.

4. Select the data table field that you want to permanently delete, and then click Delete.
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Delete a data table attachment
When data table attachments are deleted from objects, the system will perform a soft deletion. This allows the
attachment to be recovered from the Data Table Recovery Manager. You can permanently delete a data table
attachment if required.

To permanently delete a data table attachment:

1. From the Tools menu choose Data Tables > Data Tables.

2. From the File menu choose Data Table Recovery Manager.

3. Click the Attachments tab.

4. Select the data table attachment that you want to permanently delete, and then click Delete.

Recovering Deleted Data Tables, Fields and Attachments

Recover a deleted data table
You can recover a deleted data table definition (assuming the data table has not been permanently deleted).

To recover a deleted data table:

1. From the Tools menu choose Data Tables > Data Tables.

2. From the File menu choose Data Table Recovery Manager.

3. Select the data table that you want to recover, and then click Recover.

Recover a deleted data table field
You can recover any deleted fields within a data table definition (assuming the fields have not been permanently
deleted).

To recover a deleted data table field:

1. From the Tools menu choose Data Tables > Data Tables.

2. Double-click the data table definition to open it.

3. Click the Deleted Fields tab to select it.

4. Select the field that you want to recover, and then click Recover.

5. Repeat step 4 for each field that you want to recover, and then click OK.

Recover a deleted data table attachment
You can recover deleted data table attachments that have not been permanently deleted.

To recover a deleted data table attachment to the original object:

1. From the Tools menu choose Data Tables > Data Tables.

2. From the File menu choose Data Table Recovery Manager.

3. Click the Attachments tab to select it.

4. Select the data table attachment that you want to recover, and then click Recover.

5. Ensure The Original Location is selected, and then click Recover.

To recover a deleted data table attachment to a different object:

1. From the Tools menu choose Data Tables > Data Tables.
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2. From the File menu choose Data Table Recovery Manager.

3. Click the Attachments tab to select it.

4. Select the data table attachment that you want to recover, and then click Recover.

5. Select A New Location.

6. In the Diagram Selector window, first select the map, and then select the diagram, and then click OK.

7. In the Object Selector window, select the diagram object which you want to recover the object to, and then
click Finish.

Viewing Audit Logs

View the data table audit log
When a new data table definition is created, or an existing modified, the changes will be recorded in a data table
audit log.

1. From the Tools menu choose Data Tables then Data Tables.

2. From the Tools menu choose Audit Log.
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About scorecards
Scorecards provide cost-effective business insights that empower employees to make more efficient decisions,
such as communicating strategic objectives through Key Performance Indicators (KPIs). Scorecards in TIBCO
Nimbus  are used to bridge processes with measures and drive the understanding of respective metrics, both in
terms of the operational process and to sanity check the metrics in context of the end-to-end processes. 

Scorecards are registered in TIBCO Nimbus and can be Microsoft Excel file formats (xls, xlt, xlsx, xlsm, xlsb,
xltx, xltm), Salesforce.com Dashboard scorecards or web archive files (mht) that can be viewed and utilized
through the TIBCO Nimbus web environment. Attachments can also be added to a scorecard to provide
supporting information.

To utilize the full potential of scorecards in TIBCO Nimbus it is recommended that you contact your TIBCO
Nimbus account manager to arrange training.

Scorecard Roles

Assign a scorecard manager
The scorecard manager role is available to process authors only and provides them with full scorecard
administrative rights. Scorecard managers can modify scorecard system options, create, edit and delete scorecard
folders, register and create new scorecards, edit and delete existing scorecards and launch scorecards. Note that
scorecard managers can only view scorecards that they have access rights to view.

Note: Administrators are scorecard managers by default.

1. From the Tools menu choose Users and then User Accounts.

2. Double-click the user.

3. In the Settings tab select the Scorecard Manager check box.

Related topics

About scorecards

Assigning scorecard editors

Assign a scorecard editor
The scorecard editor role is available to process authors and the role is assigned to these users by default.
Scorecard editors can edit and launch existing scorecards but cannot create or edit scorecard folders.

Note: Administrators are scorecard editors by default.

 

1. From the Tools menu choose Users and then User Accounts.

2. Double-click the user.

3. In the Settings tab select the Scorecard Editor check box.

Related topics

About scorecards

Assigning scorecard managers
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Modifying Scorecard Options

Modify scorecard system options
By default, TIBCO Nimbus uses a Scorecard Repository folder, located in the same location as the Process
Repository. The Scorecard Systems Options allows you to change the location of the Scorecard Repository and
define the file types of scorecards that can be registered. Scorecard templates can also be specified. TIBCO
Nimbus uses a simple .xlt file as the default template for creating new scorecards.

Note: Only administrators and scorecard managers can modify the scorecard system options.

1. From the Tools menu choose Scorecards.

2. From the File menu choose Administration and then Scorecard System Options.

General Tab

You can change the folder where scorecards are stored. If any scorecards exist in the
current folder then these should be manually copied to the new folder to allow you to link

to them in TIBCO Nimbus. To change the scorecard folder click Browse Folder .

The file types that users can select as scorecards can be added to or removed. Click Add

 to add a new file type or to remove an existing file type  select it from the list and
click Remove . 

Automatically display file selector when adding a new scorecard will force users
to select the scorecard file before they can define any scorecard properties when new
scorecards are added. If this option is not selected then the user will be taken directly to
the scorecard properties dialog.

New Files Tab

Scorecard templates are used to create new scorecards. Templates are simply Excel
spreadsheets or templates that are designed in Excel. To add a template click Add and to
remove an existing template, select the template and click Remove.

Related topics

About scorecards

Creating Scorecards

Register a scorecard
You can register Excel files, URLs, Salesforce.com dashboards and Oracle dashboards in TIBCO Nimbus.

To register an Excel-based scorecard:

1. From the Tools menu choose Scorecards.

2. From the Edit menu choose Register Existing File.

3. Click Browse  to locate the file.

File Types
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Files that can be used are Excel spreadsheets (.xls, .xlsx, .xlsm) Excel templates (.xlt, .xltx,
xltm) and MIMI HTML (.mht) files. The default file type is XLS when searching. To select
other file types, choose the file type from the Files of type drop-down list.

TIBCO Nimbus requires the file to be placed in the scorecard repository. You will be
prompted to move the file from its current location to the scorecard repository, or to make
a copy of it.

4. Choose the sheet if you are creating a scorecard from an Excel file.

5. Modify the details (title and owner), if required.

6. Enter a description for the scorecard.

7. To modify the access rights or add attachments, see below.

8. Click OK.

To register a URL as a scorecard:

1. From the Tools menu choose Scorecards.

2. From the Edit menu choose Register URL.

3. Enter the URL.

4. Modify the details (title and owner) if required.

5. Enter a description for the scorecard.

6. To modify the access rights or add attachments, see below.

7. Click OK.

To register a Salesforce.com Dashboard as a scorecard:

1. From the Tools menu choose Scorecards.

2. From the Edit menu choose Register Salesforce.com Dashboard.

3. Click in the Dashboard URL text box and enter the URL of the Salesforce.com Dashboard.

Note: The URL must be preceded by either HTTP:// or HTTPS://.

4. In the Details panel, specify a title for the scorecard and the owner.

5. Optional. Enter a description for the scorecard.

6. To modify the access rights or add attachments, see below.

7. Click OK.

To register an Oracle Dashboard as a scorecard:

1. From the Tools menu choose Scorecards.

2. From the Edit menu choose Register Oracle Dashboard.

3. Click in the Dashboard URL text box and enter the URL of the Oracle Dashboard.

Note: The URL must be preceded by either HTTP:// or HTTPS://.



Scorecards

TIBCO Nimbus® User Guide Page 358

4. In the Details panel, specify a title for the scorecard and the owner.

5. Optional. Enter a description for the scorecard.

6. To modify the access rights or add attachments, see below.

7. Click OK.

To modify access rights:

1. Click the Access tab

2. Choose the default access rights for all users.

Note: If you choose to restrict access to all users by default then you can grant access to specific users and
user groups in the next steps.

3. Click Add  to select a user or user group.

Note: By default, the user or user group is granted access to the scorecard. To deny access, double-click
the user or user group and select Access Denied.

To add attachments:

1. Click the Attachments tab, then click New . 

Note: For more information on attachments see About attachments and links.

To change the cover image:

1. Click the Cover Image tab, then click Load Image. 

Note: To return the image to the default image click Clear Image.

Related topics

About scorecards

Creating scorecard folders

Modifying scorecard system options

Create a scorecard
If you don't have a scorecard to register you can create a new one based on a scorecard template.

1. From the Tools menu choose Scorecards.

2. From the Edit menu choose Create New File.

3. Choose the scorecard template.

Note: See Modifying scorecard system options for information on adding new templates.

4. Enter a title for the file.

5. Modify the details (title and owner) if required.

6. Enter a description for the scorecard.
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7. To modify access rights or add attachments, see below.

To modify access rights:

1. Click the Access tab

2. Choose the default access rights for all users.

Note: If you choose to restrict access to all users by default then you can grant access to specific users and
user groups in the next steps.

3. Click Add  to select a user or user group.

Note: By default, the user or user group is granted access to the scorecard. To deny access, double-click
the user or user group and select Access Denied.

To add attachments:

1. Click the Attachments tab, then click New . 

Note: For more information on attachments see About attachments and links.

To change the cover image:

1. Click the Cover Image tab, then click Load Image. 

Note: To return the image to the default image click Clear Image.

Related topics

About scorecards

Registering scorecards

Creating scorecard folders

Modifying scorecard system options

Create a scorecard folder
Scorecard folders are used to organize scorecards and folder access rights can be setup to control the scorecards
contained within them. 

Note: When a new scorecard folder is created, it inherits the access rights of the parent folder.

1. From the Tools menu choose Scorecards.

2. From the Edit menu choose Create Folder.

3. Enter a name for the folder.

To assign access rights to the folder:

1. Click the Folder Access tab.

2. Choose the default access rights for all users.

Read and write allows users to create scorecards within the folder (assuming they are scorecard editors or
scorecard managers).
Read only allows users to view the folder and the scorecards within it.
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Access Denied prevents users from viewing the folder and any scorecards contained within it.

3. Click Add  to select a user or user group.

Note: By default, the user or group is granted access to the scorecard. To deny access, double-click the
user or group and select Access Denied.

Related topics

About scorecards

Creating scorecards

Assigning scorecard managers

Assigning scorecard editors

Defining scorecard access rights

Defining Access Rights

Define scorecard access rights
Access to a scorecard can be defined to grant or deny access to users and user groups.

More info on Access Rights...

1. From the Tools menu choose Scorecards.

2. Right-click the scorecard that you want to assign access rights for and choose Edit.

3. Click the Access tab.

4. Select the default access rights.

5. Click Add  to select a user or user group.

Note: By default, the user or group is granted read/write access to the scorecard. To deny or grant read-
only access, double-click the user or group and select Access Denied or Read Only.

Related topics

About scorecards

Creating scorecards

Registering scorecards

Creating scorecard folders
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Attaching Scorecards

Attach a scorecard
Scorecards can be linked to objects to provide user access. Note: Depending on the access rights on the
scorecard that you are attaching, some users may not have access to it.

 

1. Right-click the object and choose Attachment/Links.

2. Click New and choose Scorecard Link.

3. Select the scorecard that you want to link to and click OK.

4. Modify the scorecard's link title if required.

To assign access rights to the scorecard

1. Click the View Rights tab.

2. Choose the default access rights for all users.

3. Click Add  to select a user or user group.

Note: By default, the user or group is granted access to the scorecard. To deny access, double-click the
user or group and select Access Denied.  More info on Access Rights...

Associate an attachment or link with a particular language

By associating an attachment or link to a particular language, you can direct different attachments and
links to different users based on language. For example, you may have a document written in two
languages; in this instance you would add the document twice and associate the respective language to
each document. If an attachment or link does not exist for a particular users' locale then the default
attachment or link will be made available.

Click the Advanced tab and from the Language Tag drop-down list choose a language to associate with
the attachment/link.

Related topics

About scorecards

Removing scorecards

Launching scorecards

Remove a scorecard from a diagram

1. Right-click the attachment/link icon and choose Access/Modify.

2. Select the scorecard attachment and click Delete.
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Launching Scorecards

Launch a scorecard
Launching a scorecard will launch the scorecard in the default Windows application (URLs will launch in a web
browser for example and Excel scorecards in Excel).

1. From the Tools menu choose Scorecards.

2. Select the scorecard and from the Edit menu choose Launch Scorecard.

Related topics

About scorecards

Editing Scorecards

Edit a scorecard
You can edit the properties of a scorecard, for example to change the owner or change the reference sheet (for
Excel-based scorecards).

1. From the Tools menu choose Scorecards.

2. Select the scorecard and from the Edit menu choose Edit.

Related topics

Deleting scorecards

Defining scorecard access rights

Deleting Scorecards

Delete a scorecard
Deleting a scorecard will remove it from the scorecard repository. 

Note: Deleted scorecards cannot be retrieved.

1. From the Tools menu choose Scorecards.

2. Select the scorecard and from the Edit menu choose Delete.
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About My Searches

What is My Searches

My Searches is a powerful search facility in the Web that allows users to retrieve information (diagrams,
documents and storyboards) that is relevant to their roles. In turn, this assists process adoption throughout an
organization. This is achieved by associating keywords and additional filter groups with process content.

Note: Only master versions of diagrams and documents can be retrieved. You can disable the keyword search
facility in the web interface for a specific user group by deselecting the Keyword Search user group permission.

Keywords - What are they?

Keywords are used to drive search optimization in TIBCO Nimbus, and they are the foundation of the functionality
within My Searches. Keywords are not limited to single words, however, and a more accurate terminology would
be 'key phrases'. Therefore whenever we refer to 'keywords', we also mean 'key phrases'.

Keyword Taxonomy

You do not need a complex taxonomy (categorization) for keywords, and a few simple rules will help you when
deciding how to create and group keywords.

1. Create unique keywords that represent the key questions that users may ask

For example, a user might ask 'How do I raise a purchase order?'. It is recommended that you remove
the 'How do I' element to the phrase, since it adds no value to the keyword. In this example then, you
might create a keyword 'Raise a purchase order', or 'Raising a purchase order'.  You may also decide to
simplify it to 'Purchase order'. It all depends on the amount of content and how much granularity you
want to create. Whatever method you use, it needs to be consistent when creating keywords.

2. Use multiple keywords for the same topic if the subject has different labels within different
areas

If the company is multinational, you may need to create multiple versions of keywords and attach them to
specific content. For example, 'Holiday' and 'Leave' will cater for the differences between British and US
English.

3. Consider reverse cataloging so that similar items are grouped together in the drop-down
displays

It's useful to group similar items. For example, 'Leave - sick', 'Leave - parental', 'Leave - compassionate'.
However, do not use prefixes to denote groups of keywords, as that's what keyword groups are for. The
'Leave' options in these examples are HR processes and would ideally be grouped under the 'HR
Operational Processes' keyword group.

Keyword Groups

A keyword group is a set of keywords where the topics are related. They key differentiation is that keyword
groups are topically related, not organizationally. Keyword groups are associated with user groups, and it is user
groups where organizational relationships are created.

If you sort your keywords alphabetically, the keyword groups will emerge from the keywords. For example, in a
typical end-to-end process such as Lead to Cash, there may be topics related to Leads, Opportunities, Quotes,
Contract, Order Submission, Fulfillment, Billing and Collection. If you then have multiple keywords for each of
these Lead to Cash phrases, then they will be good keyword groups. However, if you only have single keywords
for each one then Lead to Cash becomes your keyword group, since there is no value in one-to-one groups and
keywords.

User Groups

User groups contain users, and by associating user groups with keyword groups, you can then expose relevant
content to the appropriate users. If you associate all keyword groups with the <Everyone> system user group,
then all users will see all keyword groups. However, My Searches already contains a feature that allows all users
to expand a search to include everything. Searches should be constrained to users' job roles to provide quicker
and easier searching within My Searches.

You may have one-to-one relationships between user groups and keyword groups, for example user group 'Sales'
and keyword group 'Sales. This is a valid user group to keyword group relationship, although you may also want to
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work at a greater level of granularity. In the Lead to Cash example, you might associate keyword groups 'Leads',
'Opportunities', 'Quotes', 'Contract' and 'Order Submission' with the user group 'Sales'. Then you might associate
the user group 'Back Office' with the keyword groups 'Order Submission', 'Fulfillment' and 'Billing and Collection'.
Note that the keyword group 'Order Submission' is associated with both user groups, as it represents a hand-off
point between the two user groups and therefore both groups will be interested in the same process.

Additional Filter Groups

This optional feature can be used to further refine search results, whilst also keeping your list of keywords as short
as possible. Imagine you have a generic question 'How do I prepare a quote?', but the content that you want to
deliver back varies according to a user's country. In this instance you would create an additional filter group called
'Country'. Users and content are then tagged with this additional filter group to indicate which country they belong
to (which could be more than one additional filter group if necessary). Then, when a user selects the keyword
'Preparing a Quote', the system will filter the results to match the user and content profiles, thereby delivering only
relevant content to the user.

In the absence of additional filter groups you would have to present a user with all results and hope that they
select the correct content, or you would need multiple keywords, for example 'Preparing a Quote - US', 'Preparing
a Quote - UK', 'Preparing a Quite - DE', and so forth. Using additional filter groups reduces the possibility of users
selecting the wrong content by some simple tagging, thereby creating predictability in your company's operation.
Note that if content is not tagged with an additional filter group then it will be available to all users, so it then
becomes universally available.

Keywords

Creating Keywords and Keyword Groups

Create keywords

Keywords can be created and grouped. For more information see About My Searches.

To create a keyword:

1. From the Search menu choose Keywords Library.

2. Click Add.

Note: To add a keyword directly to a keyword group, first select the keyword group.

3. In the Keyword text box enter the keyword.

4. To add a custom cover image for the keyword (this will be displayed in the Web Server), click the Cover
Image tab and click Load Image to browse and select an image to use.

5. Click OK to create the keyword.

Creating Keywords From Text

You can also add keywords to the Keywords library when defining the text for an object - highlight the text
that you want to add, right-click it and choose Add as Keyword. The keyword will also be automatically
assigned to the diagram.

Note: The Text dialog is the dialog that allows you to define text for activities, flow lines, free text and
notes.

Show example

The example below will add the word 'Check existing stock' to the keywords library and assign it to
the diagram.
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To create a keyword group:

1. From the Search menu choose Keywords Library.

2. Right-click in the left pane and choose Create Group.

3. Enter the group name and, if appropriate, a description of the group.

4. Click OK.

To add a keyword to a keyword group:

When a keyword is added to a keyword group it is copied, therefore keywords can exist in multiple keyword
groups.

1. Click and drag the keyword from the right pane onto the keyword group in the left pane.

To edit or delete keywords and keyword groups:

1. Right-click the keyword or keyword group and choose either Edit or Delete.

Import keywords

Keywords can be imported from a CSV file. TIBCO Nimbus also includes a predefined set of keywords, based on
the APQC (American Productivity and Quality Center) process classification framework, which can be imported
into the Keyword Library.

Note: The predefined keywords set may have been automatically imported as part of the installation process.

To import keywords from a CSV file:

Keywords can be imported into the main Keywords Library, or into keyword groups. If a single column exists then
the data will be imported into the Keyword Library as keywords. For example:

Keyword 1
Keyword 2
Keyword 3
etc...

If two columns of data exist, the first column is assumed to be the keyword group and the second column the
actual keyword. For example:
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Group 1,Keyword 1
Group 1,Keyword 2
Group 2,Keyword 3
etc...

Any subsequent columns of data will be ignored. If a keyword group does not exist then it will be created,
otherwise an existing keyword group will be updated. Keywords that already exist in the system will not be
duplicated.

1. From the Search menu choose Keywords Library.

2. From the File menu choose Import and then Import from CSV File.

3. Browse and select the CSV file to import, then click Open.

To import the predefined set of keywords:

1. From the Search menu choose Keywords Library.

2. From the File menu choose Import and then Import Predefined Keywords.

3. Click Yes to confirm.

Related topics

About My Searches

Copy keywords

Keywords can be copied across diagrams, documents and storyboards.

 

To copy keywords from a diagram:

1. From the Search menu choose Add Keywords To Diagram.

2. Select the keywords from the associated keywords.

3. Right-click in the Diagram Keywords panel and choose Pickup Keywords.

4. Open the Keywords dialog for the document or storyboard where you want to apply them.

5. Right-click in the associated keywords panel on the right and choose Apply Keywords.

To copy keywords from a document:

1. From the Documents menu choose Document Registry.

2. Find the document that you want to add a keyword to.

3. Right-click the document and choose Details.

4. From the Search menu choose Add Keywords to Documents.

5. Right-click in the Document's Keywords panel and choose Pickup Keywords.

6. Open the Keywords dialog for the diagram or storyboard where you want to apply them.

7. Right-click in the associated keywords panel on the right and choose Apply Keywords.

To copy keywords from a storyboard:

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the Edit menu choose Edit.

3. From the Search menu choose Add Keywords to Storyboard.
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4. Right-click in the Storyboard's Keywords panel and choose Pickup Keywords.

5. Open the Keywords dialog for the diagram or document where you want to apply them.

6. Right-click in the associated keywords panel on the right and choose Apply Keywords.

Related topics

About My Searches

Searching for keywords

Merge keywords

Two keywords can be merged if they are similar. When keywords are merged, the target keyword will acquire the
properties (created by and when) of the source keyword. Any diagrams, documents or storyboards linked to the
source keyword will be updated with the target keyword (if not already associated).

Note: Administrator function only.

To merge two keywords:

1. In the Keywords Library, right-click the source keyword and choose Select Item for Merge.

2. Right-click the target keyword and choose Merge with Selected Item.

Search for keywords

You can view which keywords are associated with which diagrams and documents. Alternatively, you can use the 
My Searches Console.

1. From the Search menu choose Keyword Search.

2. Choose the keyword group from the Keyword Groups drop-down list.

Note: You can filter the keywords by keyword group by choosing the keyword group from the Keywords
Group drop-down list.

3. In the Options panel select Diagram Search and/or Document Search.

4. If you are searching diagrams then select the scope of diagrams to search for in the Scope panel.

5. Click OK.

Note: You can navigate to the diagram or open the document by double-clicking it in the list. You can also
change the display of results - by default the results are grouped by Type. To group by a column header,
click and drag the column header onto the area above the column headers (to ungroup a column header
click and drag it from the groupings back onto the column headers).

Related topics

About My Searches

Copying keywords

Adding Keywords to Content

Add keywords to single diagrams, documents and storyboards

Keywords can be associated with diagrams, documents and storyboards. Note that you must have write access to
the content that you are adding keywords to.

Diagrams
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To add keywords to a single diagram:

1. From the Search menu choose Add Keywords to Diagram.

2. To add a keyword, select the keyword from the list of available keywords and click Add Keyword .

Note: You can select multiple keywords by holding Ctrl when selecting the keywords. You can filter the
keywords by choosing a keyword group from the group drop-down list. You can also search for keywords
using the Keyword Search field. As you start typing the list will be automatically filtered, so you may not
need to enter the full keyword.

To remove a keyword, select the associated keyword in the right-hand pane and click Remove Keyword

.

To add/remove keywords to a scope of diagrams see My Searches Advanced Wizard.

To add keywords to a scope of diagrams:

See My Searches Advanced Wizard.

Documents

To add keywords to a single document:

1. From the Documents menu choose Document Registry.

2. Find the document that you want to add a keyword to.

3. Right-click the document and choose Details.

4. From the Search menu choose Add Keywords to Document.

5. Select the keyword from the list and click Add .

Note: You can select multiple keywords by holding Ctrl when selecting the keywords. You can filter the
keywords by choosing a keyword group from the group drop-down list. You can also search for keywords
using the Keyword Search field. As you start typing the list will be automatically filtered, so you may not
need to enter the full keyword.

To remove a keyword, select the associated keyword in the right-hand pane and click Remove Keyword

.

Automatically associating keywords when documents are registered

Keywords can be associated with specific category items so that when a file is registered and categorized in the
Document Registry, any associated keywords will be automatically associated with the file.

1. From the Documents menu choose Document Registry.

2. From the File menu choose Administration and then choose a filter category.

3. From the File menu choose Properties.

4. Click the Keywords tab to select it.

5. Select the keyword from the list and click Add .

Note: You can select multiple keywords by holding Ctrl when selecting the keywords. To add all keywords

click Add All .

To add keywords to a scope of documents:

See My Searches Advanced Wizard.
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Storyboards

To assign keywords to a single storyboard:

Keywords can be associated with storyboards, allowing users to search for storyboards in the web server with
respect to specific keywords.

Note: Only administrators and process authors with write access can associate keywords with storyboards.

1. From the Tools menu choose Storyboards.

2. Select the storyboard and from the Edit menu choose Edit.

3. From the Search menu choose Add Keywords to Storyboard.

4. Select the keyword from the list and click Add .

 
Note: You can select multiple keywords by holding Ctrl when selecting the keywords. You can filter the
keywords by choosing a keyword group from the group drop-down list. You can also search for keywords
using the Keyword Search field. As you start typing the list will be automatically filtered, so you may not
need to enter the full keyword.

To remove a keyword, select the associated keyword in the right-hand pane and click Remove Keyword

.

Add keywords to multiple diagrams and documents

The My Searches wizard provides a quick and easy method to add and remove keywords and additional filter
groups for a scope of diagrams or documents in one operation.

To add/remove keywords for a scope of diagrams:

1. From the Search menu choose Diagram's My Searches Wizard.

2. Select either Add Keywords or Remove Keywords, then click Next.

3. Select the keywords from the list and click Add  or Remove .

Note: Hold Ctrl to select multiple keywords.

4. Click Next.

5. Choose the scope of diagrams to assign the keywords to.

Current Diagram is the current diagram only

Current Diagram And Lower Levels is the current diagram and all lower levels

Current Process Map includes all diagrams in the current process map

Diagram Scope List File includes diagrams within a diagram scope list (DSL) file

6. Click Finish.

To add/remove keywords for a scope of documents:

1. From the Documents menu choose Document Registry.

2. Search for the documents.

3. Select the documents that you want to add or remove keywords or user groups.

Note: Hold Ctrl to select multiple documents.

4. From the Search menu choose My Searches Wizard.
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5. Select either Add Keywords or Remove Keywords, then click Next.

6. Select the keywords from the list and click Add  or Remove .

Note: Hold Ctrl to select multiple keywords.

7. Select Selected Documents and click Finish.

Related topics

About My Searches  

Diagram's My Searches Settings

Document's My Searches Settings

Associating Keywords with Users

Add keywords to users

Associating keywords with users is achieved by associating keyword groups with user groups. Users within a
specific user group will then be able to filter their searches using associated keywords.

1. From the Tools menu choose Users and then User Accounts.

2. Right-click the group (left panel) and choose Associated Keyword Groups.

3. Select the keyword group from the All Keyword Groups panel and click Add Keyword Group .
Note: To remove an associated keyword group, click the keyword from the User Group's Associated

Keyword Groups and click Remove Keyword Group .

Related topics

About My Searches

Check a user's associated keywords

You can check what keywords are associated with a user's account.

1. From the Tools menu choose Users and then User Accounts.

2. Right-click the user and choose Properties.

3. Click Check this user's associated keywords .

Related topics

About My Searches

Associating user groups with keyword groups

Defining user group categories
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Additional Filter Groups

Define additional filter groups
Additional filter groups provides additional filtering in My Searches and allows you to further direct content to
relevant users. For more information see About My Searches.

Note: Up to five levels of categorization can be defined and a user group can only be assigned to one additional
filter group.

 

1. From the Tools menu choose Users and then User Accounts.

2. From the Group menu choose Additional Filter Groups.

3. Select the check boxes for the additional filter groups that you want to enable.

4. Rename each user group category, as required.

Note: If you want to allow users to filter by additional filter groups in the Fewer Options panel in My
Searches (as they can in the More Options panel), select Include in 'Fewer Options' panel for the filter
groups that you want to include. Note that additional filters are only displayed to users that are members of
the associated groups (as defined in step 6).

Enforce selection of Additional Filter Groups in the 'Fewer Options' panel will require users to
select additional filters when searching using the Fewer Options panel.

5. Click Edit Items.

6. Click and drag the user group that you want to associate on to the additional filter group.

7. Repeat Step 6 for all user groups that you want to categorize.

Related topics

About My Searches

Associate diagrams, documents and storyboards with additional filter groups

Add additional filter groups to single diagrams, documents and
storyboards

Additional filter groups can be associated with diagrams, documents and storyboards. Note that you must have
write access to the content that you are adding additional filter groups to.

Diagrams

To add additional filter groups to a single diagram:

1. From the Search menu choose Add Keywords to Diagram.
2. Click the Additional Filter Groups tab.

3. Select the additional filter group from the list and click Associate Selected User Groups .

Note: You can select multiple additional filter groups by holding Ctrl when selecting the groups.

To remove a group, select the associated group in the right-hand pane and click Remove Selected User

Groups .
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Documents

To add additional filter groups to a single document:

1. From the Documents menu choose Document Registry.

2. Find the document that you want to add an additional filter group to.

3. Right-click the document and choose Details.

4. From the Search menu choose Add Keywords to Document.

5. Click the Additional Filter Groups tab.

6. Select the additional filter group from the list and click Associate Selected User Groups .

Note: You can select multiple additional filter groups by holding Ctrl when selecting the groups.

To remove a group, select the associated group in the right-hand pane and click Remove Selected User

Groups .

Storyboards

To add/remove additional filter groups from a storyboard:

1. From the Tools menu choose Storyboards.

2. Double-click the storyboard to open it.

3. From the Search menu choose Add Keywords to Storyboard.

4. Click the Additional Filter Groups tab.

5. Select the additional filter groups from the list and click Associate Selected User Groups .

Note: You can select multiple additional filter groups by holding Ctrl when selecting the groups.

To remove a group, select the associated group in the right-hand pane and click Remove Selected User

Groups .

Add additional filter groups to multiple diagrams and
documents

The My Searches wizard provides a quick and easy method to add and remove keywords and additional filter
groups for a scope of diagrams or documents in one operation.

Diagrams

To add/remove additional filter groups from a scope of diagrams:

1. From the Search menu choose Diagram's My Searches Wizard.

2. Select either Add Additional Filter Groups or Remove Additional Filter Groups, then click Next.

3. Select the additional filter groups from the list and click Add  or Remove .

Note: Hold Ctrl to select multiple additional filter groups.

4. Click Next.

5. Choose the scope of diagrams to associate the additional filter groups with.

Current Diagram is the current diagram only

Current Diagram And Lower Levels is the current diagram and all lower levels
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Current Process Map includes all diagrams in the current process map

Diagram Scope List File includes diagrams within a diagram scope list (DSL) file

6. Click Finish.

Documents

To add/remove additional filter groups from a scope of documents:

1. From the Documents menu choose Document Registry.

2. Search for the documents.

3. Select the documents that you want to associate with additional filter groups.

Note: Hold Ctrl to select multiple documents.

4. From the Search menu choose My Searches Wizard.

5. Select either Add Additional Filter Groups or Remove Additional Filter Groups, then click Next.

6. Select the additional filter groups from the list and click Add  or Remove .

Note: Hold Ctrl to select multiple additional filter groups.

7. Select Selected Documents and click Finish.

My Searches Console

My Searches Console
The My Searches Console provides administrators and authors with the ability to view and modify current My
Searches configuration settings. For more information see About My Searches.

To access the My Searches Console:

1. From the Search menu choose My Searches Console.

Note: To view and manage single keywords and user groups, ensure Search By Single Keyword/User
Group is selected in the File menu. Alternatively, to allow you to select multiple keywords and user groups
to view and manage, select Search By Multiple Keywords/User Groups.
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Keywords and Keyword Groups

To view what content is associated with single keywords:

1. From the File menu select Search By Single Keyword/User Group.

2. In the top panel click the Keywords and Keyword Groups tab. 

3. Select the keyword in the right-hand panel that you want to analyze.

Note: To view all keywords in the Keyword Library, select Keyword Groups (as shown below), or select a
keyword group to filter the list by keyword group.

4. In the bottom panel click one of the content-based tabs - User Groups, Keyword Groups, Draft
Diagrams, Master Diagrams, Master Documents, Storyboards or Scenarios.
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To view what content is associated with multiple keywords:

1. From the File menu choose Search By Multiple Keywords/User Groups.

2. In the top panel click the Keywords and Keyword Groups tab.

3. Hold Ctrl and select the keywords that you want to analyze.

4. In the bottom panel click one of the content-based tabs - User Groups, Keyword Groups, Draft
Diagrams, Master Diagrams, Master Documents, Storyboards or Scenarios.

Note: When reselecting keywords, click Refresh to update the associated items list in the bottom panel.

To add keywords to a diagram, document or storyboard:

1. Select the keyword that you want to add.

Note: To add multiple keywords ensure Search By Multiple Keywords/User Groups is selected in the
File menu, then hold Ctrl to select multiple keywords.

2. Select the respective content tab in the bottom panel - Master Diagrams, Master Documents or
Storyboards.

3. Click one of the following buttons (depending on the content tab you are viewing) - Add Diagram, Add
Document or Add Storyboard.
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To create a keyword:

1. Select the Keyword Groups root (shown below) in the left-hand panel, then right-click in the right-hand
panel and choose New.

To edit or delete a keyword:

1. Select the Keyword Groups root in the left-hand panel, then right-click the keyword in the right-hand panel
and choose either Edit or Delete.

Note: To delete multiple keywords ensure Search By Multiple Keywords/User Groups is selected, then
hold Ctrl to select multiple keywords.

To create a keyword group:

1. Right-click anywhere in the left-hand panel and choose Create Group.

To edit or delete a keyword group:

2. Right-click the keyword group in the left-hand panel and choose either Edit Group or Delete Group.

To add a keyword to a keyword group:

1. Select the keyword group from the left-hand panel.

2. Select the keyword in the right-hand panel.

Note: To add multiple keywords ensure Search By Multiple Keywords/User Groups is selected in the
File menu, then hold Ctrl to select multiple keywords.

3. Right-click a selected keyword in the right-hand panel and choose Add to Group.

4. In the Enter keyword text box, either choose an existing keyword or type a new keyword.

Note: You can also click and drag selected keywords from the Keyword Groups root or any keyword
group to another keyword group. This operation will copy the keywords to the new group. 

To remove a keyword from a keyword group:

1. Select the keyword group from the left-hand panel.

Note: To remove multiple keywords ensure Search By Multiple Keywords/User Groups is selected in
the File menu, then hold Ctrl to select multiple keywords.

2. Right-click the selected keyword(s) in the right-hand panel and choose Remove from Group.

Users and User Groups

To view what content is associated with single user groups:

1. In the top panel click the Users and User Groups tab. 

2. In the left panel select the user group that you want to analyze. 

3. In the bottom panel click one of the content-based tabs - User Groups, Keyword Groups, Draft
Diagrams, Master Diagrams, Master Documents, Storyboards or Scenarios.

To view what content is associated with multiple user groups:

1. From the File menu choose Search By Multiple Keywords/User Groups.

2. In the top panel click the User and User Groups tab.
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3. In the left panel, hold Ctrl and select the user groups that you want to analyze.

4. In the bottom panel click one of the content-based tabs - User Groups, Keyword Groups, Draft
Diagrams, Master Diagrams, Master Documents, Storyboards or Scenarios.

Note: When reselecting user groups, click Refresh to update the associated items list in the bottom panel.

Additional Filter Groups

To view what content is associated with additional filter groups:

1. In the top panel click the Additional Filter Groups tab. 

2. Select the user group that you want to analyze in the Additional Filter Groups panel on the right. 

3. In the bottom panel click one of the content-based tabs - User Groups, Keyword Groups, Draft
Diagrams, Master Diagrams, Master Documents, Storyboards or Scenarios.

To associate additional filter groups with a diagram, document or storyboard:

1. Select the user group in the Additional Filter Groups panel that you want to add. 

2. Select the respective content tab in the bottom panel - Master Diagrams, Master Documents or
Storyboards.

3. Click one of the following buttons (depending on the content tab you are viewing) - Add Diagram, Add
Document or Add Storyboard.

To add a user group to an additional filter group:

1. Click and drag the user group from the left panel on to an additional filter group in the right panel.

Note: You can also right-click the user group and choose Pickup, then right-click the additional filter group
and choose Apply.

To remove a user group from an additional filter group:

1. Right-click the user group in the Additional Filter Groups panel and choose Remove.
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About Collaboration
Collaboration allows users to assist in the promotion of change management and the continuous improvement of
processes. This in turn empowers employees and promotes the adoption of business processes within an
organization.

Feedback

Feedback allow users to provide feedback on diagrams, documents and storyboards. Users can also view and
reply to existing feedback from other users, thereby facilitating collaboration by allowing issues to be discussed
openly.

Reviews

Users can be requested to review diagrams and documents. Two types of review can be requested; ad hoc and
recurring reviews. Ad hoc reviews involve one review cycle and recurring reviews allow periodic reviewing of
content.

Actions

Actions provide the capability to enforce and measure a business' adoption of operational practices captured.
Actions are particularly relevant to self assessing a control structure against the risks and processes, as well as
providing a more granular checklist capability for more regular use. Actions can be created for diagrams and
documents (and also storyboards, metric links or actions not associated with content) and assigned to specific
users to undertake.

Acknowledgements

Users can be requested to formally acknowledge diagrams, documents and storyboards. This is useful, for
example, when changes are made to content and you need to prove that users have read and accepted the
changes. Users are required to enter their passwords when signing off an acknowledgement request. 
Administrators can view the status of all acknowledgement requests in the process repository - from the
Manage menu choose Acknowledgement Console.

The Collaboration Console
The Collaboration Console allows administrators, owners and authors to view and manage feedback, reviews,
actions and acknowledgement requests for diagrams, documents and storyboards.

Acknowledgement Console

Administrators can view the status of all acknowledgement requests in the process repository - from the
Manage menu choose Acknowledgement Console. In the console, click a hyperlinked number to view the
respective requests.

To access the Collaboration Console:

1. To access the Collaboration Console for a diagram or document, when viewing the diagram or the

document details, from the Manage menu choose Collaboration, or click  on the Diagram Control or
Document Control toolbar.

Note: To access the Document Details window, right-click the document and choose Details.

To access the Collaboration Console for a storyboard, in the Storyboard Edit window, from the File menu
choose Collaboration.

Note: To access the Storyboard Edit window, right-click the storyboard and choose Edit. Only
acknowledgements and actions apply to storyboards.
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To filter by user and/or status:

You can filter the view by either user and/or status. For example, you may want to view all current
acknowledgement To-Dos for a particular user, or all outstanding actions for a diagram.

1. Do one of the following:

To filter by user, choose <Select User> from the filter drop-down list. The Collaboration Filter window

opens. Click Select User   and select the user. You can also select to filter by status by selecting or
deselecting the statuses that you want to filter by. Click OK to run the filter.

To filter by status, choose <Select Status> from the filter drop-down list. The Collaboration Filter
window opens. Select or deselect the statuses that you want to filter by. Click OK to run the filter.

Note: To reset the current filter, choose <ALL> from the filter drop-down list. To change the current filter

options click .

Feedback

Create New
Topics

Create a new feedback topic. From the Feedback menu choose Start
New Topic.

Reply to
Topics

Reply to an existing feedback topic. Select the topic that you want to reply to
and from the Feedback menu choose
Reply To Topic.

Delete Topics Delete a selected feedback topic. Select the topic that you want to delete and
from the Feedback menu choose Delete.

Delete All
Topics

Delete all feedback topics for a diagram or
document.

Select the parent feedback node, or any
topic, and from the Feedback menu
choose Delete All.

Create a
Change
Request from
a Topic

Create a change request from a feedback
topic and all sub-feedback.

Select the topic and from the Feedback
menu choose Submit Feedback as
Change Request.

Print a
Feedback
Topic

Print selected a feedback topic. From the Feedback menu choose Print
Feedback.

Print All
Feedback
Topics

Print all feedback topics. From the Feedback menu choose Print All
Feedback.

Reviews

Assign
Reviewers

Assign reviewers to a scope of diagrams or
a document.

From the Reviews menu choose
Reviewers.
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Schedule a
Review

Schedule an ad hoc review for a scope of
diagrams or a document.

From the Reviews menu choose Schedule
Review.

Sign Off a
Review

Sign off a review request. Note that you can
only sign off your own review requests.

Right-click the review and choose Sign Off
Review.

Actions

Create an
Action

Create a new action for a diagram,
document or storyboard. More info...

From the Actions menu choose New
Action for Diagram/Document.

Update an
Action

Update the status of an action. Note that
you can only update an action that is
assigned to you. More info...

Right-click the action and choose Update
Action.

Acknowledgements

Assign
Acknowledge
rs

Assign acknowledgers to a scope of
diagrams, a document or a storyboard.

From the Acknowledgements menu
choose Acknowledgers.

Request
Acknowledge
ment

Request acknowledgement for a scope of
diagrams, a document or a storyboard.

From the Acknowledgements menu
choose Request Acknowledgement.

View the
Acknowledge
ment Log

View the acknowledgement log for a
diagram, document or storyboard.

From the Acknowledgements menu
choose Acknowledgement Log.

Reactivate
Last Request

Reactivate the last acknowledgement
request and set its status to 'Active'. Note
that this applies only if the last
acknowledgement request has been
completed or canceled.

From the Acknowledgements menu
choose Activate Last Request, or right-
click the last acknowledgement request in
the list and choose Set as Active.

Sign Off
Request

Acknowledge a scope of diagrams, a
document or a storyboard. Note that you
can only sign off a request that is assigned
to you.

Right-click the acknowledgement request
and choose Sign Off Acknowledgement.

Complete
Active
Request

Complete an acknowledgement group
request. Note that this will remove any
outstanding requests from users' To-Do
lists.

From the Acknowledgements menu
choose Complete active request, or
right-click the active acknowledgement
request and choose Set as Complete.

Cancel Active
Request

Cancel an active acknowledgement group
request, available to administrators, map
administrators, storyboard managers,
owners and authors. Note that this will
remove any outstanding requests from
users' To-Do lists.

From the Acknowledgements menu
choose Cancel active request, or right-
click the active acknowledgement request
and choose Cancel Acknowledgement
Request.

Recreate To-
Do

Recreate an acknowledgement To-Do item
in users' To-Do lists. This is used when new
acknowledgers are assigned. Note that this
only applies to active requests and for users
that have not yet acknowledged.

Right-click the user or user group and
choose Recreate To-Do. To recreate a To-
Do item for all users that have not yet
acknowledged an active request, right-click
the parent acknowledgement node and
choose Recreate To-Do.

Resend
Acknowledge
ment
Request

Resend an acknowledgement request
notification to users. This is used when new
acknowledgers are assigned. Note that this
only applies to active requests and for users
that have not yet acknowledged.

Right-click the user or user group and
choose Resend Acknowledgement
Request. To resend the request to all users
that have not yet acknowledged an active
request, right-click the parent
acknowledgement node and choose 
Resend Acknowledgement Request.

Change Due
Date

Change the due date for all users or
individual users of an active request. Note
that this only applies to users that have not
yet acknowledged.

Right-click the active acknowledgement
request, or an individual user or user group,
and choose Change Due Date. To change
the due date for all users that have not yet
acknowledged an active request, right-click
the actual acknowledgement request node
and choose Change Due Date.

Add
Acknowledge
rs

Add acknowledgers to an existing
acknowledgement request. Note that his
option only applies to active requests. A
different due date can be specified for new
acknowledgers added in this way. Users will

Right-click the active acknowledgement
request and choose Add Acknowledgers.
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be automatically notified and a new request
will appear in their To-Do lists.

Remove an
Acknowledge
r

Remove a selected acknowledger from a
diagram, document or storyboard. Note that
this only applies to active requests and for
users that have not yet acknowledged.

Right-click the user and choose Remove
Acknowledger.



Action Management

TIBCO Nimbus® User Guide Page 382

About actions
Actions can be created for diagrams, documents, storyboards and metric links, or general actions can be
assigned to users that are not associated with any content.

Note: Two roles exist that provide users with various privileges with regard to actions; Action Manager and
Action Creator. For more information see User Account Details.

Action Registry
The Action Registry provides a single interface to allow actions to be tracked and managed.

See Action Registry for more information.

My Actions
My Actions allows you to view and manage the actions that are assigned to you to undertake.

See My Actions for more information.

The Action Registry
The Action Registry allows you to track and manage current actions (diagram, document, storyboard, metric link
and general actions). If you are an administrator, an action manager or an action creator, then you can create and
modify actions through the Action Registry.

Note: You may not be able to view an action, depending upon the specific viewing rights.

To View Actions

To view all actions in the Action Registry ensure that there are no display filters specified and click Search.
Otherwise you can apply one or more filters to your search, such as the owner of the action, the current status,
etc. Double-click an action to view it.

Tell me more about the filters

Action Number allows you to filter by the unique action ID that is assigned to the action upon creation

Subject allows you to filter actions by text that appears in the subject of the action

Owner allows you to filter by the action owner

Assignee allows you to filter by any user(s) that are assigned to the action

Priority allows you to filter by action priorities

Status allows you to filter by active, completed and closed actions

Category allows you to filter by action categories

Comments allows you to filter by a word, or words, that appear in the comments

Due Date allows you to specify the action completion date

Export a list of actions

After conducting a search you can export the current list to either a .txt, .xls, .xml or .html file - from the File
menu choose Export Grid As Shown To.

Open the associated link

You can open the diagram, document, metric link or storyboard associated with a particular action. Right-click the
action and choose Open Host.

To Create Actions

The Action Registry allows you to create actions against diagrams, documents and metric links. General, i.e. non-
specific actions, can also be created.

1. Click New .

2. Select a type of action to create, then click Next.
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3. Expand the text below for the action type that you are creating:

General Action

4. Enter the properties of the action, then click Next.

Note: If you do not want to be the owner of the action then click Select  to specify a different
user.

5. To add assignees (users required to undertake the action) click Add. C lick Next to proceed.

6. To add editors (users permitted to edit the action) click Add. C lick Next to proceed.

7. To add viewers (users permitted to view the action, default is everyone) click Add. C lick Next to
proceed.

8. Enter a description for the action, such as the reason for it. C lick Next to proceed.

9. Fill out any additional information with respect to the action category (this step may not be
available). Click Next to proceed.

10. Fill out any additional information with respect to the action in general (this step my not be
available). Click Next to proceed.

11. Click New  to add any attachments to support the action. 

12. Add any reminders and escalations, then click Finish.

Diagram Action

4. Click Select and select a diagram, then click OK. C lick Next to proceed.

5. Enter the properties of the action, then click Next.

Note: If you want to assign a different owner to the action then click Select .

6. To add assignees (users required to undertake the action) click Add. C lick Next to proceed.

7. To add editors (users permitted to edit the action) click Add. C lick Next to proceed.

8. To add viewers (users permitted to view the action, default is everyone) click Add. C lick Next to
proceed.

9. Enter a description of the action, such as the reason for it. C lick Next to proceed.

10. Fill out any additional information with respect to the action category (this step may not be
available). Click Next to proceed.

11. Fill out any additional information with respect to the action in general (this step my not be
available). Click Next to proceed.

12. Click New  to add any attachments to support the action. 

4. Add any reminders and escalations, then click Finish.

Document Action

4. Click Select.

5. In the Document Registry, search for the document that you want to assign the action to, select it
and click Accept and Close , then click Next.

Hint: For information on searching for documents in the Document Registry see Finding documents.

6. Enter the properties of the action, then click Next.

Note: If you want to assign a different owner to the action then click Select .

7. To add assignees (users required to undertake the action) click Add. C lick Next to proceed.
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8. To add editors (users permitted to edit the action) click Add. C lick Next to proceed.

9. To add viewers (users permitted to view the action, default is everyone) click Add. C lick Next to
proceed.

10. Enter a description of the action, such as the reason for it. C lick Next to proceed.

11. Fill out any additional information with respect to the action category (this step may not be
available). Click Next to proceed.

12. Fill out any additional information with respect to the action in general (this step my not be
available). Click Next to proceed.

13. Click New  to add any attachments to support the action.

14. Add any reminders and escalations, then click Finish.

Storyboard Action

4. Click Select.

5. Select the storyboard to create an action against, then click OK.

6. Select the scope, click Next, then enter the properties of the action, and click Next again.

Note: If you want to assign a different owner for the action then click Select .

7. To add assignees (users required to undertake the action) click Add. C lick Next to proceed.

8. To add editors (users permitted to edit the action) click Add. C lick Next to proceed.

9. To add viewers (users permitted to view the action, default is everyone) click Add. C lick Next to
proceed.

10. Enter a description of the action, such as the reason for it. C lick Next to proceed.

11. Fill out any additional information with respect to the action category (this step may not be
available). Click Next to proceed.

12. Fill out any additional information with respect to the action in general (this step my not be
available). Click Next to proceed.

13. Click New  to add any attachments to support the action.

14. Add any reminders and escalations, then click Finish.

Metric Action

4. Click Select to select a diagram, then click OK. C lick Next to proceed.

5. Select the activity that as associated with the metric link that you want to assign an action to. Click 
Next to proceed.

6. Enter the properties of the action, then click Next.

Note: If you want to assign a different owner to the action then click Select .

7. To add assignees (users required to undertake the action) click Add. C lick Next to proceed.

8. To add editors (users permitted to edit the action) click Add. C lick Next to proceed.

9. To add viewers (users permitted to view the action, default is everyone) click Add. C lick Next to
proceed.

10. Enter a description of the action, such as the reason for it. C lick Next to proceed.

11. Fill out any additional information with respect to the action category (this step may not be
available). Click Next to proceed.

12. Fill out any additional information with respect to the action in general (this step my not be
available). Click Next to proceed.
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13. Click New  to add any attachments to support the action.

14. Add any reminders and escalations, then click Finish.

Related topics

My Actions

Defining action roles

Viewing actions

Completing actions

Closing actions

Defining action categories and statuses

Deleting actions

Importing actions

Exporting actions

My Actions
My Actions allows you to view and manage the actions and reviews that are currently assigned to you.

Note: Actions that appear in red are past due (overdue).

To view your actions:

1. In the Action Registry (Actions>Action Registry), from the File menu choose My Actions.

To update the status of an action, double-click it to open the Update Action dialog. In this dialog you can also
view and edit the action (if you have the correct access rights) by clicking Full Details.

Note: To sign off the action choose Completed from the Status drop-down list.

To view actions of other users:

1. Click User and Groups Filter  to search for the user.

Note: You must be an action manager to view other users' actions.

Related topics

Action Registry

Defining action roles

Creating actions

Viewing actions

Completing Actions

Closing actions

Deleting actions
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Defining Action Settings

Define action categories
Define the action categories that are used when creating actions. Administrators and action managers only.

Note: The settings defined in the 'No Category' action category will be the default settings used for the creation
of non-categorized actions. The settings that can be configured here are restricted however.

To define a new action category:

1. From the Actions menu choose Action Registry.

2. From the File menu choose Administration and then Categories.

3. Click New Item .

4. Enter a name and description (optional).

5. Set any of the following options.

Allow multiple sign off enables assignees to sign off multiple actions in one operation from their My
Actions page for actions assigned to a specific category. If this option is not selected, users must open
these actions individually to sign them off.

Hide category from My Tasks list if no actions are active will hide the category in users' My
Tasks (in the web) if they do not have any actions assigned under the category.

Actions require password authentication will require users to enter their passwords when creating,
modifying or changing the status of assigned actions.

Assignee must enter a note when completing the action will require users to enter notes when
setting an assigned action to 'Complete'.

Lock assignee's action when it is set to completed will prevent assignees from changing the status
of an action once they've set it to complete (note that administrators, action managers and the owner
can change the status of assignees' actions). Users will still be able to add attachments and comments to
the owner's action group record.

Archive off completed action records after x days defines the number of days after which
completed actions are automatically archived.

Applicable Owner Settings

On this tab you can add additional data fields for owners to fill out (by associating a data table) and assign specific
statuses for owners for this action category.

6. To add additional data fields, from the Action owner metadata fields applicable only to this category
of actions choose a data table definition.

7. Choose one of the following options for action statuses:

Use all available statuses will provide owners with all available statuses for actions of this category.

Use selected statuses only allows you to limit the statuses available to owners for actions of this
category. In the list of available statuses, select or deselect which status to include. See Creating action
statuses for more information on creating statuses.

Applicable Assignee Settings

On this tab you can add additional data fields for assignees to fill out (by associating a data table) and assign
specific statuses for assignees for this action category.

8. To add additional data fields, from the Action assignee metadata fields applicable only to this
category of actions choose a data table definition.

9. Choose one of the following options for action statuses:

Use all available statuses will provide assignees with all available statuses for actions of this
category.

Use selected statuses only allows you to limit the statuses available to assignees for actions of this
category. In the list of available statuses, select or deselect which status to include. See Creating action
statuses for more information on creating statuses.

Default Values

On this tab you can set default values and attachments for actions of this category. The information set here will
autopopulate action information when actions are created for this category.
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10. Enter any default information into the fields, as required.

Note: By default, users will be able to modify any of the information when creating an action of this
category. To prevent a user from editing a field, deselect the check box to the right of a field (under Allow
User to Modify?) to prevent that field from being edited.

Only require 1 assignee to complete action will allow the action owner to close actions of this
category after only one of the assignees has completed it.

Applicable Functionality

On this tab you can select which functionality actions of this category can be created against. By default, users will
be able to create actions of this category for all types of functionality that apply to actions.

11. Select or deselect which functionality to allow actions of this category to be created for.

12. Click OK to save the action category.

To delete an action category:

1. From the Actions menu choose Action Registry.

2. From the File menu choose Administration and then Categories.

3. Right-click the action category that you want to delete and choose Delete.

To edit an action category:

1. From the Actions menu choose Action Registry.

2. From the File menu choose Administration and then Categories.

3. Right-click the action category that you want to edit and choose Properties.

Related topics

Action Registry

Defining action roles

Creating actions

Viewing actions

Completing Actions

Closing actions

Deleting actions

Define action statuses
Define available action statuses for actions. Administrators and action managers only.

To define a new action status:

1. From the Actions menu choose Action Registry.

2. From the File menu choose Administration, then either Assignee Statuses or Owner Statuses.

3. Click New Item .

4. Enter a name and description (optional).

5. Select a status type from either Active, Completed or Closed.

6. Click OK.

To delete an action status:

1. From the Actions menu choose Action Registry.

2. From the File menu choose Administration, then either Assignee Statuses or Owner Statuses.

3. Right-click the status that you want to delete and choose Delete.

To edit an action status:
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1. From the Actions menu choose Action Registry.

2. From the File menu choose Administration, then either Assignee Statuses or Owner Statuses.

3. Right-click the status that you want to edit and choose Properties.

Related topics

Action Registry

Defining action roles

Creating actions

Viewing actions

Completing Actions

Closing actions

Deleting actions

Add additional fields
Additional data fields can be added to action records by associating a data table definition. Only one data table
can be assigned and this will apply to all actions.

To add additional fields to action records:

1. From the Actions menu choose Action Registry.

2. From the File menu choose Administration, and then Additional Fields.

3. From the Additional Fields drop-down options, choose a data table definition to associate with all action
records and then click OK.

Related topics

Action Registry

Defining action roles

Creating actions

Viewing actions

Completing Actions

Closing actions

Deleting actions

Define action roles
Two roles exist that provide users with various privileges with regard to actions; Action Manager and Action
Creator. For more information see User Account Details.

Creating Actions

Create an action
You can create general actions and actions that are created for diagrams, documents, storyboards and metric
links. General actions can also be created, which are not associated with any object. Once the action is created,
assignees will be notified and their To-do lists will be updated.

  Only administrators, action managers and action creators can create actions.

Actions can also be linked with statement records. More information...

To create a new action:
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1. From the Actions menu choose Action Registry.

2. Click New  and choose an action type.

3. Click Next and follow the steps in the wizard.

Note: When creating a recurring action for documents or storyboards, you can select multiple documents or
storyboards to create an action for by holding Ctrl. You can also select a storyboard folder to create actions
for all storyboards in the folder. Alternatively, scope list files can also be selected for diagrams, documents
and storyboards. If you are planning to create an action against a scope list file then you do not need to first
select a target diagram or storyboard.

Properties

Enter the details of the action, including subject, owner, due date and associated categories.

Recurrence

Enter the details of how frequently the action should recur. Note: This step is only available when
creating a recurring statement record action. See Create a recurring statement action.

Assignees

Add users and user groups to complete the action.

Only require 1 assignee to complete action will allow the action owner to close the action after only
one of the assignees has completed it.

Editors

Add users that are able to modify the action (editors cannot complete the action unless they are an
assignee).

Viewers

Add users that are able to view the action (by default all users can view the action through Action
Registry).

Description

Add any information about the action, such as the reason for carrying out the action.

Owner Category Data

If you selected an action category that has a data table associated with it, you can provide additional
data with respect to the action category.

Additional Data

If a data table has been associated with all actions, you can provide additional information with respect
to the action.

Attachments

Add any attachments to further support the action, if applicable. Attachments can be file links, application

links, email links, SAP transaction links, document links, storyboard links and URL links. Click New  to
add an attachment. To modify the access rights for a particular action, select the attachment and click 

Set View Rights .

Reminders and Escalation

Email and SMS notifications can be sent to users to remind them about an upcoming or overdue action.
An escalation date can also be set which will send an email notification to users' line managers if they fail
to action a particular To-do item. Default notification and escalation options are defined in the system
options. If you have the privileges to do so, you can modify these settings for individual actions requests
before submitting them.

Enable email reminders will send reminder emails to users until they have completed the action.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
completed the action.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.
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Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

Related topics

Create a storyboard action

Create a document action

Create a diagram action

Importing actions

Defining action roles

Viewing actions

Closing actions

Deleting actions

Copy an action
Actions can be copied, for example if you want to create a new action based on an existing one.

To create a new action:

1. In the Action Registry (Actions>Actions Registry), right-click the action that you want to copy and choose
Clone Action.

Create and manage recurring actions
Actions can be automatically generated at frequent intervals through Recurring Action Templates, including
recurring actions linked to statement records. Recurring action templates can be created which include the details
of an action and how often an action is generated.

Note: For information on creating recurring action templates linked to statement records click here.

To create a recurring action template:

1. In the Action Registry (Actions>Action Registry), from the File menu choose Administration and then
Recurring Action Templates.

2. Click New  and choose an action type.

Note: When creating a recurring action for documents or storyboards, you can select multiple documents or
storyboards by holding Ctrl. You can also select a storyboard folder to create a recurring action for all
storyboards in the folder.

3. Click Next and follow the steps in the wizard.

Properties

Enter the details of the action, including subject, owner, due date and associated categories.

Recurrence

Enter the details of how frequently the action should recur.

First Due Date is when you want to schedule the creation of the first action from. Choose a date,
time and a timezone.

Recurrence pattern is how often to create the action. The following options are available:
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Daily allows you to schedule the action to be created every day (7 days a week) or on week
days only (Monday to Friday).

Weekly allows you to schedule the action to be created every x weeks on selected days.

Monthly allows you to schedule the action to be created on selected days for selected months.
In the Months drop-down options, choose which months you want to run the recurring action and
then choose one of the following options:

Days will schedule the action to be created on selected days for the selected months.

On will schedule the action to be created on the first, second, third, fourth or last days of the
selected days (for example, the second Monday and Wednesday of each month).

Yearly allows you to schedule the action to be created on a selected date once a year.

Custom allows you schedule the action to be created on custom dates. Double-click a date in the
calendar to add it. You can add multiple dates. Once the last action has been generated you can
notify selected users in the Final Action Notification step (see below).

Repeat Times

Specify if and when the action should be repeated on the selected days you have scheduled the action
template to run. For example, you may want to create the action twice on selected days.

1. To add an additional time to run the action template, click Add repeat time.

2. Specify the time and the timezone (if required).

Note: You can add multiple repeat times. To delete a time, select the check box of the time(s) that
you want to delete and click Delete Selected.

3. Click OK when you have finished defining repeat times.

Final Action Notification

This step will only be displayed if you have selected a Custom recurrence pattern. After the last action
has been generated, you can set the system to automatically notify selected users, such as the action
owner, the action editors and specific users/user groups. The notification text that is sent to users can be
modified in the system options.

Assignees

Add users and user groups to complete the action.

Only require 1 assignee to complete action will allow the action owner to close the action after
only one of the assignees has completed it.

Editors

Add users that are able to modify the action (editors cannot complete the action unless they are an
assignee).

Viewers

Add users that are able to view the action (by default all users can view the action through Action
Registry).

Description

Add any information about the action, such as the reason for carrying out the action.

Owner Category Data

If you selected an action category that has a data table associated with it, you can provide additional
data with respect to the action category.

Additional Data

If a data table has been associated with all actions, you can provide additional information with respect
to the action.

Attachments

Add any attachments to further support the action, if applicable. Attachments can be file links, application

links, email links, SAP transaction links, document links, storyboard links and URL links. Click New  to
add an attachment. To modify the access rights for a particular action, select the attachment and click 

Set View Rights .

Reminders and Escalation
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Email and SMS notifications can be sent to users to remind them about an upcoming or overdue action.
An escalation date can also be set which will send an email notification to users' line managers if they fail
to action a particular To-do item. Default notification and escalation options are defined in the system
options. If you have the privileges to do so, you can modify these settings for individual actions requests
before submitting them.

Enable email reminders will send reminder emails to users until they have completed the action.

Enable SMS reminders will send reminder SMS messages to assigned reviewers until they have
completed the action.

Reminders to be sent every is the frequency of days in which email and SMS reminders are sent.

Start sending reminders x days before item is overdue is the number of days to start sending
email and SMS reminders prior to the due date (set this option to '0' if you only want to remind users
after the due date has passed).

Enable escalations will escalate an overdue request by notifying users' line managers by email.

Escalate after is the number of days after the due date has passed before notifying users' line
managers.

To manually trigger a recurring action:

1. In the Action Registry (Actions>Action Registry), from the File menu choose Administration and then
Recurring Action Templates..

2. Right-click a selected recurring action and choose Trigger Actions.

To edit a recurring action:

1. In the Action Registry (Actions>Action Registry), from the File menu choose Administration and then
Recurring Action Templates.

2. Right-click the recurring action template and choose Properties.

3. Edit any of the information on the various tabs, then click OK.

To delete a recurring action:

1. In the Action Registry (Actions>Action Registry), from the File menu choose Administration and then
Recurring Action Templates..

2. Right-click the recurring action template and choose Delete.

Related topics

Create an action

Link a statement record with an action

Viewing Actions

View an action
Actions that are assigned to you will appear in your My Actions. Diagram actions can also be viewed in a tree
structure within the Feedback dialog (from the Diagram menu choose Feedback).

To view the actions assigned to you:

1. From the Actions menu, open the Action Registry and in File, choose My Actions.

2. Double-click an action to view the respective details.

If you have completed an action see Completing an action for information on signing off the action.

To view the actions assigned to a diagram:
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1. When viewing a diagram, from the Diagram menu choose Feedback.

2. Expand the Actions node.

To view the actions assigned to a document:

1. Right-click a document following a Document Registry search and choose Details.

2. From the File menu choose Feedback, then expand the Actions node.

To view the actions owned by you:

You can filter the list of actions in the Action Registry to display only actions that are owned by you.

1. From the Actions menu choose Action Registry.

Enter your user name in the Owner field to retrieve only actions that are owned by you.

See The Action Registry for more details.

To view data added to actions by assignees:

You can view any data that has been entered by any of the assignees when completing their actions. If an

assignee has entered data then  will appear next to their name in the Assignees tab for a particular action.
To view the information they've added, double-click the assignee.

Related topics

Defining action roles

Creating actions

Closing actions

Deleting actions

Importing and Exporting Actions

Import actions
Importing actions from a CSV file into the Action Registry is a quick way in which to create and assign actions in
TIBCO Nimbus. The following CSV file format is required:

Subject,Category,Priority,Owner,Due Date,Assignee1;Assignee2;Assigneen...

Note: Only Action Managers and TIBCO Nimbus Administrators can import actions. Any users that don't exist in
TIBCO Nimbus will be created as new TIBCO Nimbus unassigned users.

1. From the Actions menu choose Action Registry.

2. From the File menu choose Import From CSV.

3. Locate and select the CSV file, then click Open.

Related topics

Creating actions

Viewing actions

Closing actions
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Deleting actions

Exporting actions

Export actions
Export a list of actions to either Excel or a number of different formats and (.txt, .xml and .html).

1. From the Actions menu choose Action Registry.

2. Search for the actions that you want to export.

3. From the File menu choose Export Grid As Shown To and then choose a format.

Related topics

Creating actions

Viewing actions

Closing actions

Deleting actions

Importing actions

Managing Actions

Edit an action
If you are the owner of an action, or an assigned action editor, you can edit the details of an action, add
assignees, editors and viewers, add attachments, update the notes, etc.

1. In the Action Registry, right-click the action that you want to edit and choose Properties.

Action Properties

Note: You can view any data that has been entered by any of the assignees. If an assignee has entered

data then  will appear next to their name in the Assignees tab. To view the information they've added,
double-click the assignee.

2. Click OK to close the action.

Complete an action
Once you have completed an action that you have been assigned to undertake you must set the status to
complete.

Note: This will not close the action as this must be done by the action owner or an administrator.

1. From the Action menu choose My Actions.

2. Double-click the action that you want to sign off.

3. In the Sign Off tab choose Completed from the Status drop-down list.

Note: The Finished field will be automatically populated with the current date and time when you set the status
to Completed. You can change the date and time if you wish to do so.

4. Enter any relevant notes in the Notes panel.

5. If available, enter any additional information relating to the action category.

6. Click OK.

Related topics
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Defining action roles

Closing actions

Creating actions

Viewing actions

Deleting actions

Close an action
An action can be closed by the action owner, or administrator, once all assignees have completed the action. 
Note: If enabled, an action can be closed when only one assignee has completed it.

1. From the Action menu choose Action Registry.

2. Search for the action that you want to close and double-click it to open it.

Hint: See The Action Registry for details on searching for actions.

3. In the Settings panel on the Action tab, from the Status drop-down list choose Closed.

4. Click OK.

Related topics

Signing off actions

Defining action roles

Creating actions

Viewing actions

Deleting actions

Deleting Actions

Delete an action
If you are the owner of an action and it is no longer valid then you can delete it. When an action is deleted it will
remain in the system until it is deleted a second time. Actions that are initially deleted will have a status of
'Deleted' and can still be viewed by users in the Action Registry (deleted records are no displayed by default).

1. From the Actions menu choose Action Registry.

2. Right-click the action and choose Delete.

Note: To physically remove an action from the system this process must be repeated.

Related topics

Defining action roles

Creating actions

Viewing actions

Closing actions
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About Reports
A variety of data can be reported on in TIBCO Nimbus. These reports can be printed and exported as text, XLS,
XML and HTML.

Note: Only administrators can create and maintain scheduled reports.

Report Types

Diagram reports:

Activities (SIPOC): Builds a list of all activities within a specified scope of diagrams, and shows activity ID, text
and notes. 

Activity Inputs and Outputs: Builds a list of all the activity's input and output flow lines across the diagrams
within a specified scope of diagrams. 

Data Table Links: Builds a list of all places where a data table link exists within a specified scope of diagrams,
and includes information such as the name of data table. 

Diagram Costs: Builds a list of all the diagrams within a specified scope of diagrams, and includes all the costing,
volume, etc. information relevant to a diagram.

Diagram Links: Builds a list of all diagram links within a specified scope of diagrams, and includes information
such as the source diagram, destination diagram, etc.

Diagrams: Builds a list of all diagrams within the specified scope of diagrams, and includes information such as
author, owner, version, etc. 

File and Document Links: Builds a list of all file links and document links within a specified scope of diagrams,
and includes information such as the file, title, document number, document owner, etc.

Flow Line Links: Builds a list of all flow line links within a specified scope of diagrams, and includes information
such as the flow line link type, source diagram, destination diagram, etc. 

Images: Builds a list of all the image objects used within a specified scope of diagrams, and includes information
such as the type of the image, the sizes of the original and displayed  images, and the size of the image.

Internal Attachments: Builds a list of all internal document attachments and internal image attachments, within
a specified scope of diagrams and includes information such as the title, diagram, etc. 

Metric Links: Builds a list of all metric links within a specified scope of diagrams, and includes information such as
the data source and the link's target. 

Object Language Text Usage: Builds a list of all language variants used within a specified scope of diagrams.

Object Language Text Variants: Builds a list of objects within a specified scope of diagrams, for example
activities, notes bubbles, etc. and provides details of each language variant supported in the process repository.

Objects: Builds a list of all the various diagram objects within a specified scope of diagrams, for example
activities, free text, flow lines, notes bubbles, etc. This report is useful for data extraction.

Oracle Links: Builds a list of all Oracle link attachments in a scope of diagrams, and includes information such as
the URL, title, etc.

Salesforce.com Links: Builds a list of all Salesforce.com links in the specified scope of diagrams, and includes
information such as the URL, title, etc.

SAP Transaction Links: Builds a list of all SAP transaction links within the specified scope of diagrams, and
includes information such as the SAP transaction code, link title, etc. 

Scorecard Links: Builds a list of all scorecard links within the specified scope of diagrams, and includes
information such as the scorecard's name and the link's title. 

Storyboard Dependency: Builds a list of diagram and activity steps referenced in storyboards for a scope of
diagrams.



Reporting

TIBCO Nimbus® User GuidePage 397

Storyboard Links: Builds a list of all storyboard links within a specified scope of diagrams, and includes
information such as the storyboard's title and the link's title.

Swimlanes: Builds a list of all activities within a specified scope of diagrams and shows which swimlane activities
belong to and includes activity ID, activity text, etc.

URL Links: Builds a list of all URL web links within a specified scope of diagrams, and includes information such as
the URL, title, etc. 

Document Control reports:

Access Rights: Builds a list to show the default access rights and specific user access rights for all diagrams
across a specified scope of diagrams.

Acknowledgement Progress: Builds a list of the acknowledgement statuses for each acknowledger on each
diagram within a specified scope of diagrams. This can help to show where any delays exists in the
acknowledgement cycle.

Acknowledgement Requests: Builds a list of acknowledgement requests across a scope of diagrams.

Acknowledgement Summary: Builds a high-level overview of the acknowledgement progress for a selected
scope of diagrams. Note that you can double-click a row to view the Acknowledgement Progress report for a
specific diagram.

Acknowledgements: Builds a list of all user acknowledgements across a specified scope of diagrams. 

Actions: Builds a list of all actions across a specified scope of diagrams. 

Change Logs: Builds a list of all diagram change log entries across a specified scope of diagrams. 

Change Requests: Builds a list of all change requests across a specified scope of diagrams, and allows individual
change requests to be progressed onto their next stage in the cycle.

Feedback: Builds a list of all feedback within a specified scope of diagrams, and includes information such as
feedback title, user, date, diagram, etc. 

Keyword Groups: Builds a report showing the keyword groups and associated keywords in the current Process
Repository. 

Keywords: Builds a list of all the keywords that are associated across a scope of diagrams or across a scope of
documents in the Document Registry. Each keyword associated with a diagram/document is listed as a new row in
the report. 

Map Compliance Report: Builds a report that displays statement sets and their links to maps in a selected scope
of maps within the Process Repository. 

Recurring Reviews: Builds a report that displays all recurring reviews across a selected scope of diagrams within
the Process Repository.

Review Progress: Builds a report of the current review statuses of diagrams across a scope of diagrams.

Subscriptions: Builds a list of subscriptions within a specified scope of diagrams, and allows filtering and grouping
on the users..   

User Group Associations: Builds a report to show all the user groups that are associated across a scope of
diagrams or documents. 

Resource reports:

Resource Costs: Builds a list of all resource within the specified scope of diagrams and includes all costing
information relevant to the activity resource relationship. 

Resource Groups: Shows a list of all resource groups. 
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Resource Usage: A usage count for all central resources. This is based on the resources used across a selected
scope of diagrams. 

Resources: Identifies where a selected resource exists within a specified scope of diagrams and displays
information such as the diagram, activity, other resources, etc. Note that Suppliers are the other resources on any
activities connected as inputs to a particular activity, and Customers are the other resources on activities
connected as outputs from a particular activity.

User Activities: Identifies all activities where a selected user or user group exists based on their assigned
resource roles within a specified scope of diagrams. 

User Resources: Lists all the users and their resource roles. 

Costing reports:

Activity Costs: Builds a list of all activities within a specified scope of diagrams and includes all the activity
costing information. 

Diagram Costs: Builds a list of all the diagrams within a specified scope of diagrams, and includes all the costing,
volume, etc. information relevant to a diagram. 

Resource Costs: Builds a list of all resource within a specified scope of diagrams and includes all costing
information relevant to the activity resource relationship.

Data Table reports:

<Activity-DEFAULT>: Extracts all the activities and lines where selected table query criteria are satisfied.

<Change Request-DEFAULT>: Extracts all the activities and lines where selected table query criteria are
satisfied.

Data Table Links: Builds a list of all places where a data table link exists within a specified scope of diagrams,
and includes information such as the name of data table.

Business Control reports:

Business Controls Usage: Builds a list of all business controls within a specified scope of diagrams, and includes
information such as the business control name and the object text.

Business Controls Comparison: Builds a list of all business controls used within a specified map and shows
whether the same business controls are used, or not, within a selected copy of the map.

User Information reports:

Actions: View and manage Control actions, including change request, acknowledgement and review actions. 

Active Users: This shows a list of the users that are currently logged into the system and includes an Email all
active users option. (This is note appropriate to a scope of diagrams). 

Assigned Users: Builds a list of all authorizers, acknowledger, reviewers, subscribers, owners and authors for all
diagrams within a specified scope of diagrams. 

Deleted Users: This shows a list of deleted user accounts. (This is not applicable to a scope of diagrams).

My Information: Builds a report showing all different functions within the scope of diagrams where your user
account is assigned, e.g. where users are an authorizer, acknowledger, subscriber, author, owner, reviewer, etc. 

User Activities: Identifies all activities where a selected user or user group exists based on their assigned
resource roles, within a specified scope of diagrams. 
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User Group Favorite Managers: Shows a list of users that have permission to edit User Groups Favorites in the
Web.  The report also shows which groups these users can edit

User Groups: This shows a list of all user groups. Active users are shown in blue. (This is note appropriate to a
scope of diagrams). 

User Resources: Lists all the users and their resource roles. Also includes a date and time stamp of when the
user last logged into the Client and Web Server.

Users: This shows a list of all user accounts. (This is not appropriate to a scope of diagrams). You can add a
group column to the report which shows which group(s) users are members of. Double-click a user account to
access it.

Authorization reports:

Audit Trail: Builds a list of audit trail entries for all diagrams within a specified scope of diagrams. 

Authorization Progress: Builds a list of the sign-off status for each authorizer on each diagram within a
specified scope of diagrams. This can help to show where any delays exists in the authorization sign-off cycle. 

Document Registry reports:

For further information on Document Registry Reports, please click here.

Statement reports:

Linked Statements vs. Activity Links: Builds a list of all activity statement links within a specified scope of
diagrams. It displays the difference between these activity statement links and the other statements from
associated statement sets.

SAP Blueprint vs SAP End User Roles: Builds a comparison between the user roles specified in SAP Solution
Manager and the actual usage of SAP transactions.

SAP End User Roles (Actual): Builds a list of all statement links to a SAP Solution Manager statement set and
shows which transaction SAP users use. Note: This requires that a SAP Usage statement set has been imported for
the Solution Manager set.

Statement Compliance Report: Builds a list of a matrix of statements and selected maps, indicating which maps
have statement links and which maps do not. Note: Right-click a statement and choose Statement Audits to
view and associated statement audit records.

Statement Link Audit Log: Builds a list of all statement audit log records within the specified scope of diagrams
and includes information such as the statement name, diagram name, etc.

Statement Link Audits: Builds a list of all activity statement link audit records within a specified scope of
diagrams, and includes information such as the audit date, audit description, compliance statement, activity text,
etc. Note: Right-click an activity statement link record and choose Open Audit Record to view the details of the
audit record.

Statement Link Audits and Statement Data: Builds a list of all activity statement link audit records for a
specified scope of diagrams and includes information such as the audit date, audit description, statement,
statement’s additional data, activity text, etc.

Statement Link Audits Audit Log: Builds a list of all statement link audits audit log records within a specified
scope of diagrams and includes information such as the statement name, audit description, audit status, etc.

Statement Links: Builds a list of all activity statement links within a specified scope of diagrams, and includes
information such as the compliance statement, activity text, etc. 

Statement Links and Statement Data: Builds a list of all activity statement links within a specified scope of
diagrams and includes information such as the statement, statement’s additional data, activity text, etc.
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Statement Set Usage: Builds a list of all diagrams within the specified scope of diagrams, and includes
information such as the names of any Statement Sets that the diagram has any links to.

Statement Links and Related Statements: Builds a list of all activity statement links within the specified scope
of diagrams for a selected statement set and includes information such as the statement name, additional data,
activity text, etc. It also includes all statement-to-statement references for another nominated statement set.

The following reports are only available from within the Statement Report Select window

Statement Audits: Builds a list of all statement audit records within the specified scope of statements and
includes information such as the compliance statement, audit status, audit description, etc.

Statement Audits and Statement Data: Builds a list of all statement audit records within the specified scope of
statements and includes information such as the statement, statement's additional data, audit status, audit
description, etc.

Statement Details: Builds a list of all statement records within the specified scope of statements and includes
information such as the statement name, status, description, etc.

Statement Usage: Builds a list of all statement records within the specified scope of statements and includes the
total number of links to the statement.

Statement Audit Log: Builds a list of all statement audit log records within the specified scope of statements and
includes information such as the statement name, status, description, etc.

Statement Audits Audit Log: Builds a list of all statement audits audit log records within the specified scope of
statements and includes information such as the statement name, status, description, etc.

Statement Data, Links and Link Audits: Builds a list of all statements in the selected scope of statements and
for each statement record includes all the statement links and for each statement link it includes all the statement
link audit records.

Linked Statements: Builds a list of all the statements in the selected scope of statements and for each statement
record includes all linked statements.

Administration reports:

System Options Audit: Builds an audit history log of changes to the System Options.

Action Management reports:

Action Category Totals: Builds a report that displays total actions for all categories and statuses.

Assignee Actions: Builds a report of all actions for a selected action category with associated assignee metadata
fields (note that if the selected category is associated with an action assignee-related data table you will be
presented with the option to apply filters against any of the data table fields). Note: Double-click an action to view
the details.

Owner Actions: Builds a report of all actions for a selected action category with associated owner metadata fields
(note that if the selected category is associated with an action owner-related data table you will be presented with
the option to apply filters against any of the data table fields). Note: Double-click an action to view the details.

Generate a Report
A variety of data can be reported on in TIBCO Nimbus. See Report types for information on what reports can be
generated.

1. From the Tools menu choose Reports.

2. From the Categories column choose the report category.
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3. From the Reports column choose the report type.

Note: For a description of what data will be generated in a report type, click the report type and the Report
Description (at the bottom of the dialog) will update.

4. From the Scope column choose the scope of diagrams to include in the report.

5. Click OK.

Note: For Statement Compliance reports, you can view and create associated statement audit records by
right-clicking statements and choosing Statement Audits.

To report on the Document Registry:

A number of reports can be run on all documents, or selected document, from the Document Registry, such as
the subscribers for a scope of documents or the usage of all documents in the Document Registry.

Note: You must have at least one document displayed in the Document Registry to enable the reporting options.

1. From the Documents menu choose Document Registry.

2. Search for the document(s) that you want to report on.

Note: If you want to report on all documents in the Document Registry then it is not important what you
search for.

3. From the Manage menu choose Reports and choose a report type to run.

4. Choose the scope of files/documents to report on and click OK.

Related topics

Report types

Generating data table reports

Customize a report

Schedule a report

Save a report

Print a report

Document registry reports

Generate a Data Table Report
Data table reporting allows you to search for specific data associated with diagrams, for example:

· All activities that triggered a non-conformance in an internal audit, conducted by J.Smith on or after the 5th
June 2007.

· All flow line links that carry invoice information between activities across the company.
· All activities where customer information is referenced.
· All activities with an internal or external customer satisfaction index of 6 or less.
· All activities that are involved in the test cycle of a new prototype product.
· All activities that are non-value added across the company.
· All activities involving procurement across the company.

Reporting on data tables is a very powerful tool, but it relies on data tables being structured logically.
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If you are reporting on a data table, an additional dialog will appear following the selection of the data table that
you want to report on. The Data Table Report/Extract Wizard dialog allows you to filter on any field(s).

1. From the Tools menu choose Reports.

2. Select Data Tables in the Categories column.

3. Select the data table that you want to report on in the Reports column.

4. Choose the scope of diagrams that you want to report against.

5. Click OK.

6. To filter the data table report, see below, otherwise click Generate Report.

To filter the data table report:

1. Double-click a field that you want to apply a filter to.

2. Choose the filter operator from the Filter Operation drop-down list.

3. Enter a value to filter against in the Filter Value text box.

To edit data table records:

After generating a data table report, you can update any of the data records if you have the required access
rights.

1. Select the data row that you want to update and click Edit.

2. Edit the chosen value, then click OK.

Hint: You can also double-click an individual value in the report to edit it.

Updating multiple records:

To update multiple data records, hold Ctrl and select the data table rows that you want to update and then
click Edit. Update any of the data values and click OK.

To delete data table records:

After generating a report, you can delete data records if you have the required access rights.

1. In the data table report, select the record that you want to delete.

Note: Hold Ctrl to select multiple records.

2. Click Delete.

Customize a Report
Report data can be sorted, filtered and grouped and columns can be added, removed and repositioned.

To add a column:

1. From the View menu choose Column Customizing.

A list of additional columns will be displayed in the Customize window.



Reporting

TIBCO Nimbus® User GuidePage 403

2. To add a column, drag the column header from the Customize window and drop it in between the two column
headers in the report view where you want the new column to appear.

Note: Green arrows indicate that the column can be dropped into place.

To remove a column:

1. Drag the column header from the report view into the Customize window.

To group columns:

1. Drag and drop the column header into the gray area above.

You can then expand each group category by clicking the expand button .

To ungroup a column, drag and drop the column header back into place within the existing ungrouped
column headers.

Multiple columns can be grouped. The precedence of grouping is determined by the order of the column
headers in the grouping area, i.e. the first column header will be grouped first, followed by the second
column header and so forth.

To reposition a column:

1. Drag and drop the column header in between the two column headers where you want the column to appear.

Note: Green arrows indicate that the column can be dropped into place.

To sort columns:

1. Click the column header to toggle the direction of data.

To filter column data:

1. Click the filter button  for the column you want to filter and choose either (Custom...) to define a custom
filter or choose one of the existing data records.

Note: Filtered columns will be indicated with a blue filter button. To remove a filter select the (All) option.

Related topics

Generate a report

Schedule a report

Save a report

Print a report

Report Scheduling

Schedule a report
Reports can be automatically scheduled to run using the Scheduled Report Manager. Only administrators and
report managers can create, edit and delete scheduled reports. Scheduled reports are handled by the Batch
Server.

Note: Any reports that are run through the Scheduled Report Manager are logged. You can access this log file in
the Scheduled Reports dialog -  from the File menu choose View Log. You can schedule reports to be available
in the web server. See Scheduling a web server report for more details.
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1. From the Tools menu choose Scheduled Reports.

2. From the File menu choose New.

Report Parameters

3. For the Report Parameters, click Select and choose one of the following options:

Main Report allows you to choose any of the main reports to schedule. See Report types for more
information on the available reports.

Document Report allows you to schedule a report for a scope of documents or all documents in the
Document Registry. In the Scope panel, choose the scope of documents to schedule a report against.

All Documents will schedule the report against all documents.

Selected Documents will schedule the report against all the documents that you select. Search for
the documents and then hold Ctrl to select multiple documents (as required).

Storyboard Report allows you to schedule a report for a scope of storyboards. When this option is
selected, the Storyboard Selector window will be displayed. In the Select Scope panel, choose the scope
of storyboards to schedule a report against.

Selected Storyboards will schedule the report against the storyboards that you select. Hold Ctrl
to select multiple storyboards.

All Storyboards will schedule the report against all storyboards.

Current Folder will schedule the report against all storyboards in a selected folder.

Current Folder and Child Folders will schedule the report against all storyboards in a selected
folder and all child folders.

Storyboard Scope List will schedule the report against all storyboards in a storyboard scope list
file.

Statement Set Report allows you to schedule a report against a statement set.

Scheduled Item Name

4. You can change the name of the scheduled report in the Scheduled Item Name field.

Send Notification To

5. You can change the user that will be notified when a scheduled report is completed or if it fails. This will
default to you but you can select another user by clicking Select.

Schedule Information 

6. Click Configure to define when you want the report to run. The following options are available:

First Due Date is when you want to schedule the report generation from. Choose a date, time and a
timezone.

Recurrence pattern is how often to create the report. The following options are available:

Disabled (will disable the scheduled report, i.e. it will not run).

Daily allows you to schedule the report to run every day (7 days a week) or on week days only
(Monday to Friday).

Weekly allows you to schedule the report to run every x weeks on selected days.

Monthly allows you to schedule the report to run on selected days for selected months. In the
Months drop-down options, choose which months you want to run the scheduled report and then
choose one of the following options:

Days will schedule the report to run on selected days for the selected months.

On will schedule the report to run on the first, second, third, fourth or last days of selected days
(for example, the second Monday and Wednesday of each month).

Yearly allows you to schedule the report to run on a selected date once a year.

Custom allows you schedule the report to run on custom dates. Use the calendar to select a date

and then click Add Selected  to add the date. Repeat this step for all of the dates that you want
the report to be scheduled for.

7. Click Next.

Repeat Times

The next step allows you to add repeat times on the days you have scheduled the report to run. For
example, you may want to schedule the report to run twice on the selected days, once in the morning and
once in the afternoon.

8. To add an additional time to run the scheduled report, click Add repeat time.

9. Specify the time and the timezone (if required).
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Note: You can add multiple repeat times. To delete a time, select the check box of the time(s) that you want
to delete and click Delete Selected.

10. Click OK when you have finished defining repeat times.

Saving Data

11. Choose what format to save the report in from the following options:

Save Data to a Folder on Disk allows you to save the report in either Excel or HTML format to a local
drive or to a network location.

Note: Exporting to Excel format will truncate data cells over 256 characters. If the reports that are
being generated are likely to exceed data cells over 256 characters then choose Save File in
HTML Format and select the Use .xls Extension for the File option.

Save Data for Web Server will save the report in the system and it will be available for users to view
in the web interface. See Schedule a web report for more information.

12. Choose where to save the report by clicking Browse for the Data Location field.

13. Click OK to save the scheduled report.

Related topics

Editing scheduled reports

Deleting scheduled reports

Scheduling web reports

Generating reports

Customizing reports

Manually running scheduled reports

Saving reports

Printing reports

Schedule a web report
Reports can be automatically scheduled to run using the Scheduled Report Manager and made available to users in
the TIBCO Nimbus web interface. Only administrators and report managers can create, edit and delete scheduled
reports.

Note: Any reports that are run through the Scheduled Report Manager are logged. You can access this log file in
the Scheduled Reports dialog -  from the File menu choose View Log.

1. From the Tools menu choose Scheduled Reports.

2. From the File menu choose New.

Report Parameters

3. For the Report Parameters, click Select and choose one of the following options:

Main Report allows you to choose any of the main reports to schedule. See Report types for more
information on the available reports.

Document Report allows you to schedule a report for a scope of documents or all documents in the
Document Registry. In the Scope panel, choose the scope of documents to schedule a report against.

All Documents will schedule the report against all documents.

Selected Documents will schedule the report against all the documents that you select. Search for
the documents and then hold Ctrl to select multiple documents (as required).

Storyboard Report allows you to schedule a report for a scope of storyboards. When this option is
selected, the Storyboard Selector window will be displayed. In the Select Scope panel, choose the scope
of storyboards to schedule a report against.

Selected Storyboards will schedule the report against the storyboards that you select. Hold Ctrl
to select multiple storyboards.

All Storyboards will schedule the report against all storyboards.

Current Folder will schedule the report against all storyboards in a selected folder.

Current Folder and Child Folders will schedule the report against all storyboards in a selected
folder and all child folders.

Storyboard Scope List will schedule the report against all storyboards in a storyboard scope list
file.

Statement Set Report allows you to schedule a report against a statement set.
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Scheduled Item Name

4. You can change the name of the scheduled report in the Scheduled Item Name field.

Send Notification To

5. You can change the user that will be notified when a scheduled report is completed or if it fails. This will
default to you but you can select another user by clicking Select.

Schedule Information

6. Click Configure to define when you want the report to run. The following options are available:

First Due Date is when you want to schedule the report generation from. Choose a date, time and a
timezone.

Recurrence pattern is how often to create the report. The following options are available:

Disabled (will disable the scheduled report, i.e. it will not run).

Daily allows you to schedule the report to run every day (7 days a week) or on week days only
(Monday to Friday).

Weekly allows you to schedule the report to run every x weeks on selected days.

Monthly allows you to schedule the report to run on selected days for selected months. In the
Months drop-down options, choose which months you want to run the scheduled report and then
choose one of the following options:

Days will schedule the report to run on selected days for the selected months.

On will schedule the report to run on the first, second, third, fourth or last days of selected days
(for example, the second Monday and Wednesday of each month).

Yearly allows you to schedule the report to run on a selected date once a year.

Custom allows you schedule the report to run on custom dates. Use the calendar to select a date

and then click Add Selected  to add the date. Repeat this step for all of the dates that you want
the report to be scheduled for.

7. Click Next.

Repeat Times

The next step allows you to add repeat times on the days you have scheduled the report to run. For
example, you may want to schedule the report to run twice on the selected days, once in the morning and
once in the afternoon.

8. To add an additional time to run the scheduled report, click Add repeat time.

9. Specify the time and the timezone (if required).

Note: You can add multiple repeat times. To delete a time, select the check box of the time(s) that you want
to delete and click Delete Selected.

10. Click OK when you have finished defining repeat times.

11. Select Save Data for Web Server. 

Access Rights

By default, all users in the system are granted access to the report. You can change the default access
rights (applied to all users) and also assign specific access rights to users and user groups. Note that there
are two levels of access rights that can be applied as you can also assign access rights to web folders used
to store web reports in.

12. Click Configure (adjacent to Save Data for Web Server option) to define access rights on the report.

13. Click Browse to specify which folder in the process repository you want to save the report to.

Hint: You can create new folder. In the Web Reports Repository Management window that appears, from
the Edit menu choose New Folder.

14. After selecting the folder, click OK to save the scheduled report.

Managing folders in the web report repository

Web reports are saved in the web report repository. The default location of the web report repository is:

...\TIBCO Nimbus\Process Repository\System\Web Reports

You can create, edit and delete folders within the web report repository.

To create a new folder:
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1. In the Scheduled Reports dialog (Tools>Scheduled Reports), from the File menu choose Web
Reports.

2. From the Edit menu choose New Folder.

3. Enter a name for the web report folder.

4. Define default user access rights and specific user access rights.

By default, all users are granted access to the web report folder. Select the default access rights for all
users, if required. To assign access rights to specific users click Add  and select a user.

Note: A user must have access to both the web report and the web report folder in which the report is
stored to view the report in the web server.

5. Click OK.

To edit a folder (update the folder name or access rights):

1. Select the web report folder and from the Edit menu choose Edit Folder.

To delete a folder:

1. Select the web report folder and from the Edit menu choose Delete Folder.

Related topics

Scheduling reports

Manually run a scheduled report
Scheduled reports can be manually run at any time.

1. From the Tools menu choose Scheduled Reports.

2. Right-click the scheduled report and choose Run Now.

Related topics

Scheduling reports

Editing scheduled reports

Deleting scheduled reports

Generating reports

Customizing reports

Saving reports

Printing reports

Edit a scheduled report
Edit a scheduled report.

1. From the Tools menu choose Scheduled Reports.

2. Double-click the scheduled report.

Copy a scheduled report
Scheduled reports can be copied. Please note that the scheduled task details are not copied, therefore these will
have to be defined manually.

1. From the Tools menu choose Scheduled Reports.

2. Right-click the scheduled report that you want to copy and choose Copy.
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Related topics

Scheduling reports

Editing scheduled reports

Deleting scheduled reports

Generating reports

Customizing reports

Saving reports

Printing reports

Delete a scheduled report
Delete a scheduled report.

1. From the Tools menu choose Scheduled Reports.

2. Select the scheduled report and press Delete.

Save a Report
Reports can be saved in TXT, XLS, XML and HTML formats.

1. From the File menu choose Export Grid As Shown To and choose a file format.

2. Browse to a location to save the report in, enter a name in the File name box and click Save.

Related topics

Generate a report

Customize a report

Schedule a report

Print a report

Print a Report
Entire reports or selected diagrams within a report can be printed.

1. From the File menu choose Print.

Note: To print selected diagrams, select the diagrams that you want to print by holding Ctrl and from the
File menu choose Print Selected Diagrams.

Related topics

Generate a report

Customize a report

Schedule a report

Save a report
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Printing Maps

Page Setup
You can define the page setup with respect to printing across a scope of diagrams. These options will apply to all
users when they print the selected diagram(s).

Note:  The page setup options of templates can be defined and these will be used unless the Override
Template option is selected.

1. From the File menu choose Page Setup.

2. In the Print Scaling tab you can choose how to scale the diagrams.

Always scale diagram to fit page will scale diagrams up or down to fit the page.

Scale diagram to fit, only when larger than page will only scale down diagrams that are too large
for the page. Diagrams that are smaller than the page will not be scaled up.

Scale diagram to fit user defined area allows you to define a printable area. If this option is selected
then resizing handles will be present when you exit Page Setup. When you adjust the print area of one
diagram then all lower level diagrams (for the current diagram and all lower levels and the current
process map options) will also be set. Diagrams can also be adjusted individually. You can also enter
specific dimensions for the print area by clicking Adjust Manually.

Note: The Scale diagram to fit user defined area option is pixel based and not true page size. TIBCO
Nimbus will compress or expand the diagram to fit the standard page size of the printer that it is being sent
to. A4/A3, for example, is determined by your printer and what you see on the screen is literally what you
get when the page is printed.

3. Choose the scope of diagrams to set the printing options for.

Override Template will override any template page setup settings defined for applied templates. If this
option is not selected then the template page setup settings will be used.

4. Click the Orientation and Size tab to change the print orientation, margins and header and footer font sizes.

The print margins define the distance from each edge of the printable area (the printable area is between the
bottom of the title area at the top and the document control panel at the bottom). The Header And Footer
panel allows you to change the font point sizes of the control panel and title.

Print diagrams
The current diagram, the current diagram and all lower levels and the current process map can be printed.
Various print options allow you to include or exclude various diagram objects and the page setup can be
modified. 

1. From the File menu choose Print.

2. Select from the following options:

General tab

Select or deselect the features that you want to include in the printout and choose the number of copies that
you want to print.

Scope tab

Choose the scope of diagrams that you want to print.

Choose any multiple printing options:

1 Diagram per Page will print 1 page for each diagram in the selected scope.
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Fit To allows you to specify how many pages to print for the selected scope of diagrams. For example, if
you have 5 diagrams in the selected scope and you choose 1 by 1, TIBCO Nimbus will print all 5
diagrams on one page. If you are printing the current diagram only and select to fit it to 3 by 3 pages, it
will stretch the diagram over 9 pages.

Choose the layout if printing multiple diagrams per page.

Rows of Diagrams:

 

Hierarchically Structured:

 

3. Click Print.

Related topics

Page Setup

Printing Documents

Print the Document Registry
The Document Registry view can be printed.

1. From the File menu choose Print.

Note: One field can be used as a preview field, which is displayed in between each row in the report. Choose
a field from the Preview Field drop-down list (located top right on the Document Registry dialog). To toggle
the preview field on/off, from the View menu choose Preview.
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Related topics

Designing the print format

Page setup

Page setup
You can configure the print output, including page settings, margins, headers, footers and page scale.

1. From the File menu choose Page Setup.

Design the print format
You can design the print format when printing from the Document Registry. Designing the print format is
undertaken when you are ready to print.

Note: The settings are not saved between printing sessions.

1. From the File menu choose Print Preview.

2. Then choose Design.

Within the design panel it is possible to customize and define the style of your printed documents.

Printing Storyboards

Print a storyboard
You can print a storyboard and select what attributes to include in the output.

1. In the Storyboard Management window, select the storyboard that you want to print.

2. From the File menu choose Print Storyboard.

3. Select any of the print options, as required. 

4. Click OK.
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Educational Services
TIBCO offer a wide range of training courses to suit the needs of both individuals and companies.

Further information on TIBCO Educational Services can be found here Educational Services

http://www.tibco.com/services/educational
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Contact Details

Our specialized team are on hand to provide assistance with the Nimbus® product. TIBCO Support is an online
resource where you can log cases directly, 24 hours a day, 7 days a week.  You can also view updates on current
cases and search the Nimbus® Knowledge Base. 

Use the links below to access the relevant service.

Requirement Contact Details

  To register for a TIBCO Support account.
Request an account for TIBCO Support

  To log in to TIBCO Support.
support.tibco.com

If your support issue is urgent and you have not yet
registered for an account please email.

support@tibco.com

For further information on service level agreements.
TIBCO Support Services

 Access the TIBCO Community site.
TIBCO Community

https://support.tibco.com/s/contact-support-agent
https://support.tibco.com
mailto:support@tibco.com
https://www.tibco.com/services/support
https://community.tibco.com/products/tibco-nimbus
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SOME TIBCO SOFTWARE EMBEDS OR BUNDLES OTHER TIBCO SOFTWARE. USE OF SUCH EMBEDDED
OR BUNDLED TIBCO SOFTWARE IS SOLELY TO ENABLE THE FUNCTIONALITY (OR PROVIDE LIMITED
ADD-ON FUNCTIONALITY) OF THE LICENSED TIBCO SOFTWARE. THE EMBEDDED OR BUNDLED
SOFTWARE IS NOT LICENSED TO BE USED OR ACCESSED BY ANY OTHER TIBCO SOFTWARE OR FOR
ANY OTHER PURPOSE. 

USE OF TIBCO SOFTWARE AND THIS DOCUMENT IS SUBJECT TO THE TERMS AND CONDITIONS OF A
LICENSE AGREEMENT FOUND IN EITHER A SEPARATELY EXECUTED SOFTWARE LICENSE AGREEMENT,
OR, IF THERE IS NO SUCH SEPARATE AGREEMENT, THE CLICKWRAP END USER LICENSE AGREEMENT
WHICH IS DISPLAYED DURING DOWNLOAD OR INSTALLATION OF THE SOFTWARE (AND WHICH IS
DUPLICATED IN THE LICENSE FILE) OR IF THERE IS NO SUCH SOFTWARE LICENSE AGREEMENT OR
CLICKWRAP END USER LICENSE AGREEMENT, THE LICENSE(S) LOCATED IN THE LICENSE FILE(S) OF
THE SOFTWARE. USE OF THIS DOCUMENT IS SUBJECT TO THOSE TERMS AND CONDITIONS, AND
YOUR USE HEREOF SHALL CONSTITUTE ACCEPTANCE OF AND AN AGREEMENT TO BE BOUND BY THE
SAME. 

This document contains confidential information that is subject to U.S. and international copyright
laws and treaties. No part of this document may be reproduced in any form without the written
authorization of TIBCO Software Inc. 

TIBCO, the TIBCO logo, the TIBCO O logo, and Nimbus are either registered trademarks or trademarks
of TIBCO Software Inc. in the United States and/or other countries.

All other product and company names and marks mentioned in this document are the property of their
respective owners and are mentioned for identification purposes only.

This software may be available on multiple operating systems. However, not all operating system
platforms for a specific software version are released at the same time. See the readme file for the
availability of this software version on a specific operating system platform. 

THIS DOCUMENT IS PROVIDED AS IS WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY,
FITNESS FOR A PARTICULAR PURPOSE, OR NON-INFRINGEMENT. 

THIS DOCUMENT COULD INCLUDE TECHNICAL INACCURACIES OR TYPOGRAPHICAL ERRORS.
CHANGES ARE PERIODICALLY ADDED TO THE INFORMATION HEREIN; THESE CHANGES WILL BE
INCORPORATED IN NEW EDITIONS OF THIS DOCUMENT. TIBCO SOFTWARE INC. MAY MAKE
IMPROVEMENTS AND/OR CHANGES IN THE PRODUCT(S) AND/OR THE PROGRAM(S) DESCRIBED IN
THIS DOCUMENT AT ANY TIME.

THE CONTENTS OF THIS DOCUMENT MAY BE MODIFIED AND/OR QUALIFIED, DIRECTLY OR
INDIRECTLY, BY OTHER DOCUMENTATION WHICH ACCOMPANIES THIS SOFTWARE, INCLUDING BUT
NOT LIMITED TO ANY RELEASE NOTES AND "READ ME" FILES. 

This and other products of TIBCO Software Inc. may be covered by registered patents. Please refer to
TIBCO's Virtual Patent Marking document (https://www.tibco.com/patents) for details.

Copyright © 1997-2020 TIBCO Software Inc. All Rights Reserved.
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Selecting users
The following two methods document how to search for and add users.

Note: If you are assigning access rights, the default access rights apply to all users unless specific access user
rights are defined.

To search for and add users:

1. Select Search Users in the list (top-left).

2. In the Criteria panel select to search against Account, First Name, Last Name or Group by selecting the
relevant radio button.

3. Enter the search text in the relevant text box or select the user group from the group drop-down list..

Hint: You can enter part of the text. For example, entering 'Jo' as the first name will return names beginning

with 'Jo', such as John, Joanne, etc.

Note: You can retrieve all users by leaving the fields blank.

4. Click Find.

5. Select the user from the list of users that is returned and click Add.

Hint: Hold Ctrl to select multiple users.

Note: Click Me to add yourself. The <Owner> option (applicable to reviews only) will automatically assign

the owner of a diagram or document as a reviewer.

6. Click OK.

To search for and add groups:

1. Select Search Groups in the list (top-left).

2. Enter the name of the group in the Name text box and click Find.

Note: You can retrieve all groups by leaving the field blank.

3. Select the user from the list of groups that is returned and click Add.

Hint: Hold Ctrl to select multiple groups.

4. Click OK.
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